Setting tag nodemanager-5.2-10
[nodemanager.git] / nodemanager-lib.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 5.2
5 %define taglevel 10
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 ########## use initscripts or systemd unit files to start installed services
10 %if "%{distro}" == "Fedora" && %{distrorelease} >= 18
11 %define make_options WITH_SYSTEMD=true
12 %define initdir /usr/lib/systemd/system
13 %else
14 %define make_options WITH_INIT=true
15 %define initdir %{_initrddir}
16 %endif
17
18 Summary: PlanetLab Node Manager Library
19 Name: %{name}
20 Version: %{version}
21 Release: %{release}
22 License: PlanetLab
23 Group: System Environment/Daemons
24 Source0: %{name}-%{version}.tar.gz
25 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
26
27 Vendor: PlanetLab
28 Packager: PlanetLab Central <support@planet-lab.org>
29 Distribution: PlanetLab %{plrelease}
30 URL: %{SCMURL}
31
32 # not possible because of forward_api_calls
33 #BuildArch: noarch
34
35 # make sure we can invoke systemctl in post install script
36 %if "%{initdir}" != "%{_initrddir}"
37 Requires: systemd
38 %endif
39
40 # Uses function decorators
41 Requires: python >= 2.7
42 # connecting PLC
43 Requires: python-pycurl
44 # Signed tickets
45 Requires: gnupg
46 # sioc/plnet
47 Requires: pyplnet >= 4.3
48 # we do need the slice images in any case
49 Requires: sliceimage-%{slicefamily}
50 # for bwlimit
51 Requires: plnode-utils
52
53 %description
54 The PlanetLab Node Manager manages all aspects of PlanetLab node and
55 slice management once the node has been initialized and configured by
56 the Boot Manager. It periodically contacts its management authority
57 for configuration updates. It provides an XML-RPC API for performing
58 local operations on slices.
59 nodemanager-lib only provides a skeleton and needs as a companion
60 either nodemanager-vs or nodemanager-lxc
61
62 ##############################
63 %prep
64 %setup -q
65
66 %build
67 # make manages the C and Python stuff
68 %{__make} %{?_smp_mflags} %{make_options} lib 
69
70 %install
71 # make manages the C and Python stuff
72 rm -rf $RPM_BUILD_ROOT
73 %{__make} %{?_smp_mflags} %{make_options} install-lib DESTDIR="$RPM_BUILD_ROOT"
74
75 ##############################
76 %post
77 ########## traditional init
78 %if "%{initdir}" == "%{_initrddir}"
79 ##########
80 chkconfig --add conf_files
81 chkconfig conf_files on
82 chkconfig --add nm
83 chkconfig nm on
84 chkconfig --add fuse-pl
85 chkconfig fuse-pl on
86 if [ "$PL_BOOTCD" != "1" ] ; then
87     service nm restart
88     service fuse-pl restart
89 fi
90 ##########
91 %else
92 ########## systemd
93 systemctl enable nm.service
94 systemctl enable conf_files.service
95 # empty
96 #systemctl enable fuse-pl.service
97 if [ "$PL_BOOTCD" != "1" ] ; then
98     systemctl restart nm.service
99 #    systemctl restart fuse-pl.service
100 fi
101 ##########
102 %endif
103
104 ##############################
105 %preun
106 # 0 = erase, 1 = upgrade
107 ########## traditional init
108 %if "%{initdir}" == "%{_initrddir}"
109 ##########
110 if [ $1 -eq 0 ] ; then
111     chkconfig fuse-pl off
112     chkconfig --del fuse-pl
113     chkconfig nm off
114     chkconfig --del nm
115     chkconfig conf_files off
116     chkconfig --del conf_files
117 fi
118 ##########
119 %else
120 ########## systemd
121 if [ $1 -eq 0 ] ; then
122 #    systemctl disable fuse-pl.service
123     systemctl disable conf_files.service
124     systemctl disable nm.service
125 fi
126 ##########
127 %endif
128
129 ##############################
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %files
134 %defattr(-,root,root,-)
135 %{_datadir}/NodeManager/
136 %{_bindir}/forward_api_calls
137 %{initdir}/
138 %{_sysconfdir}/logrotate.d/nodemanager
139 /var/lib/nodemanager/
140 /bin/sshsh
141
142 %changelog
143 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-10
144 - comes with systemd native unit files on >= f18
145 - user-provided initscript gets started through systemd in slivers >= f18
146 - smarter to locate cgroups for various versions of libvirt
147 - nicer log format - and log program termination
148 - tweaks in codemux plugin
149 - bug fixes in libvirt driver, esp. for finding out if domain is running
150
151 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
152 - fixes in hostmap, and in interfaces
153 - new vsys_sysctl
154 - privatebridge now comes with nodemanager-lib
155
156 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
157 - omf plugin does not block any longer when running trigger script
158 - log goes into sliver's /var/log instead
159
160 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
161 - new install-scripts target in Makefile
162 - conf_files and fuse-pl initscripts chmod'ed +x
163 - omf_resctl config template tweaked to use _slicename_%_hostname_
164
165 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
166 - make sure to create /etc/planetlab/virt so others can read that
167 - expose get_node_virt() and command_in_slice()
168 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
169 - user's .profile now has right owner
170 - other tweaks in lxc slivers
171
172 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
173 - lxc slice creation: slice user was created with unknown gid - fixed
174 - lxc slice creation: .profile for root and user - fixed
175
176 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
177 - fix umounting of ssh directory when deleting omf-friendly slivers
178 - support for writing cgroups in subsystems other than cpuset
179 - add xid to template match
180 - finer-grained split between -lib -vs and -lxc
181 - first roughly complete omf_resctl for omfv6
182 - minor fix for when getslivers does not have minexemptrate
183
184 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
185 - Fix path, machine arch in slivers
186
187 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
188
189 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
190 - no-op bump to 5.2 to be in line with the rest of the system
191
192 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
193 - improvements to privatebridge
194
195 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
196 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
197
198 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
199 - fix wrong gre tunnel deleted when topology changes
200
201 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
202 - Update /etc/hosts in slivers from sliver_hostmap tag.
203
204 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
205 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
206 - initial check-in of privatebridge plugin.
207
208 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
209 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
210
211 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
212 - fix slices not deleted properly when they use vsys
213
214 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
215 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
216
217 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
218 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
219
220 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
221 - Bridge virtual interfaces to VLANs
222
223 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
224 - Add support for L2 bridged interfaces with public IPs inside a slice
225
226 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
227 - Support for freezing BestEffort slices for Vicci
228
229 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
230 - Change to use new vsh (wrapper for lxcsu)
231
232 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
233 - add missing import
234 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
235
236 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
237 - tag 2.1-7 was broken for OMF-friendly slices
238 - expose_ssh_dir was erroneously defined on the Worker class
239
240 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
241 - bwlimitlxc now ships with plnode-utils
242
243 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
244 - set LD_PRELOAD for linux-containers nodes
245
246 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
247 - first complete version for vs and lxc - functional but not thoroughly tested though
248
249 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
250 - split packaging in 3 (lib, lxc, vs)
251 - this tag will only work with lxc though
252
253 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
254 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
255
256 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
257 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
258 - purpose being to be able to run this branch on vserver nodes as well
259
260 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
261 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
262 - passes tests with lxc but won't build against vs due to conflict
263 - as bwlimit.py also ships with util-vserver-pl
264
265 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
266 - refactoring: isolate initscript functionality
267 - aimed at making initscript implementation with lxc straightforward
268 - show stack trace when module loading fails
269 - accounts.py renamed into account.py for consistency
270
271 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
272 - /var/log/nodemanager shows duration of mainloop
273
274 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
275 - first working draft for dealing with libvirt/lxc on f16 nodes
276 - not expected to work with mainline nodes (use 2.0 for that for now)
277
278 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
279 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
280
281 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
282 - Added memory scheduling to core scheduler
283 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
284
285 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
286 - tweaked log policy for the core scheduler
287 - curlwrapper has an optional verbose mode
288
289 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
290 - fixes for hmac and omf_control tags
291 - optional besteffort flag to core scheduler
292 - logrotate entry for /var/log/nodemanager.daemon
293 - a template for bash initscripts
294
295 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
296 - rename initscript_body into initscript_code
297 - fix generic vinit for broken bash syntax &>>
298
299 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
300 - new initscript_body slice tag, with stop and restart
301 - generic vinit script live updated
302 - new coresched module
303 - protect against non-existing vsys scripts
304 - use Config. instead of globals
305
306 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
307 - more robust reservation plugin
308
309 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
310 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
311 - reservation plugin more robust
312
313 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
314 - pass device to bwlimit
315
316 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
317 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
318
319 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
320 - Catch all exceptions for sfa plugin
321
322 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
323 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
324
325 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
326 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
327
328 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
329 - plugins/sliverauth.py improvements
330
331 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
332 - Disable sfagids plugin
333
334 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
335 - Re-tag nodemanager to include conflicted commits
336
337 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
338 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
339 - sfagids plugin deleted
340 - band-aid patch for lack of GetSliceFamily removed
341
342 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
343
344 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
345 - revert curlwrapper to former forking-curl version
346 - fixes in the omf plugin for ssh key location and node hrn
347 - set umask 0022 in tools.daemon
348
349 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
350 - configure omf-resctl for keys
351
352 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
353 - fix key generation
354
355 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
356 - name changes and fix typos
357
358 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
359 - remove config and options parameters from start function
360
361 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
362 - working version of reservable nodes
363 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
364 - dismantled the -s|--startup option (no convincing need for that)
365 - simpler and more robust init.d/nm
366 - initscript content management through replace_file_with_string
367 - sliverauth uses replace_file_with_string
368 - curlwrapper has a debug mode
369
370 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
371 - pretty-printing/normalized python code - hopefully neutral
372
373 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
374 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
375 - that triggers /etc/init.d/vinit.slice if present and executable
376 - (2) install the slice-provided initscript (as per the initscript tag) as
377 - /etc/init.d/vinit.slice
378 - (3) as a result the initscript are now triggered by rc as part of the
379 - standard vserver .. start, properly attached to the vserver,
380 - and properly killed upon vserver .. stop
381 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
382
383 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
384 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
385 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
386 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
387 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
388 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
389 - cleanup: nodemanger now is a class; however plugins are still dumb modules
390 - cleanup: does not depend on obsolete Set
391
392 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
393 - tagging before RC
394
395 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
396 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
397 - Added some precautions to the slice id-saving code
398 - Added log message to code that records the slice id
399
400 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
401 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
402 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
403 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
404
405 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
406 - fix log_call in plugins/drl.py
407
408 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
409 - protect against nodes in migrated PLC's not having the hrn tag yet
410
411 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
412 - new omf-resctl and drl plugins
413 - specialaccount optimized to overwrite authorized keys only upon changes
414 - codemux plugin has support for a new 'ip' setting
415 - mainloop to display ordered modules&plugins at all times
416
417 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
418 - modules and plugins have a priority
419 - specialaccounts appears soon in the priority chain
420 - logger.log_call logs process output, and has a timeout
421 - vuser{add,del} run through bash -x
422 - nm initscript has support for 'service nm restartverbose'
423 - logs reviewed for consistency
424 - use hashlib module instead of sha when available
425
426 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
427 - first working version of 5.0:
428 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
429 - nodefamily is 3-fold with pldistro-fcdistro-arch
430 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
431 - (in addition to the 'vref' tag that's still exposed too)
432 - logging reviewed for more convenience
433 - support for 'service nm restartdebug'
434 - make sync knows how to publish uncommitted code on a test node
435
436 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
437 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
438
439 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
440 - support for f10 and f12 in the vref slice tag
441
442 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
443 - build on fedora12
444 - uses slicename 'sfacm' instead of 'genicw'
445
446 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
447 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
448 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
449 - days ago.
450
451 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
452 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
453 - self-contained. With this change, they will be able to refer to the attributes associated with a
454 - slice.
455
456 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
457 - fix for syntax error
458
459 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
460 - -fixed problem with sioc import at the build side
461 - -bwlimit.set() now accepts the device and does not asume that it is eth0
462
463 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
464 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
465
466 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
467 - The seed for random previously was the meaning of life (i.e., 42) but
468 - that resulted in a not so random choice for the hmac.  This
469 - implementation now uses a random.seed that is based on the current
470 - time.
471
472 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
473 - Minor fix such that sliverauth.py makes a more specific call to
474 - GetSliceTags that include that specific tagname it is looking for.
475
476 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
477 - Fix bug that prevented 'OVERRIDES' for working correctly.
478
479 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
480 - Increase disk limits to 10G per sliver
481 - Sanity check slice for home directory before starting (hack)
482 - Check codemux arguments
483
484 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
485 - * Fix Delegation
486 - * Move plcapi in plugin-api GetSlivers() calls.
487 - * Persistent Authcheck and resync session when auth failure
488
489 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
490 - Disabling sliverauth module.  Not ready for deployment.
491
492 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
493 - Fixing overrides semantics.
494
495 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
496 - Generalized plugins
497 - Fixed initscript start up bug.
498
499 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
500 - * Fix delegation authentication problem
501 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
502
503 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
504 - * Rerun initscripts when slice goes from disabled to enabled.
505
506 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
507 - * Update session key when out of synch with PLC
508 - * PLCDefaults uses tagname
509
510 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
511 - log invokations of vsys
512
513 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
514
515 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
516
517 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
518 - Codemux supports multiple hosts mapping to single slice
519 - Fixed bug in delegation support where tickets delivered weren't
520   being passed to sm.deliver_ticket().
521
522 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
523 - Codemux now configured via slice attribute (host,port)
524 - Support for multiple vserver reference images (including different archs)
525 - Mom BW emails are sent to list defined by MyPLC's config
526 - Sirius BW loans honored correctly.  Fixed.
527 - BW totals preserved for dynamic slices so as not to game the system.
528
529 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
530 - Configures vsys via vsys slice attribute {name: vsys, value: script}
531 - CPU reservations are now calculated via percentages instead of shares
532 - BW totals preserved for dynamic slices
533 - Closes bug where node cap sets off bw slice alarms for all slices.
534
535 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
536 - Switched to SVN.
537
538 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
539 - Initial build.