python-2.7
[nodemanager.git] / nodemanager-lib.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 5.2
5 %define taglevel 9
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 Summary: PlanetLab Node Manager Library
10 Name: %{name}
11 Version: %{version}
12 Release: %{release}
13 License: PlanetLab
14 Group: System Environment/Daemons
15 Source0: %{name}-%{version}.tar.gz
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17
18 Vendor: PlanetLab
19 Packager: PlanetLab Central <support@planet-lab.org>
20 Distribution: PlanetLab %{plrelease}
21 URL: %{SCMURL}
22
23 # not possible because of forward_api_calls
24 #BuildArch: noarch
25
26 # Uses function decorators
27 Requires: python >= 2.7
28 # connecting PLC
29 Requires: python-pycurl
30 # Signed tickets
31 Requires: gnupg
32 # sioc/plnet
33 Requires: pyplnet >= 4.3
34 # we do need the slice images in any case
35 Requires: sliceimage-%{slicefamily}
36 # for bwlimit
37 Requires: plnode-utils
38
39 %description
40 The PlanetLab Node Manager manages all aspects of PlanetLab node and
41 slice management once the node has been initialized and configured by
42 the Boot Manager. It periodically contacts its management authority
43 for configuration updates. It provides an XML-RPC API for performing
44 local operations on slices.
45 nodemanager-lib only provides a skeleton and needs as a companion
46 either nodemanager-vs or nodemanager-lxc
47
48 ########## use initscripts or systemd unit files to start installed services
49 %if "%{distro}" == "Fedora" && %{distrorelease} >= 18
50 %define make_options WITH_SYSTEMD=true
51 %define initdir /usr/lib/systemd/system
52 %else
53 %define make_options WITH_INIT=true
54 %define initdir %{_initrddir}
55 %endif
56
57 ##############################
58 %prep
59 %setup -q
60
61 %build
62 # make manages the C and Python stuff
63 %{__make} %{?_smp_mflags} %{make_options} lib 
64
65 %install
66 # make manages the C and Python stuff
67 rm -rf $RPM_BUILD_ROOT
68 %{__make} %{?_smp_mflags} %{make_options} install-lib DESTDIR="$RPM_BUILD_ROOT"
69
70 ##############################
71 %post
72 ########## traditional init
73 %if "%{initdir}" == "%{_initrddir}"
74 ##########
75 chkconfig --add conf_files
76 chkconfig conf_files on
77 chkconfig --add nm
78 chkconfig nm on
79 chkconfig --add fuse-pl
80 chkconfig fuse-pl on
81 if [ "$PL_BOOTCD" != "1" ] ; then
82     service nm restart
83     service fuse-pl restart
84 fi
85 ##########
86 %else
87 ########## systemd
88 systemctl enable nm.service
89 systemctl enable conf_files.service
90 # empty
91 #systemctl enable fuse-pl.service
92 if [ "$PL_BOOTCD" != "1" ] ; then
93     systemctl restart nm.service
94 #    systemctl restart fuse-pl.service
95 fi
96 ##########
97 %endif
98
99 ##############################
100 %preun
101 # 0 = erase, 1 = upgrade
102 ########## traditional init
103 %if "%{initdir}" == "%{_initrddir}"
104 ##########
105 if [ $1 -eq 0 ] ; then
106     chkconfig fuse-pl off
107     chkconfig --del fuse-pl
108     chkconfig nm off
109     chkconfig --del nm
110     chkconfig conf_files off
111     chkconfig --del conf_files
112 fi
113 ##########
114 %else
115 ########## systemd
116 if [ $1 -eq 0 ] ; then
117 #    systemctl disable fuse-pl.service
118     systemctl disable conf_files.service
119     systemctl disable nm.service
120 fi
121 ##########
122 %endif
123
124 ##############################
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %files
129 %defattr(-,root,root,-)
130 %{_datadir}/NodeManager/
131 %{_bindir}/forward_api_calls
132 %{initdir}/
133 %{_sysconfdir}/logrotate.d/nodemanager
134 /var/lib/nodemanager/
135 /bin/sshsh
136
137 %changelog
138 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
139 - fixes in hostmap, and in interfaces
140 - new vsys_sysctl
141 - privatebridge now comes with nodemanager-lib
142
143 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
144 - omf plugin does not block any longer when running trigger script
145 - log goes into sliver's /var/log instead
146
147 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
148 - new install-scripts target in Makefile
149 - conf_files and fuse-pl initscripts chmod'ed +x
150 - omf_resctl config template tweaked to use _slicename_%_hostname_
151
152 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
153 - make sure to create /etc/planetlab/virt so others can read that
154 - expose get_node_virt() and command_in_slice()
155 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
156 - user's .profile now has right owner
157 - other tweaks in lxc slivers
158
159 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
160 - lxc slice creation: slice user was created with unknown gid - fixed
161 - lxc slice creation: .profile for root and user - fixed
162
163 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
164 - fix umounting of ssh directory when deleting omf-friendly slivers
165 - support for writing cgroups in subsystems other than cpuset
166 - add xid to template match
167 - finer-grained split between -lib -vs and -lxc
168 - first roughly complete omf_resctl for omfv6
169 - minor fix for when getslivers does not have minexemptrate
170
171 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
172 - Fix path, machine arch in slivers
173
174 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
175
176 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
177 - no-op bump to 5.2 to be in line with the rest of the system
178
179 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
180 - improvements to privatebridge
181
182 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
183 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
184
185 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
186 - fix wrong gre tunnel deleted when topology changes
187
188 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
189 - Update /etc/hosts in slivers from sliver_hostmap tag.
190
191 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
192 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
193 - initial check-in of privatebridge plugin.
194
195 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
196 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
197
198 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
199 - fix slices not deleted properly when they use vsys
200
201 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
202 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
203
204 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
205 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
206
207 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
208 - Bridge virtual interfaces to VLANs
209
210 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
211 - Add support for L2 bridged interfaces with public IPs inside a slice
212
213 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
214 - Support for freezing BestEffort slices for Vicci
215
216 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
217 - Change to use new vsh (wrapper for lxcsu)
218
219 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
220 - add missing import
221 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
222
223 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
224 - tag 2.1-7 was broken for OMF-friendly slices
225 - expose_ssh_dir was erroneously defined on the Worker class
226
227 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
228 - bwlimitlxc now ships with plnode-utils
229
230 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
231 - set LD_PRELOAD for linux-containers nodes
232
233 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
234 - first complete version for vs and lxc - functional but not thoroughly tested though
235
236 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
237 - split packaging in 3 (lib, lxc, vs)
238 - this tag will only work with lxc though
239
240 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
241 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
242
243 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
244 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
245 - purpose being to be able to run this branch on vserver nodes as well
246
247 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
248 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
249 - passes tests with lxc but won't build against vs due to conflict
250 - as bwlimit.py also ships with util-vserver-pl
251
252 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
253 - refactoring: isolate initscript functionality
254 - aimed at making initscript implementation with lxc straightforward
255 - show stack trace when module loading fails
256 - accounts.py renamed into account.py for consistency
257
258 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
259 - /var/log/nodemanager shows duration of mainloop
260
261 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
262 - first working draft for dealing with libvirt/lxc on f16 nodes
263 - not expected to work with mainline nodes (use 2.0 for that for now)
264
265 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
266 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
267
268 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
269 - Added memory scheduling to core scheduler
270 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
271
272 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
273 - tweaked log policy for the core scheduler
274 - curlwrapper has an optional verbose mode
275
276 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
277 - fixes for hmac and omf_control tags
278 - optional besteffort flag to core scheduler
279 - logrotate entry for /var/log/nodemanager.daemon
280 - a template for bash initscripts
281
282 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
283 - rename initscript_body into initscript_code
284 - fix generic vinit for broken bash syntax &>>
285
286 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
287 - new initscript_body slice tag, with stop and restart
288 - generic vinit script live updated
289 - new coresched module
290 - protect against non-existing vsys scripts
291 - use Config. instead of globals
292
293 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
294 - more robust reservation plugin
295
296 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
297 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
298 - reservation plugin more robust
299
300 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
301 - pass device to bwlimit
302
303 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
304 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
305
306 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
307 - Catch all exceptions for sfa plugin
308
309 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
310 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
311
312 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
313 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
314
315 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
316 - plugins/sliverauth.py improvements
317
318 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
319 - Disable sfagids plugin
320
321 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
322 - Re-tag nodemanager to include conflicted commits
323
324 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
325 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
326 - sfagids plugin deleted
327 - band-aid patch for lack of GetSliceFamily removed
328
329 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
330
331 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
332 - revert curlwrapper to former forking-curl version
333 - fixes in the omf plugin for ssh key location and node hrn
334 - set umask 0022 in tools.daemon
335
336 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
337 - configure omf-resctl for keys
338
339 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
340 - fix key generation
341
342 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
343 - name changes and fix typos
344
345 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
346 - remove config and options parameters from start function
347
348 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
349 - working version of reservable nodes
350 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
351 - dismantled the -s|--startup option (no convincing need for that)
352 - simpler and more robust init.d/nm
353 - initscript content management through replace_file_with_string
354 - sliverauth uses replace_file_with_string
355 - curlwrapper has a debug mode
356
357 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
358 - pretty-printing/normalized python code - hopefully neutral
359
360 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
361 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
362 - that triggers /etc/init.d/vinit.slice if present and executable
363 - (2) install the slice-provided initscript (as per the initscript tag) as
364 - /etc/init.d/vinit.slice
365 - (3) as a result the initscript are now triggered by rc as part of the
366 - standard vserver .. start, properly attached to the vserver,
367 - and properly killed upon vserver .. stop
368 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
369
370 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
371 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
372 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
373 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
374 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
375 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
376 - cleanup: nodemanger now is a class; however plugins are still dumb modules
377 - cleanup: does not depend on obsolete Set
378
379 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
380 - tagging before RC
381
382 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
383 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
384 - Added some precautions to the slice id-saving code
385 - Added log message to code that records the slice id
386
387 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
388 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
389 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
390 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
391
392 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
393 - fix log_call in plugins/drl.py
394
395 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
396 - protect against nodes in migrated PLC's not having the hrn tag yet
397
398 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
399 - new omf-resctl and drl plugins
400 - specialaccount optimized to overwrite authorized keys only upon changes
401 - codemux plugin has support for a new 'ip' setting
402 - mainloop to display ordered modules&plugins at all times
403
404 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
405 - modules and plugins have a priority
406 - specialaccounts appears soon in the priority chain
407 - logger.log_call logs process output, and has a timeout
408 - vuser{add,del} run through bash -x
409 - nm initscript has support for 'service nm restartverbose'
410 - logs reviewed for consistency
411 - use hashlib module instead of sha when available
412
413 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
414 - first working version of 5.0:
415 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
416 - nodefamily is 3-fold with pldistro-fcdistro-arch
417 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
418 - (in addition to the 'vref' tag that's still exposed too)
419 - logging reviewed for more convenience
420 - support for 'service nm restartdebug'
421 - make sync knows how to publish uncommitted code on a test node
422
423 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
424 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
425
426 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
427 - support for f10 and f12 in the vref slice tag
428
429 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
430 - build on fedora12
431 - uses slicename 'sfacm' instead of 'genicw'
432
433 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
434 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
435 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
436 - days ago.
437
438 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
439 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
440 - self-contained. With this change, they will be able to refer to the attributes associated with a
441 - slice.
442
443 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
444 - fix for syntax error
445
446 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
447 - -fixed problem with sioc import at the build side
448 - -bwlimit.set() now accepts the device and does not asume that it is eth0
449
450 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
451 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
452
453 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
454 - The seed for random previously was the meaning of life (i.e., 42) but
455 - that resulted in a not so random choice for the hmac.  This
456 - implementation now uses a random.seed that is based on the current
457 - time.
458
459 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
460 - Minor fix such that sliverauth.py makes a more specific call to
461 - GetSliceTags that include that specific tagname it is looking for.
462
463 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
464 - Fix bug that prevented 'OVERRIDES' for working correctly.
465
466 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
467 - Increase disk limits to 10G per sliver
468 - Sanity check slice for home directory before starting (hack)
469 - Check codemux arguments
470
471 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
472 - * Fix Delegation
473 - * Move plcapi in plugin-api GetSlivers() calls.
474 - * Persistent Authcheck and resync session when auth failure
475
476 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
477 - Disabling sliverauth module.  Not ready for deployment.
478
479 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
480 - Fixing overrides semantics.
481
482 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
483 - Generalized plugins
484 - Fixed initscript start up bug.
485
486 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
487 - * Fix delegation authentication problem
488 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
489
490 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
491 - * Rerun initscripts when slice goes from disabled to enabled.
492
493 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
494 - * Update session key when out of synch with PLC
495 - * PLCDefaults uses tagname
496
497 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
498 - log invokations of vsys
499
500 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
501
502 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
503
504 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
505 - Codemux supports multiple hosts mapping to single slice
506 - Fixed bug in delegation support where tickets delivered weren't
507   being passed to sm.deliver_ticket().
508
509 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
510 - Codemux now configured via slice attribute (host,port)
511 - Support for multiple vserver reference images (including different archs)
512 - Mom BW emails are sent to list defined by MyPLC's config
513 - Sirius BW loans honored correctly.  Fixed.
514 - BW totals preserved for dynamic slices so as not to game the system.
515
516 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
517 - Configures vsys via vsys slice attribute {name: vsys, value: script}
518 - CPU reservations are now calculated via percentages instead of shares
519 - BW totals preserved for dynamic slices
520 - Closes bug where node cap sets off bw slice alarms for all slices.
521
522 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
523 - Switched to SVN.
524
525 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
526 - Initial build.