Setting tag nodemanager-2.1-19
[nodemanager.git] / nodemanager-lib.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 2.1
5 %define taglevel 19
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
9
10 Summary: PlanetLab Node Manager Library
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: System Environment/Daemons
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 # not possible because of forward_api_calls
25 #BuildArch: noarch
26
27 # Uses function decorators
28 Requires: python >= 2.4
29 # connecting PLC
30 Requires: python-pycurl
31 # Signed tickets
32 Requires: gnupg
33 # sioc/plnet
34 Requires: pyplnet >= 4.3
35 # we do need the slice images in any case
36 Requires: sliceimage-%{slicefamily}
37 # for bwlimit
38 Requires: plnode-utils
39
40 %description
41 The PlanetLab Node Manager manages all aspects of PlanetLab node and
42 slice management once the node has been initialized and configured by
43 the Boot Manager. It periodically contacts its management authority
44 for configuration updates. It provides an XML-RPC API for performing
45 local operations on slices.
46 nodemanager-lib only provides a skeleton and needs as a companion
47 either nodemanager-vs or nodemanager-lxc
48
49 %prep
50 %setup -q
51
52 %build
53 # make manages the C and Python stuff
54 %{__make} %{?_smp_mflags} lib
55
56 %install
57 # make manages the C and Python stuff
58 rm -rf $RPM_BUILD_ROOT
59 %{__make} %{?_smp_mflags} install-lib DESTDIR="$RPM_BUILD_ROOT"
60 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
61
62 # install the sliver initscript (that triggers the slice initscript if any)
63 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
64 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
65 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
66
67 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
68 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
69 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
70
71 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
72
73 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
74 install -D -m 755 sshsh $RPM_BUILD_ROOT/bin/sshsh
75
76 ##########
77 %post
78 # tmp - handle file renamings; old names are from 2.0-8
79 renamings="
80 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
81 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
82 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
83 /var/log/nm@/var/log/nodemanager
84 /var/log/nm.daemon@/var/log/nodemanager.daemon
85 /var/run/nm.pid@/var/run/nodemanager.pid
86 /tmp/sliver_mgr.api@/tmp/nodemanager.api
87 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
88 "
89 for renaming in $renamings; do
90   old=$(echo $renaming | cut -d@ -f1)
91   new=$(echo $renaming | cut -d@ -f2)
92   newdir=$(dirname $new)
93   if [ -e "$old" -a ! -e "$new" ] ; then
94       mkdir -p $newdir
95       mv -f $old $new
96   fi
97 done
98 #
99 chkconfig --add conf_files
100 chkconfig conf_files on
101 chkconfig --add nm
102 chkconfig nm on
103 chkconfig --add fuse-pl
104 chkconfig fuse-pl on
105 if [ "$PL_BOOTCD" != "1" ] ; then
106         service nm restart
107         service fuse-pl restart
108 fi
109
110 ##########
111 %preun
112 # 0 = erase, 1 = upgrade
113 if [ $1 -eq 0 ] ; then
114     chkconfig fuse-pl off
115     chkconfig --del fuse-pl
116     chkconfig nm off
117     chkconfig --del nm
118     chkconfig conf_files off
119     chkconfig --del conf_files
120 fi
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(-,root,root,-)
127 %{_datadir}/NodeManager/
128 %{_bindir}/forward_api_calls
129 %{_initrddir}/
130 %{_sysconfdir}/logrotate.d/nodemanager
131 /var/lib/
132 /bin/sshsh
133
134 %changelog
135 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
136 - Update /etc/hosts in slivers from sliver_hostmap tag.
137
138 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
139 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
140 - initial check-in of privatebridge plugin.
141
142 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
143 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
144
145 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
146 - fix slices not deleted properly when they use vsys
147
148 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
149 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
150
151 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
152 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
153
154 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
155 - Bridge virtual interfaces to VLANs
156
157 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
158 - Add support for L2 bridged interfaces with public IPs inside a slice
159
160 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
161 - Support for freezing BestEffort slices for Vicci
162
163 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
164 - Change to use new vsh (wrapper for lxcsu)
165
166 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
167 - add missing import
168 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
169
170 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
171 - tag 2.1-7 was broken for OMF-friendly slices
172 - expose_ssh_dir was erroneously defined on the Worker class
173
174 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
175 - bwlimitlxc now ships with plnode-utils
176
177 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
178 - set LD_PRELOAD for linux-containers nodes
179
180 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
181 - first complete version for vs and lxc - functional but not thoroughly tested though
182
183 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
184 - split packaging in 3 (lib, lxc, vs)
185 - this tag will only work with lxc though
186
187 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
188 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
189
190 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
191 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
192 - purpose being to be able to run this branch on vserver nodes as well
193
194 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
195 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
196 - passes tests with lxc but won't build against vs due to conflict
197 - as bwlimit.py also ships with util-vserver-pl
198
199 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
200 - refactoring: isolate initscript functionality
201 - aimed at making initscript implementation with lxc straightforward
202 - show stack trace when module loading fails
203 - accounts.py renamed into account.py for consistency
204
205 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
206 - /var/log/nodemanager shows duration of mainloop
207
208 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
209 - first working draft for dealing with libvirt/lxc on f16 nodes
210 - not expected to work with mainline nodes (use 2.0 for that for now)
211
212 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
213 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
214
215 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
216 - Added memory scheduling to core scheduler
217 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
218
219 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
220 - tweaked log policy for the core scheduler
221 - curlwrapper has an optional verbose mode
222
223 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
224 - fixes for hmac and omf_control tags
225 - optional besteffort flag to core scheduler
226 - logrotate entry for /var/log/nodemanager.daemon
227 - a template for bash initscripts
228
229 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
230 - rename initscript_body into initscript_code
231 - fix generic vinit for broken bash syntax &>>
232
233 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
234 - new initscript_body slice tag, with stop and restart
235 - generic vinit script live updated
236 - new coresched module
237 - protect against non-existing vsys scripts
238 - use Config. instead of globals
239
240 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
241 - more robust reservation plugin
242
243 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
244 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
245 - reservation plugin more robust
246
247 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
248 - pass device to bwlimit
249
250 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
251 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
252
253 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
254 - Catch all exceptions for sfa plugin
255
256 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
257 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
258
259 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
260 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
261
262 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
263 - plugins/sliverauth.py improvements
264
265 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
266 - Disable sfagids plugin
267
268 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
269 - Re-tag nodemanager to include conflicted commits
270
271 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
272 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
273 - sfagids plugin deleted
274 - band-aid patch for lack of GetSliceFamily removed
275
276 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
277
278 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
279 - revert curlwrapper to former forking-curl version
280 - fixes in the omf plugin for ssh key location and node hrn
281 - set umask 0022 in tools.daemon
282
283 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
284 - configure omf-resctl for keys
285
286 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
287 - fix key generation
288
289 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
290 - name changes and fix typos
291
292 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
293 - remove config and options parameters from start function
294
295 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
296 - working version of reservable nodes
297 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
298 - dismantled the -s|--startup option (no convincing need for that)
299 - simpler and more robust init.d/nm
300 - initscript content management through replace_file_with_string
301 - sliverauth uses replace_file_with_string
302 - curlwrapper has a debug mode
303
304 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
305 - pretty-printing/normalized python code - hopefully neutral
306
307 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
308 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
309 - that triggers /etc/init.d/vinit.slice if present and executable
310 - (2) install the slice-provided initscript (as per the initscript tag) as
311 - /etc/init.d/vinit.slice
312 - (3) as a result the initscript are now triggered by rc as part of the
313 - standard vserver .. start, properly attached to the vserver,
314 - and properly killed upon vserver .. stop
315 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
316
317 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
318 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
319 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
320 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
321 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
322 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
323 - cleanup: nodemanger now is a class; however plugins are still dumb modules
324 - cleanup: does not depend on obsolete Set
325
326 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
327 - tagging before RC
328
329 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
330 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
331 - Added some precautions to the slice id-saving code
332 - Added log message to code that records the slice id
333
334 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
335 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
336 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
337 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
338
339 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
340 - fix log_call in plugins/drl.py
341
342 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
343 - protect against nodes in migrated PLC's not having the hrn tag yet
344
345 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
346 - new omf-resctl and drl plugins
347 - specialaccount optimized to overwrite authorized keys only upon changes
348 - codemux plugin has support for a new 'ip' setting
349 - mainloop to display ordered modules&plugins at all times
350
351 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
352 - modules and plugins have a priority
353 - specialaccounts appears soon in the priority chain
354 - logger.log_call logs process output, and has a timeout
355 - vuser{add,del} run through bash -x
356 - nm initscript has support for 'service nm restartverbose'
357 - logs reviewed for consistency
358 - use hashlib module instead of sha when available
359
360 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
361 - first working version of 5.0:
362 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
363 - nodefamily is 3-fold with pldistro-fcdistro-arch
364 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
365 - (in addition to the 'vref' tag that's still exposed too)
366 - logging reviewed for more convenience
367 - support for 'service nm restartdebug'
368 - make sync knows how to publish uncommitted code on a test node
369
370 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
371 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
372
373 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
374 - support for f10 and f12 in the vref slice tag
375
376 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
377 - build on fedora12
378 - uses slicename 'sfacm' instead of 'genicw'
379
380 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
381 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
382 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
383 - days ago.
384
385 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
386 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
387 - self-contained. With this change, they will be able to refer to the attributes associated with a
388 - slice.
389
390 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
391 - fix for syntax error
392
393 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
394 - -fixed problem with sioc import at the build side
395 - -bwlimit.set() now accepts the device and does not asume that it is eth0
396
397 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
398 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
399
400 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
401 - The seed for random previously was the meaning of life (i.e., 42) but
402 - that resulted in a not so random choice for the hmac.  This
403 - implementation now uses a random.seed that is based on the current
404 - time.
405
406 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
407 - Minor fix such that sliverauth.py makes a more specific call to
408 - GetSliceTags that include that specific tagname it is looking for.
409
410 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
411 - Fix bug that prevented 'OVERRIDES' for working correctly.
412
413 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
414 - Increase disk limits to 10G per sliver
415 - Sanity check slice for home directory before starting (hack)
416 - Check codemux arguments
417
418 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
419 - * Fix Delegation
420 - * Move plcapi in plugin-api GetSlivers() calls.
421 - * Persistent Authcheck and resync session when auth failure
422
423 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
424 - Disabling sliverauth module.  Not ready for deployment.
425
426 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
427 - Fixing overrides semantics.
428
429 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
430 - Generalized plugins
431 - Fixed initscript start up bug.
432
433 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
434 - * Fix delegation authentication problem
435 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
436
437 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
438 - * Rerun initscripts when slice goes from disabled to enabled.
439
440 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
441 - * Update session key when out of synch with PLC
442 - * PLCDefaults uses tagname
443
444 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
445 - log invokations of vsys
446
447 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
448
449 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
450
451 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
452 - Codemux supports multiple hosts mapping to single slice
453 - Fixed bug in delegation support where tickets delivered weren't
454   being passed to sm.deliver_ticket().
455 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
456 - Codemux now configured via slice attribute (host,port)
457 - Support for multiple vserver reference images (including different archs)
458 - Mom BW emails are sent to list defined by MyPLC's config
459 - Sirius BW loans honored correctly.  Fixed.
460 - BW totals preserved for dynamic slices so as not to game the system.
461 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
462 - Configures vsys via vsys slice attribute {name: vsys, value: script}
463 - CPU reservations are now calculated via percentages instead of shares
464 - BW totals preserved for dynamic slices
465 - Closes bug where node cap sets off bw slice alarms for all slices.
466
467 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
468 - Switched to SVN.
469
470 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
471 - Initial build.