Setting tag nodemanager-5.2-13
[nodemanager.git] / nodemanager-lib.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 5.2
5 %define taglevel 13
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 ########## use initscripts or systemd unit files to start installed services
10 %if "%{distro}" == "Fedora" && %{distrorelease} >= 18
11 %define make_options WITH_SYSTEMD=true
12 %define initdir /usr/lib/systemd/system
13 %else
14 %define make_options WITH_INIT=true
15 %define initdir %{_initrddir}
16 %endif
17
18 Summary: PlanetLab Node Manager Library
19 Name: %{name}
20 Version: %{version}
21 Release: %{release}
22 License: PlanetLab
23 Group: System Environment/Daemons
24 Source0: %{name}-%{version}.tar.gz
25 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
26
27 Vendor: PlanetLab
28 Packager: PlanetLab Central <support@planet-lab.org>
29 Distribution: PlanetLab %{plrelease}
30 URL: %{SCMURL}
31
32 # not possible because of forward_api_calls
33 #BuildArch: noarch
34
35 # make sure we can invoke systemctl in post install script
36 %if "%{initdir}" != "%{_initrddir}"
37 Requires: systemd
38 %endif
39
40 # Uses function decorators
41 Requires: python >= 2.7
42 # connecting PLC
43 Requires: python-pycurl
44 # Signed tickets
45 Requires: gnupg
46 # sioc/plnet
47 Requires: pyplnet >= 4.3
48 # we do need the slice images in any case
49 Requires: sliceimage-%{slicefamily}
50 # for bwlimit
51 Requires: plnode-utils
52
53 %description
54 The PlanetLab Node Manager manages all aspects of PlanetLab node and
55 slice management once the node has been initialized and configured by
56 the Boot Manager. It periodically contacts its management authority
57 for configuration updates. It provides an XML-RPC API for performing
58 local operations on slices.
59 nodemanager-lib only provides a skeleton and needs as a companion
60 either nodemanager-vs or nodemanager-lxc
61
62 ##############################
63 %prep
64 %setup -q
65
66 %build
67 # make manages the C and Python stuff
68 %{__make} %{?_smp_mflags} %{make_options} lib 
69
70 %install
71 # make manages the C and Python stuff
72 rm -rf $RPM_BUILD_ROOT
73 %{__make} %{?_smp_mflags} %{make_options} install-lib DESTDIR="$RPM_BUILD_ROOT"
74
75 ##############################
76 %post
77 ########## traditional init
78 %if "%{initdir}" == "%{_initrddir}"
79 ##########
80 chkconfig --add conf_files
81 chkconfig conf_files on
82 chkconfig --add nm
83 chkconfig nm on
84 chkconfig --add fuse-pl
85 chkconfig fuse-pl on
86 if [ "$PL_BOOTCD" != "1" ] ; then
87     service nm restart
88     service fuse-pl restart
89 fi
90 ##########
91 %else
92 ########## systemd
93 systemctl enable nm.service
94 systemctl enable conf_files.service
95 # empty
96 #systemctl enable fuse-pl.service
97 if [ "$PL_BOOTCD" != "1" ] ; then
98     systemctl restart nm.service
99 #    systemctl restart fuse-pl.service
100 fi
101 ##########
102 %endif
103
104 ##############################
105 %preun
106 # 0 = erase, 1 = upgrade
107 ########## traditional init
108 %if "%{initdir}" == "%{_initrddir}"
109 ##########
110 if [ $1 -eq 0 ] ; then
111     chkconfig fuse-pl off
112     chkconfig --del fuse-pl
113     chkconfig nm off
114     chkconfig --del nm
115     chkconfig conf_files off
116     chkconfig --del conf_files
117 fi
118 ##########
119 %else
120 ########## systemd
121 if [ $1 -eq 0 ] ; then
122 #    systemctl disable fuse-pl.service
123     systemctl disable conf_files.service
124     systemctl disable nm.service
125 fi
126 ##########
127 %endif
128
129 ##############################
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %files
134 %defattr(-,root,root,-)
135 %{_datadir}/NodeManager/
136 %{_bindir}/forward_api_calls
137 %{initdir}/
138 %{_sysconfdir}/logrotate.d/nodemanager
139 /var/lib/nodemanager/
140 %config(noreplace) /etc/sysconfig/nodemanager
141
142 %changelog
143 * Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-13
144 - improve network management in slices
145 - _has_systemctl was not declared as global - vsys was failing to restart
146
147 * Fri Apr 04 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-12
148 - this tag for the first time passes the full range of tests on fedora20
149 - robustified slice teardown wrt vsys
150 - Scott's fix for repairing veth devs
151 - removed sshsh
152 - tools.has_systemctl
153
154 * Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-11
155 - ship /etc/sysconfig/nodemanager
156 - trash sshsh
157
158 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-10
159 - comes with systemd native unit files on >= f18
160 - user-provided initscript gets started through systemd in slivers >= f18
161 - smarter to locate cgroups for various versions of libvirt
162 - nicer log format - and log program termination
163 - tweaks in codemux plugin
164 - bug fixes in libvirt driver, esp. for finding out if domain is running
165
166 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
167 - fixes in hostmap, and in interfaces
168 - new vsys_sysctl
169 - privatebridge now comes with nodemanager-lib
170
171 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
172 - omf plugin does not block any longer when running trigger script
173 - log goes into sliver's /var/log instead
174
175 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
176 - new install-scripts target in Makefile
177 - conf_files and fuse-pl initscripts chmod'ed +x
178 - omf_resctl config template tweaked to use _slicename_%_hostname_
179
180 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
181 - make sure to create /etc/planetlab/virt so others can read that
182 - expose get_node_virt() and command_in_slice()
183 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
184 - user's .profile now has right owner
185 - other tweaks in lxc slivers
186
187 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
188 - lxc slice creation: slice user was created with unknown gid - fixed
189 - lxc slice creation: .profile for root and user - fixed
190
191 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
192 - fix umounting of ssh directory when deleting omf-friendly slivers
193 - support for writing cgroups in subsystems other than cpuset
194 - add xid to template match
195 - finer-grained split between -lib -vs and -lxc
196 - first roughly complete omf_resctl for omfv6
197 - minor fix for when getslivers does not have minexemptrate
198
199 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
200 - Fix path, machine arch in slivers
201
202 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
203
204 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
205 - no-op bump to 5.2 to be in line with the rest of the system
206
207 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
208 - improvements to privatebridge
209
210 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
211 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
212
213 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
214 - fix wrong gre tunnel deleted when topology changes
215
216 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
217 - Update /etc/hosts in slivers from sliver_hostmap tag.
218
219 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
220 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
221 - initial check-in of privatebridge plugin.
222
223 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
224 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
225
226 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
227 - fix slices not deleted properly when they use vsys
228
229 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
230 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
231
232 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
233 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
234
235 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
236 - Bridge virtual interfaces to VLANs
237
238 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
239 - Add support for L2 bridged interfaces with public IPs inside a slice
240
241 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
242 - Support for freezing BestEffort slices for Vicci
243
244 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
245 - Change to use new vsh (wrapper for lxcsu)
246
247 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
248 - add missing import
249 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
250
251 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
252 - tag 2.1-7 was broken for OMF-friendly slices
253 - expose_ssh_dir was erroneously defined on the Worker class
254
255 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
256 - bwlimitlxc now ships with plnode-utils
257
258 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
259 - set LD_PRELOAD for linux-containers nodes
260
261 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
262 - first complete version for vs and lxc - functional but not thoroughly tested though
263
264 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
265 - split packaging in 3 (lib, lxc, vs)
266 - this tag will only work with lxc though
267
268 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
269 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
270
271 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
272 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
273 - purpose being to be able to run this branch on vserver nodes as well
274
275 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
276 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
277 - passes tests with lxc but won't build against vs due to conflict
278 - as bwlimit.py also ships with util-vserver-pl
279
280 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
281 - refactoring: isolate initscript functionality
282 - aimed at making initscript implementation with lxc straightforward
283 - show stack trace when module loading fails
284 - accounts.py renamed into account.py for consistency
285
286 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
287 - /var/log/nodemanager shows duration of mainloop
288
289 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
290 - first working draft for dealing with libvirt/lxc on f16 nodes
291 - not expected to work with mainline nodes (use 2.0 for that for now)
292
293 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
294 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
295
296 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
297 - Added memory scheduling to core scheduler
298 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
299
300 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
301 - tweaked log policy for the core scheduler
302 - curlwrapper has an optional verbose mode
303
304 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
305 - fixes for hmac and omf_control tags
306 - optional besteffort flag to core scheduler
307 - logrotate entry for /var/log/nodemanager.daemon
308 - a template for bash initscripts
309
310 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
311 - rename initscript_body into initscript_code
312 - fix generic vinit for broken bash syntax &>>
313
314 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
315 - new initscript_body slice tag, with stop and restart
316 - generic vinit script live updated
317 - new coresched module
318 - protect against non-existing vsys scripts
319 - use Config. instead of globals
320
321 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
322 - more robust reservation plugin
323
324 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
325 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
326 - reservation plugin more robust
327
328 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
329 - pass device to bwlimit
330
331 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
332 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
333
334 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
335 - Catch all exceptions for sfa plugin
336
337 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
338 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
339
340 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
341 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
342
343 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
344 - plugins/sliverauth.py improvements
345
346 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
347 - Disable sfagids plugin
348
349 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
350 - Re-tag nodemanager to include conflicted commits
351
352 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
353 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
354 - sfagids plugin deleted
355 - band-aid patch for lack of GetSliceFamily removed
356
357 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
358
359 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
360 - revert curlwrapper to former forking-curl version
361 - fixes in the omf plugin for ssh key location and node hrn
362 - set umask 0022 in tools.daemon
363
364 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
365 - configure omf-resctl for keys
366
367 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
368 - fix key generation
369
370 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
371 - name changes and fix typos
372
373 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
374 - remove config and options parameters from start function
375
376 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
377 - working version of reservable nodes
378 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
379 - dismantled the -s|--startup option (no convincing need for that)
380 - simpler and more robust init.d/nm
381 - initscript content management through replace_file_with_string
382 - sliverauth uses replace_file_with_string
383 - curlwrapper has a debug mode
384
385 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
386 - pretty-printing/normalized python code - hopefully neutral
387
388 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
389 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
390 - that triggers /etc/init.d/vinit.slice if present and executable
391 - (2) install the slice-provided initscript (as per the initscript tag) as
392 - /etc/init.d/vinit.slice
393 - (3) as a result the initscript are now triggered by rc as part of the
394 - standard vserver .. start, properly attached to the vserver,
395 - and properly killed upon vserver .. stop
396 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
397
398 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
399 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
400 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
401 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
402 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
403 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
404 - cleanup: nodemanger now is a class; however plugins are still dumb modules
405 - cleanup: does not depend on obsolete Set
406
407 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
408 - tagging before RC
409
410 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
411 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
412 - Added some precautions to the slice id-saving code
413 - Added log message to code that records the slice id
414
415 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
416 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
417 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
418 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
419
420 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
421 - fix log_call in plugins/drl.py
422
423 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
424 - protect against nodes in migrated PLC's not having the hrn tag yet
425
426 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
427 - new omf-resctl and drl plugins
428 - specialaccount optimized to overwrite authorized keys only upon changes
429 - codemux plugin has support for a new 'ip' setting
430 - mainloop to display ordered modules&plugins at all times
431
432 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
433 - modules and plugins have a priority
434 - specialaccounts appears soon in the priority chain
435 - logger.log_call logs process output, and has a timeout
436 - vuser{add,del} run through bash -x
437 - nm initscript has support for 'service nm restartverbose'
438 - logs reviewed for consistency
439 - use hashlib module instead of sha when available
440
441 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
442 - first working version of 5.0:
443 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
444 - nodefamily is 3-fold with pldistro-fcdistro-arch
445 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
446 - (in addition to the 'vref' tag that's still exposed too)
447 - logging reviewed for more convenience
448 - support for 'service nm restartdebug'
449 - make sync knows how to publish uncommitted code on a test node
450
451 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
452 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
453
454 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
455 - support for f10 and f12 in the vref slice tag
456
457 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
458 - build on fedora12
459 - uses slicename 'sfacm' instead of 'genicw'
460
461 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
462 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
463 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
464 - days ago.
465
466 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
467 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
468 - self-contained. With this change, they will be able to refer to the attributes associated with a
469 - slice.
470
471 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
472 - fix for syntax error
473
474 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
475 - -fixed problem with sioc import at the build side
476 - -bwlimit.set() now accepts the device and does not asume that it is eth0
477
478 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
479 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
480
481 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
482 - The seed for random previously was the meaning of life (i.e., 42) but
483 - that resulted in a not so random choice for the hmac.  This
484 - implementation now uses a random.seed that is based on the current
485 - time.
486
487 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
488 - Minor fix such that sliverauth.py makes a more specific call to
489 - GetSliceTags that include that specific tagname it is looking for.
490
491 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
492 - Fix bug that prevented 'OVERRIDES' for working correctly.
493
494 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
495 - Increase disk limits to 10G per sliver
496 - Sanity check slice for home directory before starting (hack)
497 - Check codemux arguments
498
499 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
500 - * Fix Delegation
501 - * Move plcapi in plugin-api GetSlivers() calls.
502 - * Persistent Authcheck and resync session when auth failure
503
504 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
505 - Disabling sliverauth module.  Not ready for deployment.
506
507 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
508 - Fixing overrides semantics.
509
510 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
511 - Generalized plugins
512 - Fixed initscript start up bug.
513
514 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
515 - * Fix delegation authentication problem
516 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
517
518 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
519 - * Rerun initscripts when slice goes from disabled to enabled.
520
521 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
522 - * Update session key when out of synch with PLC
523 - * PLCDefaults uses tagname
524
525 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
526 - log invokations of vsys
527
528 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
529
530 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
531
532 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
533 - Codemux supports multiple hosts mapping to single slice
534 - Fixed bug in delegation support where tickets delivered weren't
535   being passed to sm.deliver_ticket().
536
537 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
538 - Codemux now configured via slice attribute (host,port)
539 - Support for multiple vserver reference images (including different archs)
540 - Mom BW emails are sent to list defined by MyPLC's config
541 - Sirius BW loans honored correctly.  Fixed.
542 - BW totals preserved for dynamic slices so as not to game the system.
543
544 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
545 - Configures vsys via vsys slice attribute {name: vsys, value: script}
546 - CPU reservations are now calculated via percentages instead of shares
547 - BW totals preserved for dynamic slices
548 - Closes bug where node cap sets off bw slice alarms for all slices.
549
550 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
551 - Switched to SVN.
552
553 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
554 - Initial build.