dfa2f703acd06b99e459cbeb176b056ee27a15fe
[nodemanager.git] / nodemanager-lib.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 5.2
5 %define taglevel 9
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 Summary: PlanetLab Node Manager Library
10 Name: %{name}
11 Version: %{version}
12 Release: %{release}
13 License: PlanetLab
14 Group: System Environment/Daemons
15 Source0: %{name}-%{version}.tar.gz
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17
18 Vendor: PlanetLab
19 Packager: PlanetLab Central <support@planet-lab.org>
20 Distribution: PlanetLab %{plrelease}
21 URL: %{SCMURL}
22
23 # not possible because of forward_api_calls
24 #BuildArch: noarch
25
26 # Uses function decorators
27 Requires: python >= 2.4
28 # connecting PLC
29 Requires: python-pycurl
30 # Signed tickets
31 Requires: gnupg
32 # sioc/plnet
33 Requires: pyplnet >= 4.3
34 # we do need the slice images in any case
35 Requires: sliceimage-%{slicefamily}
36 # for bwlimit
37 Requires: plnode-utils
38
39 %description
40 The PlanetLab Node Manager manages all aspects of PlanetLab node and
41 slice management once the node has been initialized and configured by
42 the Boot Manager. It periodically contacts its management authority
43 for configuration updates. It provides an XML-RPC API for performing
44 local operations on slices.
45 nodemanager-lib only provides a skeleton and needs as a companion
46 either nodemanager-vs or nodemanager-lxc
47
48 # use initscripts or systemd unit files to start installed services
49 %if "%{distro}" == "Fedora" && %{distrorelease} >= 18
50 %define make_options WITH_SYSTEMD=true
51 %else
52 %define make_options WITH_INIT=true
53 %endif
54
55 %prep
56 %setup -q
57
58 %build
59 # make manages the C and Python stuff
60 %{__make} %{?_smp_mflags} %{make_options} lib 
61
62 %install
63 # make manages the C and Python stuff
64 rm -rf $RPM_BUILD_ROOT
65 %{__make} %{?_smp_mflags} %{make_options} install-lib DESTDIR="$RPM_BUILD_ROOT"
66
67 # install the sliver initscript (that triggers the slice initscript if any)
68 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
69 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
70 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
71
72 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
73 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
74 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
75
76 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
77
78 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
79 install -D -m 755 sshsh $RPM_BUILD_ROOT/bin/sshsh
80
81 ##########
82 %post
83 # tmp - handle file renamings; old names are from 2.0-8
84 renamings="
85 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
86 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
87 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
88 /var/log/nm@/var/log/nodemanager
89 /var/log/nm.daemon@/var/log/nodemanager.daemon
90 /var/run/nm.pid@/var/run/nodemanager.pid
91 /tmp/sliver_mgr.api@/tmp/nodemanager.api
92 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
93 "
94 for renaming in $renamings; do
95   old=$(echo $renaming | cut -d@ -f1)
96   new=$(echo $renaming | cut -d@ -f2)
97   newdir=$(dirname $new)
98   if [ -e "$old" -a ! -e "$new" ] ; then
99       mkdir -p $newdir
100       mv -f $old $new
101   fi
102 done
103 #
104 chkconfig --add conf_files
105 chkconfig conf_files on
106 chkconfig --add nm
107 chkconfig nm on
108 chkconfig --add fuse-pl
109 chkconfig fuse-pl on
110 if [ "$PL_BOOTCD" != "1" ] ; then
111         service nm restart
112         service fuse-pl restart
113 fi
114
115 ##########
116 %preun
117 # 0 = erase, 1 = upgrade
118 if [ $1 -eq 0 ] ; then
119     chkconfig fuse-pl off
120     chkconfig --del fuse-pl
121     chkconfig nm off
122     chkconfig --del nm
123     chkconfig conf_files off
124     chkconfig --del conf_files
125 fi
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %files
131 %defattr(-,root,root,-)
132 %{_datadir}/NodeManager/
133 %{_bindir}/forward_api_calls
134 %{_initrddir}/
135 %{_sysconfdir}/logrotate.d/nodemanager
136 /var/lib/
137 /bin/sshsh
138
139 %changelog
140 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
141 - fixes in hostmap, and in interfaces
142 - new vsys_sysctl
143 - privatebridge now comes with nodemanager-lib
144
145 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
146 - omf plugin does not block any longer when running trigger script
147 - log goes into sliver's /var/log instead
148
149 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
150 - new install-scripts target in Makefile
151 - conf_files and fuse-pl initscripts chmod'ed +x
152 - omf_resctl config template tweaked to use _slicename_%_hostname_
153
154 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
155 - make sure to create /etc/planetlab/virt so others can read that
156 - expose get_node_virt() and command_in_slice()
157 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
158 - user's .profile now has right owner
159 - other tweaks in lxc slivers
160
161 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
162 - lxc slice creation: slice user was created with unknown gid - fixed
163 - lxc slice creation: .profile for root and user - fixed
164
165 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
166 - fix umounting of ssh directory when deleting omf-friendly slivers
167 - support for writing cgroups in subsystems other than cpuset
168 - add xid to template match
169 - finer-grained split between -lib -vs and -lxc
170 - first roughly complete omf_resctl for omfv6
171 - minor fix for when getslivers does not have minexemptrate
172
173 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
174 - Fix path, machine arch in slivers
175
176 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
177
178 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
179 - no-op bump to 5.2 to be in line with the rest of the system
180
181 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
182 - improvements to privatebridge
183
184 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
185 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
186
187 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
188 - fix wrong gre tunnel deleted when topology changes
189
190 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
191 - Update /etc/hosts in slivers from sliver_hostmap tag.
192
193 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
194 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
195 - initial check-in of privatebridge plugin.
196
197 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
198 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
199
200 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
201 - fix slices not deleted properly when they use vsys
202
203 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
204 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
205
206 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
207 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
208
209 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
210 - Bridge virtual interfaces to VLANs
211
212 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
213 - Add support for L2 bridged interfaces with public IPs inside a slice
214
215 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
216 - Support for freezing BestEffort slices for Vicci
217
218 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
219 - Change to use new vsh (wrapper for lxcsu)
220
221 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
222 - add missing import
223 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
224
225 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
226 - tag 2.1-7 was broken for OMF-friendly slices
227 - expose_ssh_dir was erroneously defined on the Worker class
228
229 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
230 - bwlimitlxc now ships with plnode-utils
231
232 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
233 - set LD_PRELOAD for linux-containers nodes
234
235 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
236 - first complete version for vs and lxc - functional but not thoroughly tested though
237
238 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
239 - split packaging in 3 (lib, lxc, vs)
240 - this tag will only work with lxc though
241
242 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
243 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
244
245 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
246 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
247 - purpose being to be able to run this branch on vserver nodes as well
248
249 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
250 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
251 - passes tests with lxc but won't build against vs due to conflict
252 - as bwlimit.py also ships with util-vserver-pl
253
254 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
255 - refactoring: isolate initscript functionality
256 - aimed at making initscript implementation with lxc straightforward
257 - show stack trace when module loading fails
258 - accounts.py renamed into account.py for consistency
259
260 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
261 - /var/log/nodemanager shows duration of mainloop
262
263 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
264 - first working draft for dealing with libvirt/lxc on f16 nodes
265 - not expected to work with mainline nodes (use 2.0 for that for now)
266
267 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
268 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
269
270 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
271 - Added memory scheduling to core scheduler
272 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
273
274 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
275 - tweaked log policy for the core scheduler
276 - curlwrapper has an optional verbose mode
277
278 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
279 - fixes for hmac and omf_control tags
280 - optional besteffort flag to core scheduler
281 - logrotate entry for /var/log/nodemanager.daemon
282 - a template for bash initscripts
283
284 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
285 - rename initscript_body into initscript_code
286 - fix generic vinit for broken bash syntax &>>
287
288 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
289 - new initscript_body slice tag, with stop and restart
290 - generic vinit script live updated
291 - new coresched module
292 - protect against non-existing vsys scripts
293 - use Config. instead of globals
294
295 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
296 - more robust reservation plugin
297
298 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
299 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
300 - reservation plugin more robust
301
302 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
303 - pass device to bwlimit
304
305 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
306 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
307
308 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
309 - Catch all exceptions for sfa plugin
310
311 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
312 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
313
314 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
315 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
316
317 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
318 - plugins/sliverauth.py improvements
319
320 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
321 - Disable sfagids plugin
322
323 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
324 - Re-tag nodemanager to include conflicted commits
325
326 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
327 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
328 - sfagids plugin deleted
329 - band-aid patch for lack of GetSliceFamily removed
330
331 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
332
333 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
334 - revert curlwrapper to former forking-curl version
335 - fixes in the omf plugin for ssh key location and node hrn
336 - set umask 0022 in tools.daemon
337
338 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
339 - configure omf-resctl for keys
340
341 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
342 - fix key generation
343
344 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
345 - name changes and fix typos
346
347 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
348 - remove config and options parameters from start function
349
350 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
351 - working version of reservable nodes
352 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
353 - dismantled the -s|--startup option (no convincing need for that)
354 - simpler and more robust init.d/nm
355 - initscript content management through replace_file_with_string
356 - sliverauth uses replace_file_with_string
357 - curlwrapper has a debug mode
358
359 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
360 - pretty-printing/normalized python code - hopefully neutral
361
362 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
363 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
364 - that triggers /etc/init.d/vinit.slice if present and executable
365 - (2) install the slice-provided initscript (as per the initscript tag) as
366 - /etc/init.d/vinit.slice
367 - (3) as a result the initscript are now triggered by rc as part of the
368 - standard vserver .. start, properly attached to the vserver,
369 - and properly killed upon vserver .. stop
370 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
371
372 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
373 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
374 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
375 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
376 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
377 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
378 - cleanup: nodemanger now is a class; however plugins are still dumb modules
379 - cleanup: does not depend on obsolete Set
380
381 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
382 - tagging before RC
383
384 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
385 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
386 - Added some precautions to the slice id-saving code
387 - Added log message to code that records the slice id
388
389 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
390 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
391 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
392 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
393
394 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
395 - fix log_call in plugins/drl.py
396
397 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
398 - protect against nodes in migrated PLC's not having the hrn tag yet
399
400 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
401 - new omf-resctl and drl plugins
402 - specialaccount optimized to overwrite authorized keys only upon changes
403 - codemux plugin has support for a new 'ip' setting
404 - mainloop to display ordered modules&plugins at all times
405
406 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
407 - modules and plugins have a priority
408 - specialaccounts appears soon in the priority chain
409 - logger.log_call logs process output, and has a timeout
410 - vuser{add,del} run through bash -x
411 - nm initscript has support for 'service nm restartverbose'
412 - logs reviewed for consistency
413 - use hashlib module instead of sha when available
414
415 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
416 - first working version of 5.0:
417 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
418 - nodefamily is 3-fold with pldistro-fcdistro-arch
419 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
420 - (in addition to the 'vref' tag that's still exposed too)
421 - logging reviewed for more convenience
422 - support for 'service nm restartdebug'
423 - make sync knows how to publish uncommitted code on a test node
424
425 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
426 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
427
428 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
429 - support for f10 and f12 in the vref slice tag
430
431 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
432 - build on fedora12
433 - uses slicename 'sfacm' instead of 'genicw'
434
435 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
436 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
437 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
438 - days ago.
439
440 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
441 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
442 - self-contained. With this change, they will be able to refer to the attributes associated with a
443 - slice.
444
445 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
446 - fix for syntax error
447
448 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
449 - -fixed problem with sioc import at the build side
450 - -bwlimit.set() now accepts the device and does not asume that it is eth0
451
452 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
453 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
454
455 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
456 - The seed for random previously was the meaning of life (i.e., 42) but
457 - that resulted in a not so random choice for the hmac.  This
458 - implementation now uses a random.seed that is based on the current
459 - time.
460
461 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
462 - Minor fix such that sliverauth.py makes a more specific call to
463 - GetSliceTags that include that specific tagname it is looking for.
464
465 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
466 - Fix bug that prevented 'OVERRIDES' for working correctly.
467
468 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
469 - Increase disk limits to 10G per sliver
470 - Sanity check slice for home directory before starting (hack)
471 - Check codemux arguments
472
473 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
474 - * Fix Delegation
475 - * Move plcapi in plugin-api GetSlivers() calls.
476 - * Persistent Authcheck and resync session when auth failure
477
478 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
479 - Disabling sliverauth module.  Not ready for deployment.
480
481 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
482 - Fixing overrides semantics.
483
484 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
485 - Generalized plugins
486 - Fixed initscript start up bug.
487
488 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
489 - * Fix delegation authentication problem
490 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
491
492 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
493 - * Rerun initscripts when slice goes from disabled to enabled.
494
495 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
496 - * Update session key when out of synch with PLC
497 - * PLCDefaults uses tagname
498
499 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
500 - log invokations of vsys
501
502 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
503
504 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
505
506 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
507 - Codemux supports multiple hosts mapping to single slice
508 - Fixed bug in delegation support where tickets delivered weren't
509   being passed to sm.deliver_ticket().
510
511 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
512 - Codemux now configured via slice attribute (host,port)
513 - Support for multiple vserver reference images (including different archs)
514 - Mom BW emails are sent to list defined by MyPLC's config
515 - Sirius BW loans honored correctly.  Fixed.
516 - BW totals preserved for dynamic slices so as not to game the system.
517
518 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
519 - Configures vsys via vsys slice attribute {name: vsys, value: script}
520 - CPU reservations are now calculated via percentages instead of shares
521 - BW totals preserved for dynamic slices
522 - Closes bug where node cap sets off bw slice alarms for all slices.
523
524 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
525 - Switched to SVN.
526
527 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
528 - Initial build.