Setting tag nodemanager-5.2-7
[nodemanager.git] / nodemanager-lib.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 5.2
5 %define taglevel 7
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
9
10 Summary: PlanetLab Node Manager Library
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: System Environment/Daemons
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 # not possible because of forward_api_calls
25 #BuildArch: noarch
26
27 # Uses function decorators
28 Requires: python >= 2.4
29 # connecting PLC
30 Requires: python-pycurl
31 # Signed tickets
32 Requires: gnupg
33 # sioc/plnet
34 Requires: pyplnet >= 4.3
35 # we do need the slice images in any case
36 Requires: sliceimage-%{slicefamily}
37 # for bwlimit
38 Requires: plnode-utils
39
40 %description
41 The PlanetLab Node Manager manages all aspects of PlanetLab node and
42 slice management once the node has been initialized and configured by
43 the Boot Manager. It periodically contacts its management authority
44 for configuration updates. It provides an XML-RPC API for performing
45 local operations on slices.
46 nodemanager-lib only provides a skeleton and needs as a companion
47 either nodemanager-vs or nodemanager-lxc
48
49 %prep
50 %setup -q
51
52 %build
53 # make manages the C and Python stuff
54 %{__make} %{?_smp_mflags} lib
55
56 %install
57 # make manages the C and Python stuff
58 rm -rf $RPM_BUILD_ROOT
59 %{__make} %{?_smp_mflags} install-lib DESTDIR="$RPM_BUILD_ROOT"
60 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
61
62 # install the sliver initscript (that triggers the slice initscript if any)
63 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
64 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
65 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
66
67 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
68 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
69 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
70
71 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
72
73 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
74 install -D -m 755 sshsh $RPM_BUILD_ROOT/bin/sshsh
75
76 ##########
77 %post
78 # tmp - handle file renamings; old names are from 2.0-8
79 renamings="
80 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
81 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
82 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
83 /var/log/nm@/var/log/nodemanager
84 /var/log/nm.daemon@/var/log/nodemanager.daemon
85 /var/run/nm.pid@/var/run/nodemanager.pid
86 /tmp/sliver_mgr.api@/tmp/nodemanager.api
87 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
88 "
89 for renaming in $renamings; do
90   old=$(echo $renaming | cut -d@ -f1)
91   new=$(echo $renaming | cut -d@ -f2)
92   newdir=$(dirname $new)
93   if [ -e "$old" -a ! -e "$new" ] ; then
94       mkdir -p $newdir
95       mv -f $old $new
96   fi
97 done
98 #
99 chkconfig --add conf_files
100 chkconfig conf_files on
101 chkconfig --add nm
102 chkconfig nm on
103 chkconfig --add fuse-pl
104 chkconfig fuse-pl on
105 if [ "$PL_BOOTCD" != "1" ] ; then
106         service nm restart
107         service fuse-pl restart
108 fi
109
110 ##########
111 %preun
112 # 0 = erase, 1 = upgrade
113 if [ $1 -eq 0 ] ; then
114     chkconfig fuse-pl off
115     chkconfig --del fuse-pl
116     chkconfig nm off
117     chkconfig --del nm
118     chkconfig conf_files off
119     chkconfig --del conf_files
120 fi
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(-,root,root,-)
127 %{_datadir}/NodeManager/
128 %{_bindir}/forward_api_calls
129 %{_initrddir}/
130 %{_sysconfdir}/logrotate.d/nodemanager
131 /var/lib/
132 /bin/sshsh
133
134 %changelog
135 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
136 - new install-scripts target in Makefile
137 - conf_files and fuse-pl initscripts chmod'ed +x
138 - omf_resctl config template tweaked to use _slicename_%_hostname_
139
140 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
141 - make sure to create /etc/planetlab/virt so others can read that
142 - expose get_node_virt() and command_in_slice()
143 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
144 - user's .profile now has right owner
145 - other tweaks in lxc slivers
146
147 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
148 - lxc slice creation: slice user was created with unknown gid - fixed
149 - lxc slice creation: .profile for root and user - fixed
150
151 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
152 - fix umounting of ssh directory when deleting omf-friendly slivers
153 - support for writing cgroups in subsystems other than cpuset
154 - add xid to template match
155 - finer-grained split between -lib -vs and -lxc
156 - first roughly complete omf_resctl for omfv6
157 - minor fix for when getslivers does not have minexemptrate
158
159 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
160 - Fix path, machine arch in slivers
161
162 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
163
164 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
165 - no-op bump to 5.2 to be in line with the rest of the system
166
167 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
168 - improvements to privatebridge
169
170 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
171 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
172
173 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
174 - fix wrong gre tunnel deleted when topology changes
175
176 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
177 - Update /etc/hosts in slivers from sliver_hostmap tag.
178
179 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
180 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
181 - initial check-in of privatebridge plugin.
182
183 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
184 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
185
186 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
187 - fix slices not deleted properly when they use vsys
188
189 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
190 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
191
192 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
193 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
194
195 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
196 - Bridge virtual interfaces to VLANs
197
198 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
199 - Add support for L2 bridged interfaces with public IPs inside a slice
200
201 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
202 - Support for freezing BestEffort slices for Vicci
203
204 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
205 - Change to use new vsh (wrapper for lxcsu)
206
207 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
208 - add missing import
209 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
210
211 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
212 - tag 2.1-7 was broken for OMF-friendly slices
213 - expose_ssh_dir was erroneously defined on the Worker class
214
215 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
216 - bwlimitlxc now ships with plnode-utils
217
218 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
219 - set LD_PRELOAD for linux-containers nodes
220
221 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
222 - first complete version for vs and lxc - functional but not thoroughly tested though
223
224 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
225 - split packaging in 3 (lib, lxc, vs)
226 - this tag will only work with lxc though
227
228 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
229 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
230
231 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
232 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
233 - purpose being to be able to run this branch on vserver nodes as well
234
235 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
236 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
237 - passes tests with lxc but won't build against vs due to conflict
238 - as bwlimit.py also ships with util-vserver-pl
239
240 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
241 - refactoring: isolate initscript functionality
242 - aimed at making initscript implementation with lxc straightforward
243 - show stack trace when module loading fails
244 - accounts.py renamed into account.py for consistency
245
246 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
247 - /var/log/nodemanager shows duration of mainloop
248
249 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
250 - first working draft for dealing with libvirt/lxc on f16 nodes
251 - not expected to work with mainline nodes (use 2.0 for that for now)
252
253 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
254 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
255
256 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
257 - Added memory scheduling to core scheduler
258 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
259
260 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
261 - tweaked log policy for the core scheduler
262 - curlwrapper has an optional verbose mode
263
264 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
265 - fixes for hmac and omf_control tags
266 - optional besteffort flag to core scheduler
267 - logrotate entry for /var/log/nodemanager.daemon
268 - a template for bash initscripts
269
270 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
271 - rename initscript_body into initscript_code
272 - fix generic vinit for broken bash syntax &>>
273
274 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
275 - new initscript_body slice tag, with stop and restart
276 - generic vinit script live updated
277 - new coresched module
278 - protect against non-existing vsys scripts
279 - use Config. instead of globals
280
281 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
282 - more robust reservation plugin
283
284 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
285 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
286 - reservation plugin more robust
287
288 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
289 - pass device to bwlimit
290
291 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
292 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
293
294 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
295 - Catch all exceptions for sfa plugin
296
297 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
298 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
299
300 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
301 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
302
303 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
304 - plugins/sliverauth.py improvements
305
306 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
307 - Disable sfagids plugin
308
309 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
310 - Re-tag nodemanager to include conflicted commits
311
312 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
313 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
314 - sfagids plugin deleted
315 - band-aid patch for lack of GetSliceFamily removed
316
317 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
318
319 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
320 - revert curlwrapper to former forking-curl version
321 - fixes in the omf plugin for ssh key location and node hrn
322 - set umask 0022 in tools.daemon
323
324 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
325 - configure omf-resctl for keys
326
327 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
328 - fix key generation
329
330 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
331 - name changes and fix typos
332
333 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
334 - remove config and options parameters from start function
335
336 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
337 - working version of reservable nodes
338 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
339 - dismantled the -s|--startup option (no convincing need for that)
340 - simpler and more robust init.d/nm
341 - initscript content management through replace_file_with_string
342 - sliverauth uses replace_file_with_string
343 - curlwrapper has a debug mode
344
345 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
346 - pretty-printing/normalized python code - hopefully neutral
347
348 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
349 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
350 - that triggers /etc/init.d/vinit.slice if present and executable
351 - (2) install the slice-provided initscript (as per the initscript tag) as
352 - /etc/init.d/vinit.slice
353 - (3) as a result the initscript are now triggered by rc as part of the
354 - standard vserver .. start, properly attached to the vserver,
355 - and properly killed upon vserver .. stop
356 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
357
358 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
359 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
360 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
361 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
362 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
363 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
364 - cleanup: nodemanger now is a class; however plugins are still dumb modules
365 - cleanup: does not depend on obsolete Set
366
367 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
368 - tagging before RC
369
370 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
371 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
372 - Added some precautions to the slice id-saving code
373 - Added log message to code that records the slice id
374
375 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
376 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
377 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
378 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
379
380 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
381 - fix log_call in plugins/drl.py
382
383 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
384 - protect against nodes in migrated PLC's not having the hrn tag yet
385
386 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
387 - new omf-resctl and drl plugins
388 - specialaccount optimized to overwrite authorized keys only upon changes
389 - codemux plugin has support for a new 'ip' setting
390 - mainloop to display ordered modules&plugins at all times
391
392 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
393 - modules and plugins have a priority
394 - specialaccounts appears soon in the priority chain
395 - logger.log_call logs process output, and has a timeout
396 - vuser{add,del} run through bash -x
397 - nm initscript has support for 'service nm restartverbose'
398 - logs reviewed for consistency
399 - use hashlib module instead of sha when available
400
401 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
402 - first working version of 5.0:
403 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
404 - nodefamily is 3-fold with pldistro-fcdistro-arch
405 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
406 - (in addition to the 'vref' tag that's still exposed too)
407 - logging reviewed for more convenience
408 - support for 'service nm restartdebug'
409 - make sync knows how to publish uncommitted code on a test node
410
411 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
412 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
413
414 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
415 - support for f10 and f12 in the vref slice tag
416
417 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
418 - build on fedora12
419 - uses slicename 'sfacm' instead of 'genicw'
420
421 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
422 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
423 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
424 - days ago.
425
426 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
427 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
428 - self-contained. With this change, they will be able to refer to the attributes associated with a
429 - slice.
430
431 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
432 - fix for syntax error
433
434 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
435 - -fixed problem with sioc import at the build side
436 - -bwlimit.set() now accepts the device and does not asume that it is eth0
437
438 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
439 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
440
441 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
442 - The seed for random previously was the meaning of life (i.e., 42) but
443 - that resulted in a not so random choice for the hmac.  This
444 - implementation now uses a random.seed that is based on the current
445 - time.
446
447 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
448 - Minor fix such that sliverauth.py makes a more specific call to
449 - GetSliceTags that include that specific tagname it is looking for.
450
451 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
452 - Fix bug that prevented 'OVERRIDES' for working correctly.
453
454 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
455 - Increase disk limits to 10G per sliver
456 - Sanity check slice for home directory before starting (hack)
457 - Check codemux arguments
458
459 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
460 - * Fix Delegation
461 - * Move plcapi in plugin-api GetSlivers() calls.
462 - * Persistent Authcheck and resync session when auth failure
463
464 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
465 - Disabling sliverauth module.  Not ready for deployment.
466
467 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
468 - Fixing overrides semantics.
469
470 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
471 - Generalized plugins
472 - Fixed initscript start up bug.
473
474 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
475 - * Fix delegation authentication problem
476 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
477
478 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
479 - * Rerun initscripts when slice goes from disabled to enabled.
480
481 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
482 - * Update session key when out of synch with PLC
483 - * PLCDefaults uses tagname
484
485 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
486 - log invokations of vsys
487
488 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
489
490 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
491
492 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
493 - Codemux supports multiple hosts mapping to single slice
494 - Fixed bug in delegation support where tickets delivered weren't
495   being passed to sm.deliver_ticket().
496
497 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
498 - Codemux now configured via slice attribute (host,port)
499 - Support for multiple vserver reference images (including different archs)
500 - Mom BW emails are sent to list defined by MyPLC's config
501 - Sirius BW loans honored correctly.  Fixed.
502 - BW totals preserved for dynamic slices so as not to game the system.
503
504 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
505 - Configures vsys via vsys slice attribute {name: vsys, value: script}
506 - CPU reservations are now calculated via percentages instead of shares
507 - BW totals preserved for dynamic slices
508 - Closes bug where node cap sets off bw slice alarms for all slices.
509
510 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
511 - Switched to SVN.
512
513 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
514 - Initial build.