give (chown) slice's .profile to slice
[nodemanager.git] / nodemanager-lib.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 5.2
5 %define taglevel 5
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
9
10 Summary: PlanetLab Node Manager Library
11 Name: %{name}
12 Version: %{version}
13 Release: %{release}
14 License: PlanetLab
15 Group: System Environment/Daemons
16 Source0: %{name}-%{version}.tar.gz
17 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19 Vendor: PlanetLab
20 Packager: PlanetLab Central <support@planet-lab.org>
21 Distribution: PlanetLab %{plrelease}
22 URL: %{SCMURL}
23
24 # not possible because of forward_api_calls
25 #BuildArch: noarch
26
27 # Uses function decorators
28 Requires: python >= 2.4
29 # connecting PLC
30 Requires: python-pycurl
31 # Signed tickets
32 Requires: gnupg
33 # sioc/plnet
34 Requires: pyplnet >= 4.3
35 # we do need the slice images in any case
36 Requires: sliceimage-%{slicefamily}
37 # for bwlimit
38 Requires: plnode-utils
39
40 %description
41 The PlanetLab Node Manager manages all aspects of PlanetLab node and
42 slice management once the node has been initialized and configured by
43 the Boot Manager. It periodically contacts its management authority
44 for configuration updates. It provides an XML-RPC API for performing
45 local operations on slices.
46 nodemanager-lib only provides a skeleton and needs as a companion
47 either nodemanager-vs or nodemanager-lxc
48
49 %prep
50 %setup -q
51
52 %build
53 # make manages the C and Python stuff
54 %{__make} %{?_smp_mflags} lib
55
56 %install
57 # make manages the C and Python stuff
58 rm -rf $RPM_BUILD_ROOT
59 %{__make} %{?_smp_mflags} install-lib DESTDIR="$RPM_BUILD_ROOT"
60 PYTHON_SITEARCH=`python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)'`
61
62 # install the sliver initscript (that triggers the slice initscript if any)
63 mkdir -p $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
64 rsync -av sliver-initscripts/ $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
65 chmod 755 $RPM_BUILD_ROOT/usr/share/NodeManager/sliver-initscripts/
66
67 mkdir -p $RPM_BUILD_ROOT/%{_initrddir}/
68 rsync -av initscripts/ $RPM_BUILD_ROOT/%{_initrddir}/
69 chmod 755 $RPM_BUILD_ROOT/%{_initrddir}/*
70
71 install -d -m 755 $RPM_BUILD_ROOT/var/lib/nodemanager
72
73 install -D -m 644 logrotate/nodemanager $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/nodemanager
74 install -D -m 755 sshsh $RPM_BUILD_ROOT/bin/sshsh
75
76 ##########
77 %post
78 # tmp - handle file renamings; old names are from 2.0-8
79 renamings="
80 /var/lib/misc/bwmon.dat@/var/lib/nodemanager/bwmon.pickle
81 /root/sliver_mgr_db.pickle@/var/lib/nodemanager/database.pickle
82 /var/log/getslivers.txt@/var/lib/nodemanager/getslivers.txt
83 /var/log/nm@/var/log/nodemanager
84 /var/log/nm.daemon@/var/log/nodemanager.daemon
85 /var/run/nm.pid@/var/run/nodemanager.pid
86 /tmp/sliver_mgr.api@/tmp/nodemanager.api
87 /etc/logrotate.d/nm@/etc/logrotate.d/nodemanager
88 "
89 for renaming in $renamings; do
90   old=$(echo $renaming | cut -d@ -f1)
91   new=$(echo $renaming | cut -d@ -f2)
92   newdir=$(dirname $new)
93   if [ -e "$old" -a ! -e "$new" ] ; then
94       mkdir -p $newdir
95       mv -f $old $new
96   fi
97 done
98 #
99 chkconfig --add conf_files
100 chkconfig conf_files on
101 chkconfig --add nm
102 chkconfig nm on
103 chkconfig --add fuse-pl
104 chkconfig fuse-pl on
105 if [ "$PL_BOOTCD" != "1" ] ; then
106         service nm restart
107         service fuse-pl restart
108 fi
109
110 ##########
111 %preun
112 # 0 = erase, 1 = upgrade
113 if [ $1 -eq 0 ] ; then
114     chkconfig fuse-pl off
115     chkconfig --del fuse-pl
116     chkconfig nm off
117     chkconfig --del nm
118     chkconfig conf_files off
119     chkconfig --del conf_files
120 fi
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(-,root,root,-)
127 %{_datadir}/NodeManager/
128 %{_bindir}/forward_api_calls
129 %{_initrddir}/
130 %{_sysconfdir}/logrotate.d/nodemanager
131 /var/lib/
132 /bin/sshsh
133
134 %changelog
135 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
136 - lxc slice creation: slice user was created with unknown gid - fixed
137 - lxc slice creation: .profile for root and user - fixed
138
139 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
140 - fix umounting of ssh directory when deleting omf-friendly slivers
141 - support for writing cgroups in subsystems other than cpuset
142 - add xid to template match
143 - finer-grained split between -lib -vs and -lxc
144 - first roughly complete omf_resctl for omfv6
145 - minor fix for when getslivers does not have minexemptrate
146
147 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
148 - Fix path, machine arch in slivers
149
150 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
151
152 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
153 - no-op bump to 5.2 to be in line with the rest of the system
154
155 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
156 - improvements to privatebridge
157
158 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
159 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
160
161 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
162 - fix wrong gre tunnel deleted when topology changes
163
164 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
165 - Update /etc/hosts in slivers from sliver_hostmap tag.
166
167 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
168 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
169 - initial check-in of privatebridge plugin.
170
171 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
172 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
173
174 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
175 - fix slices not deleted properly when they use vsys
176
177 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
178 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
179
180 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
181 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
182
183 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
184 - Bridge virtual interfaces to VLANs
185
186 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
187 - Add support for L2 bridged interfaces with public IPs inside a slice
188
189 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
190 - Support for freezing BestEffort slices for Vicci
191
192 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
193 - Change to use new vsh (wrapper for lxcsu)
194
195 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
196 - add missing import
197 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
198
199 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
200 - tag 2.1-7 was broken for OMF-friendly slices
201 - expose_ssh_dir was erroneously defined on the Worker class
202
203 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
204 - bwlimitlxc now ships with plnode-utils
205
206 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
207 - set LD_PRELOAD for linux-containers nodes
208
209 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
210 - first complete version for vs and lxc - functional but not thoroughly tested though
211
212 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
213 - split packaging in 3 (lib, lxc, vs)
214 - this tag will only work with lxc though
215
216 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
217 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
218
219 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
220 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
221 - purpose being to be able to run this branch on vserver nodes as well
222
223 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
224 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
225 - passes tests with lxc but won't build against vs due to conflict
226 - as bwlimit.py also ships with util-vserver-pl
227
228 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
229 - refactoring: isolate initscript functionality
230 - aimed at making initscript implementation with lxc straightforward
231 - show stack trace when module loading fails
232 - accounts.py renamed into account.py for consistency
233
234 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
235 - /var/log/nodemanager shows duration of mainloop
236
237 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
238 - first working draft for dealing with libvirt/lxc on f16 nodes
239 - not expected to work with mainline nodes (use 2.0 for that for now)
240
241 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
242 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
243
244 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
245 - Added memory scheduling to core scheduler
246 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
247
248 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
249 - tweaked log policy for the core scheduler
250 - curlwrapper has an optional verbose mode
251
252 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
253 - fixes for hmac and omf_control tags
254 - optional besteffort flag to core scheduler
255 - logrotate entry for /var/log/nodemanager.daemon
256 - a template for bash initscripts
257
258 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
259 - rename initscript_body into initscript_code
260 - fix generic vinit for broken bash syntax &>>
261
262 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
263 - new initscript_body slice tag, with stop and restart
264 - generic vinit script live updated
265 - new coresched module
266 - protect against non-existing vsys scripts
267 - use Config. instead of globals
268
269 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
270 - more robust reservation plugin
271
272 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
273 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
274 - reservation plugin more robust
275
276 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
277 - pass device to bwlimit
278
279 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
280 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
281
282 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
283 - Catch all exceptions for sfa plugin
284
285 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
286 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
287
288 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
289 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
290
291 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
292 - plugins/sliverauth.py improvements
293
294 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
295 - Disable sfagids plugin
296
297 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
298 - Re-tag nodemanager to include conflicted commits
299
300 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
301 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
302 - sfagids plugin deleted
303 - band-aid patch for lack of GetSliceFamily removed
304
305 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
306
307 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
308 - revert curlwrapper to former forking-curl version
309 - fixes in the omf plugin for ssh key location and node hrn
310 - set umask 0022 in tools.daemon
311
312 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
313 - configure omf-resctl for keys
314
315 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
316 - fix key generation
317
318 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
319 - name changes and fix typos
320
321 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
322 - remove config and options parameters from start function
323
324 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
325 - working version of reservable nodes
326 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
327 - dismantled the -s|--startup option (no convincing need for that)
328 - simpler and more robust init.d/nm
329 - initscript content management through replace_file_with_string
330 - sliverauth uses replace_file_with_string
331 - curlwrapper has a debug mode
332
333 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
334 - pretty-printing/normalized python code - hopefully neutral
335
336 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
337 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
338 - that triggers /etc/init.d/vinit.slice if present and executable
339 - (2) install the slice-provided initscript (as per the initscript tag) as
340 - /etc/init.d/vinit.slice
341 - (3) as a result the initscript are now triggered by rc as part of the
342 - standard vserver .. start, properly attached to the vserver,
343 - and properly killed upon vserver .. stop
344 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
345
346 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
347 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
348 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
349 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
350 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
351 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
352 - cleanup: nodemanger now is a class; however plugins are still dumb modules
353 - cleanup: does not depend on obsolete Set
354
355 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
356 - tagging before RC
357
358 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
359 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
360 - Added some precautions to the slice id-saving code
361 - Added log message to code that records the slice id
362
363 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
364 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
365 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
366 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
367
368 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
369 - fix log_call in plugins/drl.py
370
371 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
372 - protect against nodes in migrated PLC's not having the hrn tag yet
373
374 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
375 - new omf-resctl and drl plugins
376 - specialaccount optimized to overwrite authorized keys only upon changes
377 - codemux plugin has support for a new 'ip' setting
378 - mainloop to display ordered modules&plugins at all times
379
380 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
381 - modules and plugins have a priority
382 - specialaccounts appears soon in the priority chain
383 - logger.log_call logs process output, and has a timeout
384 - vuser{add,del} run through bash -x
385 - nm initscript has support for 'service nm restartverbose'
386 - logs reviewed for consistency
387 - use hashlib module instead of sha when available
388
389 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
390 - first working version of 5.0:
391 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
392 - nodefamily is 3-fold with pldistro-fcdistro-arch
393 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
394 - (in addition to the 'vref' tag that's still exposed too)
395 - logging reviewed for more convenience
396 - support for 'service nm restartdebug'
397 - make sync knows how to publish uncommitted code on a test node
398
399 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
400 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
401
402 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
403 - support for f10 and f12 in the vref slice tag
404
405 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
406 - build on fedora12
407 - uses slicename 'sfacm' instead of 'genicw'
408
409 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
410 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
411 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
412 - days ago.
413
414 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
415 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
416 - self-contained. With this change, they will be able to refer to the attributes associated with a
417 - slice.
418
419 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
420 - fix for syntax error
421
422 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
423 - -fixed problem with sioc import at the build side
424 - -bwlimit.set() now accepts the device and does not asume that it is eth0
425
426 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
427 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
428
429 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
430 - The seed for random previously was the meaning of life (i.e., 42) but
431 - that resulted in a not so random choice for the hmac.  This
432 - implementation now uses a random.seed that is based on the current
433 - time.
434
435 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
436 - Minor fix such that sliverauth.py makes a more specific call to
437 - GetSliceTags that include that specific tagname it is looking for.
438
439 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
440 - Fix bug that prevented 'OVERRIDES' for working correctly.
441
442 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
443 - Increase disk limits to 10G per sliver
444 - Sanity check slice for home directory before starting (hack)
445 - Check codemux arguments
446
447 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
448 - * Fix Delegation
449 - * Move plcapi in plugin-api GetSlivers() calls.
450 - * Persistent Authcheck and resync session when auth failure
451
452 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
453 - Disabling sliverauth module.  Not ready for deployment.
454
455 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
456 - Fixing overrides semantics.
457
458 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
459 - Generalized plugins
460 - Fixed initscript start up bug.
461
462 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
463 - * Fix delegation authentication problem
464 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
465
466 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
467 - * Rerun initscripts when slice goes from disabled to enabled.
468
469 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
470 - * Update session key when out of synch with PLC
471 - * PLCDefaults uses tagname
472
473 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
474 - log invokations of vsys
475
476 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
477
478 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
479
480 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
481 - Codemux supports multiple hosts mapping to single slice
482 - Fixed bug in delegation support where tickets delivered weren't
483   being passed to sm.deliver_ticket().
484
485 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
486 - Codemux now configured via slice attribute (host,port)
487 - Support for multiple vserver reference images (including different archs)
488 - Mom BW emails are sent to list defined by MyPLC's config
489 - Sirius BW loans honored correctly.  Fixed.
490 - BW totals preserved for dynamic slices so as not to game the system.
491
492 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
493 - Configures vsys via vsys slice attribute {name: vsys, value: script}
494 - CPU reservations are now calculated via percentages instead of shares
495 - BW totals preserved for dynamic slices
496 - Closes bug where node cap sets off bw slice alarms for all slices.
497
498 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
499 - Switched to SVN.
500
501 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
502 - Initial build.