fix slices that use vsys not deleted correctly
[nodemanager.git] / nodemanager-lxc.spec
1 # we define this in a separate specfile because we cannot produce all the 3 packages
2 # nodemanager-lib nodemanager-vs nodemanager-lxc in a single build
3
4 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
5
6 %define name nodemanager-lxc
7 %define version 2.1
8 %define taglevel 15
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Node Manager Plugin for lxc nodes
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: System Environment/Daemons
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %{SCMURL}
25
26 # we use libvirt
27 Requires: libvirt
28 Requires: libvirt-python
29 # cgroups.py needs this
30 Requires: python-inotify
31 # the common package for nodemanager
32 Requires: nodemanager-lib
33 # the lxc-specific tools for using slice images
34 Requires: lxc-sliceimage
35 Requires: openvswitch
36 # Requires: sliceimage-lxc-f16-x86_64 >= 5.1-3
37
38 %description
39 nodemanager-lxc provides the lxc code for the PlanetLab Node Manager.
40
41 %prep
42 %setup -q
43
44 %build
45 # make manages the C and Python stuff
46 %{__make} %{?_smp_mflags} lxc
47
48 %install
49 # make manages the C and Python stuff
50 rm -rf $RPM_BUILD_ROOT
51 %{__make} %{?_smp_mflags} install-lxc DESTDIR="$RPM_BUILD_ROOT"
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(-,root,root,-)
58 %{_datadir}/NodeManager/
59
60 %changelog
61 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
62 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
63
64 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
65 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
66
67 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
68 - Bridge virtual interfaces to VLANs
69
70 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
71 - Add support for L2 bridged interfaces with public IPs inside a slice
72
73 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
74 - Support for freezing BestEffort slices for Vicci
75
76 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
77 - Change to use new vsh (wrapper for lxcsu)
78
79 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
80 - add missing import
81 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
82
83 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
84 - tag 2.1-7 was broken for OMF-friendly slices
85 - expose_ssh_dir was erroneously defined on the Worker class
86
87 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
88 - bwlimitlxc now ships with plnode-utils
89
90 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
91 - set LD_PRELOAD for linux-containers nodes
92
93 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
94 - first complete version for vs and lxc - functional but not thoroughly tested though
95
96 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
97 - split packaging in 3 (lib, lxc, vs)
98 - this tag will only work with lxc though
99