install for sytemd *or* init
[nodemanager.git] / nodemanager-lxc.spec
1 # we define this in a separate specfile because we cannot produce all the 3 packages
2 # nodemanager-lib nodemanager-vs nodemanager-lxc in a single build
3
4 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
5
6 %define name nodemanager-lxc
7 %define version 5.2
8 %define taglevel 9
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Node Manager Plugin for lxc nodes
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: System Environment/Daemons
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %{SCMURL}
25
26 # for nodeupdate 
27 Provides: nodemanager
28
29 # we use libvirt
30 Requires: libvirt
31 Requires: libvirt-python
32 # cgroups.py needs this
33 Requires: python-inotify
34 # the common package for nodemanager
35 Requires: nodemanager-lib = %{version}
36 # the lxc-specific tools for using slice images
37 Requires: lxc-sliceimage
38 Requires: openvswitch
39 # Requires: sliceimage-lxc-f16-x86_64 >= 5.1-3
40
41 %description
42 nodemanager-lxc provides the lxc code for the PlanetLab Node Manager.
43
44 %prep
45 %setup -q
46
47 %build
48 # make manages the C and Python stuff
49 %{__make} %{?_smp_mflags} lxc
50
51 %install
52 # make manages the C and Python stuff
53 rm -rf $RPM_BUILD_ROOT
54 %{__make} %{?_smp_mflags} install-lxc DESTDIR="$RPM_BUILD_ROOT"
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(-,root,root,-)
61 %{_datadir}/NodeManager/
62
63 %changelog
64 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
65 - fixes in hostmap, and in interfaces
66 - new vsys_sysctl
67 - privatebridge now comes with nodemanager-lib
68
69 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
70 - omf plugin does not block any longer when running trigger script
71 - log goes into sliver's /var/log instead
72
73 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
74 - new install-scripts target in Makefile
75 - conf_files and fuse-pl initscripts chmod'ed +x
76 - omf_resctl config template tweaked to use _slicename_%_hostname_
77
78 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
79 - make sure to create /etc/planetlab/virt so others can read that
80 - expose get_node_virt() and command_in_slice()
81 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
82 - user's .profile now has right owner
83 - other tweaks in lxc slivers
84
85 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
86 - lxc slice creation: slice user was created with unknown gid - fixed
87 - lxc slice creation: .profile for root and user - fixed
88
89 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
90 - fix umounting of ssh directory when deleting omf-friendly slivers
91 - support for writing cgroups in subsystems other than cpuset
92 - add xid to template match
93 - finer-grained split between -lib -vs and -lxc
94 - first roughly complete omf_resctl for omfv6
95 - minor fix for when getslivers does not have minexemptrate
96
97 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
98 - Fix path, machine arch in slivers
99
100 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
101
102 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
103 - no-op bump to 5.2 to be in line with the rest of the system
104
105 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
106 - improvements to privatebridge
107
108 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
109 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
110
111 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
112 - fix wrong gre tunnel deleted when topology changes
113
114 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
115 - Update /etc/hosts in slivers from sliver_hostmap tag.
116
117 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
118 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
119 - initial check-in of privatebridge plugin.
120
121 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
122 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
123
124 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
125 - fix slices not deleted properly when they use vsys
126
127 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
128 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
129
130 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
131 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
132
133 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
134 - Bridge virtual interfaces to VLANs
135
136 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
137 - Add support for L2 bridged interfaces with public IPs inside a slice
138
139 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
140 - Support for freezing BestEffort slices for Vicci
141
142 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
143 - Change to use new vsh (wrapper for lxcsu)
144
145 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
146 - add missing import
147 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
148
149 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
150 - tag 2.1-7 was broken for OMF-friendly slices
151 - expose_ssh_dir was erroneously defined on the Worker class
152
153 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
154 - bwlimitlxc now ships with plnode-utils
155
156 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
157 - set LD_PRELOAD for linux-containers nodes
158
159 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
160 - first complete version for vs and lxc - functional but not thoroughly tested though
161
162 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
163 - split packaging in 3 (lib, lxc, vs)
164 - this tag will only work with lxc though
165