Setting tag nodemanager-2.1-10
[nodemanager.git] / nodemanager-lxc.spec
1 # we define this in a separate specfile because we cannot produce all the 3 packages
2 # nodemanager-lib nodemanager-vs nodemanager-lxc in a single build
3
4 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
5
6 %define name nodemanager-lxc
7 %define version 2.1
8 %define taglevel 10
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Node Manager Plugin for lxc nodes
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: System Environment/Daemons
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %{SCMURL}
25
26 # we use libvirt
27 Requires: libvirt
28 Requires: libvirt-python
29 # cgroups.py needs this
30 Requires: python-inotify
31 # the common package for nodemanager
32 Requires: nodemanager-lib
33 # the lxc-specific tools for using slice images
34 Requires: lxc-sliceimage
35
36 %description
37 nodemanager-lxc provides the lxc code for the PlanetLab Node Manager.
38
39 %prep
40 %setup -q
41
42 %build
43 # make manages the C and Python stuff
44 %{__make} %{?_smp_mflags} lxc
45
46 %install
47 # make manages the C and Python stuff
48 rm -rf $RPM_BUILD_ROOT
49 %{__make} %{?_smp_mflags} install-lxc DESTDIR="$RPM_BUILD_ROOT"
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(-,root,root,-)
56 %{_datadir}/NodeManager/
57
58 %changelog
59 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
60 - Change to use new vsh (wrapper for lxcsu)
61
62 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
63 - add missing import
64 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
65
66 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
67 - tag 2.1-7 was broken for OMF-friendly slices
68 - expose_ssh_dir was erroneously defined on the Worker class
69
70 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
71 - bwlimitlxc now ships with plnode-utils
72
73 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
74 - set LD_PRELOAD for linux-containers nodes
75
76 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
77 - first complete version for vs and lxc - functional but not thoroughly tested though
78
79 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
80 - split packaging in 3 (lib, lxc, vs)
81 - this tag will only work with lxc though
82