Setting tag nodemanager-5.2-12
[nodemanager.git] / nodemanager-lxc.spec
1 # we define this in a separate specfile because we cannot produce all the 3 packages
2 # nodemanager-lib nodemanager-vs nodemanager-lxc in a single build
3
4 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
5
6 %define name nodemanager-lxc
7 %define version 5.2
8 %define taglevel 12
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Node Manager Plugin for lxc nodes
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: System Environment/Daemons
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %{SCMURL}
25
26 # for nodeupdate 
27 Provides: nodemanager
28
29 # we use libvirt
30 Requires: libvirt
31 Requires: libvirt-python
32 # cgroups.py needs this
33 Requires: python-inotify
34 # the common package for nodemanager
35 Requires: nodemanager-lib = %{version}
36 # the lxc-specific tools for using slice images
37 Requires: lxc-sliceimage
38 Requires: openvswitch
39 # Requires: sliceimage-lxc-f16-x86_64 >= 5.1-3
40
41 %description
42 nodemanager-lxc provides the lxc code for the PlanetLab Node Manager.
43
44 %prep
45 %setup -q
46
47 %build
48 # make manages the C and Python stuff
49 %{__make} %{?_smp_mflags} lxc
50
51 %install
52 # make manages the C and Python stuff
53 rm -rf $RPM_BUILD_ROOT
54 %{__make} %{?_smp_mflags} install-lxc DESTDIR="$RPM_BUILD_ROOT"
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(-,root,root,-)
61 %{_datadir}/NodeManager/
62
63 %changelog
64 * Fri Apr 04 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-12
65 - this tag for the first time passes the full range of tests on fedora20
66 - robustified slice teardown wrt vsys
67 - Scott's fix for repairing veth devs
68 - removed sshsh
69 - tools.has_systemctl
70
71 * Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-11
72 - ship /etc/sysconfig/nodemanager
73 - trash sshsh
74
75 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-10
76 - comes with systemd native unit files on >= f18
77 - user-provided initscript gets started through systemd in slivers >= f18
78 - smarter to locate cgroups for various versions of libvirt
79 - nicer log format - and log program termination
80 - tweaks in codemux plugin
81 - bug fixes in libvirt driver, esp. for finding out if domain is running
82
83 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
84 - fixes in hostmap, and in interfaces
85 - new vsys_sysctl
86 - privatebridge now comes with nodemanager-lib
87
88 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
89 - omf plugin does not block any longer when running trigger script
90 - log goes into sliver's /var/log instead
91
92 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
93 - new install-scripts target in Makefile
94 - conf_files and fuse-pl initscripts chmod'ed +x
95 - omf_resctl config template tweaked to use _slicename_%_hostname_
96
97 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
98 - make sure to create /etc/planetlab/virt so others can read that
99 - expose get_node_virt() and command_in_slice()
100 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
101 - user's .profile now has right owner
102 - other tweaks in lxc slivers
103
104 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
105 - lxc slice creation: slice user was created with unknown gid - fixed
106 - lxc slice creation: .profile for root and user - fixed
107
108 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
109 - fix umounting of ssh directory when deleting omf-friendly slivers
110 - support for writing cgroups in subsystems other than cpuset
111 - add xid to template match
112 - finer-grained split between -lib -vs and -lxc
113 - first roughly complete omf_resctl for omfv6
114 - minor fix for when getslivers does not have minexemptrate
115
116 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
117 - Fix path, machine arch in slivers
118
119 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
120
121 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
122 - no-op bump to 5.2 to be in line with the rest of the system
123
124 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
125 - improvements to privatebridge
126
127 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
128 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
129
130 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
131 - fix wrong gre tunnel deleted when topology changes
132
133 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
134 - Update /etc/hosts in slivers from sliver_hostmap tag.
135
136 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
137 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
138 - initial check-in of privatebridge plugin.
139
140 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
141 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
142
143 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
144 - fix slices not deleted properly when they use vsys
145
146 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
147 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
148
149 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
150 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
151
152 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
153 - Bridge virtual interfaces to VLANs
154
155 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
156 - Add support for L2 bridged interfaces with public IPs inside a slice
157
158 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
159 - Support for freezing BestEffort slices for Vicci
160
161 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
162 - Change to use new vsh (wrapper for lxcsu)
163
164 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
165 - add missing import
166 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
167
168 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
169 - tag 2.1-7 was broken for OMF-friendly slices
170 - expose_ssh_dir was erroneously defined on the Worker class
171
172 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
173 - bwlimitlxc now ships with plnode-utils
174
175 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
176 - set LD_PRELOAD for linux-containers nodes
177
178 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
179 - first complete version for vs and lxc - functional but not thoroughly tested though
180
181 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
182 - split packaging in 3 (lib, lxc, vs)
183 - this tag will only work with lxc though
184