Setting tag nodemanager-5.2-13
[nodemanager.git] / nodemanager-lxc.spec
1 # we define this in a separate specfile because we cannot produce all the 3 packages
2 # nodemanager-lib nodemanager-vs nodemanager-lxc in a single build
3
4 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
5
6 %define name nodemanager-lxc
7 %define version 5.2
8 %define taglevel 13
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Node Manager Plugin for lxc nodes
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: System Environment/Daemons
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %{SCMURL}
25
26 # for nodeupdate 
27 Provides: nodemanager
28
29 # we use libvirt
30 Requires: libvirt
31 Requires: libvirt-python
32 # cgroups.py needs this
33 Requires: python-inotify
34 # the common package for nodemanager
35 Requires: nodemanager-lib = %{version}
36 # the lxc-specific tools for using slice images
37 Requires: lxc-sliceimage
38 Requires: openvswitch
39 # Requires: sliceimage-lxc-f16-x86_64 >= 5.1-3
40
41 %description
42 nodemanager-lxc provides the lxc code for the PlanetLab Node Manager.
43
44 %prep
45 %setup -q
46
47 %build
48 # make manages the C and Python stuff
49 %{__make} %{?_smp_mflags} lxc
50
51 %install
52 # make manages the C and Python stuff
53 rm -rf $RPM_BUILD_ROOT
54 %{__make} %{?_smp_mflags} install-lxc DESTDIR="$RPM_BUILD_ROOT"
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(-,root,root,-)
61 %{_datadir}/NodeManager/
62
63 %changelog
64 * Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-13
65 - improve network management in slices
66 - _has_systemctl was not declared as global - vsys was failing to restart
67
68 * Fri Apr 04 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-12
69 - this tag for the first time passes the full range of tests on fedora20
70 - robustified slice teardown wrt vsys
71 - Scott's fix for repairing veth devs
72 - removed sshsh
73 - tools.has_systemctl
74
75 * Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-11
76 - ship /etc/sysconfig/nodemanager
77 - trash sshsh
78
79 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-10
80 - comes with systemd native unit files on >= f18
81 - user-provided initscript gets started through systemd in slivers >= f18
82 - smarter to locate cgroups for various versions of libvirt
83 - nicer log format - and log program termination
84 - tweaks in codemux plugin
85 - bug fixes in libvirt driver, esp. for finding out if domain is running
86
87 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
88 - fixes in hostmap, and in interfaces
89 - new vsys_sysctl
90 - privatebridge now comes with nodemanager-lib
91
92 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
93 - omf plugin does not block any longer when running trigger script
94 - log goes into sliver's /var/log instead
95
96 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
97 - new install-scripts target in Makefile
98 - conf_files and fuse-pl initscripts chmod'ed +x
99 - omf_resctl config template tweaked to use _slicename_%_hostname_
100
101 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
102 - make sure to create /etc/planetlab/virt so others can read that
103 - expose get_node_virt() and command_in_slice()
104 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
105 - user's .profile now has right owner
106 - other tweaks in lxc slivers
107
108 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
109 - lxc slice creation: slice user was created with unknown gid - fixed
110 - lxc slice creation: .profile for root and user - fixed
111
112 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
113 - fix umounting of ssh directory when deleting omf-friendly slivers
114 - support for writing cgroups in subsystems other than cpuset
115 - add xid to template match
116 - finer-grained split between -lib -vs and -lxc
117 - first roughly complete omf_resctl for omfv6
118 - minor fix for when getslivers does not have minexemptrate
119
120 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
121 - Fix path, machine arch in slivers
122
123 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
124
125 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
126 - no-op bump to 5.2 to be in line with the rest of the system
127
128 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
129 - improvements to privatebridge
130
131 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
132 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
133
134 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
135 - fix wrong gre tunnel deleted when topology changes
136
137 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
138 - Update /etc/hosts in slivers from sliver_hostmap tag.
139
140 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
141 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
142 - initial check-in of privatebridge plugin.
143
144 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
145 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
146
147 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
148 - fix slices not deleted properly when they use vsys
149
150 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
151 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
152
153 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
154 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
155
156 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
157 - Bridge virtual interfaces to VLANs
158
159 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
160 - Add support for L2 bridged interfaces with public IPs inside a slice
161
162 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
163 - Support for freezing BestEffort slices for Vicci
164
165 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
166 - Change to use new vsh (wrapper for lxcsu)
167
168 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
169 - add missing import
170 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
171
172 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
173 - tag 2.1-7 was broken for OMF-friendly slices
174 - expose_ssh_dir was erroneously defined on the Worker class
175
176 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
177 - bwlimitlxc now ships with plnode-utils
178
179 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
180 - set LD_PRELOAD for linux-containers nodes
181
182 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
183 - first complete version for vs and lxc - functional but not thoroughly tested though
184
185 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
186 - split packaging in 3 (lib, lxc, vs)
187 - this tag will only work with lxc though
188