merged split packaging (-lib and -vs) from master, add a 3rd one for lxc
[nodemanager.git] / nodemanager-lxc.spec
1 # we define this in a separate specfile because we cannot produce all the 3 packages
2 # nodemanager-lib nodemanager-vs nodemanager-lxc in a single build
3
4 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
5
6 %define name nodemanager-lxc
7 %define version 2.1
8 %define taglevel 3
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Node Manager Plugin for lxc nodes
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: System Environment/Daemons
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %{SCMURL}
25
26 # we use libvirt
27 Requires: libvirt-python
28 # the common package for nodemanager
29 Requires: nodemanager-lib
30 # the lxc-specific tools for using slice images
31 Requires: lxc-sliceimage
32
33 %description
34 nodemanager-lxc provides the lxc code for the PlanetLab Node Manager.
35
36 %prep
37 %setup -q
38
39 %build
40 # make manages the C and Python stuff
41 %{__make} %{?_smp_mflags} lxc
42
43 %install
44 # make manages the C and Python stuff
45 rm -rf $RPM_BUILD_ROOT
46 %{__make} %{?_smp_mflags} install-lxc DESTDIR="$RPM_BUILD_ROOT"
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(-,root,root,-)
53 %{_datadir}/NodeManager/
54
55 %changelog