Setting tag nodemanager-5.2-8
[nodemanager.git] / nodemanager-lxc.spec
1 # we define this in a separate specfile because we cannot produce all the 3 packages
2 # nodemanager-lib nodemanager-vs nodemanager-lxc in a single build
3
4 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
5
6 %define name nodemanager-lxc
7 %define version 5.2
8 %define taglevel 8
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Node Manager Plugin for lxc nodes
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: System Environment/Daemons
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %{SCMURL}
25
26 # we use libvirt
27 Requires: libvirt
28 Requires: libvirt-python
29 # cgroups.py needs this
30 Requires: python-inotify
31 # the common package for nodemanager
32 Requires: nodemanager-lib
33 # the lxc-specific tools for using slice images
34 Requires: lxc-sliceimage
35 Requires: openvswitch
36 # Requires: sliceimage-lxc-f16-x86_64 >= 5.1-3
37
38 %description
39 nodemanager-lxc provides the lxc code for the PlanetLab Node Manager.
40
41 %prep
42 %setup -q
43
44 %build
45 # make manages the C and Python stuff
46 %{__make} %{?_smp_mflags} lxc
47
48 %install
49 # make manages the C and Python stuff
50 rm -rf $RPM_BUILD_ROOT
51 %{__make} %{?_smp_mflags} install-lxc DESTDIR="$RPM_BUILD_ROOT"
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(-,root,root,-)
58 %{_datadir}/NodeManager/
59
60 %changelog
61 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
62 - omf plugin does not block any longer when running trigger script
63 - log goes into sliver's /var/log instead
64
65 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
66 - new install-scripts target in Makefile
67 - conf_files and fuse-pl initscripts chmod'ed +x
68 - omf_resctl config template tweaked to use _slicename_%_hostname_
69
70 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
71 - make sure to create /etc/planetlab/virt so others can read that
72 - expose get_node_virt() and command_in_slice()
73 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
74 - user's .profile now has right owner
75 - other tweaks in lxc slivers
76
77 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
78 - lxc slice creation: slice user was created with unknown gid - fixed
79 - lxc slice creation: .profile for root and user - fixed
80
81 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
82 - fix umounting of ssh directory when deleting omf-friendly slivers
83 - support for writing cgroups in subsystems other than cpuset
84 - add xid to template match
85 - finer-grained split between -lib -vs and -lxc
86 - first roughly complete omf_resctl for omfv6
87 - minor fix for when getslivers does not have minexemptrate
88
89 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
90 - Fix path, machine arch in slivers
91
92 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
93
94 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
95 - no-op bump to 5.2 to be in line with the rest of the system
96
97 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
98 - improvements to privatebridge
99
100 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
101 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
102
103 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
104 - fix wrong gre tunnel deleted when topology changes
105
106 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
107 - Update /etc/hosts in slivers from sliver_hostmap tag.
108
109 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
110 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
111 - initial check-in of privatebridge plugin.
112
113 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
114 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
115
116 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
117 - fix slices not deleted properly when they use vsys
118
119 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
120 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
121
122 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
123 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
124
125 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
126 - Bridge virtual interfaces to VLANs
127
128 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
129 - Add support for L2 bridged interfaces with public IPs inside a slice
130
131 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
132 - Support for freezing BestEffort slices for Vicci
133
134 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
135 - Change to use new vsh (wrapper for lxcsu)
136
137 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
138 - add missing import
139 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
140
141 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
142 - tag 2.1-7 was broken for OMF-friendly slices
143 - expose_ssh_dir was erroneously defined on the Worker class
144
145 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
146 - bwlimitlxc now ships with plnode-utils
147
148 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
149 - set LD_PRELOAD for linux-containers nodes
150
151 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
152 - first complete version for vs and lxc - functional but not thoroughly tested though
153
154 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
155 - split packaging in 3 (lib, lxc, vs)
156 - this tag will only work with lxc though
157