Setting tag nodemanager-5.2-11
[nodemanager.git] / nodemanager-lxc.spec
1 # we define this in a separate specfile because we cannot produce all the 3 packages
2 # nodemanager-lib nodemanager-vs nodemanager-lxc in a single build
3
4 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
5
6 %define name nodemanager-lxc
7 %define version 5.2
8 %define taglevel 11
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Node Manager Plugin for lxc nodes
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: System Environment/Daemons
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %{SCMURL}
25
26 # for nodeupdate 
27 Provides: nodemanager
28
29 # we use libvirt
30 Requires: libvirt
31 Requires: libvirt-python
32 # cgroups.py needs this
33 Requires: python-inotify
34 # the common package for nodemanager
35 Requires: nodemanager-lib = %{version}
36 # the lxc-specific tools for using slice images
37 Requires: lxc-sliceimage
38 Requires: openvswitch
39 # Requires: sliceimage-lxc-f16-x86_64 >= 5.1-3
40
41 %description
42 nodemanager-lxc provides the lxc code for the PlanetLab Node Manager.
43
44 %prep
45 %setup -q
46
47 %build
48 # make manages the C and Python stuff
49 %{__make} %{?_smp_mflags} lxc
50
51 %install
52 # make manages the C and Python stuff
53 rm -rf $RPM_BUILD_ROOT
54 %{__make} %{?_smp_mflags} install-lxc DESTDIR="$RPM_BUILD_ROOT"
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(-,root,root,-)
61 %{_datadir}/NodeManager/
62
63 %changelog
64 * Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-11
65 - ship /etc/sysconfig/nodemanager
66 - trash sshsh
67
68 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-10
69 - comes with systemd native unit files on >= f18
70 - user-provided initscript gets started through systemd in slivers >= f18
71 - smarter to locate cgroups for various versions of libvirt
72 - nicer log format - and log program termination
73 - tweaks in codemux plugin
74 - bug fixes in libvirt driver, esp. for finding out if domain is running
75
76 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
77 - fixes in hostmap, and in interfaces
78 - new vsys_sysctl
79 - privatebridge now comes with nodemanager-lib
80
81 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
82 - omf plugin does not block any longer when running trigger script
83 - log goes into sliver's /var/log instead
84
85 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
86 - new install-scripts target in Makefile
87 - conf_files and fuse-pl initscripts chmod'ed +x
88 - omf_resctl config template tweaked to use _slicename_%_hostname_
89
90 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
91 - make sure to create /etc/planetlab/virt so others can read that
92 - expose get_node_virt() and command_in_slice()
93 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
94 - user's .profile now has right owner
95 - other tweaks in lxc slivers
96
97 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
98 - lxc slice creation: slice user was created with unknown gid - fixed
99 - lxc slice creation: .profile for root and user - fixed
100
101 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
102 - fix umounting of ssh directory when deleting omf-friendly slivers
103 - support for writing cgroups in subsystems other than cpuset
104 - add xid to template match
105 - finer-grained split between -lib -vs and -lxc
106 - first roughly complete omf_resctl for omfv6
107 - minor fix for when getslivers does not have minexemptrate
108
109 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
110 - Fix path, machine arch in slivers
111
112 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
113
114 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
115 - no-op bump to 5.2 to be in line with the rest of the system
116
117 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
118 - improvements to privatebridge
119
120 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
121 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
122
123 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
124 - fix wrong gre tunnel deleted when topology changes
125
126 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
127 - Update /etc/hosts in slivers from sliver_hostmap tag.
128
129 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
130 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
131 - initial check-in of privatebridge plugin.
132
133 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
134 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
135
136 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
137 - fix slices not deleted properly when they use vsys
138
139 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
140 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
141
142 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
143 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
144
145 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
146 - Bridge virtual interfaces to VLANs
147
148 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
149 - Add support for L2 bridged interfaces with public IPs inside a slice
150
151 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
152 - Support for freezing BestEffort slices for Vicci
153
154 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
155 - Change to use new vsh (wrapper for lxcsu)
156
157 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
158 - add missing import
159 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
160
161 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
162 - tag 2.1-7 was broken for OMF-friendly slices
163 - expose_ssh_dir was erroneously defined on the Worker class
164
165 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
166 - bwlimitlxc now ships with plnode-utils
167
168 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
169 - set LD_PRELOAD for linux-containers nodes
170
171 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
172 - first complete version for vs and lxc - functional but not thoroughly tested though
173
174 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
175 - split packaging in 3 (lib, lxc, vs)
176 - this tag will only work with lxc though
177