install for sytemd *or* init
[nodemanager.git] / nodemanager-vs.spec
1 # we define this in a separate specfile because we cannot produce all the 3 packages
2 # nodemanager-lib nodemanager-vs nodemanager-lxc in a single build
3
4 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
5
6 %define name nodemanager-vs
7 %define version 5.2
8 %define taglevel 9
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Node Manager Plugin for vserver nodes
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: System Environment/Daemons
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %{SCMURL}
25
26 # old name, when all came as a single package with vserver wired in
27 Obsoletes: NodeManager
28 # for nodeupdate 
29 Provides: nodemanager
30
31 # our interface to the vserver patch
32 Requires: util-vserver >= 0.30.208-17
33 # and the planetlab utilities
34 Requires: util-vserver-python > 0.3-16
35 # the common package for nodemanager
36 Requires: nodemanager-lib = %{version}
37 # the vserver-specific tools for using slice images
38 Requires: vserver-sliceimage
39
40 %description
41 nodemanager-vs provides the vserver code for the PlanetLab Node Manager.
42
43 %prep
44 %setup -q
45
46 %build
47 # make manages the C and Python stuff
48 %{__make} %{?_smp_mflags} vs
49
50 %install
51 # make manages the C and Python stuff
52 rm -rf $RPM_BUILD_ROOT
53 %{__make} %{?_smp_mflags} install-vs DESTDIR="$RPM_BUILD_ROOT"
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(-,root,root,-)
60 %{_datadir}/NodeManager/
61
62 %changelog
63 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
64 - fixes in hostmap, and in interfaces
65 - new vsys_sysctl
66 - privatebridge now comes with nodemanager-lib
67
68 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
69 - omf plugin does not block any longer when running trigger script
70 - log goes into sliver's /var/log instead
71
72 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
73 - new install-scripts target in Makefile
74 - conf_files and fuse-pl initscripts chmod'ed +x
75 - omf_resctl config template tweaked to use _slicename_%_hostname_
76
77 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
78 - make sure to create /etc/planetlab/virt so others can read that
79 - expose get_node_virt() and command_in_slice()
80 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
81 - user's .profile now has right owner
82 - other tweaks in lxc slivers
83
84 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
85 - lxc slice creation: slice user was created with unknown gid - fixed
86 - lxc slice creation: .profile for root and user - fixed
87
88 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
89 - fix umounting of ssh directory when deleting omf-friendly slivers
90 - support for writing cgroups in subsystems other than cpuset
91 - add xid to template match
92 - finer-grained split between -lib -vs and -lxc
93 - first roughly complete omf_resctl for omfv6
94 - minor fix for when getslivers does not have minexemptrate
95
96 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
97 - Fix path, machine arch in slivers
98
99 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
100
101 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
102 - no-op bump to 5.2 to be in line with the rest of the system
103
104 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
105 - improvements to privatebridge
106
107 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
108 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
109
110 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
111 - fix wrong gre tunnel deleted when topology changes
112
113 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
114 - Update /etc/hosts in slivers from sliver_hostmap tag.
115
116 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
117 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
118 - initial check-in of privatebridge plugin.
119
120 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
121 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
122
123 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
124 - fix slices not deleted properly when they use vsys
125
126 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
127 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
128
129 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
130 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
131
132 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
133 - Bridge virtual interfaces to VLANs
134
135 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
136 - Add support for L2 bridged interfaces with public IPs inside a slice
137
138 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
139 - Support for freezing BestEffort slices for Vicci
140
141 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
142 - Change to use new vsh (wrapper for lxcsu)
143
144 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
145 - add missing import
146 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
147
148 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
149 - tag 2.1-7 was broken for OMF-friendly slices
150 - expose_ssh_dir was erroneously defined on the Worker class
151
152 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
153 - bwlimitlxc now ships with plnode-utils
154
155 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
156 - set LD_PRELOAD for linux-containers nodes
157
158 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
159 - first complete version for vs and lxc - functional but not thoroughly tested though
160
161 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
162 - split packaging in 3 (lib, lxc, vs)
163 - this tag will only work with lxc though
164
165 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
166 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
167