Setting tag nodemanager-5.2-7
[nodemanager.git] / nodemanager-vs.spec
1 # we define this in a separate specfile because we cannot produce all the 3 packages
2 # nodemanager-lib nodemanager-vs nodemanager-lxc in a single build
3
4 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
5
6 %define name nodemanager-vs
7 %define version 5.2
8 %define taglevel 7
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Node Manager Plugin for vserver nodes
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: System Environment/Daemons
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %{SCMURL}
25
26 # old name, when all came as a single package with vserver wired in
27 Obsoletes: NodeManager
28
29 # our interface to the vserver patch
30 Requires: util-vserver >= 0.30.208-17
31 # and the planetlab utilities
32 Requires: util-vserver-python > 0.3-16
33 # the common package for nodemanager
34 Requires: nodemanager-lib
35 # the vserver-specific tools for using slice images
36 Requires: vserver-sliceimage
37
38 %description
39 nodemanager-vs provides the vserver code for the PlanetLab Node Manager.
40
41 %prep
42 %setup -q
43
44 %build
45 # make manages the C and Python stuff
46 %{__make} %{?_smp_mflags} vs
47
48 %install
49 # make manages the C and Python stuff
50 rm -rf $RPM_BUILD_ROOT
51 %{__make} %{?_smp_mflags} install-vs DESTDIR="$RPM_BUILD_ROOT"
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(-,root,root,-)
58 %{_datadir}/NodeManager/
59
60 %changelog
61 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
62 - new install-scripts target in Makefile
63 - conf_files and fuse-pl initscripts chmod'ed +x
64 - omf_resctl config template tweaked to use _slicename_%_hostname_
65
66 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
67 - make sure to create /etc/planetlab/virt so others can read that
68 - expose get_node_virt() and command_in_slice()
69 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
70 - user's .profile now has right owner
71 - other tweaks in lxc slivers
72
73 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
74 - lxc slice creation: slice user was created with unknown gid - fixed
75 - lxc slice creation: .profile for root and user - fixed
76
77 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
78 - fix umounting of ssh directory when deleting omf-friendly slivers
79 - support for writing cgroups in subsystems other than cpuset
80 - add xid to template match
81 - finer-grained split between -lib -vs and -lxc
82 - first roughly complete omf_resctl for omfv6
83 - minor fix for when getslivers does not have minexemptrate
84
85 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
86 - Fix path, machine arch in slivers
87
88 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
89
90 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
91 - no-op bump to 5.2 to be in line with the rest of the system
92
93 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
94 - improvements to privatebridge
95
96 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
97 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
98
99 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
100 - fix wrong gre tunnel deleted when topology changes
101
102 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
103 - Update /etc/hosts in slivers from sliver_hostmap tag.
104
105 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
106 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
107 - initial check-in of privatebridge plugin.
108
109 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
110 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
111
112 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
113 - fix slices not deleted properly when they use vsys
114
115 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
116 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
117
118 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
119 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
120
121 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
122 - Bridge virtual interfaces to VLANs
123
124 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
125 - Add support for L2 bridged interfaces with public IPs inside a slice
126
127 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
128 - Support for freezing BestEffort slices for Vicci
129
130 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
131 - Change to use new vsh (wrapper for lxcsu)
132
133 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
134 - add missing import
135 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
136
137 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
138 - tag 2.1-7 was broken for OMF-friendly slices
139 - expose_ssh_dir was erroneously defined on the Worker class
140
141 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
142 - bwlimitlxc now ships with plnode-utils
143
144 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
145 - set LD_PRELOAD for linux-containers nodes
146
147 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
148 - first complete version for vs and lxc - functional but not thoroughly tested though
149
150 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
151 - split packaging in 3 (lib, lxc, vs)
152 - this tag will only work with lxc though
153
154 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
155 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
156