Setting tag nodemanager-5.2-6
[nodemanager.git] / nodemanager-vs.spec
1 # we define this in a separate specfile because we cannot produce all the 3 packages
2 # nodemanager-lib nodemanager-vs nodemanager-lxc in a single build
3
4 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
5
6 %define name nodemanager-vs
7 %define version 5.2
8 %define taglevel 6
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Node Manager Plugin for vserver nodes
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: System Environment/Daemons
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %{SCMURL}
25
26 # old name, when all came as a single package with vserver wired in
27 Obsoletes: NodeManager
28
29 # our interface to the vserver patch
30 Requires: util-vserver >= 0.30.208-17
31 # and the planetlab utilities
32 Requires: util-vserver-python > 0.3-16
33 # the common package for nodemanager
34 Requires: nodemanager-lib
35 # the vserver-specific tools for using slice images
36 Requires: vserver-sliceimage
37
38 %description
39 nodemanager-vs provides the vserver code for the PlanetLab Node Manager.
40
41 %prep
42 %setup -q
43
44 %build
45 # make manages the C and Python stuff
46 %{__make} %{?_smp_mflags} vs
47
48 %install
49 # make manages the C and Python stuff
50 rm -rf $RPM_BUILD_ROOT
51 %{__make} %{?_smp_mflags} install-vs DESTDIR="$RPM_BUILD_ROOT"
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(-,root,root,-)
58 %{_datadir}/NodeManager/
59
60 %changelog
61 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
62 - make sure to create /etc/planetlab/virt so others can read that
63 - expose get_node_virt() and command_in_slice()
64 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
65 - user's .profile now has right owner
66 - other tweaks in lxc slivers
67
68 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
69 - lxc slice creation: slice user was created with unknown gid - fixed
70 - lxc slice creation: .profile for root and user - fixed
71
72 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
73 - fix umounting of ssh directory when deleting omf-friendly slivers
74 - support for writing cgroups in subsystems other than cpuset
75 - add xid to template match
76 - finer-grained split between -lib -vs and -lxc
77 - first roughly complete omf_resctl for omfv6
78 - minor fix for when getslivers does not have minexemptrate
79
80 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
81 - Fix path, machine arch in slivers
82
83 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
84
85 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
86 - no-op bump to 5.2 to be in line with the rest of the system
87
88 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
89 - improvements to privatebridge
90
91 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
92 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
93
94 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
95 - fix wrong gre tunnel deleted when topology changes
96
97 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
98 - Update /etc/hosts in slivers from sliver_hostmap tag.
99
100 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
101 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
102 - initial check-in of privatebridge plugin.
103
104 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
105 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
106
107 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
108 - fix slices not deleted properly when they use vsys
109
110 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
111 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
112
113 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
114 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
115
116 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
117 - Bridge virtual interfaces to VLANs
118
119 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
120 - Add support for L2 bridged interfaces with public IPs inside a slice
121
122 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
123 - Support for freezing BestEffort slices for Vicci
124
125 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
126 - Change to use new vsh (wrapper for lxcsu)
127
128 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
129 - add missing import
130 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
131
132 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
133 - tag 2.1-7 was broken for OMF-friendly slices
134 - expose_ssh_dir was erroneously defined on the Worker class
135
136 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
137 - bwlimitlxc now ships with plnode-utils
138
139 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
140 - set LD_PRELOAD for linux-containers nodes
141
142 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
143 - first complete version for vs and lxc - functional but not thoroughly tested though
144
145 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
146 - split packaging in 3 (lib, lxc, vs)
147 - this tag will only work with lxc though
148
149 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
150 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
151