Setting tag nodemanager-5.2-11
[nodemanager.git] / nodemanager-vs.spec
1 # we define this in a separate specfile because we cannot produce all the 3 packages
2 # nodemanager-lib nodemanager-vs nodemanager-lxc in a single build
3
4 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
5
6 %define name nodemanager-vs
7 %define version 5.2
8 %define taglevel 11
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Node Manager Plugin for vserver nodes
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: System Environment/Daemons
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %{SCMURL}
25
26 # old name, when all came as a single package with vserver wired in
27 Obsoletes: NodeManager
28 # for nodeupdate 
29 Provides: nodemanager
30
31 # our interface to the vserver patch
32 Requires: util-vserver >= 0.30.208-17
33 # and the planetlab utilities
34 Requires: util-vserver-python > 0.3-16
35 # the common package for nodemanager
36 Requires: nodemanager-lib = %{version}
37 # the vserver-specific tools for using slice images
38 Requires: vserver-sliceimage
39
40 %description
41 nodemanager-vs provides the vserver code for the PlanetLab Node Manager.
42
43 %prep
44 %setup -q
45
46 %build
47 # make manages the C and Python stuff
48 %{__make} %{?_smp_mflags} vs
49
50 %install
51 # make manages the C and Python stuff
52 rm -rf $RPM_BUILD_ROOT
53 %{__make} %{?_smp_mflags} install-vs DESTDIR="$RPM_BUILD_ROOT"
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(-,root,root,-)
60 %{_datadir}/NodeManager/
61
62 %changelog
63 * Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-11
64 - ship /etc/sysconfig/nodemanager
65 - trash sshsh
66
67 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-10
68 - comes with systemd native unit files on >= f18
69 - user-provided initscript gets started through systemd in slivers >= f18
70 - smarter to locate cgroups for various versions of libvirt
71 - nicer log format - and log program termination
72 - tweaks in codemux plugin
73 - bug fixes in libvirt driver, esp. for finding out if domain is running
74
75 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
76 - fixes in hostmap, and in interfaces
77 - new vsys_sysctl
78 - privatebridge now comes with nodemanager-lib
79
80 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
81 - omf plugin does not block any longer when running trigger script
82 - log goes into sliver's /var/log instead
83
84 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
85 - new install-scripts target in Makefile
86 - conf_files and fuse-pl initscripts chmod'ed +x
87 - omf_resctl config template tweaked to use _slicename_%_hostname_
88
89 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
90 - make sure to create /etc/planetlab/virt so others can read that
91 - expose get_node_virt() and command_in_slice()
92 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
93 - user's .profile now has right owner
94 - other tweaks in lxc slivers
95
96 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
97 - lxc slice creation: slice user was created with unknown gid - fixed
98 - lxc slice creation: .profile for root and user - fixed
99
100 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
101 - fix umounting of ssh directory when deleting omf-friendly slivers
102 - support for writing cgroups in subsystems other than cpuset
103 - add xid to template match
104 - finer-grained split between -lib -vs and -lxc
105 - first roughly complete omf_resctl for omfv6
106 - minor fix for when getslivers does not have minexemptrate
107
108 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
109 - Fix path, machine arch in slivers
110
111 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
112
113 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
114 - no-op bump to 5.2 to be in line with the rest of the system
115
116 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
117 - improvements to privatebridge
118
119 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
120 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
121
122 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
123 - fix wrong gre tunnel deleted when topology changes
124
125 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
126 - Update /etc/hosts in slivers from sliver_hostmap tag.
127
128 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
129 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
130 - initial check-in of privatebridge plugin.
131
132 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
133 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
134
135 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
136 - fix slices not deleted properly when they use vsys
137
138 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
139 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
140
141 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
142 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
143
144 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
145 - Bridge virtual interfaces to VLANs
146
147 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
148 - Add support for L2 bridged interfaces with public IPs inside a slice
149
150 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
151 - Support for freezing BestEffort slices for Vicci
152
153 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
154 - Change to use new vsh (wrapper for lxcsu)
155
156 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
157 - add missing import
158 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
159
160 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
161 - tag 2.1-7 was broken for OMF-friendly slices
162 - expose_ssh_dir was erroneously defined on the Worker class
163
164 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
165 - bwlimitlxc now ships with plnode-utils
166
167 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
168 - set LD_PRELOAD for linux-containers nodes
169
170 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
171 - first complete version for vs and lxc - functional but not thoroughly tested though
172
173 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
174 - split packaging in 3 (lib, lxc, vs)
175 - this tag will only work with lxc though
176
177 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
178 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
179