Setting tag nodemanager-5.2-10
[nodemanager.git] / nodemanager-vs.spec
1 # we define this in a separate specfile because we cannot produce all the 3 packages
2 # nodemanager-lib nodemanager-vs nodemanager-lxc in a single build
3
4 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
5
6 %define name nodemanager-vs
7 %define version 5.2
8 %define taglevel 10
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Node Manager Plugin for vserver nodes
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: System Environment/Daemons
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %{SCMURL}
25
26 # old name, when all came as a single package with vserver wired in
27 Obsoletes: NodeManager
28 # for nodeupdate 
29 Provides: nodemanager
30
31 # our interface to the vserver patch
32 Requires: util-vserver >= 0.30.208-17
33 # and the planetlab utilities
34 Requires: util-vserver-python > 0.3-16
35 # the common package for nodemanager
36 Requires: nodemanager-lib = %{version}
37 # the vserver-specific tools for using slice images
38 Requires: vserver-sliceimage
39
40 %description
41 nodemanager-vs provides the vserver code for the PlanetLab Node Manager.
42
43 %prep
44 %setup -q
45
46 %build
47 # make manages the C and Python stuff
48 %{__make} %{?_smp_mflags} vs
49
50 %install
51 # make manages the C and Python stuff
52 rm -rf $RPM_BUILD_ROOT
53 %{__make} %{?_smp_mflags} install-vs DESTDIR="$RPM_BUILD_ROOT"
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(-,root,root,-)
60 %{_datadir}/NodeManager/
61
62 %changelog
63 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-10
64 - comes with systemd native unit files on >= f18
65 - user-provided initscript gets started through systemd in slivers >= f18
66 - smarter to locate cgroups for various versions of libvirt
67 - nicer log format - and log program termination
68 - tweaks in codemux plugin
69 - bug fixes in libvirt driver, esp. for finding out if domain is running
70
71 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
72 - fixes in hostmap, and in interfaces
73 - new vsys_sysctl
74 - privatebridge now comes with nodemanager-lib
75
76 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
77 - omf plugin does not block any longer when running trigger script
78 - log goes into sliver's /var/log instead
79
80 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
81 - new install-scripts target in Makefile
82 - conf_files and fuse-pl initscripts chmod'ed +x
83 - omf_resctl config template tweaked to use _slicename_%_hostname_
84
85 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
86 - make sure to create /etc/planetlab/virt so others can read that
87 - expose get_node_virt() and command_in_slice()
88 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
89 - user's .profile now has right owner
90 - other tweaks in lxc slivers
91
92 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
93 - lxc slice creation: slice user was created with unknown gid - fixed
94 - lxc slice creation: .profile for root and user - fixed
95
96 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
97 - fix umounting of ssh directory when deleting omf-friendly slivers
98 - support for writing cgroups in subsystems other than cpuset
99 - add xid to template match
100 - finer-grained split between -lib -vs and -lxc
101 - first roughly complete omf_resctl for omfv6
102 - minor fix for when getslivers does not have minexemptrate
103
104 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
105 - Fix path, machine arch in slivers
106
107 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
108
109 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
110 - no-op bump to 5.2 to be in line with the rest of the system
111
112 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
113 - improvements to privatebridge
114
115 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
116 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
117
118 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
119 - fix wrong gre tunnel deleted when topology changes
120
121 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
122 - Update /etc/hosts in slivers from sliver_hostmap tag.
123
124 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
125 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
126 - initial check-in of privatebridge plugin.
127
128 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
129 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
130
131 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
132 - fix slices not deleted properly when they use vsys
133
134 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
135 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
136
137 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
138 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
139
140 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
141 - Bridge virtual interfaces to VLANs
142
143 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
144 - Add support for L2 bridged interfaces with public IPs inside a slice
145
146 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
147 - Support for freezing BestEffort slices for Vicci
148
149 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
150 - Change to use new vsh (wrapper for lxcsu)
151
152 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
153 - add missing import
154 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
155
156 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
157 - tag 2.1-7 was broken for OMF-friendly slices
158 - expose_ssh_dir was erroneously defined on the Worker class
159
160 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
161 - bwlimitlxc now ships with plnode-utils
162
163 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
164 - set LD_PRELOAD for linux-containers nodes
165
166 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
167 - first complete version for vs and lxc - functional but not thoroughly tested though
168
169 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
170 - split packaging in 3 (lib, lxc, vs)
171 - this tag will only work with lxc though
172
173 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
174 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
175