Setting tag nodemanager-5.2-13
[nodemanager.git] / nodemanager-vs.spec
1 # we define this in a separate specfile because we cannot produce all the 3 packages
2 # nodemanager-lib nodemanager-vs nodemanager-lxc in a single build
3
4 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
5
6 %define name nodemanager-vs
7 %define version 5.2
8 %define taglevel 13
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Summary: PlanetLab Node Manager Plugin for vserver nodes
13 Name: %{name}
14 Version: %{version}
15 Release: %{release}
16 License: PlanetLab
17 Group: System Environment/Daemons
18 Source0: %{name}-%{version}.tar.gz
19 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20
21 Vendor: PlanetLab
22 Packager: PlanetLab Central <support@planet-lab.org>
23 Distribution: PlanetLab %{plrelease}
24 URL: %{SCMURL}
25
26 # old name, when all came as a single package with vserver wired in
27 Obsoletes: NodeManager
28 # for nodeupdate 
29 Provides: nodemanager
30
31 # our interface to the vserver patch
32 Requires: util-vserver >= 0.30.208-17
33 # and the planetlab utilities
34 Requires: util-vserver-python > 0.3-16
35 # the common package for nodemanager
36 Requires: nodemanager-lib = %{version}
37 # the vserver-specific tools for using slice images
38 Requires: vserver-sliceimage
39
40 %description
41 nodemanager-vs provides the vserver code for the PlanetLab Node Manager.
42
43 %prep
44 %setup -q
45
46 %build
47 # make manages the C and Python stuff
48 %{__make} %{?_smp_mflags} vs
49
50 %install
51 # make manages the C and Python stuff
52 rm -rf $RPM_BUILD_ROOT
53 %{__make} %{?_smp_mflags} install-vs DESTDIR="$RPM_BUILD_ROOT"
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(-,root,root,-)
60 %{_datadir}/NodeManager/
61
62 %changelog
63 * Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-13
64 - improve network management in slices
65 - _has_systemctl was not declared as global - vsys was failing to restart
66
67 * Fri Apr 04 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-12
68 - this tag for the first time passes the full range of tests on fedora20
69 - robustified slice teardown wrt vsys
70 - Scott's fix for repairing veth devs
71 - removed sshsh
72 - tools.has_systemctl
73
74 * Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-11
75 - ship /etc/sysconfig/nodemanager
76 - trash sshsh
77
78 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-10
79 - comes with systemd native unit files on >= f18
80 - user-provided initscript gets started through systemd in slivers >= f18
81 - smarter to locate cgroups for various versions of libvirt
82 - nicer log format - and log program termination
83 - tweaks in codemux plugin
84 - bug fixes in libvirt driver, esp. for finding out if domain is running
85
86 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
87 - fixes in hostmap, and in interfaces
88 - new vsys_sysctl
89 - privatebridge now comes with nodemanager-lib
90
91 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
92 - omf plugin does not block any longer when running trigger script
93 - log goes into sliver's /var/log instead
94
95 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
96 - new install-scripts target in Makefile
97 - conf_files and fuse-pl initscripts chmod'ed +x
98 - omf_resctl config template tweaked to use _slicename_%_hostname_
99
100 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
101 - make sure to create /etc/planetlab/virt so others can read that
102 - expose get_node_virt() and command_in_slice()
103 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
104 - user's .profile now has right owner
105 - other tweaks in lxc slivers
106
107 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
108 - lxc slice creation: slice user was created with unknown gid - fixed
109 - lxc slice creation: .profile for root and user - fixed
110
111 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
112 - fix umounting of ssh directory when deleting omf-friendly slivers
113 - support for writing cgroups in subsystems other than cpuset
114 - add xid to template match
115 - finer-grained split between -lib -vs and -lxc
116 - first roughly complete omf_resctl for omfv6
117 - minor fix for when getslivers does not have minexemptrate
118
119 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
120 - Fix path, machine arch in slivers
121
122 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
123
124 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
125 - no-op bump to 5.2 to be in line with the rest of the system
126
127 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
128 - improvements to privatebridge
129
130 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
131 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
132
133 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
134 - fix wrong gre tunnel deleted when topology changes
135
136 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
137 - Update /etc/hosts in slivers from sliver_hostmap tag.
138
139 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
140 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
141 - initial check-in of privatebridge plugin.
142
143 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
144 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
145
146 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
147 - fix slices not deleted properly when they use vsys
148
149 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
150 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
151
152 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
153 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
154
155 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
156 - Bridge virtual interfaces to VLANs
157
158 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
159 - Add support for L2 bridged interfaces with public IPs inside a slice
160
161 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
162 - Support for freezing BestEffort slices for Vicci
163
164 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
165 - Change to use new vsh (wrapper for lxcsu)
166
167 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
168 - add missing import
169 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
170
171 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
172 - tag 2.1-7 was broken for OMF-friendly slices
173 - expose_ssh_dir was erroneously defined on the Worker class
174
175 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
176 - bwlimitlxc now ships with plnode-utils
177
178 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
179 - set LD_PRELOAD for linux-containers nodes
180
181 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
182 - first complete version for vs and lxc - functional but not thoroughly tested though
183
184 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
185 - split packaging in 3 (lib, lxc, vs)
186 - this tag will only work with lxc though
187
188 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
189 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
190