4319cbbc63dbafb46344488faca81772a296fac2
[nodemanager.git] / nodemanager.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 7.0
5 %define taglevel 0
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 ##############################
10 # for now we just extract all the files but package them only for either vs or lxc
11 # so bottom line is we have missing files at the end
12 # plan is to separate these target-dependant files in subdirs at some point
13 %define _unpackaged_files_terminate_build      0
14
15 ##############################
16 # only systemd unit files to start installed services
17 %define make_options WITH_SYSTEMD=true
18 %define systemddir /usr/lib/systemd/system
19 %define build_lxc 1
20
21 ##############################
22 Summary: PlanetLab Node Manager Library
23 Name: %{name}
24 Version: %{version}
25 Release: %{release}
26 License: PlanetLab
27 Group: System Environment/Daemons
28 Source0: %{name}-%{version}.tar.gz
29 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
30
31 Vendor: PlanetLab
32 Packager: PlanetLab Central <support@planet-lab.org>
33 Distribution: PlanetLab %{plrelease}
34 URL: %{SCMURL}
35
36 # not possible because of forward_api_calls
37 #BuildArch: noarch
38
39 # make sure we can invoke systemctl in post install script
40 Requires: systemd
41
42 # Uses function decorators
43 Requires: python3
44 # connecting PLC
45 Requires: python3-pycurl
46 # Signed tickets
47 Requires: gnupg
48 # sioc/plnet
49 Requires: pyplnet >= 4.3
50 # we do need the slice images in any case
51 Requires: sliceimage-%{slicefamily}
52 # for bwlimit
53 Requires: plnode-utils
54
55 %description
56 The PlanetLab Node Manager manages all aspects of PlanetLab node and
57 slice management once the node has been initialized and configured by
58 the Boot Manager. It periodically contacts its management authority
59 for configuration updates. It provides an XML-RPC API for performing
60 local operations on slices.
61 nodemanager-lib only provides a skeleton and needs as a companion
62 either nodemanager-vs or nodemanager-lxc
63
64 ##############################
65 %prep
66 %setup -q
67
68 %build
69 # make manages the C and Python stuff
70 %{__make} %{?_smp_mflags} %{make_options}
71
72 %install
73 # make manages the C and Python stuff
74 rm -rf $RPM_BUILD_ROOT
75 %{__make} %{?_smp_mflags} %{make_options} install DESTDIR="$RPM_BUILD_ROOT"
76
77 ##############################
78 %post
79 systemctl enable nm.service
80 systemctl enable conf_files.service
81 # empty
82 #systemctl enable fuse-pl.service
83 if [ "$PL_BOOTCD" != "1" ] ; then
84     systemctl restart nm.service
85 #    systemctl restart fuse-pl.service
86 fi
87
88 ##############################
89 %preun
90 # 0 = erase, 1 = upgrade
91 if [ $1 -eq 0 ] ; then
92 #    systemctl disable fuse-pl.service
93     systemctl disable conf_files.service
94     systemctl disable nm.service
95 fi
96
97 ##############################
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 ##############################
102 %files
103 %defattr(-,root,root,-)
104 %{_datadir}/NodeManager/account.*
105 %{_datadir}/NodeManager/api.*
106 %{_datadir}/NodeManager/api_calls.*
107 %{_datadir}/NodeManager/bwmon.*
108 %{_datadir}/NodeManager/conf_files.*
109 %{_datadir}/NodeManager/config.*
110 %{_datadir}/NodeManager/controller.*
111 %{_datadir}/NodeManager/curlwrapper.*
112 %{_datadir}/NodeManager/database.*
113 %{_datadir}/NodeManager/initscript.*
114 %{_datadir}/NodeManager/iptables.*
115 %{_datadir}/NodeManager/logger.*
116 %{_datadir}/NodeManager/net.*
117 %{_datadir}/NodeManager/nodemanager.*
118 %{_datadir}/NodeManager/plcapi.*
119 %{_datadir}/NodeManager/safexmlrpc.*
120 %{_datadir}/NodeManager/slivermanager.*
121 %{_datadir}/NodeManager/ticket.*
122 %{_datadir}/NodeManager/tools.*
123 %{_datadir}/NodeManager/plugins/__init__.*
124 %{_datadir}/NodeManager/plugins/hostmap.*
125 %{_datadir}/NodeManager/plugins/interfaces.*
126 %{_datadir}/NodeManager/plugins/omf_resctl.*
127 %{_datadir}/NodeManager/plugins/rawdisk.*
128 %{_datadir}/NodeManager/plugins/reservation.*
129 %{_datadir}/NodeManager/plugins/sfagids.*
130 %{_datadir}/NodeManager/plugins/sliverauth.*
131 %{_datadir}/NodeManager/plugins/specialaccounts.*
132 %{_datadir}/NodeManager/plugins/syndicate.*
133 %{_datadir}/NodeManager/plugins/vsys.*
134 %{_datadir}/NodeManager/plugins/vsys_privs.*
135 %{_datadir}/NodeManager/plugins/ipv6.*
136 %{_datadir}/NodeManager/plugins/update_ipv6addr_slivertag.*
137 %{_datadir}/NodeManager/sliver-initscripts/
138 %{_datadir}/NodeManager/sliver-systemd/
139 %{_bindir}/forward_api_calls
140 %{systemddir}/
141 %{_sysconfdir}/logrotate.d/nodemanager
142 /var/lib/nodemanager/
143 %config(noreplace) /etc/sysconfig/nodemanager
144
145 ##############################
146 %if "%{build_lxc}" == "1"
147
148 %package -n nodemanager-lxc
149 Summary: PlanetLab Node Manager Plugin for lxc nodes
150 Group: System Environment/Daemons
151 # we use libvirt
152 Requires: libvirt
153 Requires: python3-libvirt
154 # cgroups.py needs this
155 Requires: python3-inotify
156 # the common package for nodemanager
157 Requires: nodemanager-lib = %{version}
158 # the lxc-specific tools for using slice images
159 Requires: lxc-sliceimage
160 Requires: openvswitch
161
162 %description -n nodemanager-lxc
163 nodemanager-lxc provides the lxc code for the PlanetLab Node Manager.
164
165 %files -n nodemanager-lxc
166 %{_datadir}/NodeManager/sliver_libvirt.*
167 %{_datadir}/NodeManager/sliver_lxc.*
168 %{_datadir}/NodeManager/cgroups.*
169 %{_datadir}/NodeManager/coresched_lxc.*
170 %{_datadir}/NodeManager/plugins/privatebridge.*
171
172 %endif
173 ##############################
174
175 ##############################
176 %if "%{build_vs}" == "1"
177
178 %package -n nodemanager-vs
179 Summary: PlanetLab Node Manager Plugin for vserver nodes
180 Group: System Environment/Daemons
181
182 # old name, when all came as a single package with vserver wired in
183 Obsoletes: NodeManager
184 # for nodeupdate
185 Provides: nodemanager
186
187 # our interface to the vserver patch
188 Requires: util-vserver >= 0.30.208-17
189 # and the planetlab utilities
190 Requires: util-vserver-python > 0.3-16
191 # the common package for nodemanager
192 Requires: nodemanager-lib = %{version}
193 # the vserver-specific tools for using slice images
194 Requires: vserver-sliceimage
195
196 %description -n nodemanager-vs
197 nodemanager-vs provides the vserver code for the PlanetLab Node Manager.
198
199 %files -n nodemanager-vs
200 %{_datadir}/NodeManager/sliver_vs.*
201 %{_datadir}/NodeManager/coresched_vs.*
202 # this plugin uses vserver for now
203 %{_datadir}/NodeManager/plugins/drl.*
204 # in vs only : turn off the codemux plugin in lxc for now as
205 # it is responsible for the slice re-creation issue
206 %{_datadir}/NodeManager/plugins/codemux.*
207
208 %endif
209 ##############################
210
211 ##############################
212 %changelog
213 * Mon Jan 07 2019 Thierry Parmentelat <thierry.parmentelat@inria.fr> - nodemanager-7.0-0
214 - ported to python3
215 - add a systemd dependency to network-online so the service won't start too early
216 - only support systemd, removed init-oriented business
217 - also removed debian-oriented business
218
219 * Mon Jan 07 2019 Thierry Parmentelat <thierry.parmentelat@inria.fr> - nodemanager-5.2-20
220 - simply make conf_files.py executable, so that bootmanager can be py2/py3 compliant
221
222 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-19
223 - tweak to run against libvirt-python-1.3.3 under f24
224 - fix by Thomas Dreibholz - misspelled ovs-ovsctl
225 - default vrf is f24 - not that it matters much
226
227 * Fri Nov 13 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-18
228 - remove codemux plugin from lxc - was causing slice re-creation issue
229 - has reconnect capabilities to libvirt deamon
230 - reinstate code from a previous version, that deals with btrfs cleaning up
231 - cleaned up cgroups.py
232
233 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-17
234 - first step towards auto slice-reimaging
235 - slices that would be reimaged because of a change of slicefamily are
236 - identified in the nodemanager's log
237 - might have fixed fd leaks (use context managers whenever possible)
238
239 * Fri Apr 03 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-16
240 - initscript plugin reviewed
241 - turn off the initscript machinery completely on hosts that run f>=20
242 - some tweaks related to cgroup naming in f>=20, including for ipv6
243 - ideally all code depending on the cgroup naming scheme should use cgroups.py
244 - we are not there yet but this is a bit cleaner already
245
246 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-15
247 - addition to support for ipv6 to lxc slivers
248 - (thanks to Guilherme Sperb Machado)
249 - privatebridge plugin is back to the -lxc rpm
250 - add systemd dependency to network.target
251
252 * Tue Jul 22 2014 Thomas Dreibholz <dreibh@simula.no> - nodeimage-5.2-15
253 - nm.service fix: the node manager needs network.target, since it needs to contact the PLC.
254
255 * Wed Jul 16 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-14
256 - review packaging : one single spec file
257 - review packaging : some cleanup towards debians although not complete yet
258 - minor tweaks in exposing user's .ssh dir readonly
259
260 * Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-13
261 - improve network management in slices
262 - _has_systemctl was not declared as global - vsys was failing to restart
263
264 * Fri Apr 04 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-12
265 - this tag for the first time passes the full range of tests on fedora20
266 - robustified slice teardown wrt vsys
267 - Scott's fix for repairing veth devs
268 - removed sshsh
269 - tools.has_systemctl
270
271 * Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-11
272 - ship /etc/sysconfig/nodemanager
273 - trash sshsh
274
275 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-10
276 - comes with systemd native unit files on >= f18
277 - user-provided initscript gets started through systemd in slivers >= f18
278 - smarter to locate cgroups for various versions of libvirt
279 - nicer log format - and log program termination
280 - tweaks in codemux plugin
281 - bug fixes in libvirt driver, esp. for finding out if domain is running
282
283 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
284 - fixes in hostmap, and in interfaces
285 - new vsys_sysctl
286 - privatebridge now comes with nodemanager-lib
287
288 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
289 - omf plugin does not block any longer when running trigger script
290 - log goes into sliver's /var/log instead
291
292 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
293 - new install-scripts target in Makefile
294 - conf_files and fuse-pl initscripts chmod'ed +x
295 - omf_resctl config template tweaked to use _slicename_%_hostname_
296
297 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
298 - make sure to create /etc/planetlab/virt so others can read that
299 - expose get_node_virt() and command_in_slice()
300 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
301 - user's .profile now has right owner
302 - other tweaks in lxc slivers
303
304 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
305 - lxc slice creation: slice user was created with unknown gid - fixed
306 - lxc slice creation: .profile for root and user - fixed
307
308 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
309 - fix umounting of ssh directory when deleting omf-friendly slivers
310 - support for writing cgroups in subsystems other than cpuset
311 - add xid to template match
312 - finer-grained split between -lib -vs and -lxc
313 - first roughly complete omf_resctl for omfv6
314 - minor fix for when getslivers does not have minexemptrate
315
316 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
317 - Fix path, machine arch in slivers
318
319 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
320
321 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
322 - no-op bump to 5.2 to be in line with the rest of the system
323
324 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
325 - improvements to privatebridge
326
327 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
328 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
329
330 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
331 - fix wrong gre tunnel deleted when topology changes
332
333 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
334 - Update /etc/hosts in slivers from sliver_hostmap tag.
335
336 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
337 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
338 - initial check-in of privatebridge plugin.
339
340 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
341 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
342
343 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
344 - fix slices not deleted properly when they use vsys
345
346 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
347 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
348
349 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
350 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
351
352 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
353 - Bridge virtual interfaces to VLANs
354
355 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
356 - Add support for L2 bridged interfaces with public IPs inside a slice
357
358 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
359 - Support for freezing BestEffort slices for Vicci
360
361 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
362 - Change to use new vsh (wrapper for lxcsu)
363
364 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
365 - add missing import
366 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
367
368 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
369 - tag 2.1-7 was broken for OMF-friendly slices
370 - expose_ssh_dir was erroneously defined on the Worker class
371
372 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
373 - bwlimitlxc now ships with plnode-utils
374
375 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
376 - set LD_PRELOAD for linux-containers nodes
377
378 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
379 - first complete version for vs and lxc - functional but not thoroughly tested though
380
381 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
382 - split packaging in 3 (lib, lxc, vs)
383 - this tag will only work with lxc though
384
385 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
386 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
387
388 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
389 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
390 - purpose being to be able to run this branch on vserver nodes as well
391
392 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
393 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
394 - passes tests with lxc but won't build against vs due to conflict
395 - as bwlimit.py also ships with util-vserver-pl
396
397 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
398 - refactoring: isolate initscript functionality
399 - aimed at making initscript implementation with lxc straightforward
400 - show stack trace when module loading fails
401 - accounts.py renamed into account.py for consistency
402
403 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
404 - /var/log/nodemanager shows duration of mainloop
405
406 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
407 - first working draft for dealing with libvirt/lxc on f16 nodes
408 - not expected to work with mainline nodes (use 2.0 for that for now)
409
410 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
411 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
412
413 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
414 - Added memory scheduling to core scheduler
415 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
416
417 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
418 - tweaked log policy for the core scheduler
419 - curlwrapper has an optional verbose mode
420
421 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
422 - fixes for hmac and omf_control tags
423 - optional besteffort flag to core scheduler
424 - logrotate entry for /var/log/nodemanager.daemon
425 - a template for bash initscripts
426
427 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
428 - rename initscript_body into initscript_code
429 - fix generic vinit for broken bash syntax &>>
430
431 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
432 - new initscript_body slice tag, with stop and restart
433 - generic vinit script live updated
434 - new coresched module
435 - protect against non-existing vsys scripts
436 - use Config. instead of globals
437
438 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
439 - more robust reservation plugin
440
441 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
442 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
443 - reservation plugin more robust
444
445 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
446 - pass device to bwlimit
447
448 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
449 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
450
451 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
452 - Catch all exceptions for sfa plugin
453
454 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
455 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
456
457 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
458 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
459
460 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
461 - plugins/sliverauth.py improvements
462
463 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
464 - Disable sfagids plugin
465
466 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
467 - Re-tag nodemanager to include conflicted commits
468
469 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
470 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
471 - sfagids plugin deleted
472 - band-aid patch for lack of GetSliceFamily removed
473
474 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
475
476 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
477 - revert curlwrapper to former forking-curl version
478 - fixes in the omf plugin for ssh key location and node hrn
479 - set umask 0022 in tools.daemon
480
481 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
482 - configure omf-resctl for keys
483
484 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
485 - fix key generation
486
487 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
488 - name changes and fix typos
489
490 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
491 - remove config and options parameters from start function
492
493 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
494 - working version of reservable nodes
495 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
496 - dismantled the -s|--startup option (no convincing need for that)
497 - simpler and more robust init.d/nm
498 - initscript content management through replace_file_with_string
499 - sliverauth uses replace_file_with_string
500 - curlwrapper has a debug mode
501
502 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
503 - pretty-printing/normalized python code - hopefully neutral
504
505 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
506 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
507 - that triggers /etc/init.d/vinit.slice if present and executable
508 - (2) install the slice-provided initscript (as per the initscript tag) as
509 - /etc/init.d/vinit.slice
510 - (3) as a result the initscript are now triggered by rc as part of the
511 - standard vserver .. start, properly attached to the vserver,
512 - and properly killed upon vserver .. stop
513 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
514
515 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
516 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
517 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
518 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
519 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
520 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
521 - cleanup: nodemanger now is a class; however plugins are still dumb modules
522 - cleanup: does not depend on obsolete Set
523
524 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
525 - tagging before RC
526
527 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
528 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
529 - Added some precautions to the slice id-saving code
530 - Added log message to code that records the slice id
531
532 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
533 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
534 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
535 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
536
537 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
538 - fix log_call in plugins/drl.py
539
540 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
541 - protect against nodes in migrated PLC's not having the hrn tag yet
542
543 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
544 - new omf-resctl and drl plugins
545 - specialaccount optimized to overwrite authorized keys only upon changes
546 - codemux plugin has support for a new 'ip' setting
547 - mainloop to display ordered modules&plugins at all times
548
549 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
550 - modules and plugins have a priority
551 - specialaccounts appears soon in the priority chain
552 - logger.log_call logs process output, and has a timeout
553 - vuser{add,del} run through bash -x
554 - nm initscript has support for 'service nm restartverbose'
555 - logs reviewed for consistency
556 - use hashlib module instead of sha when available
557
558 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
559 - first working version of 5.0:
560 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
561 - nodefamily is 3-fold with pldistro-fcdistro-arch
562 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
563 - (in addition to the 'vref' tag that's still exposed too)
564 - logging reviewed for more convenience
565 - support for 'service nm restartdebug'
566 - make sync knows how to publish uncommitted code on a test node
567
568 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
569 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
570
571 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
572 - support for f10 and f12 in the vref slice tag
573
574 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
575 - build on fedora12
576 - uses slicename 'sfacm' instead of 'genicw'
577
578 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
579 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
580 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
581 - days ago.
582
583 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
584 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
585 - self-contained. With this change, they will be able to refer to the attributes associated with a
586 - slice.
587
588 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
589 - fix for syntax error
590
591 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
592 - -fixed problem with sioc import at the build side
593 - -bwlimit.set() now accepts the device and does not asume that it is eth0
594
595 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
596 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
597
598 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
599 - The seed for random previously was the meaning of life (i.e., 42) but
600 - that resulted in a not so random choice for the hmac.  This
601 - implementation now uses a random.seed that is based on the current
602 - time.
603
604 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
605 - Minor fix such that sliverauth.py makes a more specific call to
606 - GetSliceTags that include that specific tagname it is looking for.
607
608 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
609 - Fix bug that prevented 'OVERRIDES' for working correctly.
610
611 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
612 - Increase disk limits to 10G per sliver
613 - Sanity check slice for home directory before starting (hack)
614 - Check codemux arguments
615
616 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
617 - * Fix Delegation
618 - * Move plcapi in plugin-api GetSlivers() calls.
619 - * Persistent Authcheck and resync session when auth failure
620
621 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
622 - Disabling sliverauth module.  Not ready for deployment.
623
624 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
625 - Fixing overrides semantics.
626
627 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
628 - Generalized plugins
629 - Fixed initscript start up bug.
630
631 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
632 - * Fix delegation authentication problem
633 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
634
635 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
636 - * Rerun initscripts when slice goes from disabled to enabled.
637
638 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
639 - * Update session key when out of synch with PLC
640 - * PLCDefaults uses tagname
641
642 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
643 - log invokations of vsys
644
645 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
646
647 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
648
649 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
650 - Codemux supports multiple hosts mapping to single slice
651 - Fixed bug in delegation support where tickets delivered weren't
652   being passed to sm.deliver_ticket().
653
654 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
655 - Codemux now configured via slice attribute (host,port)
656 - Support for multiple vserver reference images (including different archs)
657 - Mom BW emails are sent to list defined by MyPLC's config
658 - Sirius BW loans honored correctly.  Fixed.
659 - BW totals preserved for dynamic slices so as not to game the system.
660
661 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
662 - Configures vsys via vsys slice attribute {name: vsys, value: script}
663 - CPU reservations are now calculated via percentages instead of shares
664 - BW totals preserved for dynamic slices
665 - Closes bug where node cap sets off bw slice alarms for all slices.
666
667 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
668 - Switched to SVN.
669
670 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> -
671 - Initial build.