4a52cd5e43f5df3c0f0d236d52cb092068dd1799
[nodemanager.git] / nodemanager.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 5.2
5 %define taglevel 17
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 ##############################
10 # for now we just extract all the files but package them only for either vs or lxc
11 # so bottom line is we have missing files at the end
12 # plan is to separate these target-dependant files in subdirs at some point
13 %define _unpackaged_files_terminate_build      0
14
15 ##############################
16 # use initscripts or systemd unit files to start installed services
17 %if "%{distro}" == "Fedora" && "%{distrorelease}" >= "18"
18 %define make_options WITH_SYSTEMD=true
19 %define initdir /usr/lib/systemd/system
20 %define build_lxc 1
21 %else
22 %define make_options WITH_INIT=true
23 %define initdir %{_initrddir}
24 %define build_vs 1
25 %endif
26
27 ##############################
28 Summary: PlanetLab Node Manager Library
29 Name: %{name}
30 Version: %{version}
31 Release: %{release}
32 License: PlanetLab
33 Group: System Environment/Daemons
34 Source0: %{name}-%{version}.tar.gz
35 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
36
37 Vendor: PlanetLab
38 Packager: PlanetLab Central <support@planet-lab.org>
39 Distribution: PlanetLab %{plrelease}
40 URL: %{SCMURL}
41
42 # not possible because of forward_api_calls
43 #BuildArch: noarch
44
45 # make sure we can invoke systemctl in post install script
46 %if "%{initdir}" != "%{_initrddir}"
47 Requires: systemd
48 %endif
49
50 # Uses function decorators
51 Requires: python >= 2.7
52 # connecting PLC
53 Requires: python-pycurl
54 # Signed tickets
55 Requires: gnupg
56 # sioc/plnet
57 Requires: pyplnet >= 4.3
58 # we do need the slice images in any case
59 Requires: sliceimage-%{slicefamily}
60 # for bwlimit
61 Requires: plnode-utils
62
63 %description
64 The PlanetLab Node Manager manages all aspects of PlanetLab node and
65 slice management once the node has been initialized and configured by
66 the Boot Manager. It periodically contacts its management authority
67 for configuration updates. It provides an XML-RPC API for performing
68 local operations on slices.
69 nodemanager-lib only provides a skeleton and needs as a companion
70 either nodemanager-vs or nodemanager-lxc
71
72 ##############################
73 %prep
74 %setup -q
75
76 %build
77 # make manages the C and Python stuff
78 %{__make} %{?_smp_mflags} %{make_options}
79
80 %install
81 # make manages the C and Python stuff
82 rm -rf $RPM_BUILD_ROOT
83 %{__make} %{?_smp_mflags} %{make_options} install DESTDIR="$RPM_BUILD_ROOT"
84
85 ##############################
86 %post
87 ########## traditional init
88 %if "%{initdir}" == "%{_initrddir}"
89 ##########
90 chkconfig --add conf_files
91 chkconfig conf_files on
92 chkconfig --add nm
93 chkconfig nm on
94 chkconfig --add fuse-pl
95 chkconfig fuse-pl on
96 if [ "$PL_BOOTCD" != "1" ] ; then
97     service nm restart
98     service fuse-pl restart
99 fi
100 ##########
101 %else
102 ########## systemd
103 systemctl enable nm.service
104 systemctl enable conf_files.service
105 # empty
106 #systemctl enable fuse-pl.service
107 if [ "$PL_BOOTCD" != "1" ] ; then
108     systemctl restart nm.service
109 #    systemctl restart fuse-pl.service
110 fi
111 ##########
112 %endif
113
114 ##############################
115 %preun
116 # 0 = erase, 1 = upgrade
117 ########## traditional init
118 %if "%{initdir}" == "%{_initrddir}"
119 ##########
120 if [ $1 -eq 0 ] ; then
121     chkconfig fuse-pl off
122     chkconfig --del fuse-pl
123     chkconfig nm off
124     chkconfig --del nm
125     chkconfig conf_files off
126     chkconfig --del conf_files
127 fi
128 ##########
129 %else
130 ########## systemd
131 if [ $1 -eq 0 ] ; then
132 #    systemctl disable fuse-pl.service
133     systemctl disable conf_files.service
134     systemctl disable nm.service
135 fi
136 ##########
137 %endif
138
139 ##############################
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 ##############################
144 %files
145 %defattr(-,root,root,-)
146 %{_datadir}/NodeManager/account.*
147 %{_datadir}/NodeManager/api.*
148 %{_datadir}/NodeManager/api_calls.*
149 %{_datadir}/NodeManager/bwmon.*
150 %{_datadir}/NodeManager/conf_files.*
151 %{_datadir}/NodeManager/config.*
152 %{_datadir}/NodeManager/controller.*
153 %{_datadir}/NodeManager/curlwrapper.*
154 %{_datadir}/NodeManager/database.*
155 %{_datadir}/NodeManager/initscript.*
156 %{_datadir}/NodeManager/iptables.*
157 %{_datadir}/NodeManager/logger.*
158 %{_datadir}/NodeManager/net.*
159 %{_datadir}/NodeManager/nodemanager.*
160 %{_datadir}/NodeManager/plcapi.*
161 %{_datadir}/NodeManager/safexmlrpc.*
162 %{_datadir}/NodeManager/slivermanager.*
163 %{_datadir}/NodeManager/ticket.*
164 %{_datadir}/NodeManager/tools.*
165 %{_datadir}/NodeManager/plugins/__init__.*
166 %{_datadir}/NodeManager/plugins/hostmap.*
167 %{_datadir}/NodeManager/plugins/interfaces.*
168 %{_datadir}/NodeManager/plugins/omf_resctl.*
169 %{_datadir}/NodeManager/plugins/rawdisk.*
170 %{_datadir}/NodeManager/plugins/reservation.*
171 %{_datadir}/NodeManager/plugins/sfagids.*
172 %{_datadir}/NodeManager/plugins/sliverauth.*
173 %{_datadir}/NodeManager/plugins/specialaccounts.*
174 %{_datadir}/NodeManager/plugins/syndicate.*
175 %{_datadir}/NodeManager/plugins/vsys.*
176 %{_datadir}/NodeManager/plugins/vsys_privs.*
177 %{_datadir}/NodeManager/plugins/ipv6.*
178 %{_datadir}/NodeManager/plugins/update_ipv6addr_slivertag.*
179 %{_datadir}/NodeManager/sliver-initscripts/
180 %{_datadir}/NodeManager/sliver-systemd/
181 %{_bindir}/forward_api_calls
182 %{initdir}/
183 %{_sysconfdir}/logrotate.d/nodemanager
184 /var/lib/nodemanager/
185 %config(noreplace) /etc/sysconfig/nodemanager
186
187 ##############################
188 %if "%{build_lxc}" == "1"
189
190 %package -n nodemanager-lxc
191 Summary: PlanetLab Node Manager Plugin for lxc nodes
192 Group: System Environment/Daemons
193 # we use libvirt
194 Requires: libvirt
195 Requires: libvirt-python
196 # cgroups.py needs this
197 Requires: python-inotify
198 # the common package for nodemanager
199 Requires: nodemanager-lib = %{version}
200 # the lxc-specific tools for using slice images
201 Requires: lxc-sliceimage
202 Requires: openvswitch
203
204 %description -n nodemanager-lxc
205 nodemanager-lxc provides the lxc code for the PlanetLab Node Manager.
206
207 %files -n nodemanager-lxc
208 %{_datadir}/NodeManager/sliver_libvirt.*
209 %{_datadir}/NodeManager/sliver_lxc.*
210 %{_datadir}/NodeManager/cgroups.*
211 %{_datadir}/NodeManager/coresched_lxc.*
212 %{_datadir}/NodeManager/plugins/privatebridge.*
213
214 %endif
215 ##############################
216
217 ##############################
218 %if "%{build_vs}" == "1"
219
220 %package -n nodemanager-vs
221 Summary: PlanetLab Node Manager Plugin for vserver nodes
222 Group: System Environment/Daemons
223
224 # old name, when all came as a single package with vserver wired in
225 Obsoletes: NodeManager
226 # for nodeupdate 
227 Provides: nodemanager
228
229 # our interface to the vserver patch
230 Requires: util-vserver >= 0.30.208-17
231 # and the planetlab utilities
232 Requires: util-vserver-python > 0.3-16
233 # the common package for nodemanager
234 Requires: nodemanager-lib = %{version}
235 # the vserver-specific tools for using slice images
236 Requires: vserver-sliceimage
237
238 %description -n nodemanager-vs
239 nodemanager-vs provides the vserver code for the PlanetLab Node Manager.
240
241 %files -n nodemanager-vs
242 %{_datadir}/NodeManager/sliver_vs.*
243 %{_datadir}/NodeManager/coresched_vs.*
244 # this plugin uses vserver for now
245 %{_datadir}/NodeManager/plugins/drl.*
246 # in vs only : turn off the codemux plugin in lxc for now as
247 # it is responsible for the slice re-creation issue
248 %{_datadir}/NodeManager/plugins/codemux.*
249
250 %endif
251 ##############################
252
253 ##############################
254 %changelog
255 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-17
256 - first step towards auto slice-reimaging
257 - slices that would be reimaged because of a change of slicefamily are
258 - identified in the nodemanager's log
259 - might have fixed fd leaks (use context managers whenever possible)
260
261 * Fri Apr 03 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-16
262 - initscript plugin reviewed
263 - turn off the initscript machinery completely on hosts that run f>=20
264 - some tweaks related to cgroup naming in f>=20, including for ipv6
265 - ideally all code depending on the cgroup naming scheme should use cgroups.py
266 - we are not there yet but this is a bit cleaner already
267
268 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-15
269 - addition to support for ipv6 to lxc slivers
270 - (thanks to Guilherme Sperb Machado)
271 - privatebridge plugin is back to the -lxc rpm
272 - add systemd dependency to network.target
273
274 * Tue Jul 22 2014 Thomas Dreibholz <dreibh@simula.no> - nodeimage-5.2-15
275 - nm.service fix: the node manager needs network.target, since it needs to contact the PLC.
276
277 * Wed Jul 16 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-14
278 - review packaging : one single spec file
279 - review packaging : some cleanup towards debians although not complete yet
280 - minor tweaks in exposing user's .ssh dir readonly
281
282 * Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-13
283 - improve network management in slices
284 - _has_systemctl was not declared as global - vsys was failing to restart
285
286 * Fri Apr 04 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-12
287 - this tag for the first time passes the full range of tests on fedora20
288 - robustified slice teardown wrt vsys
289 - Scott's fix for repairing veth devs
290 - removed sshsh
291 - tools.has_systemctl
292
293 * Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-11
294 - ship /etc/sysconfig/nodemanager
295 - trash sshsh
296
297 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-10
298 - comes with systemd native unit files on >= f18
299 - user-provided initscript gets started through systemd in slivers >= f18
300 - smarter to locate cgroups for various versions of libvirt
301 - nicer log format - and log program termination
302 - tweaks in codemux plugin
303 - bug fixes in libvirt driver, esp. for finding out if domain is running
304
305 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
306 - fixes in hostmap, and in interfaces
307 - new vsys_sysctl
308 - privatebridge now comes with nodemanager-lib
309
310 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
311 - omf plugin does not block any longer when running trigger script
312 - log goes into sliver's /var/log instead
313
314 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
315 - new install-scripts target in Makefile
316 - conf_files and fuse-pl initscripts chmod'ed +x
317 - omf_resctl config template tweaked to use _slicename_%_hostname_
318
319 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
320 - make sure to create /etc/planetlab/virt so others can read that
321 - expose get_node_virt() and command_in_slice()
322 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
323 - user's .profile now has right owner
324 - other tweaks in lxc slivers
325
326 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
327 - lxc slice creation: slice user was created with unknown gid - fixed
328 - lxc slice creation: .profile for root and user - fixed
329
330 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
331 - fix umounting of ssh directory when deleting omf-friendly slivers
332 - support for writing cgroups in subsystems other than cpuset
333 - add xid to template match
334 - finer-grained split between -lib -vs and -lxc
335 - first roughly complete omf_resctl for omfv6
336 - minor fix for when getslivers does not have minexemptrate
337
338 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
339 - Fix path, machine arch in slivers
340
341 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
342
343 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
344 - no-op bump to 5.2 to be in line with the rest of the system
345
346 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
347 - improvements to privatebridge
348
349 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
350 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
351
352 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
353 - fix wrong gre tunnel deleted when topology changes
354
355 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
356 - Update /etc/hosts in slivers from sliver_hostmap tag.
357
358 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
359 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
360 - initial check-in of privatebridge plugin.
361
362 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
363 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
364
365 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
366 - fix slices not deleted properly when they use vsys
367
368 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
369 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
370
371 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
372 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
373
374 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
375 - Bridge virtual interfaces to VLANs
376
377 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
378 - Add support for L2 bridged interfaces with public IPs inside a slice
379
380 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
381 - Support for freezing BestEffort slices for Vicci
382
383 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
384 - Change to use new vsh (wrapper for lxcsu)
385
386 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
387 - add missing import
388 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
389
390 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
391 - tag 2.1-7 was broken for OMF-friendly slices
392 - expose_ssh_dir was erroneously defined on the Worker class
393
394 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
395 - bwlimitlxc now ships with plnode-utils
396
397 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
398 - set LD_PRELOAD for linux-containers nodes
399
400 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
401 - first complete version for vs and lxc - functional but not thoroughly tested though
402
403 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
404 - split packaging in 3 (lib, lxc, vs)
405 - this tag will only work with lxc though
406
407 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
408 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
409
410 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
411 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
412 - purpose being to be able to run this branch on vserver nodes as well
413
414 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
415 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
416 - passes tests with lxc but won't build against vs due to conflict
417 - as bwlimit.py also ships with util-vserver-pl
418
419 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
420 - refactoring: isolate initscript functionality
421 - aimed at making initscript implementation with lxc straightforward
422 - show stack trace when module loading fails
423 - accounts.py renamed into account.py for consistency
424
425 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
426 - /var/log/nodemanager shows duration of mainloop
427
428 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
429 - first working draft for dealing with libvirt/lxc on f16 nodes
430 - not expected to work with mainline nodes (use 2.0 for that for now)
431
432 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
433 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
434
435 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
436 - Added memory scheduling to core scheduler
437 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
438
439 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
440 - tweaked log policy for the core scheduler
441 - curlwrapper has an optional verbose mode
442
443 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
444 - fixes for hmac and omf_control tags
445 - optional besteffort flag to core scheduler
446 - logrotate entry for /var/log/nodemanager.daemon
447 - a template for bash initscripts
448
449 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
450 - rename initscript_body into initscript_code
451 - fix generic vinit for broken bash syntax &>>
452
453 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
454 - new initscript_body slice tag, with stop and restart
455 - generic vinit script live updated
456 - new coresched module
457 - protect against non-existing vsys scripts
458 - use Config. instead of globals
459
460 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
461 - more robust reservation plugin
462
463 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
464 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
465 - reservation plugin more robust
466
467 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
468 - pass device to bwlimit
469
470 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
471 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
472
473 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
474 - Catch all exceptions for sfa plugin
475
476 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
477 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
478
479 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
480 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
481
482 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
483 - plugins/sliverauth.py improvements
484
485 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
486 - Disable sfagids plugin
487
488 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
489 - Re-tag nodemanager to include conflicted commits
490
491 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
492 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
493 - sfagids plugin deleted
494 - band-aid patch for lack of GetSliceFamily removed
495
496 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
497
498 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
499 - revert curlwrapper to former forking-curl version
500 - fixes in the omf plugin for ssh key location and node hrn
501 - set umask 0022 in tools.daemon
502
503 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
504 - configure omf-resctl for keys
505
506 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
507 - fix key generation
508
509 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
510 - name changes and fix typos
511
512 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
513 - remove config and options parameters from start function
514
515 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
516 - working version of reservable nodes
517 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
518 - dismantled the -s|--startup option (no convincing need for that)
519 - simpler and more robust init.d/nm
520 - initscript content management through replace_file_with_string
521 - sliverauth uses replace_file_with_string
522 - curlwrapper has a debug mode
523
524 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
525 - pretty-printing/normalized python code - hopefully neutral
526
527 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
528 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
529 - that triggers /etc/init.d/vinit.slice if present and executable
530 - (2) install the slice-provided initscript (as per the initscript tag) as
531 - /etc/init.d/vinit.slice
532 - (3) as a result the initscript are now triggered by rc as part of the
533 - standard vserver .. start, properly attached to the vserver,
534 - and properly killed upon vserver .. stop
535 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
536
537 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
538 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
539 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
540 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
541 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
542 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
543 - cleanup: nodemanger now is a class; however plugins are still dumb modules
544 - cleanup: does not depend on obsolete Set
545
546 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
547 - tagging before RC
548
549 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
550 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
551 - Added some precautions to the slice id-saving code
552 - Added log message to code that records the slice id
553
554 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
555 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
556 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
557 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
558
559 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
560 - fix log_call in plugins/drl.py
561
562 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
563 - protect against nodes in migrated PLC's not having the hrn tag yet
564
565 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
566 - new omf-resctl and drl plugins
567 - specialaccount optimized to overwrite authorized keys only upon changes
568 - codemux plugin has support for a new 'ip' setting
569 - mainloop to display ordered modules&plugins at all times
570
571 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
572 - modules and plugins have a priority
573 - specialaccounts appears soon in the priority chain
574 - logger.log_call logs process output, and has a timeout
575 - vuser{add,del} run through bash -x
576 - nm initscript has support for 'service nm restartverbose'
577 - logs reviewed for consistency
578 - use hashlib module instead of sha when available
579
580 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
581 - first working version of 5.0:
582 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
583 - nodefamily is 3-fold with pldistro-fcdistro-arch
584 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
585 - (in addition to the 'vref' tag that's still exposed too)
586 - logging reviewed for more convenience
587 - support for 'service nm restartdebug'
588 - make sync knows how to publish uncommitted code on a test node
589
590 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
591 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
592
593 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
594 - support for f10 and f12 in the vref slice tag
595
596 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
597 - build on fedora12
598 - uses slicename 'sfacm' instead of 'genicw'
599
600 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
601 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
602 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
603 - days ago.
604
605 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
606 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
607 - self-contained. With this change, they will be able to refer to the attributes associated with a
608 - slice.
609
610 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
611 - fix for syntax error
612
613 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
614 - -fixed problem with sioc import at the build side
615 - -bwlimit.set() now accepts the device and does not asume that it is eth0
616
617 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
618 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
619
620 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
621 - The seed for random previously was the meaning of life (i.e., 42) but
622 - that resulted in a not so random choice for the hmac.  This
623 - implementation now uses a random.seed that is based on the current
624 - time.
625
626 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
627 - Minor fix such that sliverauth.py makes a more specific call to
628 - GetSliceTags that include that specific tagname it is looking for.
629
630 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
631 - Fix bug that prevented 'OVERRIDES' for working correctly.
632
633 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
634 - Increase disk limits to 10G per sliver
635 - Sanity check slice for home directory before starting (hack)
636 - Check codemux arguments
637
638 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
639 - * Fix Delegation
640 - * Move plcapi in plugin-api GetSlivers() calls.
641 - * Persistent Authcheck and resync session when auth failure
642
643 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
644 - Disabling sliverauth module.  Not ready for deployment.
645
646 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
647 - Fixing overrides semantics.
648
649 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
650 - Generalized plugins
651 - Fixed initscript start up bug.
652
653 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
654 - * Fix delegation authentication problem
655 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
656
657 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
658 - * Rerun initscripts when slice goes from disabled to enabled.
659
660 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
661 - * Update session key when out of synch with PLC
662 - * PLCDefaults uses tagname
663
664 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
665 - log invokations of vsys
666
667 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
668
669 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
670
671 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
672 - Codemux supports multiple hosts mapping to single slice
673 - Fixed bug in delegation support where tickets delivered weren't
674   being passed to sm.deliver_ticket().
675
676 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
677 - Codemux now configured via slice attribute (host,port)
678 - Support for multiple vserver reference images (including different archs)
679 - Mom BW emails are sent to list defined by MyPLC's config
680 - Sirius BW loans honored correctly.  Fixed.
681 - BW totals preserved for dynamic slices so as not to game the system.
682
683 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
684 - Configures vsys via vsys slice attribute {name: vsys, value: script}
685 - CPU reservations are now calculated via percentages instead of shares
686 - BW totals preserved for dynamic slices
687 - Closes bug where node cap sets off bw slice alarms for all slices.
688
689 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
690 - Switched to SVN.
691
692 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
693 - Initial build.