Setting tag nodemanager-7.0-0
[nodemanager.git] / nodemanager.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 7.0
5 %define taglevel 0
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 ##############################
10 # for now we just extract all the files but package them only for either vs or lxc
11 # so bottom line is we have missing files at the end
12 # plan is to separate these target-dependant files in subdirs at some point
13 %define _unpackaged_files_terminate_build      0
14
15 ##############################
16 # only systemd unit files to start installed services
17 %define make_options WITH_SYSTEMD=true
18 %define systemddir /usr/lib/systemd/system
19 %define build_lxc 1
20
21 ##############################
22 Summary: PlanetLab Node Manager Library
23 Name: %{name}
24 Version: %{version}
25 Release: %{release}
26 License: PlanetLab
27 Group: System Environment/Daemons
28 Source0: %{name}-%{version}.tar.gz
29 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
30
31 Vendor: PlanetLab
32 Packager: PlanetLab Central <support@planet-lab.org>
33 Distribution: PlanetLab %{plrelease}
34 URL: %{SCMURL}
35
36 # not possible because of forward_api_calls
37 #BuildArch: noarch
38
39 # make sure we can invoke systemctl in post install script
40 Requires: systemd
41
42 # Uses function decorators
43 Requires: python3
44 # connecting PLC
45 Requires: python3-pycurl
46 # Signed tickets
47 Requires: gnupg
48 # sioc/plnet
49 Requires: pyplnet >= 4.3
50 # we do need the slice images in any case
51 Requires: sliceimage-%{slicefamily}
52 # for bwlimit
53 Requires: plnode-utils
54
55 %description
56 The PlanetLab Node Manager manages all aspects of PlanetLab node and
57 slice management once the node has been initialized and configured by
58 the Boot Manager. It periodically contacts its management authority
59 for configuration updates. It provides an XML-RPC API for performing
60 local operations on slices.
61 nodemanager-lib only provides a skeleton and needs as a companion
62 either nodemanager-vs or nodemanager-lxc
63
64 ##############################
65 %prep
66 %setup -q
67
68 %build
69 # make manages the C and Python stuff
70 %{__make} %{?_smp_mflags} %{make_options}
71
72 %install
73 # make manages the C and Python stuff
74 rm -rf $RPM_BUILD_ROOT
75 %{__make} %{?_smp_mflags} %{make_options} install DESTDIR="$RPM_BUILD_ROOT"
76
77 ##############################
78 %post
79 systemctl enable nm.service
80 systemctl enable conf_files.service
81 # empty
82 #systemctl enable fuse-pl.service
83 if [ "$PL_BOOTCD" != "1" ] ; then
84     systemctl restart nm.service
85 #    systemctl restart fuse-pl.service
86 fi
87
88 ##############################
89 %preun
90 # 0 = erase, 1 = upgrade
91 if [ $1 -eq 0 ] ; then
92 #    systemctl disable fuse-pl.service
93     systemctl disable conf_files.service
94     systemctl disable nm.service
95 fi
96
97 ##############################
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 ##############################
102 %files
103 %defattr(-,root,root,-)
104 %{_datadir}/NodeManager/account.*
105 %{_datadir}/NodeManager/api.*
106 %{_datadir}/NodeManager/api_calls.*
107 %{_datadir}/NodeManager/bwmon.*
108 %{_datadir}/NodeManager/conf_files.*
109 %{_datadir}/NodeManager/config.*
110 %{_datadir}/NodeManager/controller.*
111 %{_datadir}/NodeManager/curlwrapper.*
112 %{_datadir}/NodeManager/database.*
113 %{_datadir}/NodeManager/initscript.*
114 %{_datadir}/NodeManager/iptables.*
115 %{_datadir}/NodeManager/logger.*
116 %{_datadir}/NodeManager/net.*
117 %{_datadir}/NodeManager/nodemanager.*
118 %{_datadir}/NodeManager/plcapi.*
119 %{_datadir}/NodeManager/safexmlrpc.*
120 %{_datadir}/NodeManager/slivermanager.*
121 %{_datadir}/NodeManager/ticket.*
122 %{_datadir}/NodeManager/tools.*
123 %{_datadir}/NodeManager/plugins/__init__.*
124 %{_datadir}/NodeManager/plugins/hostmap.*
125 %{_datadir}/NodeManager/plugins/interfaces.*
126 %{_datadir}/NodeManager/plugins/omf_resctl.*
127 %{_datadir}/NodeManager/plugins/rawdisk.*
128 %{_datadir}/NodeManager/plugins/reservation.*
129 %{_datadir}/NodeManager/plugins/sfagids.*
130 %{_datadir}/NodeManager/plugins/sliverauth.*
131 %{_datadir}/NodeManager/plugins/specialaccounts.*
132 %{_datadir}/NodeManager/plugins/syndicate.*
133 %{_datadir}/NodeManager/plugins/vsys.*
134 %{_datadir}/NodeManager/plugins/vsys_privs.*
135 %{_datadir}/NodeManager/plugins/ipv6.*
136 %{_datadir}/NodeManager/plugins/update_ipv6addr_slivertag.*
137 %{_datadir}/NodeManager/sliver-initscripts/
138 %{_datadir}/NodeManager/sliver-systemd/
139 %{_bindir}/forward_api_calls
140 %{systemddir}/
141 %{_sysconfdir}/logrotate.d/nodemanager
142 /var/lib/nodemanager/
143 %config(noreplace) /etc/sysconfig/nodemanager
144
145 ##############################
146 %if "%{build_lxc}" == "1"
147
148 %package -n nodemanager-lxc
149 Summary: PlanetLab Node Manager Plugin for lxc nodes
150 Group: System Environment/Daemons
151 # we use libvirt
152 Requires: libvirt
153 Requires: python3-libvirt
154 # cgroups.py needs this
155 Requires: python3-inotify
156 # the common package for nodemanager
157 Requires: nodemanager-lib = %{version}
158 # the lxc-specific tools for using slice images
159 Requires: lxc-sliceimage
160 Requires: openvswitch
161
162 %description -n nodemanager-lxc
163 nodemanager-lxc provides the lxc code for the PlanetLab Node Manager.
164
165 %files -n nodemanager-lxc
166 %{_datadir}/NodeManager/sliver_libvirt.*
167 %{_datadir}/NodeManager/sliver_lxc.*
168 %{_datadir}/NodeManager/cgroups.*
169 %{_datadir}/NodeManager/coresched_lxc.*
170 %{_datadir}/NodeManager/plugins/privatebridge.*
171
172 %endif
173 ##############################
174
175 ##############################
176 %if "%{build_vs}" == "1"
177
178 %package -n nodemanager-vs
179 Summary: PlanetLab Node Manager Plugin for vserver nodes
180 Group: System Environment/Daemons
181
182 # old name, when all came as a single package with vserver wired in
183 Obsoletes: NodeManager
184 # for nodeupdate
185 Provides: nodemanager
186
187 # our interface to the vserver patch
188 Requires: util-vserver >= 0.30.208-17
189 # and the planetlab utilities
190 Requires: util-vserver-python > 0.3-16
191 # the common package for nodemanager
192 Requires: nodemanager-lib = %{version}
193 # the vserver-specific tools for using slice images
194 Requires: vserver-sliceimage
195
196 %description -n nodemanager-vs
197 nodemanager-vs provides the vserver code for the PlanetLab Node Manager.
198
199 %files -n nodemanager-vs
200 %{_datadir}/NodeManager/sliver_vs.*
201 %{_datadir}/NodeManager/coresched_vs.*
202 # this plugin uses vserver for now
203 %{_datadir}/NodeManager/plugins/drl.*
204 # in vs only : turn off the codemux plugin in lxc for now as
205 # it is responsible for the slice re-creation issue
206 %{_datadir}/NodeManager/plugins/codemux.*
207
208 %endif
209 ##############################
210
211 ##############################
212 %changelog
213 * Mon Jan 07 2019 Thierry <Parmentelat> - nodemanager-7.0-0
214 - ported to python3
215 - add a systemd dependency to network-online so the service won't start too early
216 - only support systemd, removed init-oriented business
217 - also removed debian-oriented business
218
219 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-19
220 - tweak to run against libvirt-python-1.3.3 under f24
221 - fix by Thomas Dreibholz - misspelled ovs-ovsctl
222 - default vrf is f24 - not that it matters much
223
224 * Fri Nov 13 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-18
225 - remove codemux plugin from lxc - was causing slice re-creation issue
226 - has reconnect capabilities to libvirt deamon
227 - reinstate code from a previous version, that deals with btrfs cleaning up
228 - cleaned up cgroups.py
229
230 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-17
231 - first step towards auto slice-reimaging
232 - slices that would be reimaged because of a change of slicefamily are
233 - identified in the nodemanager's log
234 - might have fixed fd leaks (use context managers whenever possible)
235
236 * Fri Apr 03 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-16
237 - initscript plugin reviewed
238 - turn off the initscript machinery completely on hosts that run f>=20
239 - some tweaks related to cgroup naming in f>=20, including for ipv6
240 - ideally all code depending on the cgroup naming scheme should use cgroups.py
241 - we are not there yet but this is a bit cleaner already
242
243 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-15
244 - addition to support for ipv6 to lxc slivers
245 - (thanks to Guilherme Sperb Machado)
246 - privatebridge plugin is back to the -lxc rpm
247 - add systemd dependency to network.target
248
249 * Tue Jul 22 2014 Thomas Dreibholz <dreibh@simula.no> - nodeimage-5.2-15
250 - nm.service fix: the node manager needs network.target, since it needs to contact the PLC.
251
252 * Wed Jul 16 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-14
253 - review packaging : one single spec file
254 - review packaging : some cleanup towards debians although not complete yet
255 - minor tweaks in exposing user's .ssh dir readonly
256
257 * Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-13
258 - improve network management in slices
259 - _has_systemctl was not declared as global - vsys was failing to restart
260
261 * Fri Apr 04 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-12
262 - this tag for the first time passes the full range of tests on fedora20
263 - robustified slice teardown wrt vsys
264 - Scott's fix for repairing veth devs
265 - removed sshsh
266 - tools.has_systemctl
267
268 * Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-11
269 - ship /etc/sysconfig/nodemanager
270 - trash sshsh
271
272 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-10
273 - comes with systemd native unit files on >= f18
274 - user-provided initscript gets started through systemd in slivers >= f18
275 - smarter to locate cgroups for various versions of libvirt
276 - nicer log format - and log program termination
277 - tweaks in codemux plugin
278 - bug fixes in libvirt driver, esp. for finding out if domain is running
279
280 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
281 - fixes in hostmap, and in interfaces
282 - new vsys_sysctl
283 - privatebridge now comes with nodemanager-lib
284
285 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
286 - omf plugin does not block any longer when running trigger script
287 - log goes into sliver's /var/log instead
288
289 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
290 - new install-scripts target in Makefile
291 - conf_files and fuse-pl initscripts chmod'ed +x
292 - omf_resctl config template tweaked to use _slicename_%_hostname_
293
294 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
295 - make sure to create /etc/planetlab/virt so others can read that
296 - expose get_node_virt() and command_in_slice()
297 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
298 - user's .profile now has right owner
299 - other tweaks in lxc slivers
300
301 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
302 - lxc slice creation: slice user was created with unknown gid - fixed
303 - lxc slice creation: .profile for root and user - fixed
304
305 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
306 - fix umounting of ssh directory when deleting omf-friendly slivers
307 - support for writing cgroups in subsystems other than cpuset
308 - add xid to template match
309 - finer-grained split between -lib -vs and -lxc
310 - first roughly complete omf_resctl for omfv6
311 - minor fix for when getslivers does not have minexemptrate
312
313 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
314 - Fix path, machine arch in slivers
315
316 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
317
318 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
319 - no-op bump to 5.2 to be in line with the rest of the system
320
321 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
322 - improvements to privatebridge
323
324 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
325 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
326
327 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
328 - fix wrong gre tunnel deleted when topology changes
329
330 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
331 - Update /etc/hosts in slivers from sliver_hostmap tag.
332
333 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
334 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
335 - initial check-in of privatebridge plugin.
336
337 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
338 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
339
340 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
341 - fix slices not deleted properly when they use vsys
342
343 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
344 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
345
346 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
347 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
348
349 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
350 - Bridge virtual interfaces to VLANs
351
352 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
353 - Add support for L2 bridged interfaces with public IPs inside a slice
354
355 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
356 - Support for freezing BestEffort slices for Vicci
357
358 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
359 - Change to use new vsh (wrapper for lxcsu)
360
361 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
362 - add missing import
363 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
364
365 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
366 - tag 2.1-7 was broken for OMF-friendly slices
367 - expose_ssh_dir was erroneously defined on the Worker class
368
369 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
370 - bwlimitlxc now ships with plnode-utils
371
372 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
373 - set LD_PRELOAD for linux-containers nodes
374
375 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
376 - first complete version for vs and lxc - functional but not thoroughly tested though
377
378 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
379 - split packaging in 3 (lib, lxc, vs)
380 - this tag will only work with lxc though
381
382 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
383 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
384
385 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
386 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
387 - purpose being to be able to run this branch on vserver nodes as well
388
389 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
390 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
391 - passes tests with lxc but won't build against vs due to conflict
392 - as bwlimit.py also ships with util-vserver-pl
393
394 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
395 - refactoring: isolate initscript functionality
396 - aimed at making initscript implementation with lxc straightforward
397 - show stack trace when module loading fails
398 - accounts.py renamed into account.py for consistency
399
400 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
401 - /var/log/nodemanager shows duration of mainloop
402
403 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
404 - first working draft for dealing with libvirt/lxc on f16 nodes
405 - not expected to work with mainline nodes (use 2.0 for that for now)
406
407 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
408 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
409
410 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
411 - Added memory scheduling to core scheduler
412 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
413
414 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
415 - tweaked log policy for the core scheduler
416 - curlwrapper has an optional verbose mode
417
418 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
419 - fixes for hmac and omf_control tags
420 - optional besteffort flag to core scheduler
421 - logrotate entry for /var/log/nodemanager.daemon
422 - a template for bash initscripts
423
424 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
425 - rename initscript_body into initscript_code
426 - fix generic vinit for broken bash syntax &>>
427
428 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
429 - new initscript_body slice tag, with stop and restart
430 - generic vinit script live updated
431 - new coresched module
432 - protect against non-existing vsys scripts
433 - use Config. instead of globals
434
435 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
436 - more robust reservation plugin
437
438 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
439 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
440 - reservation plugin more robust
441
442 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
443 - pass device to bwlimit
444
445 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
446 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
447
448 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
449 - Catch all exceptions for sfa plugin
450
451 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
452 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
453
454 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
455 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
456
457 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
458 - plugins/sliverauth.py improvements
459
460 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
461 - Disable sfagids plugin
462
463 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
464 - Re-tag nodemanager to include conflicted commits
465
466 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
467 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
468 - sfagids plugin deleted
469 - band-aid patch for lack of GetSliceFamily removed
470
471 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
472
473 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
474 - revert curlwrapper to former forking-curl version
475 - fixes in the omf plugin for ssh key location and node hrn
476 - set umask 0022 in tools.daemon
477
478 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
479 - configure omf-resctl for keys
480
481 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
482 - fix key generation
483
484 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
485 - name changes and fix typos
486
487 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
488 - remove config and options parameters from start function
489
490 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
491 - working version of reservable nodes
492 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
493 - dismantled the -s|--startup option (no convincing need for that)
494 - simpler and more robust init.d/nm
495 - initscript content management through replace_file_with_string
496 - sliverauth uses replace_file_with_string
497 - curlwrapper has a debug mode
498
499 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
500 - pretty-printing/normalized python code - hopefully neutral
501
502 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
503 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
504 - that triggers /etc/init.d/vinit.slice if present and executable
505 - (2) install the slice-provided initscript (as per the initscript tag) as
506 - /etc/init.d/vinit.slice
507 - (3) as a result the initscript are now triggered by rc as part of the
508 - standard vserver .. start, properly attached to the vserver,
509 - and properly killed upon vserver .. stop
510 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
511
512 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
513 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
514 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
515 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
516 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
517 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
518 - cleanup: nodemanger now is a class; however plugins are still dumb modules
519 - cleanup: does not depend on obsolete Set
520
521 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
522 - tagging before RC
523
524 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
525 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
526 - Added some precautions to the slice id-saving code
527 - Added log message to code that records the slice id
528
529 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
530 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
531 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
532 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
533
534 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
535 - fix log_call in plugins/drl.py
536
537 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
538 - protect against nodes in migrated PLC's not having the hrn tag yet
539
540 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
541 - new omf-resctl and drl plugins
542 - specialaccount optimized to overwrite authorized keys only upon changes
543 - codemux plugin has support for a new 'ip' setting
544 - mainloop to display ordered modules&plugins at all times
545
546 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
547 - modules and plugins have a priority
548 - specialaccounts appears soon in the priority chain
549 - logger.log_call logs process output, and has a timeout
550 - vuser{add,del} run through bash -x
551 - nm initscript has support for 'service nm restartverbose'
552 - logs reviewed for consistency
553 - use hashlib module instead of sha when available
554
555 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
556 - first working version of 5.0:
557 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
558 - nodefamily is 3-fold with pldistro-fcdistro-arch
559 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
560 - (in addition to the 'vref' tag that's still exposed too)
561 - logging reviewed for more convenience
562 - support for 'service nm restartdebug'
563 - make sync knows how to publish uncommitted code on a test node
564
565 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
566 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
567
568 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
569 - support for f10 and f12 in the vref slice tag
570
571 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
572 - build on fedora12
573 - uses slicename 'sfacm' instead of 'genicw'
574
575 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
576 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
577 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
578 - days ago.
579
580 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
581 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
582 - self-contained. With this change, they will be able to refer to the attributes associated with a
583 - slice.
584
585 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
586 - fix for syntax error
587
588 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
589 - -fixed problem with sioc import at the build side
590 - -bwlimit.set() now accepts the device and does not asume that it is eth0
591
592 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
593 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
594
595 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
596 - The seed for random previously was the meaning of life (i.e., 42) but
597 - that resulted in a not so random choice for the hmac.  This
598 - implementation now uses a random.seed that is based on the current
599 - time.
600
601 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
602 - Minor fix such that sliverauth.py makes a more specific call to
603 - GetSliceTags that include that specific tagname it is looking for.
604
605 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
606 - Fix bug that prevented 'OVERRIDES' for working correctly.
607
608 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
609 - Increase disk limits to 10G per sliver
610 - Sanity check slice for home directory before starting (hack)
611 - Check codemux arguments
612
613 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
614 - * Fix Delegation
615 - * Move plcapi in plugin-api GetSlivers() calls.
616 - * Persistent Authcheck and resync session when auth failure
617
618 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
619 - Disabling sliverauth module.  Not ready for deployment.
620
621 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
622 - Fixing overrides semantics.
623
624 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
625 - Generalized plugins
626 - Fixed initscript start up bug.
627
628 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
629 - * Fix delegation authentication problem
630 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
631
632 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
633 - * Rerun initscripts when slice goes from disabled to enabled.
634
635 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
636 - * Update session key when out of synch with PLC
637 - * PLCDefaults uses tagname
638
639 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
640 - log invokations of vsys
641
642 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
643
644 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
645
646 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
647 - Codemux supports multiple hosts mapping to single slice
648 - Fixed bug in delegation support where tickets delivered weren't
649   being passed to sm.deliver_ticket().
650
651 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
652 - Codemux now configured via slice attribute (host,port)
653 - Support for multiple vserver reference images (including different archs)
654 - Mom BW emails are sent to list defined by MyPLC's config
655 - Sirius BW loans honored correctly.  Fixed.
656 - BW totals preserved for dynamic slices so as not to game the system.
657
658 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
659 - Configures vsys via vsys slice attribute {name: vsys, value: script}
660 - CPU reservations are now calculated via percentages instead of shares
661 - BW totals preserved for dynamic slices
662 - Closes bug where node cap sets off bw slice alarms for all slices.
663
664 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
665 - Switched to SVN.
666
667 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> -
668 - Initial build.