provide default to WITH_INIT and WITH_SYSTEMD right in the makefile
[nodemanager.git] / nodemanager.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 5.2
5 %define taglevel 12
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 ##############################
10 # for now we just extract all the files but package them only for either vs or lxc
11 # so bottom line is we have missing files at the end
12 # plan is to separate these target-dependant files in subdirs at some point
13 %define _unpackaged_files_terminate_build      0
14
15 ##############################
16 # use initscripts or systemd unit files to start installed services
17 %if "%{distro}" == "Fedora" && "%{distrorelease}" >= "18"
18 %define make_options WITH_SYSTEMD=true
19 %define initdir /usr/lib/systemd/system
20 %define build_lxc 1
21 %else
22 %define make_options WITH_INIT=true
23 %define initdir %{_initrddir}
24 %define build_vs 1
25 %endif
26
27 ##############################
28 Summary: PlanetLab Node Manager Library
29 Name: %{name}
30 Version: %{version}
31 Release: %{release}
32 License: PlanetLab
33 Group: System Environment/Daemons
34 Source0: %{name}-%{version}.tar.gz
35 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
36
37 Vendor: PlanetLab
38 Packager: PlanetLab Central <support@planet-lab.org>
39 Distribution: PlanetLab %{plrelease}
40 URL: %{SCMURL}
41
42 # not possible because of forward_api_calls
43 #BuildArch: noarch
44
45 # make sure we can invoke systemctl in post install script
46 %if "%{initdir}" != "%{_initrddir}"
47 Requires: systemd
48 %endif
49
50 # Uses function decorators
51 Requires: python >= 2.7
52 # connecting PLC
53 Requires: python-pycurl
54 # Signed tickets
55 Requires: gnupg
56 # sioc/plnet
57 Requires: pyplnet >= 4.3
58 # we do need the slice images in any case
59 Requires: sliceimage-%{slicefamily}
60 # for bwlimit
61 Requires: plnode-utils
62
63 %description
64 The PlanetLab Node Manager manages all aspects of PlanetLab node and
65 slice management once the node has been initialized and configured by
66 the Boot Manager. It periodically contacts its management authority
67 for configuration updates. It provides an XML-RPC API for performing
68 local operations on slices.
69 nodemanager-lib only provides a skeleton and needs as a companion
70 either nodemanager-vs or nodemanager-lxc
71
72 ##############################
73 %prep
74 %setup -q
75
76 %build
77 # make manages the C and Python stuff
78 %{__make} %{?_smp_mflags} %{make_options}
79
80 %install
81 # make manages the C and Python stuff
82 rm -rf $RPM_BUILD_ROOT
83 %{__make} %{?_smp_mflags} %{make_options} install DESTDIR="$RPM_BUILD_ROOT"
84
85 ##############################
86 %post
87 ########## traditional init
88 %if "%{initdir}" == "%{_initrddir}"
89 ##########
90 chkconfig --add conf_files
91 chkconfig conf_files on
92 chkconfig --add nm
93 chkconfig nm on
94 chkconfig --add fuse-pl
95 chkconfig fuse-pl on
96 if [ "$PL_BOOTCD" != "1" ] ; then
97     service nm restart
98     service fuse-pl restart
99 fi
100 ##########
101 %else
102 ########## systemd
103 systemctl enable nm.service
104 systemctl enable conf_files.service
105 # empty
106 #systemctl enable fuse-pl.service
107 if [ "$PL_BOOTCD" != "1" ] ; then
108     systemctl restart nm.service
109 #    systemctl restart fuse-pl.service
110 fi
111 ##########
112 %endif
113
114 ##############################
115 %preun
116 # 0 = erase, 1 = upgrade
117 ########## traditional init
118 %if "%{initdir}" == "%{_initrddir}"
119 ##########
120 if [ $1 -eq 0 ] ; then
121     chkconfig fuse-pl off
122     chkconfig --del fuse-pl
123     chkconfig nm off
124     chkconfig --del nm
125     chkconfig conf_files off
126     chkconfig --del conf_files
127 fi
128 ##########
129 %else
130 ########## systemd
131 if [ $1 -eq 0 ] ; then
132 #    systemctl disable fuse-pl.service
133     systemctl disable conf_files.service
134     systemctl disable nm.service
135 fi
136 ##########
137 %endif
138
139 ##############################
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 ##############################
144 %files
145 %defattr(-,root,root,-)
146 %{_datadir}/NodeManager/account.*
147 %{_datadir}/NodeManager/api.*
148 %{_datadir}/NodeManager/api_calls.*
149 %{_datadir}/NodeManager/bwmon.*
150 %{_datadir}/NodeManager/conf_files.*
151 %{_datadir}/NodeManager/config.*
152 %{_datadir}/NodeManager/controller.*
153 %{_datadir}/NodeManager/curlwrapper.*
154 %{_datadir}/NodeManager/database.*
155 %{_datadir}/NodeManager/initscript.*
156 %{_datadir}/NodeManager/iptables.*
157 %{_datadir}/NodeManager/logger.*
158 %{_datadir}/NodeManager/net.*
159 %{_datadir}/NodeManager/nodemanager.*
160 %{_datadir}/NodeManager/plcapi.*
161 %{_datadir}/NodeManager/safexmlrpc.*
162 %{_datadir}/NodeManager/slivermanager.*
163 %{_datadir}/NodeManager/ticket.*
164 %{_datadir}/NodeManager/tools.*
165 %{_datadir}/NodeManager/plugins/codemux.*
166 %{_datadir}/NodeManager/plugins/hostmap.*
167 %{_datadir}/NodeManager/plugins/interfaces.*
168 %{_datadir}/NodeManager/plugins/omf_resctl.*
169 %{_datadir}/NodeManager/plugins/privatebridge.*
170 %{_datadir}/NodeManager/plugins/rawdisk.*
171 %{_datadir}/NodeManager/plugins/reservation.*
172 %{_datadir}/NodeManager/plugins/sfagids.*
173 %{_datadir}/NodeManager/plugins/sliverauth.*
174 %{_datadir}/NodeManager/plugins/specialaccounts.*
175 %{_datadir}/NodeManager/plugins/syndicate.*
176 %{_datadir}/NodeManager/plugins/vsys.*
177 %{_datadir}/NodeManager/plugins/vsys_privs.*
178 %{_bindir}/forward_api_calls
179 %{initdir}/
180 %{_sysconfdir}/logrotate.d/nodemanager
181 /var/lib/nodemanager/
182 %config(noreplace) /etc/sysconfig/nodemanager
183
184 ##############################
185 %if "%{build_lxc}" == "1"
186
187 %package -n nodemanager-lxc
188 Summary: PlanetLab Node Manager Plugin for lxc nodes
189 Group: System Environment/Daemons
190 # we use libvirt
191 Requires: libvirt
192 Requires: libvirt-python
193 # cgroups.py needs this
194 Requires: python-inotify
195 # the common package for nodemanager
196 Requires: nodemanager-lib = %{version}
197 # the lxc-specific tools for using slice images
198 Requires: lxc-sliceimage
199 Requires: openvswitch
200
201 %description -n nodemanager-lxc
202 nodemanager-lxc provides the lxc code for the PlanetLab Node Manager.
203
204 %files -n nodemanager-lxc
205 %{_datadir}/NodeManager/sliver_libvirt.*
206 %{_datadir}/NodeManager/sliver_lxc.*
207 %{_datadir}/NodeManager/cgroups.*
208 %{_datadir}/NodeManager/coresched_lxc.*
209
210 %endif
211 ##############################
212
213 ##############################
214 %if "%{build_vs}" == "1"
215
216 %package -n nodemanager-vs
217 Summary: PlanetLab Node Manager Plugin for vserver nodes
218 Group: System Environment/Daemons
219
220 # old name, when all came as a single package with vserver wired in
221 Obsoletes: NodeManager
222 # for nodeupdate 
223 Provides: nodemanager
224
225 # our interface to the vserver patch
226 Requires: util-vserver >= 0.30.208-17
227 # and the planetlab utilities
228 Requires: util-vserver-python > 0.3-16
229 # the common package for nodemanager
230 Requires: nodemanager-lib = %{version}
231 # the vserver-specific tools for using slice images
232 Requires: vserver-sliceimage
233
234 %description -n nodemanager-vs
235 nodemanager-vs provides the vserver code for the PlanetLab Node Manager.
236
237 %files -n nodemanager-vs
238 %{_datadir}/NodeManager/sliver_vs.*
239 %{_datadir}/NodeManager/coresched_vs.*
240 # this plugin uses vserver for now
241 %{_datadir}/NodeManager/plugins.drl.*
242
243 %endif
244 ##############################
245
246 ##############################
247 %changelog
248 * Fri Apr 04 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-12
249 - this tag for the first time passes the full range of tests on fedora20
250 - robustified slice teardown wrt vsys
251 - Scott's fix for repairing veth devs
252 - removed sshsh
253 - tools.has_systemctl
254
255 * Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-11
256 - ship /etc/sysconfig/nodemanager
257 - trash sshsh
258
259 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-10
260 - comes with systemd native unit files on >= f18
261 - user-provided initscript gets started through systemd in slivers >= f18
262 - smarter to locate cgroups for various versions of libvirt
263 - nicer log format - and log program termination
264 - tweaks in codemux plugin
265 - bug fixes in libvirt driver, esp. for finding out if domain is running
266
267 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
268 - fixes in hostmap, and in interfaces
269 - new vsys_sysctl
270 - privatebridge now comes with nodemanager-lib
271
272 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
273 - omf plugin does not block any longer when running trigger script
274 - log goes into sliver's /var/log instead
275
276 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
277 - new install-scripts target in Makefile
278 - conf_files and fuse-pl initscripts chmod'ed +x
279 - omf_resctl config template tweaked to use _slicename_%_hostname_
280
281 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
282 - make sure to create /etc/planetlab/virt so others can read that
283 - expose get_node_virt() and command_in_slice()
284 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
285 - user's .profile now has right owner
286 - other tweaks in lxc slivers
287
288 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
289 - lxc slice creation: slice user was created with unknown gid - fixed
290 - lxc slice creation: .profile for root and user - fixed
291
292 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
293 - fix umounting of ssh directory when deleting omf-friendly slivers
294 - support for writing cgroups in subsystems other than cpuset
295 - add xid to template match
296 - finer-grained split between -lib -vs and -lxc
297 - first roughly complete omf_resctl for omfv6
298 - minor fix for when getslivers does not have minexemptrate
299
300 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
301 - Fix path, machine arch in slivers
302
303 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
304
305 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
306 - no-op bump to 5.2 to be in line with the rest of the system
307
308 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
309 - improvements to privatebridge
310
311 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
312 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
313
314 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
315 - fix wrong gre tunnel deleted when topology changes
316
317 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
318 - Update /etc/hosts in slivers from sliver_hostmap tag.
319
320 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
321 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
322 - initial check-in of privatebridge plugin.
323
324 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
325 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
326
327 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
328 - fix slices not deleted properly when they use vsys
329
330 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
331 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
332
333 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
334 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
335
336 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
337 - Bridge virtual interfaces to VLANs
338
339 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
340 - Add support for L2 bridged interfaces with public IPs inside a slice
341
342 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
343 - Support for freezing BestEffort slices for Vicci
344
345 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
346 - Change to use new vsh (wrapper for lxcsu)
347
348 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
349 - add missing import
350 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
351
352 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
353 - tag 2.1-7 was broken for OMF-friendly slices
354 - expose_ssh_dir was erroneously defined on the Worker class
355
356 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
357 - bwlimitlxc now ships with plnode-utils
358
359 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
360 - set LD_PRELOAD for linux-containers nodes
361
362 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
363 - first complete version for vs and lxc - functional but not thoroughly tested though
364
365 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
366 - split packaging in 3 (lib, lxc, vs)
367 - this tag will only work with lxc though
368
369 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
370 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
371
372 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
373 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
374 - purpose being to be able to run this branch on vserver nodes as well
375
376 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
377 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
378 - passes tests with lxc but won't build against vs due to conflict
379 - as bwlimit.py also ships with util-vserver-pl
380
381 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
382 - refactoring: isolate initscript functionality
383 - aimed at making initscript implementation with lxc straightforward
384 - show stack trace when module loading fails
385 - accounts.py renamed into account.py for consistency
386
387 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
388 - /var/log/nodemanager shows duration of mainloop
389
390 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
391 - first working draft for dealing with libvirt/lxc on f16 nodes
392 - not expected to work with mainline nodes (use 2.0 for that for now)
393
394 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
395 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
396
397 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
398 - Added memory scheduling to core scheduler
399 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
400
401 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
402 - tweaked log policy for the core scheduler
403 - curlwrapper has an optional verbose mode
404
405 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
406 - fixes for hmac and omf_control tags
407 - optional besteffort flag to core scheduler
408 - logrotate entry for /var/log/nodemanager.daemon
409 - a template for bash initscripts
410
411 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
412 - rename initscript_body into initscript_code
413 - fix generic vinit for broken bash syntax &>>
414
415 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
416 - new initscript_body slice tag, with stop and restart
417 - generic vinit script live updated
418 - new coresched module
419 - protect against non-existing vsys scripts
420 - use Config. instead of globals
421
422 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
423 - more robust reservation plugin
424
425 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
426 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
427 - reservation plugin more robust
428
429 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
430 - pass device to bwlimit
431
432 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
433 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
434
435 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
436 - Catch all exceptions for sfa plugin
437
438 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
439 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
440
441 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
442 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
443
444 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
445 - plugins/sliverauth.py improvements
446
447 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
448 - Disable sfagids plugin
449
450 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
451 - Re-tag nodemanager to include conflicted commits
452
453 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
454 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
455 - sfagids plugin deleted
456 - band-aid patch for lack of GetSliceFamily removed
457
458 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
459
460 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
461 - revert curlwrapper to former forking-curl version
462 - fixes in the omf plugin for ssh key location and node hrn
463 - set umask 0022 in tools.daemon
464
465 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
466 - configure omf-resctl for keys
467
468 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
469 - fix key generation
470
471 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
472 - name changes and fix typos
473
474 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
475 - remove config and options parameters from start function
476
477 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
478 - working version of reservable nodes
479 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
480 - dismantled the -s|--startup option (no convincing need for that)
481 - simpler and more robust init.d/nm
482 - initscript content management through replace_file_with_string
483 - sliverauth uses replace_file_with_string
484 - curlwrapper has a debug mode
485
486 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
487 - pretty-printing/normalized python code - hopefully neutral
488
489 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
490 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
491 - that triggers /etc/init.d/vinit.slice if present and executable
492 - (2) install the slice-provided initscript (as per the initscript tag) as
493 - /etc/init.d/vinit.slice
494 - (3) as a result the initscript are now triggered by rc as part of the
495 - standard vserver .. start, properly attached to the vserver,
496 - and properly killed upon vserver .. stop
497 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
498
499 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
500 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
501 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
502 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
503 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
504 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
505 - cleanup: nodemanger now is a class; however plugins are still dumb modules
506 - cleanup: does not depend on obsolete Set
507
508 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
509 - tagging before RC
510
511 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
512 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
513 - Added some precautions to the slice id-saving code
514 - Added log message to code that records the slice id
515
516 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
517 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
518 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
519 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
520
521 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
522 - fix log_call in plugins/drl.py
523
524 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
525 - protect against nodes in migrated PLC's not having the hrn tag yet
526
527 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
528 - new omf-resctl and drl plugins
529 - specialaccount optimized to overwrite authorized keys only upon changes
530 - codemux plugin has support for a new 'ip' setting
531 - mainloop to display ordered modules&plugins at all times
532
533 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
534 - modules and plugins have a priority
535 - specialaccounts appears soon in the priority chain
536 - logger.log_call logs process output, and has a timeout
537 - vuser{add,del} run through bash -x
538 - nm initscript has support for 'service nm restartverbose'
539 - logs reviewed for consistency
540 - use hashlib module instead of sha when available
541
542 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
543 - first working version of 5.0:
544 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
545 - nodefamily is 3-fold with pldistro-fcdistro-arch
546 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
547 - (in addition to the 'vref' tag that's still exposed too)
548 - logging reviewed for more convenience
549 - support for 'service nm restartdebug'
550 - make sync knows how to publish uncommitted code on a test node
551
552 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
553 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
554
555 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
556 - support for f10 and f12 in the vref slice tag
557
558 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
559 - build on fedora12
560 - uses slicename 'sfacm' instead of 'genicw'
561
562 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
563 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
564 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
565 - days ago.
566
567 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
568 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
569 - self-contained. With this change, they will be able to refer to the attributes associated with a
570 - slice.
571
572 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
573 - fix for syntax error
574
575 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
576 - -fixed problem with sioc import at the build side
577 - -bwlimit.set() now accepts the device and does not asume that it is eth0
578
579 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
580 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
581
582 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
583 - The seed for random previously was the meaning of life (i.e., 42) but
584 - that resulted in a not so random choice for the hmac.  This
585 - implementation now uses a random.seed that is based on the current
586 - time.
587
588 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
589 - Minor fix such that sliverauth.py makes a more specific call to
590 - GetSliceTags that include that specific tagname it is looking for.
591
592 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
593 - Fix bug that prevented 'OVERRIDES' for working correctly.
594
595 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
596 - Increase disk limits to 10G per sliver
597 - Sanity check slice for home directory before starting (hack)
598 - Check codemux arguments
599
600 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
601 - * Fix Delegation
602 - * Move plcapi in plugin-api GetSlivers() calls.
603 - * Persistent Authcheck and resync session when auth failure
604
605 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
606 - Disabling sliverauth module.  Not ready for deployment.
607
608 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
609 - Fixing overrides semantics.
610
611 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
612 - Generalized plugins
613 - Fixed initscript start up bug.
614
615 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
616 - * Fix delegation authentication problem
617 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
618
619 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
620 - * Rerun initscripts when slice goes from disabled to enabled.
621
622 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
623 - * Update session key when out of synch with PLC
624 - * PLCDefaults uses tagname
625
626 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
627 - log invokations of vsys
628
629 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
630
631 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
632
633 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
634 - Codemux supports multiple hosts mapping to single slice
635 - Fixed bug in delegation support where tickets delivered weren't
636   being passed to sm.deliver_ticket().
637
638 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
639 - Codemux now configured via slice attribute (host,port)
640 - Support for multiple vserver reference images (including different archs)
641 - Mom BW emails are sent to list defined by MyPLC's config
642 - Sirius BW loans honored correctly.  Fixed.
643 - BW totals preserved for dynamic slices so as not to game the system.
644
645 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
646 - Configures vsys via vsys slice attribute {name: vsys, value: script}
647 - CPU reservations are now calculated via percentages instead of shares
648 - BW totals preserved for dynamic slices
649 - Closes bug where node cap sets off bw slice alarms for all slices.
650
651 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
652 - Switched to SVN.
653
654 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
655 - Initial build.