tweak privatebridge to remove exception message when ovs is not installed - prints...
[nodemanager.git] / nodemanager.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 5.2
5 %define taglevel 14
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 ##############################
10 # for now we just extract all the files but package them only for either vs or lxc
11 # so bottom line is we have missing files at the end
12 # plan is to separate these target-dependant files in subdirs at some point
13 %define _unpackaged_files_terminate_build      0
14
15 ##############################
16 # use initscripts or systemd unit files to start installed services
17 %if "%{distro}" == "Fedora" && "%{distrorelease}" >= "18"
18 %define make_options WITH_SYSTEMD=true
19 %define initdir /usr/lib/systemd/system
20 %define build_lxc 1
21 %else
22 %define make_options WITH_INIT=true
23 %define initdir %{_initrddir}
24 %define build_vs 1
25 %endif
26
27 ##############################
28 Summary: PlanetLab Node Manager Library
29 Name: %{name}
30 Version: %{version}
31 Release: %{release}
32 License: PlanetLab
33 Group: System Environment/Daemons
34 Source0: %{name}-%{version}.tar.gz
35 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
36
37 Vendor: PlanetLab
38 Packager: PlanetLab Central <support@planet-lab.org>
39 Distribution: PlanetLab %{plrelease}
40 URL: %{SCMURL}
41
42 # not possible because of forward_api_calls
43 #BuildArch: noarch
44
45 # make sure we can invoke systemctl in post install script
46 %if "%{initdir}" != "%{_initrddir}"
47 Requires: systemd
48 %endif
49
50 # Uses function decorators
51 Requires: python >= 2.7
52 # connecting PLC
53 Requires: python-pycurl
54 # Signed tickets
55 Requires: gnupg
56 # sioc/plnet
57 Requires: pyplnet >= 4.3
58 # we do need the slice images in any case
59 Requires: sliceimage-%{slicefamily}
60 # for bwlimit
61 Requires: plnode-utils
62
63 %description
64 The PlanetLab Node Manager manages all aspects of PlanetLab node and
65 slice management once the node has been initialized and configured by
66 the Boot Manager. It periodically contacts its management authority
67 for configuration updates. It provides an XML-RPC API for performing
68 local operations on slices.
69 nodemanager-lib only provides a skeleton and needs as a companion
70 either nodemanager-vs or nodemanager-lxc
71
72 ##############################
73 %prep
74 %setup -q
75
76 %build
77 # make manages the C and Python stuff
78 %{__make} %{?_smp_mflags} %{make_options}
79
80 %install
81 # make manages the C and Python stuff
82 rm -rf $RPM_BUILD_ROOT
83 %{__make} %{?_smp_mflags} %{make_options} install DESTDIR="$RPM_BUILD_ROOT"
84
85 ##############################
86 %post
87 ########## traditional init
88 %if "%{initdir}" == "%{_initrddir}"
89 ##########
90 chkconfig --add conf_files
91 chkconfig conf_files on
92 chkconfig --add nm
93 chkconfig nm on
94 chkconfig --add fuse-pl
95 chkconfig fuse-pl on
96 if [ "$PL_BOOTCD" != "1" ] ; then
97     service nm restart
98     service fuse-pl restart
99 fi
100 ##########
101 %else
102 ########## systemd
103 systemctl enable nm.service
104 systemctl enable conf_files.service
105 # empty
106 #systemctl enable fuse-pl.service
107 if [ "$PL_BOOTCD" != "1" ] ; then
108     systemctl restart nm.service
109 #    systemctl restart fuse-pl.service
110 fi
111 ##########
112 %endif
113
114 ##############################
115 %preun
116 # 0 = erase, 1 = upgrade
117 ########## traditional init
118 %if "%{initdir}" == "%{_initrddir}"
119 ##########
120 if [ $1 -eq 0 ] ; then
121     chkconfig fuse-pl off
122     chkconfig --del fuse-pl
123     chkconfig nm off
124     chkconfig --del nm
125     chkconfig conf_files off
126     chkconfig --del conf_files
127 fi
128 ##########
129 %else
130 ########## systemd
131 if [ $1 -eq 0 ] ; then
132 #    systemctl disable fuse-pl.service
133     systemctl disable conf_files.service
134     systemctl disable nm.service
135 fi
136 ##########
137 %endif
138
139 ##############################
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 ##############################
144 %files
145 %defattr(-,root,root,-)
146 %{_datadir}/NodeManager/account.*
147 %{_datadir}/NodeManager/api.*
148 %{_datadir}/NodeManager/api_calls.*
149 %{_datadir}/NodeManager/bwmon.*
150 %{_datadir}/NodeManager/conf_files.*
151 %{_datadir}/NodeManager/config.*
152 %{_datadir}/NodeManager/controller.*
153 %{_datadir}/NodeManager/curlwrapper.*
154 %{_datadir}/NodeManager/database.*
155 %{_datadir}/NodeManager/initscript.*
156 %{_datadir}/NodeManager/iptables.*
157 %{_datadir}/NodeManager/logger.*
158 %{_datadir}/NodeManager/net.*
159 %{_datadir}/NodeManager/nodemanager.*
160 %{_datadir}/NodeManager/plcapi.*
161 %{_datadir}/NodeManager/safexmlrpc.*
162 %{_datadir}/NodeManager/slivermanager.*
163 %{_datadir}/NodeManager/ticket.*
164 %{_datadir}/NodeManager/tools.*
165 %{_datadir}/NodeManager/plugins/__init__.*
166 %{_datadir}/NodeManager/plugins/codemux.*
167 %{_datadir}/NodeManager/plugins/hostmap.*
168 %{_datadir}/NodeManager/plugins/interfaces.*
169 %{_datadir}/NodeManager/plugins/omf_resctl.*
170 %{_datadir}/NodeManager/plugins/privatebridge.*
171 %{_datadir}/NodeManager/plugins/rawdisk.*
172 %{_datadir}/NodeManager/plugins/reservation.*
173 %{_datadir}/NodeManager/plugins/sfagids.*
174 %{_datadir}/NodeManager/plugins/sliverauth.*
175 %{_datadir}/NodeManager/plugins/specialaccounts.*
176 %{_datadir}/NodeManager/plugins/syndicate.*
177 %{_datadir}/NodeManager/plugins/vsys.*
178 %{_datadir}/NodeManager/plugins/vsys_privs.*
179 %{_datadir}/NodeManager/sliver-initscripts/
180 %{_datadir}/NodeManager/sliver-systemd/
181 %{_bindir}/forward_api_calls
182 %{initdir}/
183 %{_sysconfdir}/logrotate.d/nodemanager
184 /var/lib/nodemanager/
185 %config(noreplace) /etc/sysconfig/nodemanager
186
187 ##############################
188 %if "%{build_lxc}" == "1"
189
190 %package -n nodemanager-lxc
191 Summary: PlanetLab Node Manager Plugin for lxc nodes
192 Group: System Environment/Daemons
193 # we use libvirt
194 Requires: libvirt
195 Requires: libvirt-python
196 # cgroups.py needs this
197 Requires: python-inotify
198 # the common package for nodemanager
199 Requires: nodemanager-lib = %{version}
200 # the lxc-specific tools for using slice images
201 Requires: lxc-sliceimage
202 Requires: openvswitch
203
204 %description -n nodemanager-lxc
205 nodemanager-lxc provides the lxc code for the PlanetLab Node Manager.
206
207 %files -n nodemanager-lxc
208 %{_datadir}/NodeManager/sliver_libvirt.*
209 %{_datadir}/NodeManager/sliver_lxc.*
210 %{_datadir}/NodeManager/cgroups.*
211 %{_datadir}/NodeManager/coresched_lxc.*
212
213 %endif
214 ##############################
215
216 ##############################
217 %if "%{build_vs}" == "1"
218
219 %package -n nodemanager-vs
220 Summary: PlanetLab Node Manager Plugin for vserver nodes
221 Group: System Environment/Daemons
222
223 # old name, when all came as a single package with vserver wired in
224 Obsoletes: NodeManager
225 # for nodeupdate 
226 Provides: nodemanager
227
228 # our interface to the vserver patch
229 Requires: util-vserver >= 0.30.208-17
230 # and the planetlab utilities
231 Requires: util-vserver-python > 0.3-16
232 # the common package for nodemanager
233 Requires: nodemanager-lib = %{version}
234 # the vserver-specific tools for using slice images
235 Requires: vserver-sliceimage
236
237 %description -n nodemanager-vs
238 nodemanager-vs provides the vserver code for the PlanetLab Node Manager.
239
240 %files -n nodemanager-vs
241 %{_datadir}/NodeManager/sliver_vs.*
242 %{_datadir}/NodeManager/coresched_vs.*
243 # this plugin uses vserver for now
244 %{_datadir}/NodeManager/plugins/drl.*
245
246 %endif
247 ##############################
248
249 ##############################
250 %changelog
251 * Tue Jul 22 2014 Thomas Dreibholz <dreibh@simula.no> - nodeimage-5.2-15
252 - nm.service fix: the node manager needs network.target, since it needs to contact the PLC.
253
254 * Wed Jul 16 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-14
255 - review packaging : one single spec file
256 - review packaging : some cleanup towards debians although not complete yet
257 - minor tweaks in exposing user's .ssh dir readonly
258
259 * Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-13
260 - improve network management in slices
261 - _has_systemctl was not declared as global - vsys was failing to restart
262
263 * Fri Apr 04 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-12
264 - this tag for the first time passes the full range of tests on fedora20
265 - robustified slice teardown wrt vsys
266 - Scott's fix for repairing veth devs
267 - removed sshsh
268 - tools.has_systemctl
269
270 * Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-11
271 - ship /etc/sysconfig/nodemanager
272 - trash sshsh
273
274 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-10
275 - comes with systemd native unit files on >= f18
276 - user-provided initscript gets started through systemd in slivers >= f18
277 - smarter to locate cgroups for various versions of libvirt
278 - nicer log format - and log program termination
279 - tweaks in codemux plugin
280 - bug fixes in libvirt driver, esp. for finding out if domain is running
281
282 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
283 - fixes in hostmap, and in interfaces
284 - new vsys_sysctl
285 - privatebridge now comes with nodemanager-lib
286
287 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
288 - omf plugin does not block any longer when running trigger script
289 - log goes into sliver's /var/log instead
290
291 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
292 - new install-scripts target in Makefile
293 - conf_files and fuse-pl initscripts chmod'ed +x
294 - omf_resctl config template tweaked to use _slicename_%_hostname_
295
296 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
297 - make sure to create /etc/planetlab/virt so others can read that
298 - expose get_node_virt() and command_in_slice()
299 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
300 - user's .profile now has right owner
301 - other tweaks in lxc slivers
302
303 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
304 - lxc slice creation: slice user was created with unknown gid - fixed
305 - lxc slice creation: .profile for root and user - fixed
306
307 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
308 - fix umounting of ssh directory when deleting omf-friendly slivers
309 - support for writing cgroups in subsystems other than cpuset
310 - add xid to template match
311 - finer-grained split between -lib -vs and -lxc
312 - first roughly complete omf_resctl for omfv6
313 - minor fix for when getslivers does not have minexemptrate
314
315 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
316 - Fix path, machine arch in slivers
317
318 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
319
320 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
321 - no-op bump to 5.2 to be in line with the rest of the system
322
323 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
324 - improvements to privatebridge
325
326 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
327 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
328
329 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
330 - fix wrong gre tunnel deleted when topology changes
331
332 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
333 - Update /etc/hosts in slivers from sliver_hostmap tag.
334
335 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
336 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
337 - initial check-in of privatebridge plugin.
338
339 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
340 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
341
342 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
343 - fix slices not deleted properly when they use vsys
344
345 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
346 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
347
348 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
349 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
350
351 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
352 - Bridge virtual interfaces to VLANs
353
354 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
355 - Add support for L2 bridged interfaces with public IPs inside a slice
356
357 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
358 - Support for freezing BestEffort slices for Vicci
359
360 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
361 - Change to use new vsh (wrapper for lxcsu)
362
363 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
364 - add missing import
365 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
366
367 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
368 - tag 2.1-7 was broken for OMF-friendly slices
369 - expose_ssh_dir was erroneously defined on the Worker class
370
371 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
372 - bwlimitlxc now ships with plnode-utils
373
374 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
375 - set LD_PRELOAD for linux-containers nodes
376
377 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
378 - first complete version for vs and lxc - functional but not thoroughly tested though
379
380 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
381 - split packaging in 3 (lib, lxc, vs)
382 - this tag will only work with lxc though
383
384 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
385 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
386
387 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
388 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
389 - purpose being to be able to run this branch on vserver nodes as well
390
391 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
392 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
393 - passes tests with lxc but won't build against vs due to conflict
394 - as bwlimit.py also ships with util-vserver-pl
395
396 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
397 - refactoring: isolate initscript functionality
398 - aimed at making initscript implementation with lxc straightforward
399 - show stack trace when module loading fails
400 - accounts.py renamed into account.py for consistency
401
402 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
403 - /var/log/nodemanager shows duration of mainloop
404
405 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
406 - first working draft for dealing with libvirt/lxc on f16 nodes
407 - not expected to work with mainline nodes (use 2.0 for that for now)
408
409 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
410 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
411
412 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
413 - Added memory scheduling to core scheduler
414 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
415
416 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
417 - tweaked log policy for the core scheduler
418 - curlwrapper has an optional verbose mode
419
420 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
421 - fixes for hmac and omf_control tags
422 - optional besteffort flag to core scheduler
423 - logrotate entry for /var/log/nodemanager.daemon
424 - a template for bash initscripts
425
426 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
427 - rename initscript_body into initscript_code
428 - fix generic vinit for broken bash syntax &>>
429
430 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
431 - new initscript_body slice tag, with stop and restart
432 - generic vinit script live updated
433 - new coresched module
434 - protect against non-existing vsys scripts
435 - use Config. instead of globals
436
437 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
438 - more robust reservation plugin
439
440 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
441 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
442 - reservation plugin more robust
443
444 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
445 - pass device to bwlimit
446
447 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
448 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
449
450 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
451 - Catch all exceptions for sfa plugin
452
453 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
454 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
455
456 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
457 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
458
459 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
460 - plugins/sliverauth.py improvements
461
462 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
463 - Disable sfagids plugin
464
465 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
466 - Re-tag nodemanager to include conflicted commits
467
468 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
469 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
470 - sfagids plugin deleted
471 - band-aid patch for lack of GetSliceFamily removed
472
473 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
474
475 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
476 - revert curlwrapper to former forking-curl version
477 - fixes in the omf plugin for ssh key location and node hrn
478 - set umask 0022 in tools.daemon
479
480 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
481 - configure omf-resctl for keys
482
483 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
484 - fix key generation
485
486 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
487 - name changes and fix typos
488
489 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
490 - remove config and options parameters from start function
491
492 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
493 - working version of reservable nodes
494 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
495 - dismantled the -s|--startup option (no convincing need for that)
496 - simpler and more robust init.d/nm
497 - initscript content management through replace_file_with_string
498 - sliverauth uses replace_file_with_string
499 - curlwrapper has a debug mode
500
501 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
502 - pretty-printing/normalized python code - hopefully neutral
503
504 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
505 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
506 - that triggers /etc/init.d/vinit.slice if present and executable
507 - (2) install the slice-provided initscript (as per the initscript tag) as
508 - /etc/init.d/vinit.slice
509 - (3) as a result the initscript are now triggered by rc as part of the
510 - standard vserver .. start, properly attached to the vserver,
511 - and properly killed upon vserver .. stop
512 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
513
514 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
515 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
516 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
517 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
518 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
519 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
520 - cleanup: nodemanger now is a class; however plugins are still dumb modules
521 - cleanup: does not depend on obsolete Set
522
523 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
524 - tagging before RC
525
526 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
527 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
528 - Added some precautions to the slice id-saving code
529 - Added log message to code that records the slice id
530
531 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
532 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
533 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
534 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
535
536 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
537 - fix log_call in plugins/drl.py
538
539 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
540 - protect against nodes in migrated PLC's not having the hrn tag yet
541
542 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
543 - new omf-resctl and drl plugins
544 - specialaccount optimized to overwrite authorized keys only upon changes
545 - codemux plugin has support for a new 'ip' setting
546 - mainloop to display ordered modules&plugins at all times
547
548 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
549 - modules and plugins have a priority
550 - specialaccounts appears soon in the priority chain
551 - logger.log_call logs process output, and has a timeout
552 - vuser{add,del} run through bash -x
553 - nm initscript has support for 'service nm restartverbose'
554 - logs reviewed for consistency
555 - use hashlib module instead of sha when available
556
557 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
558 - first working version of 5.0:
559 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
560 - nodefamily is 3-fold with pldistro-fcdistro-arch
561 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
562 - (in addition to the 'vref' tag that's still exposed too)
563 - logging reviewed for more convenience
564 - support for 'service nm restartdebug'
565 - make sync knows how to publish uncommitted code on a test node
566
567 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
568 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
569
570 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
571 - support for f10 and f12 in the vref slice tag
572
573 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
574 - build on fedora12
575 - uses slicename 'sfacm' instead of 'genicw'
576
577 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
578 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
579 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
580 - days ago.
581
582 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
583 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
584 - self-contained. With this change, they will be able to refer to the attributes associated with a
585 - slice.
586
587 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
588 - fix for syntax error
589
590 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
591 - -fixed problem with sioc import at the build side
592 - -bwlimit.set() now accepts the device and does not asume that it is eth0
593
594 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
595 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
596
597 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
598 - The seed for random previously was the meaning of life (i.e., 42) but
599 - that resulted in a not so random choice for the hmac.  This
600 - implementation now uses a random.seed that is based on the current
601 - time.
602
603 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
604 - Minor fix such that sliverauth.py makes a more specific call to
605 - GetSliceTags that include that specific tagname it is looking for.
606
607 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
608 - Fix bug that prevented 'OVERRIDES' for working correctly.
609
610 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
611 - Increase disk limits to 10G per sliver
612 - Sanity check slice for home directory before starting (hack)
613 - Check codemux arguments
614
615 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
616 - * Fix Delegation
617 - * Move plcapi in plugin-api GetSlivers() calls.
618 - * Persistent Authcheck and resync session when auth failure
619
620 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
621 - Disabling sliverauth module.  Not ready for deployment.
622
623 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
624 - Fixing overrides semantics.
625
626 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
627 - Generalized plugins
628 - Fixed initscript start up bug.
629
630 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
631 - * Fix delegation authentication problem
632 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
633
634 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
635 - * Rerun initscripts when slice goes from disabled to enabled.
636
637 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
638 - * Update session key when out of synch with PLC
639 - * PLCDefaults uses tagname
640
641 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
642 - log invokations of vsys
643
644 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
645
646 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
647
648 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
649 - Codemux supports multiple hosts mapping to single slice
650 - Fixed bug in delegation support where tickets delivered weren't
651   being passed to sm.deliver_ticket().
652
653 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
654 - Codemux now configured via slice attribute (host,port)
655 - Support for multiple vserver reference images (including different archs)
656 - Mom BW emails are sent to list defined by MyPLC's config
657 - Sirius BW loans honored correctly.  Fixed.
658 - BW totals preserved for dynamic slices so as not to game the system.
659
660 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
661 - Configures vsys via vsys slice attribute {name: vsys, value: script}
662 - CPU reservations are now calculated via percentages instead of shares
663 - BW totals preserved for dynamic slices
664 - Closes bug where node cap sets off bw slice alarms for all slices.
665
666 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
667 - Switched to SVN.
668
669 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
670 - Initial build.