patch by Thomas Dreibholz - ovs-vsctl and not ovs-ovsctl
[nodemanager.git] / nodemanager.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 5.2
5 %define taglevel 18
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 ##############################
10 # for now we just extract all the files but package them only for either vs or lxc
11 # so bottom line is we have missing files at the end
12 # plan is to separate these target-dependant files in subdirs at some point
13 %define _unpackaged_files_terminate_build      0
14
15 ##############################
16 # use initscripts or systemd unit files to start installed services
17 %if "%{distro}" == "Fedora" && "%{distrorelease}" >= "18"
18 %define make_options WITH_SYSTEMD=true
19 %define initdir /usr/lib/systemd/system
20 %define build_lxc 1
21 %else
22 %define make_options WITH_INIT=true
23 %define initdir %{_initrddir}
24 %define build_vs 1
25 %endif
26
27 ##############################
28 Summary: PlanetLab Node Manager Library
29 Name: %{name}
30 Version: %{version}
31 Release: %{release}
32 License: PlanetLab
33 Group: System Environment/Daemons
34 Source0: %{name}-%{version}.tar.gz
35 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
36
37 Vendor: PlanetLab
38 Packager: PlanetLab Central <support@planet-lab.org>
39 Distribution: PlanetLab %{plrelease}
40 URL: %{SCMURL}
41
42 # not possible because of forward_api_calls
43 #BuildArch: noarch
44
45 # make sure we can invoke systemctl in post install script
46 %if "%{initdir}" != "%{_initrddir}"
47 Requires: systemd
48 %endif
49
50 # Uses function decorators
51 Requires: python >= 2.7
52 # connecting PLC
53 Requires: python-pycurl
54 # Signed tickets
55 Requires: gnupg
56 # sioc/plnet
57 Requires: pyplnet >= 4.3
58 # we do need the slice images in any case
59 Requires: sliceimage-%{slicefamily}
60 # for bwlimit
61 Requires: plnode-utils
62
63 %description
64 The PlanetLab Node Manager manages all aspects of PlanetLab node and
65 slice management once the node has been initialized and configured by
66 the Boot Manager. It periodically contacts its management authority
67 for configuration updates. It provides an XML-RPC API for performing
68 local operations on slices.
69 nodemanager-lib only provides a skeleton and needs as a companion
70 either nodemanager-vs or nodemanager-lxc
71
72 ##############################
73 %prep
74 %setup -q
75
76 %build
77 # make manages the C and Python stuff
78 %{__make} %{?_smp_mflags} %{make_options}
79
80 %install
81 # make manages the C and Python stuff
82 rm -rf $RPM_BUILD_ROOT
83 %{__make} %{?_smp_mflags} %{make_options} install DESTDIR="$RPM_BUILD_ROOT"
84
85 ##############################
86 %post
87 ########## traditional init
88 %if "%{initdir}" == "%{_initrddir}"
89 ##########
90 chkconfig --add conf_files
91 chkconfig conf_files on
92 chkconfig --add nm
93 chkconfig nm on
94 chkconfig --add fuse-pl
95 chkconfig fuse-pl on
96 if [ "$PL_BOOTCD" != "1" ] ; then
97     service nm restart
98     service fuse-pl restart
99 fi
100 ##########
101 %else
102 ########## systemd
103 systemctl enable nm.service
104 systemctl enable conf_files.service
105 # empty
106 #systemctl enable fuse-pl.service
107 if [ "$PL_BOOTCD" != "1" ] ; then
108     systemctl restart nm.service
109 #    systemctl restart fuse-pl.service
110 fi
111 ##########
112 %endif
113
114 ##############################
115 %preun
116 # 0 = erase, 1 = upgrade
117 ########## traditional init
118 %if "%{initdir}" == "%{_initrddir}"
119 ##########
120 if [ $1 -eq 0 ] ; then
121     chkconfig fuse-pl off
122     chkconfig --del fuse-pl
123     chkconfig nm off
124     chkconfig --del nm
125     chkconfig conf_files off
126     chkconfig --del conf_files
127 fi
128 ##########
129 %else
130 ########## systemd
131 if [ $1 -eq 0 ] ; then
132 #    systemctl disable fuse-pl.service
133     systemctl disable conf_files.service
134     systemctl disable nm.service
135 fi
136 ##########
137 %endif
138
139 ##############################
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 ##############################
144 %files
145 %defattr(-,root,root,-)
146 %{_datadir}/NodeManager/account.*
147 %{_datadir}/NodeManager/api.*
148 %{_datadir}/NodeManager/api_calls.*
149 %{_datadir}/NodeManager/bwmon.*
150 %{_datadir}/NodeManager/conf_files.*
151 %{_datadir}/NodeManager/config.*
152 %{_datadir}/NodeManager/controller.*
153 %{_datadir}/NodeManager/curlwrapper.*
154 %{_datadir}/NodeManager/database.*
155 %{_datadir}/NodeManager/initscript.*
156 %{_datadir}/NodeManager/iptables.*
157 %{_datadir}/NodeManager/logger.*
158 %{_datadir}/NodeManager/net.*
159 %{_datadir}/NodeManager/nodemanager.*
160 %{_datadir}/NodeManager/plcapi.*
161 %{_datadir}/NodeManager/safexmlrpc.*
162 %{_datadir}/NodeManager/slivermanager.*
163 %{_datadir}/NodeManager/ticket.*
164 %{_datadir}/NodeManager/tools.*
165 %{_datadir}/NodeManager/plugins/__init__.*
166 %{_datadir}/NodeManager/plugins/hostmap.*
167 %{_datadir}/NodeManager/plugins/interfaces.*
168 %{_datadir}/NodeManager/plugins/omf_resctl.*
169 %{_datadir}/NodeManager/plugins/rawdisk.*
170 %{_datadir}/NodeManager/plugins/reservation.*
171 %{_datadir}/NodeManager/plugins/sfagids.*
172 %{_datadir}/NodeManager/plugins/sliverauth.*
173 %{_datadir}/NodeManager/plugins/specialaccounts.*
174 %{_datadir}/NodeManager/plugins/syndicate.*
175 %{_datadir}/NodeManager/plugins/vsys.*
176 %{_datadir}/NodeManager/plugins/vsys_privs.*
177 %{_datadir}/NodeManager/plugins/ipv6.*
178 %{_datadir}/NodeManager/plugins/update_ipv6addr_slivertag.*
179 %{_datadir}/NodeManager/sliver-initscripts/
180 %{_datadir}/NodeManager/sliver-systemd/
181 %{_bindir}/forward_api_calls
182 %{initdir}/
183 %{_sysconfdir}/logrotate.d/nodemanager
184 /var/lib/nodemanager/
185 %config(noreplace) /etc/sysconfig/nodemanager
186
187 ##############################
188 %if "%{build_lxc}" == "1"
189
190 %package -n nodemanager-lxc
191 Summary: PlanetLab Node Manager Plugin for lxc nodes
192 Group: System Environment/Daemons
193 # we use libvirt
194 Requires: libvirt
195 Requires: libvirt-python
196 # cgroups.py needs this
197 Requires: python-inotify
198 # the common package for nodemanager
199 Requires: nodemanager-lib = %{version}
200 # the lxc-specific tools for using slice images
201 Requires: lxc-sliceimage
202 Requires: openvswitch
203
204 %description -n nodemanager-lxc
205 nodemanager-lxc provides the lxc code for the PlanetLab Node Manager.
206
207 %files -n nodemanager-lxc
208 %{_datadir}/NodeManager/sliver_libvirt.*
209 %{_datadir}/NodeManager/sliver_lxc.*
210 %{_datadir}/NodeManager/cgroups.*
211 %{_datadir}/NodeManager/coresched_lxc.*
212 %{_datadir}/NodeManager/plugins/privatebridge.*
213
214 %endif
215 ##############################
216
217 ##############################
218 %if "%{build_vs}" == "1"
219
220 %package -n nodemanager-vs
221 Summary: PlanetLab Node Manager Plugin for vserver nodes
222 Group: System Environment/Daemons
223
224 # old name, when all came as a single package with vserver wired in
225 Obsoletes: NodeManager
226 # for nodeupdate 
227 Provides: nodemanager
228
229 # our interface to the vserver patch
230 Requires: util-vserver >= 0.30.208-17
231 # and the planetlab utilities
232 Requires: util-vserver-python > 0.3-16
233 # the common package for nodemanager
234 Requires: nodemanager-lib = %{version}
235 # the vserver-specific tools for using slice images
236 Requires: vserver-sliceimage
237
238 %description -n nodemanager-vs
239 nodemanager-vs provides the vserver code for the PlanetLab Node Manager.
240
241 %files -n nodemanager-vs
242 %{_datadir}/NodeManager/sliver_vs.*
243 %{_datadir}/NodeManager/coresched_vs.*
244 # this plugin uses vserver for now
245 %{_datadir}/NodeManager/plugins/drl.*
246 # in vs only : turn off the codemux plugin in lxc for now as
247 # it is responsible for the slice re-creation issue
248 %{_datadir}/NodeManager/plugins/codemux.*
249
250 %endif
251 ##############################
252
253 ##############################
254 %changelog
255 * Fri Nov 13 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-18
256 - remove codemux plugin from lxc - was causing slice re-creation issue
257 - has reconnect capabilities to libvirt deamon
258 - reinstate code from a previous version, that deals with btrfs cleaning up
259 - cleaned up cgroups.py
260
261 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-17
262 - first step towards auto slice-reimaging
263 - slices that would be reimaged because of a change of slicefamily are
264 - identified in the nodemanager's log
265 - might have fixed fd leaks (use context managers whenever possible)
266
267 * Fri Apr 03 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-16
268 - initscript plugin reviewed
269 - turn off the initscript machinery completely on hosts that run f>=20
270 - some tweaks related to cgroup naming in f>=20, including for ipv6
271 - ideally all code depending on the cgroup naming scheme should use cgroups.py
272 - we are not there yet but this is a bit cleaner already
273
274 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-15
275 - addition to support for ipv6 to lxc slivers
276 - (thanks to Guilherme Sperb Machado)
277 - privatebridge plugin is back to the -lxc rpm
278 - add systemd dependency to network.target
279
280 * Tue Jul 22 2014 Thomas Dreibholz <dreibh@simula.no> - nodeimage-5.2-15
281 - nm.service fix: the node manager needs network.target, since it needs to contact the PLC.
282
283 * Wed Jul 16 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-14
284 - review packaging : one single spec file
285 - review packaging : some cleanup towards debians although not complete yet
286 - minor tweaks in exposing user's .ssh dir readonly
287
288 * Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-13
289 - improve network management in slices
290 - _has_systemctl was not declared as global - vsys was failing to restart
291
292 * Fri Apr 04 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-12
293 - this tag for the first time passes the full range of tests on fedora20
294 - robustified slice teardown wrt vsys
295 - Scott's fix for repairing veth devs
296 - removed sshsh
297 - tools.has_systemctl
298
299 * Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-11
300 - ship /etc/sysconfig/nodemanager
301 - trash sshsh
302
303 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-10
304 - comes with systemd native unit files on >= f18
305 - user-provided initscript gets started through systemd in slivers >= f18
306 - smarter to locate cgroups for various versions of libvirt
307 - nicer log format - and log program termination
308 - tweaks in codemux plugin
309 - bug fixes in libvirt driver, esp. for finding out if domain is running
310
311 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
312 - fixes in hostmap, and in interfaces
313 - new vsys_sysctl
314 - privatebridge now comes with nodemanager-lib
315
316 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
317 - omf plugin does not block any longer when running trigger script
318 - log goes into sliver's /var/log instead
319
320 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
321 - new install-scripts target in Makefile
322 - conf_files and fuse-pl initscripts chmod'ed +x
323 - omf_resctl config template tweaked to use _slicename_%_hostname_
324
325 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
326 - make sure to create /etc/planetlab/virt so others can read that
327 - expose get_node_virt() and command_in_slice()
328 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
329 - user's .profile now has right owner
330 - other tweaks in lxc slivers
331
332 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
333 - lxc slice creation: slice user was created with unknown gid - fixed
334 - lxc slice creation: .profile for root and user - fixed
335
336 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
337 - fix umounting of ssh directory when deleting omf-friendly slivers
338 - support for writing cgroups in subsystems other than cpuset
339 - add xid to template match
340 - finer-grained split between -lib -vs and -lxc
341 - first roughly complete omf_resctl for omfv6
342 - minor fix for when getslivers does not have minexemptrate
343
344 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
345 - Fix path, machine arch in slivers
346
347 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
348
349 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
350 - no-op bump to 5.2 to be in line with the rest of the system
351
352 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
353 - improvements to privatebridge
354
355 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
356 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
357
358 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
359 - fix wrong gre tunnel deleted when topology changes
360
361 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
362 - Update /etc/hosts in slivers from sliver_hostmap tag.
363
364 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
365 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
366 - initial check-in of privatebridge plugin.
367
368 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
369 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
370
371 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
372 - fix slices not deleted properly when they use vsys
373
374 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
375 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
376
377 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
378 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
379
380 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
381 - Bridge virtual interfaces to VLANs
382
383 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
384 - Add support for L2 bridged interfaces with public IPs inside a slice
385
386 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
387 - Support for freezing BestEffort slices for Vicci
388
389 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
390 - Change to use new vsh (wrapper for lxcsu)
391
392 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
393 - add missing import
394 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
395
396 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
397 - tag 2.1-7 was broken for OMF-friendly slices
398 - expose_ssh_dir was erroneously defined on the Worker class
399
400 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
401 - bwlimitlxc now ships with plnode-utils
402
403 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
404 - set LD_PRELOAD for linux-containers nodes
405
406 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
407 - first complete version for vs and lxc - functional but not thoroughly tested though
408
409 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
410 - split packaging in 3 (lib, lxc, vs)
411 - this tag will only work with lxc though
412
413 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
414 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
415
416 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
417 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
418 - purpose being to be able to run this branch on vserver nodes as well
419
420 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
421 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
422 - passes tests with lxc but won't build against vs due to conflict
423 - as bwlimit.py also ships with util-vserver-pl
424
425 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
426 - refactoring: isolate initscript functionality
427 - aimed at making initscript implementation with lxc straightforward
428 - show stack trace when module loading fails
429 - accounts.py renamed into account.py for consistency
430
431 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
432 - /var/log/nodemanager shows duration of mainloop
433
434 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
435 - first working draft for dealing with libvirt/lxc on f16 nodes
436 - not expected to work with mainline nodes (use 2.0 for that for now)
437
438 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
439 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
440
441 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
442 - Added memory scheduling to core scheduler
443 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
444
445 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
446 - tweaked log policy for the core scheduler
447 - curlwrapper has an optional verbose mode
448
449 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
450 - fixes for hmac and omf_control tags
451 - optional besteffort flag to core scheduler
452 - logrotate entry for /var/log/nodemanager.daemon
453 - a template for bash initscripts
454
455 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
456 - rename initscript_body into initscript_code
457 - fix generic vinit for broken bash syntax &>>
458
459 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
460 - new initscript_body slice tag, with stop and restart
461 - generic vinit script live updated
462 - new coresched module
463 - protect against non-existing vsys scripts
464 - use Config. instead of globals
465
466 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
467 - more robust reservation plugin
468
469 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
470 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
471 - reservation plugin more robust
472
473 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
474 - pass device to bwlimit
475
476 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
477 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
478
479 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
480 - Catch all exceptions for sfa plugin
481
482 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
483 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
484
485 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
486 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
487
488 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
489 - plugins/sliverauth.py improvements
490
491 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
492 - Disable sfagids plugin
493
494 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
495 - Re-tag nodemanager to include conflicted commits
496
497 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
498 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
499 - sfagids plugin deleted
500 - band-aid patch for lack of GetSliceFamily removed
501
502 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
503
504 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
505 - revert curlwrapper to former forking-curl version
506 - fixes in the omf plugin for ssh key location and node hrn
507 - set umask 0022 in tools.daemon
508
509 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
510 - configure omf-resctl for keys
511
512 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
513 - fix key generation
514
515 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
516 - name changes and fix typos
517
518 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
519 - remove config and options parameters from start function
520
521 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
522 - working version of reservable nodes
523 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
524 - dismantled the -s|--startup option (no convincing need for that)
525 - simpler and more robust init.d/nm
526 - initscript content management through replace_file_with_string
527 - sliverauth uses replace_file_with_string
528 - curlwrapper has a debug mode
529
530 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
531 - pretty-printing/normalized python code - hopefully neutral
532
533 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
534 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
535 - that triggers /etc/init.d/vinit.slice if present and executable
536 - (2) install the slice-provided initscript (as per the initscript tag) as
537 - /etc/init.d/vinit.slice
538 - (3) as a result the initscript are now triggered by rc as part of the
539 - standard vserver .. start, properly attached to the vserver,
540 - and properly killed upon vserver .. stop
541 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
542
543 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
544 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
545 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
546 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
547 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
548 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
549 - cleanup: nodemanger now is a class; however plugins are still dumb modules
550 - cleanup: does not depend on obsolete Set
551
552 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
553 - tagging before RC
554
555 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
556 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
557 - Added some precautions to the slice id-saving code
558 - Added log message to code that records the slice id
559
560 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
561 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
562 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
563 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
564
565 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
566 - fix log_call in plugins/drl.py
567
568 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
569 - protect against nodes in migrated PLC's not having the hrn tag yet
570
571 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
572 - new omf-resctl and drl plugins
573 - specialaccount optimized to overwrite authorized keys only upon changes
574 - codemux plugin has support for a new 'ip' setting
575 - mainloop to display ordered modules&plugins at all times
576
577 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
578 - modules and plugins have a priority
579 - specialaccounts appears soon in the priority chain
580 - logger.log_call logs process output, and has a timeout
581 - vuser{add,del} run through bash -x
582 - nm initscript has support for 'service nm restartverbose'
583 - logs reviewed for consistency
584 - use hashlib module instead of sha when available
585
586 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
587 - first working version of 5.0:
588 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
589 - nodefamily is 3-fold with pldistro-fcdistro-arch
590 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
591 - (in addition to the 'vref' tag that's still exposed too)
592 - logging reviewed for more convenience
593 - support for 'service nm restartdebug'
594 - make sync knows how to publish uncommitted code on a test node
595
596 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
597 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
598
599 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
600 - support for f10 and f12 in the vref slice tag
601
602 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
603 - build on fedora12
604 - uses slicename 'sfacm' instead of 'genicw'
605
606 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
607 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
608 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
609 - days ago.
610
611 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
612 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
613 - self-contained. With this change, they will be able to refer to the attributes associated with a
614 - slice.
615
616 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
617 - fix for syntax error
618
619 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
620 - -fixed problem with sioc import at the build side
621 - -bwlimit.set() now accepts the device and does not asume that it is eth0
622
623 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
624 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
625
626 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
627 - The seed for random previously was the meaning of life (i.e., 42) but
628 - that resulted in a not so random choice for the hmac.  This
629 - implementation now uses a random.seed that is based on the current
630 - time.
631
632 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
633 - Minor fix such that sliverauth.py makes a more specific call to
634 - GetSliceTags that include that specific tagname it is looking for.
635
636 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
637 - Fix bug that prevented 'OVERRIDES' for working correctly.
638
639 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
640 - Increase disk limits to 10G per sliver
641 - Sanity check slice for home directory before starting (hack)
642 - Check codemux arguments
643
644 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
645 - * Fix Delegation
646 - * Move plcapi in plugin-api GetSlivers() calls.
647 - * Persistent Authcheck and resync session when auth failure
648
649 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
650 - Disabling sliverauth module.  Not ready for deployment.
651
652 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
653 - Fixing overrides semantics.
654
655 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
656 - Generalized plugins
657 - Fixed initscript start up bug.
658
659 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
660 - * Fix delegation authentication problem
661 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
662
663 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
664 - * Rerun initscripts when slice goes from disabled to enabled.
665
666 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
667 - * Update session key when out of synch with PLC
668 - * PLCDefaults uses tagname
669
670 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
671 - log invokations of vsys
672
673 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
674
675 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
676
677 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
678 - Codemux supports multiple hosts mapping to single slice
679 - Fixed bug in delegation support where tickets delivered weren't
680   being passed to sm.deliver_ticket().
681
682 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
683 - Codemux now configured via slice attribute (host,port)
684 - Support for multiple vserver reference images (including different archs)
685 - Mom BW emails are sent to list defined by MyPLC's config
686 - Sirius BW loans honored correctly.  Fixed.
687 - BW totals preserved for dynamic slices so as not to game the system.
688
689 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
690 - Configures vsys via vsys slice attribute {name: vsys, value: script}
691 - CPU reservations are now calculated via percentages instead of shares
692 - BW totals preserved for dynamic slices
693 - Closes bug where node cap sets off bw slice alarms for all slices.
694
695 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
696 - Switched to SVN.
697
698 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
699 - Initial build.