another pass for prettifying - mostly format instead of %
[nodemanager.git] / nodemanager.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 5.2
5 %define taglevel 16
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 ##############################
10 # for now we just extract all the files but package them only for either vs or lxc
11 # so bottom line is we have missing files at the end
12 # plan is to separate these target-dependant files in subdirs at some point
13 %define _unpackaged_files_terminate_build      0
14
15 ##############################
16 # use initscripts or systemd unit files to start installed services
17 %if "%{distro}" == "Fedora" && "%{distrorelease}" >= "18"
18 %define make_options WITH_SYSTEMD=true
19 %define initdir /usr/lib/systemd/system
20 %define build_lxc 1
21 %else
22 %define make_options WITH_INIT=true
23 %define initdir %{_initrddir}
24 %define build_vs 1
25 %endif
26
27 ##############################
28 Summary: PlanetLab Node Manager Library
29 Name: %{name}
30 Version: %{version}
31 Release: %{release}
32 License: PlanetLab
33 Group: System Environment/Daemons
34 Source0: %{name}-%{version}.tar.gz
35 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
36
37 Vendor: PlanetLab
38 Packager: PlanetLab Central <support@planet-lab.org>
39 Distribution: PlanetLab %{plrelease}
40 URL: %{SCMURL}
41
42 # not possible because of forward_api_calls
43 #BuildArch: noarch
44
45 # make sure we can invoke systemctl in post install script
46 %if "%{initdir}" != "%{_initrddir}"
47 Requires: systemd
48 %endif
49
50 # Uses function decorators
51 Requires: python >= 2.7
52 # connecting PLC
53 Requires: python-pycurl
54 # Signed tickets
55 Requires: gnupg
56 # sioc/plnet
57 Requires: pyplnet >= 4.3
58 # we do need the slice images in any case
59 Requires: sliceimage-%{slicefamily}
60 # for bwlimit
61 Requires: plnode-utils
62
63 %description
64 The PlanetLab Node Manager manages all aspects of PlanetLab node and
65 slice management once the node has been initialized and configured by
66 the Boot Manager. It periodically contacts its management authority
67 for configuration updates. It provides an XML-RPC API for performing
68 local operations on slices.
69 nodemanager-lib only provides a skeleton and needs as a companion
70 either nodemanager-vs or nodemanager-lxc
71
72 ##############################
73 %prep
74 %setup -q
75
76 %build
77 # make manages the C and Python stuff
78 %{__make} %{?_smp_mflags} %{make_options}
79
80 %install
81 # make manages the C and Python stuff
82 rm -rf $RPM_BUILD_ROOT
83 %{__make} %{?_smp_mflags} %{make_options} install DESTDIR="$RPM_BUILD_ROOT"
84
85 ##############################
86 %post
87 ########## traditional init
88 %if "%{initdir}" == "%{_initrddir}"
89 ##########
90 chkconfig --add conf_files
91 chkconfig conf_files on
92 chkconfig --add nm
93 chkconfig nm on
94 chkconfig --add fuse-pl
95 chkconfig fuse-pl on
96 if [ "$PL_BOOTCD" != "1" ] ; then
97     service nm restart
98     service fuse-pl restart
99 fi
100 ##########
101 %else
102 ########## systemd
103 systemctl enable nm.service
104 systemctl enable conf_files.service
105 # empty
106 #systemctl enable fuse-pl.service
107 if [ "$PL_BOOTCD" != "1" ] ; then
108     systemctl restart nm.service
109 #    systemctl restart fuse-pl.service
110 fi
111 ##########
112 %endif
113
114 ##############################
115 %preun
116 # 0 = erase, 1 = upgrade
117 ########## traditional init
118 %if "%{initdir}" == "%{_initrddir}"
119 ##########
120 if [ $1 -eq 0 ] ; then
121     chkconfig fuse-pl off
122     chkconfig --del fuse-pl
123     chkconfig nm off
124     chkconfig --del nm
125     chkconfig conf_files off
126     chkconfig --del conf_files
127 fi
128 ##########
129 %else
130 ########## systemd
131 if [ $1 -eq 0 ] ; then
132 #    systemctl disable fuse-pl.service
133     systemctl disable conf_files.service
134     systemctl disable nm.service
135 fi
136 ##########
137 %endif
138
139 ##############################
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 ##############################
144 %files
145 %defattr(-,root,root,-)
146 %{_datadir}/NodeManager/account.*
147 %{_datadir}/NodeManager/api.*
148 %{_datadir}/NodeManager/api_calls.*
149 %{_datadir}/NodeManager/bwmon.*
150 %{_datadir}/NodeManager/conf_files.*
151 %{_datadir}/NodeManager/config.*
152 %{_datadir}/NodeManager/controller.*
153 %{_datadir}/NodeManager/curlwrapper.*
154 %{_datadir}/NodeManager/database.*
155 %{_datadir}/NodeManager/initscript.*
156 %{_datadir}/NodeManager/iptables.*
157 %{_datadir}/NodeManager/logger.*
158 %{_datadir}/NodeManager/net.*
159 %{_datadir}/NodeManager/nodemanager.*
160 %{_datadir}/NodeManager/plcapi.*
161 %{_datadir}/NodeManager/safexmlrpc.*
162 %{_datadir}/NodeManager/slivermanager.*
163 %{_datadir}/NodeManager/ticket.*
164 %{_datadir}/NodeManager/tools.*
165 %{_datadir}/NodeManager/plugins/__init__.*
166 %{_datadir}/NodeManager/plugins/codemux.*
167 %{_datadir}/NodeManager/plugins/hostmap.*
168 %{_datadir}/NodeManager/plugins/interfaces.*
169 %{_datadir}/NodeManager/plugins/omf_resctl.*
170 %{_datadir}/NodeManager/plugins/rawdisk.*
171 %{_datadir}/NodeManager/plugins/reservation.*
172 %{_datadir}/NodeManager/plugins/sfagids.*
173 %{_datadir}/NodeManager/plugins/sliverauth.*
174 %{_datadir}/NodeManager/plugins/specialaccounts.*
175 %{_datadir}/NodeManager/plugins/syndicate.*
176 %{_datadir}/NodeManager/plugins/vsys.*
177 %{_datadir}/NodeManager/plugins/vsys_privs.*
178 %{_datadir}/NodeManager/plugins/ipv6.*
179 %{_datadir}/NodeManager/plugins/update_ipv6addr_slivertag.*
180 %{_datadir}/NodeManager/sliver-initscripts/
181 %{_datadir}/NodeManager/sliver-systemd/
182 %{_bindir}/forward_api_calls
183 %{initdir}/
184 %{_sysconfdir}/logrotate.d/nodemanager
185 /var/lib/nodemanager/
186 %config(noreplace) /etc/sysconfig/nodemanager
187
188 ##############################
189 %if "%{build_lxc}" == "1"
190
191 %package -n nodemanager-lxc
192 Summary: PlanetLab Node Manager Plugin for lxc nodes
193 Group: System Environment/Daemons
194 # we use libvirt
195 Requires: libvirt
196 Requires: libvirt-python
197 # cgroups.py needs this
198 Requires: python-inotify
199 # the common package for nodemanager
200 Requires: nodemanager-lib = %{version}
201 # the lxc-specific tools for using slice images
202 Requires: lxc-sliceimage
203 Requires: openvswitch
204
205 %description -n nodemanager-lxc
206 nodemanager-lxc provides the lxc code for the PlanetLab Node Manager.
207
208 %files -n nodemanager-lxc
209 %{_datadir}/NodeManager/sliver_libvirt.*
210 %{_datadir}/NodeManager/sliver_lxc.*
211 %{_datadir}/NodeManager/cgroups.*
212 %{_datadir}/NodeManager/coresched_lxc.*
213 %{_datadir}/NodeManager/plugins/privatebridge.*
214
215 %endif
216 ##############################
217
218 ##############################
219 %if "%{build_vs}" == "1"
220
221 %package -n nodemanager-vs
222 Summary: PlanetLab Node Manager Plugin for vserver nodes
223 Group: System Environment/Daemons
224
225 # old name, when all came as a single package with vserver wired in
226 Obsoletes: NodeManager
227 # for nodeupdate 
228 Provides: nodemanager
229
230 # our interface to the vserver patch
231 Requires: util-vserver >= 0.30.208-17
232 # and the planetlab utilities
233 Requires: util-vserver-python > 0.3-16
234 # the common package for nodemanager
235 Requires: nodemanager-lib = %{version}
236 # the vserver-specific tools for using slice images
237 Requires: vserver-sliceimage
238
239 %description -n nodemanager-vs
240 nodemanager-vs provides the vserver code for the PlanetLab Node Manager.
241
242 %files -n nodemanager-vs
243 %{_datadir}/NodeManager/sliver_vs.*
244 %{_datadir}/NodeManager/coresched_vs.*
245 # this plugin uses vserver for now
246 %{_datadir}/NodeManager/plugins/drl.*
247
248 %endif
249 ##############################
250
251 ##############################
252 %changelog
253 * Fri Apr 03 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-16
254 - initscript plugin reviewed
255 - turn off the initscript machinery completely on hosts that run f>=20
256 - some tweaks related to cgroup naming in f>=20, including for ipv6
257 - ideally all code depending on the cgroup naming scheme should use cgroups.py
258 - we are not there yet but this is a bit cleaner already
259
260 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-15
261 - addition to support for ipv6 to lxc slivers
262 - (thanks to Guilherme Sperb Machado)
263 - privatebridge plugin is back to the -lxc rpm
264 - add systemd dependency to network.target
265
266 * Tue Jul 22 2014 Thomas Dreibholz <dreibh@simula.no> - nodeimage-5.2-15
267 - nm.service fix: the node manager needs network.target, since it needs to contact the PLC.
268
269 * Wed Jul 16 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-14
270 - review packaging : one single spec file
271 - review packaging : some cleanup towards debians although not complete yet
272 - minor tweaks in exposing user's .ssh dir readonly
273
274 * Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-13
275 - improve network management in slices
276 - _has_systemctl was not declared as global - vsys was failing to restart
277
278 * Fri Apr 04 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-12
279 - this tag for the first time passes the full range of tests on fedora20
280 - robustified slice teardown wrt vsys
281 - Scott's fix for repairing veth devs
282 - removed sshsh
283 - tools.has_systemctl
284
285 * Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-11
286 - ship /etc/sysconfig/nodemanager
287 - trash sshsh
288
289 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-10
290 - comes with systemd native unit files on >= f18
291 - user-provided initscript gets started through systemd in slivers >= f18
292 - smarter to locate cgroups for various versions of libvirt
293 - nicer log format - and log program termination
294 - tweaks in codemux plugin
295 - bug fixes in libvirt driver, esp. for finding out if domain is running
296
297 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
298 - fixes in hostmap, and in interfaces
299 - new vsys_sysctl
300 - privatebridge now comes with nodemanager-lib
301
302 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
303 - omf plugin does not block any longer when running trigger script
304 - log goes into sliver's /var/log instead
305
306 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
307 - new install-scripts target in Makefile
308 - conf_files and fuse-pl initscripts chmod'ed +x
309 - omf_resctl config template tweaked to use _slicename_%_hostname_
310
311 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
312 - make sure to create /etc/planetlab/virt so others can read that
313 - expose get_node_virt() and command_in_slice()
314 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
315 - user's .profile now has right owner
316 - other tweaks in lxc slivers
317
318 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
319 - lxc slice creation: slice user was created with unknown gid - fixed
320 - lxc slice creation: .profile for root and user - fixed
321
322 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
323 - fix umounting of ssh directory when deleting omf-friendly slivers
324 - support for writing cgroups in subsystems other than cpuset
325 - add xid to template match
326 - finer-grained split between -lib -vs and -lxc
327 - first roughly complete omf_resctl for omfv6
328 - minor fix for when getslivers does not have minexemptrate
329
330 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
331 - Fix path, machine arch in slivers
332
333 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
334
335 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
336 - no-op bump to 5.2 to be in line with the rest of the system
337
338 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
339 - improvements to privatebridge
340
341 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
342 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
343
344 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
345 - fix wrong gre tunnel deleted when topology changes
346
347 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
348 - Update /etc/hosts in slivers from sliver_hostmap tag.
349
350 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
351 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
352 - initial check-in of privatebridge plugin.
353
354 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
355 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
356
357 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
358 - fix slices not deleted properly when they use vsys
359
360 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
361 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
362
363 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
364 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
365
366 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
367 - Bridge virtual interfaces to VLANs
368
369 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
370 - Add support for L2 bridged interfaces with public IPs inside a slice
371
372 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
373 - Support for freezing BestEffort slices for Vicci
374
375 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
376 - Change to use new vsh (wrapper for lxcsu)
377
378 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
379 - add missing import
380 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
381
382 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
383 - tag 2.1-7 was broken for OMF-friendly slices
384 - expose_ssh_dir was erroneously defined on the Worker class
385
386 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
387 - bwlimitlxc now ships with plnode-utils
388
389 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
390 - set LD_PRELOAD for linux-containers nodes
391
392 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
393 - first complete version for vs and lxc - functional but not thoroughly tested though
394
395 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
396 - split packaging in 3 (lib, lxc, vs)
397 - this tag will only work with lxc though
398
399 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
400 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
401
402 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
403 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
404 - purpose being to be able to run this branch on vserver nodes as well
405
406 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
407 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
408 - passes tests with lxc but won't build against vs due to conflict
409 - as bwlimit.py also ships with util-vserver-pl
410
411 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
412 - refactoring: isolate initscript functionality
413 - aimed at making initscript implementation with lxc straightforward
414 - show stack trace when module loading fails
415 - accounts.py renamed into account.py for consistency
416
417 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
418 - /var/log/nodemanager shows duration of mainloop
419
420 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
421 - first working draft for dealing with libvirt/lxc on f16 nodes
422 - not expected to work with mainline nodes (use 2.0 for that for now)
423
424 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
425 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
426
427 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
428 - Added memory scheduling to core scheduler
429 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
430
431 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
432 - tweaked log policy for the core scheduler
433 - curlwrapper has an optional verbose mode
434
435 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
436 - fixes for hmac and omf_control tags
437 - optional besteffort flag to core scheduler
438 - logrotate entry for /var/log/nodemanager.daemon
439 - a template for bash initscripts
440
441 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
442 - rename initscript_body into initscript_code
443 - fix generic vinit for broken bash syntax &>>
444
445 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
446 - new initscript_body slice tag, with stop and restart
447 - generic vinit script live updated
448 - new coresched module
449 - protect against non-existing vsys scripts
450 - use Config. instead of globals
451
452 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
453 - more robust reservation plugin
454
455 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
456 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
457 - reservation plugin more robust
458
459 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
460 - pass device to bwlimit
461
462 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
463 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
464
465 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
466 - Catch all exceptions for sfa plugin
467
468 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
469 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
470
471 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
472 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
473
474 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
475 - plugins/sliverauth.py improvements
476
477 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
478 - Disable sfagids plugin
479
480 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
481 - Re-tag nodemanager to include conflicted commits
482
483 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
484 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
485 - sfagids plugin deleted
486 - band-aid patch for lack of GetSliceFamily removed
487
488 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
489
490 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
491 - revert curlwrapper to former forking-curl version
492 - fixes in the omf plugin for ssh key location and node hrn
493 - set umask 0022 in tools.daemon
494
495 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
496 - configure omf-resctl for keys
497
498 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
499 - fix key generation
500
501 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
502 - name changes and fix typos
503
504 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
505 - remove config and options parameters from start function
506
507 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
508 - working version of reservable nodes
509 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
510 - dismantled the -s|--startup option (no convincing need for that)
511 - simpler and more robust init.d/nm
512 - initscript content management through replace_file_with_string
513 - sliverauth uses replace_file_with_string
514 - curlwrapper has a debug mode
515
516 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
517 - pretty-printing/normalized python code - hopefully neutral
518
519 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
520 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
521 - that triggers /etc/init.d/vinit.slice if present and executable
522 - (2) install the slice-provided initscript (as per the initscript tag) as
523 - /etc/init.d/vinit.slice
524 - (3) as a result the initscript are now triggered by rc as part of the
525 - standard vserver .. start, properly attached to the vserver,
526 - and properly killed upon vserver .. stop
527 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
528
529 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
530 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
531 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
532 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
533 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
534 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
535 - cleanup: nodemanger now is a class; however plugins are still dumb modules
536 - cleanup: does not depend on obsolete Set
537
538 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
539 - tagging before RC
540
541 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
542 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
543 - Added some precautions to the slice id-saving code
544 - Added log message to code that records the slice id
545
546 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
547 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
548 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
549 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
550
551 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
552 - fix log_call in plugins/drl.py
553
554 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
555 - protect against nodes in migrated PLC's not having the hrn tag yet
556
557 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
558 - new omf-resctl and drl plugins
559 - specialaccount optimized to overwrite authorized keys only upon changes
560 - codemux plugin has support for a new 'ip' setting
561 - mainloop to display ordered modules&plugins at all times
562
563 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
564 - modules and plugins have a priority
565 - specialaccounts appears soon in the priority chain
566 - logger.log_call logs process output, and has a timeout
567 - vuser{add,del} run through bash -x
568 - nm initscript has support for 'service nm restartverbose'
569 - logs reviewed for consistency
570 - use hashlib module instead of sha when available
571
572 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
573 - first working version of 5.0:
574 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
575 - nodefamily is 3-fold with pldistro-fcdistro-arch
576 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
577 - (in addition to the 'vref' tag that's still exposed too)
578 - logging reviewed for more convenience
579 - support for 'service nm restartdebug'
580 - make sync knows how to publish uncommitted code on a test node
581
582 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
583 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
584
585 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
586 - support for f10 and f12 in the vref slice tag
587
588 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
589 - build on fedora12
590 - uses slicename 'sfacm' instead of 'genicw'
591
592 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
593 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
594 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
595 - days ago.
596
597 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
598 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
599 - self-contained. With this change, they will be able to refer to the attributes associated with a
600 - slice.
601
602 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
603 - fix for syntax error
604
605 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
606 - -fixed problem with sioc import at the build side
607 - -bwlimit.set() now accepts the device and does not asume that it is eth0
608
609 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
610 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
611
612 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
613 - The seed for random previously was the meaning of life (i.e., 42) but
614 - that resulted in a not so random choice for the hmac.  This
615 - implementation now uses a random.seed that is based on the current
616 - time.
617
618 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
619 - Minor fix such that sliverauth.py makes a more specific call to
620 - GetSliceTags that include that specific tagname it is looking for.
621
622 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
623 - Fix bug that prevented 'OVERRIDES' for working correctly.
624
625 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
626 - Increase disk limits to 10G per sliver
627 - Sanity check slice for home directory before starting (hack)
628 - Check codemux arguments
629
630 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
631 - * Fix Delegation
632 - * Move plcapi in plugin-api GetSlivers() calls.
633 - * Persistent Authcheck and resync session when auth failure
634
635 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
636 - Disabling sliverauth module.  Not ready for deployment.
637
638 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
639 - Fixing overrides semantics.
640
641 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
642 - Generalized plugins
643 - Fixed initscript start up bug.
644
645 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
646 - * Fix delegation authentication problem
647 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
648
649 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
650 - * Rerun initscripts when slice goes from disabled to enabled.
651
652 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
653 - * Update session key when out of synch with PLC
654 - * PLCDefaults uses tagname
655
656 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
657 - log invokations of vsys
658
659 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
660
661 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
662
663 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
664 - Codemux supports multiple hosts mapping to single slice
665 - Fixed bug in delegation support where tickets delivered weren't
666   being passed to sm.deliver_ticket().
667
668 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
669 - Codemux now configured via slice attribute (host,port)
670 - Support for multiple vserver reference images (including different archs)
671 - Mom BW emails are sent to list defined by MyPLC's config
672 - Sirius BW loans honored correctly.  Fixed.
673 - BW totals preserved for dynamic slices so as not to game the system.
674
675 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
676 - Configures vsys via vsys slice attribute {name: vsys, value: script}
677 - CPU reservations are now calculated via percentages instead of shares
678 - BW totals preserved for dynamic slices
679 - Closes bug where node cap sets off bw slice alarms for all slices.
680
681 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
682 - Switched to SVN.
683
684 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
685 - Initial build.