Merge branch 'ipv6'
[nodemanager.git] / nodemanager.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 5.2
5 %define taglevel 14
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 ##############################
10 # for now we just extract all the files but package them only for either vs or lxc
11 # so bottom line is we have missing files at the end
12 # plan is to separate these target-dependant files in subdirs at some point
13 %define _unpackaged_files_terminate_build      0
14
15 ##############################
16 # use initscripts or systemd unit files to start installed services
17 %if "%{distro}" == "Fedora" && "%{distrorelease}" >= "18"
18 %define make_options WITH_SYSTEMD=true
19 %define initdir /usr/lib/systemd/system
20 %define build_lxc 1
21 %else
22 %define make_options WITH_INIT=true
23 %define initdir %{_initrddir}
24 %define build_vs 1
25 %endif
26
27 ##############################
28 Summary: PlanetLab Node Manager Library
29 Name: %{name}
30 Version: %{version}
31 Release: %{release}
32 License: PlanetLab
33 Group: System Environment/Daemons
34 Source0: %{name}-%{version}.tar.gz
35 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
36
37 Vendor: PlanetLab
38 Packager: PlanetLab Central <support@planet-lab.org>
39 Distribution: PlanetLab %{plrelease}
40 URL: %{SCMURL}
41
42 # not possible because of forward_api_calls
43 #BuildArch: noarch
44
45 # make sure we can invoke systemctl in post install script
46 %if "%{initdir}" != "%{_initrddir}"
47 Requires: systemd
48 %endif
49
50 # Uses function decorators
51 Requires: python >= 2.7
52 # connecting PLC
53 Requires: python-pycurl
54 # Signed tickets
55 Requires: gnupg
56 # sioc/plnet
57 Requires: pyplnet >= 4.3
58 # we do need the slice images in any case
59 Requires: sliceimage-%{slicefamily}
60 # for bwlimit
61 Requires: plnode-utils
62
63 %description
64 The PlanetLab Node Manager manages all aspects of PlanetLab node and
65 slice management once the node has been initialized and configured by
66 the Boot Manager. It periodically contacts its management authority
67 for configuration updates. It provides an XML-RPC API for performing
68 local operations on slices.
69 nodemanager-lib only provides a skeleton and needs as a companion
70 either nodemanager-vs or nodemanager-lxc
71
72 ##############################
73 %prep
74 %setup -q
75
76 %build
77 # make manages the C and Python stuff
78 %{__make} %{?_smp_mflags} %{make_options}
79
80 %install
81 # make manages the C and Python stuff
82 rm -rf $RPM_BUILD_ROOT
83 %{__make} %{?_smp_mflags} %{make_options} install DESTDIR="$RPM_BUILD_ROOT"
84
85 ##############################
86 %post
87 ########## traditional init
88 %if "%{initdir}" == "%{_initrddir}"
89 ##########
90 chkconfig --add conf_files
91 chkconfig conf_files on
92 chkconfig --add nm
93 chkconfig nm on
94 chkconfig --add fuse-pl
95 chkconfig fuse-pl on
96 if [ "$PL_BOOTCD" != "1" ] ; then
97     service nm restart
98     service fuse-pl restart
99 fi
100 ##########
101 %else
102 ########## systemd
103 systemctl enable nm.service
104 systemctl enable conf_files.service
105 # empty
106 #systemctl enable fuse-pl.service
107 if [ "$PL_BOOTCD" != "1" ] ; then
108     systemctl restart nm.service
109 #    systemctl restart fuse-pl.service
110 fi
111 ##########
112 %endif
113
114 ##############################
115 %preun
116 # 0 = erase, 1 = upgrade
117 ########## traditional init
118 %if "%{initdir}" == "%{_initrddir}"
119 ##########
120 if [ $1 -eq 0 ] ; then
121     chkconfig fuse-pl off
122     chkconfig --del fuse-pl
123     chkconfig nm off
124     chkconfig --del nm
125     chkconfig conf_files off
126     chkconfig --del conf_files
127 fi
128 ##########
129 %else
130 ########## systemd
131 if [ $1 -eq 0 ] ; then
132 #    systemctl disable fuse-pl.service
133     systemctl disable conf_files.service
134     systemctl disable nm.service
135 fi
136 ##########
137 %endif
138
139 ##############################
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 ##############################
144 %files
145 %defattr(-,root,root,-)
146 %{_datadir}/NodeManager/account.*
147 %{_datadir}/NodeManager/api.*
148 %{_datadir}/NodeManager/api_calls.*
149 %{_datadir}/NodeManager/bwmon.*
150 %{_datadir}/NodeManager/conf_files.*
151 %{_datadir}/NodeManager/config.*
152 %{_datadir}/NodeManager/controller.*
153 %{_datadir}/NodeManager/curlwrapper.*
154 %{_datadir}/NodeManager/database.*
155 %{_datadir}/NodeManager/initscript.*
156 %{_datadir}/NodeManager/iptables.*
157 %{_datadir}/NodeManager/logger.*
158 %{_datadir}/NodeManager/net.*
159 %{_datadir}/NodeManager/nodemanager.*
160 %{_datadir}/NodeManager/plcapi.*
161 %{_datadir}/NodeManager/safexmlrpc.*
162 %{_datadir}/NodeManager/slivermanager.*
163 %{_datadir}/NodeManager/ticket.*
164 %{_datadir}/NodeManager/tools.*
165 %{_datadir}/NodeManager/plugins/__init__.*
166 %{_datadir}/NodeManager/plugins/codemux.*
167 %{_datadir}/NodeManager/plugins/hostmap.*
168 %{_datadir}/NodeManager/plugins/interfaces.*
169 %{_datadir}/NodeManager/plugins/omf_resctl.*
170 %{_datadir}/NodeManager/plugins/rawdisk.*
171 %{_datadir}/NodeManager/plugins/reservation.*
172 %{_datadir}/NodeManager/plugins/sfagids.*
173 %{_datadir}/NodeManager/plugins/sliverauth.*
174 %{_datadir}/NodeManager/plugins/specialaccounts.*
175 %{_datadir}/NodeManager/plugins/syndicate.*
176 %{_datadir}/NodeManager/plugins/vsys.*
177 %{_datadir}/NodeManager/plugins/vsys_privs.*
178 %{_datadir}/NodeManager/plugins/ipv6.*
179 %{_datadir}/NodeManager/plugins/update_ipv6addr_slivertag.*
180 %{_datadir}/NodeManager/sliver-initscripts/
181 %{_datadir}/NodeManager/sliver-systemd/
182 %{_bindir}/forward_api_calls
183 %{initdir}/
184 %{_sysconfdir}/logrotate.d/nodemanager
185 /var/lib/nodemanager/
186 %config(noreplace) /etc/sysconfig/nodemanager
187
188 ##############################
189 %if "%{build_lxc}" == "1"
190
191 %package -n nodemanager-lxc
192 Summary: PlanetLab Node Manager Plugin for lxc nodes
193 Group: System Environment/Daemons
194 # we use libvirt
195 Requires: libvirt
196 Requires: libvirt-python
197 # cgroups.py needs this
198 Requires: python-inotify
199 # the common package for nodemanager
200 Requires: nodemanager-lib = %{version}
201 # the lxc-specific tools for using slice images
202 Requires: lxc-sliceimage
203 Requires: openvswitch
204
205 %description -n nodemanager-lxc
206 nodemanager-lxc provides the lxc code for the PlanetLab Node Manager.
207
208 %files -n nodemanager-lxc
209 %{_datadir}/NodeManager/sliver_libvirt.*
210 %{_datadir}/NodeManager/sliver_lxc.*
211 %{_datadir}/NodeManager/cgroups.*
212 %{_datadir}/NodeManager/coresched_lxc.*
213 %{_datadir}/NodeManager/plugins/privatebridge.*
214
215 %endif
216 ##############################
217
218 ##############################
219 %if "%{build_vs}" == "1"
220
221 %package -n nodemanager-vs
222 Summary: PlanetLab Node Manager Plugin for vserver nodes
223 Group: System Environment/Daemons
224
225 # old name, when all came as a single package with vserver wired in
226 Obsoletes: NodeManager
227 # for nodeupdate 
228 Provides: nodemanager
229
230 # our interface to the vserver patch
231 Requires: util-vserver >= 0.30.208-17
232 # and the planetlab utilities
233 Requires: util-vserver-python > 0.3-16
234 # the common package for nodemanager
235 Requires: nodemanager-lib = %{version}
236 # the vserver-specific tools for using slice images
237 Requires: vserver-sliceimage
238
239 %description -n nodemanager-vs
240 nodemanager-vs provides the vserver code for the PlanetLab Node Manager.
241
242 %files -n nodemanager-vs
243 %{_datadir}/NodeManager/sliver_vs.*
244 %{_datadir}/NodeManager/coresched_vs.*
245 # this plugin uses vserver for now
246 %{_datadir}/NodeManager/plugins/drl.*
247
248 %endif
249 ##############################
250
251 ##############################
252 %changelog
253 * Tue Jul 22 2014 Thomas Dreibholz <dreibh@simula.no> - nodeimage-5.2-15
254 - nm.service fix: the node manager needs network.target, since it needs to contact the PLC.
255
256 * Wed Jul 16 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-14
257 - review packaging : one single spec file
258 - review packaging : some cleanup towards debians although not complete yet
259 - minor tweaks in exposing user's .ssh dir readonly
260
261 * Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-13
262 - improve network management in slices
263 - _has_systemctl was not declared as global - vsys was failing to restart
264
265 * Fri Apr 04 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-12
266 - this tag for the first time passes the full range of tests on fedora20
267 - robustified slice teardown wrt vsys
268 - Scott's fix for repairing veth devs
269 - removed sshsh
270 - tools.has_systemctl
271
272 * Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-11
273 - ship /etc/sysconfig/nodemanager
274 - trash sshsh
275
276 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-10
277 - comes with systemd native unit files on >= f18
278 - user-provided initscript gets started through systemd in slivers >= f18
279 - smarter to locate cgroups for various versions of libvirt
280 - nicer log format - and log program termination
281 - tweaks in codemux plugin
282 - bug fixes in libvirt driver, esp. for finding out if domain is running
283
284 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
285 - fixes in hostmap, and in interfaces
286 - new vsys_sysctl
287 - privatebridge now comes with nodemanager-lib
288
289 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
290 - omf plugin does not block any longer when running trigger script
291 - log goes into sliver's /var/log instead
292
293 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
294 - new install-scripts target in Makefile
295 - conf_files and fuse-pl initscripts chmod'ed +x
296 - omf_resctl config template tweaked to use _slicename_%_hostname_
297
298 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
299 - make sure to create /etc/planetlab/virt so others can read that
300 - expose get_node_virt() and command_in_slice()
301 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
302 - user's .profile now has right owner
303 - other tweaks in lxc slivers
304
305 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
306 - lxc slice creation: slice user was created with unknown gid - fixed
307 - lxc slice creation: .profile for root and user - fixed
308
309 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
310 - fix umounting of ssh directory when deleting omf-friendly slivers
311 - support for writing cgroups in subsystems other than cpuset
312 - add xid to template match
313 - finer-grained split between -lib -vs and -lxc
314 - first roughly complete omf_resctl for omfv6
315 - minor fix for when getslivers does not have minexemptrate
316
317 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
318 - Fix path, machine arch in slivers
319
320 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
321
322 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
323 - no-op bump to 5.2 to be in line with the rest of the system
324
325 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
326 - improvements to privatebridge
327
328 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
329 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
330
331 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
332 - fix wrong gre tunnel deleted when topology changes
333
334 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
335 - Update /etc/hosts in slivers from sliver_hostmap tag.
336
337 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
338 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
339 - initial check-in of privatebridge plugin.
340
341 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
342 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
343
344 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
345 - fix slices not deleted properly when they use vsys
346
347 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
348 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
349
350 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
351 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
352
353 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
354 - Bridge virtual interfaces to VLANs
355
356 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
357 - Add support for L2 bridged interfaces with public IPs inside a slice
358
359 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
360 - Support for freezing BestEffort slices for Vicci
361
362 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
363 - Change to use new vsh (wrapper for lxcsu)
364
365 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
366 - add missing import
367 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
368
369 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
370 - tag 2.1-7 was broken for OMF-friendly slices
371 - expose_ssh_dir was erroneously defined on the Worker class
372
373 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
374 - bwlimitlxc now ships with plnode-utils
375
376 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
377 - set LD_PRELOAD for linux-containers nodes
378
379 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
380 - first complete version for vs and lxc - functional but not thoroughly tested though
381
382 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
383 - split packaging in 3 (lib, lxc, vs)
384 - this tag will only work with lxc though
385
386 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
387 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
388
389 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
390 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
391 - purpose being to be able to run this branch on vserver nodes as well
392
393 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
394 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
395 - passes tests with lxc but won't build against vs due to conflict
396 - as bwlimit.py also ships with util-vserver-pl
397
398 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
399 - refactoring: isolate initscript functionality
400 - aimed at making initscript implementation with lxc straightforward
401 - show stack trace when module loading fails
402 - accounts.py renamed into account.py for consistency
403
404 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
405 - /var/log/nodemanager shows duration of mainloop
406
407 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
408 - first working draft for dealing with libvirt/lxc on f16 nodes
409 - not expected to work with mainline nodes (use 2.0 for that for now)
410
411 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
412 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
413
414 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
415 - Added memory scheduling to core scheduler
416 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
417
418 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
419 - tweaked log policy for the core scheduler
420 - curlwrapper has an optional verbose mode
421
422 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
423 - fixes for hmac and omf_control tags
424 - optional besteffort flag to core scheduler
425 - logrotate entry for /var/log/nodemanager.daemon
426 - a template for bash initscripts
427
428 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
429 - rename initscript_body into initscript_code
430 - fix generic vinit for broken bash syntax &>>
431
432 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
433 - new initscript_body slice tag, with stop and restart
434 - generic vinit script live updated
435 - new coresched module
436 - protect against non-existing vsys scripts
437 - use Config. instead of globals
438
439 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
440 - more robust reservation plugin
441
442 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
443 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
444 - reservation plugin more robust
445
446 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
447 - pass device to bwlimit
448
449 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
450 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
451
452 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
453 - Catch all exceptions for sfa plugin
454
455 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
456 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
457
458 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
459 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
460
461 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
462 - plugins/sliverauth.py improvements
463
464 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
465 - Disable sfagids plugin
466
467 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
468 - Re-tag nodemanager to include conflicted commits
469
470 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
471 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
472 - sfagids plugin deleted
473 - band-aid patch for lack of GetSliceFamily removed
474
475 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
476
477 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
478 - revert curlwrapper to former forking-curl version
479 - fixes in the omf plugin for ssh key location and node hrn
480 - set umask 0022 in tools.daemon
481
482 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
483 - configure omf-resctl for keys
484
485 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
486 - fix key generation
487
488 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
489 - name changes and fix typos
490
491 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
492 - remove config and options parameters from start function
493
494 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
495 - working version of reservable nodes
496 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
497 - dismantled the -s|--startup option (no convincing need for that)
498 - simpler and more robust init.d/nm
499 - initscript content management through replace_file_with_string
500 - sliverauth uses replace_file_with_string
501 - curlwrapper has a debug mode
502
503 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
504 - pretty-printing/normalized python code - hopefully neutral
505
506 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
507 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
508 - that triggers /etc/init.d/vinit.slice if present and executable
509 - (2) install the slice-provided initscript (as per the initscript tag) as
510 - /etc/init.d/vinit.slice
511 - (3) as a result the initscript are now triggered by rc as part of the
512 - standard vserver .. start, properly attached to the vserver,
513 - and properly killed upon vserver .. stop
514 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
515
516 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
517 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
518 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
519 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
520 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
521 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
522 - cleanup: nodemanger now is a class; however plugins are still dumb modules
523 - cleanup: does not depend on obsolete Set
524
525 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
526 - tagging before RC
527
528 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
529 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
530 - Added some precautions to the slice id-saving code
531 - Added log message to code that records the slice id
532
533 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
534 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
535 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
536 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
537
538 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
539 - fix log_call in plugins/drl.py
540
541 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
542 - protect against nodes in migrated PLC's not having the hrn tag yet
543
544 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
545 - new omf-resctl and drl plugins
546 - specialaccount optimized to overwrite authorized keys only upon changes
547 - codemux plugin has support for a new 'ip' setting
548 - mainloop to display ordered modules&plugins at all times
549
550 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
551 - modules and plugins have a priority
552 - specialaccounts appears soon in the priority chain
553 - logger.log_call logs process output, and has a timeout
554 - vuser{add,del} run through bash -x
555 - nm initscript has support for 'service nm restartverbose'
556 - logs reviewed for consistency
557 - use hashlib module instead of sha when available
558
559 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
560 - first working version of 5.0:
561 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
562 - nodefamily is 3-fold with pldistro-fcdistro-arch
563 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
564 - (in addition to the 'vref' tag that's still exposed too)
565 - logging reviewed for more convenience
566 - support for 'service nm restartdebug'
567 - make sync knows how to publish uncommitted code on a test node
568
569 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
570 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
571
572 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
573 - support for f10 and f12 in the vref slice tag
574
575 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
576 - build on fedora12
577 - uses slicename 'sfacm' instead of 'genicw'
578
579 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
580 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
581 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
582 - days ago.
583
584 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
585 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
586 - self-contained. With this change, they will be able to refer to the attributes associated with a
587 - slice.
588
589 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
590 - fix for syntax error
591
592 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
593 - -fixed problem with sioc import at the build side
594 - -bwlimit.set() now accepts the device and does not asume that it is eth0
595
596 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
597 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
598
599 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
600 - The seed for random previously was the meaning of life (i.e., 42) but
601 - that resulted in a not so random choice for the hmac.  This
602 - implementation now uses a random.seed that is based on the current
603 - time.
604
605 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
606 - Minor fix such that sliverauth.py makes a more specific call to
607 - GetSliceTags that include that specific tagname it is looking for.
608
609 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
610 - Fix bug that prevented 'OVERRIDES' for working correctly.
611
612 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
613 - Increase disk limits to 10G per sliver
614 - Sanity check slice for home directory before starting (hack)
615 - Check codemux arguments
616
617 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
618 - * Fix Delegation
619 - * Move plcapi in plugin-api GetSlivers() calls.
620 - * Persistent Authcheck and resync session when auth failure
621
622 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
623 - Disabling sliverauth module.  Not ready for deployment.
624
625 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
626 - Fixing overrides semantics.
627
628 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
629 - Generalized plugins
630 - Fixed initscript start up bug.
631
632 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
633 - * Fix delegation authentication problem
634 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
635
636 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
637 - * Rerun initscripts when slice goes from disabled to enabled.
638
639 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
640 - * Update session key when out of synch with PLC
641 - * PLCDefaults uses tagname
642
643 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
644 - log invokations of vsys
645
646 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
647
648 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
649
650 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
651 - Codemux supports multiple hosts mapping to single slice
652 - Fixed bug in delegation support where tickets delivered weren't
653   being passed to sm.deliver_ticket().
654
655 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
656 - Codemux now configured via slice attribute (host,port)
657 - Support for multiple vserver reference images (including different archs)
658 - Mom BW emails are sent to list defined by MyPLC's config
659 - Sirius BW loans honored correctly.  Fixed.
660 - BW totals preserved for dynamic slices so as not to game the system.
661
662 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
663 - Configures vsys via vsys slice attribute {name: vsys, value: script}
664 - CPU reservations are now calculated via percentages instead of shares
665 - BW totals preserved for dynamic slices
666 - Closes bug where node cap sets off bw slice alarms for all slices.
667
668 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
669 - Switched to SVN.
670
671 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
672 - Initial build.