Setting tag nodemanager-5.2-14
[nodemanager.git] / nodemanager.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 5.2
5 %define taglevel 14
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 ##############################
10 # for now we just extract all the files but package them only for either vs or lxc
11 # so bottom line is we have missing files at the end
12 # plan is to separate these target-dependant files in subdirs at some point
13 %define _unpackaged_files_terminate_build      0
14
15 ##############################
16 # use initscripts or systemd unit files to start installed services
17 %if "%{distro}" == "Fedora" && "%{distrorelease}" >= "18"
18 %define make_options WITH_SYSTEMD=true
19 %define initdir /usr/lib/systemd/system
20 %define build_lxc 1
21 %else
22 %define make_options WITH_INIT=true
23 %define initdir %{_initrddir}
24 %define build_vs 1
25 %endif
26
27 ##############################
28 Summary: PlanetLab Node Manager Library
29 Name: %{name}
30 Version: %{version}
31 Release: %{release}
32 License: PlanetLab
33 Group: System Environment/Daemons
34 Source0: %{name}-%{version}.tar.gz
35 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
36
37 Vendor: PlanetLab
38 Packager: PlanetLab Central <support@planet-lab.org>
39 Distribution: PlanetLab %{plrelease}
40 URL: %{SCMURL}
41
42 # not possible because of forward_api_calls
43 #BuildArch: noarch
44
45 # make sure we can invoke systemctl in post install script
46 %if "%{initdir}" != "%{_initrddir}"
47 Requires: systemd
48 %endif
49
50 # Uses function decorators
51 Requires: python >= 2.7
52 # connecting PLC
53 Requires: python-pycurl
54 # Signed tickets
55 Requires: gnupg
56 # sioc/plnet
57 Requires: pyplnet >= 4.3
58 # we do need the slice images in any case
59 Requires: sliceimage-%{slicefamily}
60 # for bwlimit
61 Requires: plnode-utils
62
63 %description
64 The PlanetLab Node Manager manages all aspects of PlanetLab node and
65 slice management once the node has been initialized and configured by
66 the Boot Manager. It periodically contacts its management authority
67 for configuration updates. It provides an XML-RPC API for performing
68 local operations on slices.
69 nodemanager-lib only provides a skeleton and needs as a companion
70 either nodemanager-vs or nodemanager-lxc
71
72 ##############################
73 %prep
74 %setup -q
75
76 %build
77 # make manages the C and Python stuff
78 %{__make} %{?_smp_mflags} %{make_options}
79
80 %install
81 # make manages the C and Python stuff
82 rm -rf $RPM_BUILD_ROOT
83 %{__make} %{?_smp_mflags} %{make_options} install DESTDIR="$RPM_BUILD_ROOT"
84
85 ##############################
86 %post
87 ########## traditional init
88 %if "%{initdir}" == "%{_initrddir}"
89 ##########
90 chkconfig --add conf_files
91 chkconfig conf_files on
92 chkconfig --add nm
93 chkconfig nm on
94 chkconfig --add fuse-pl
95 chkconfig fuse-pl on
96 if [ "$PL_BOOTCD" != "1" ] ; then
97     service nm restart
98     service fuse-pl restart
99 fi
100 ##########
101 %else
102 ########## systemd
103 systemctl enable nm.service
104 systemctl enable conf_files.service
105 # empty
106 #systemctl enable fuse-pl.service
107 if [ "$PL_BOOTCD" != "1" ] ; then
108     systemctl restart nm.service
109 #    systemctl restart fuse-pl.service
110 fi
111 ##########
112 %endif
113
114 ##############################
115 %preun
116 # 0 = erase, 1 = upgrade
117 ########## traditional init
118 %if "%{initdir}" == "%{_initrddir}"
119 ##########
120 if [ $1 -eq 0 ] ; then
121     chkconfig fuse-pl off
122     chkconfig --del fuse-pl
123     chkconfig nm off
124     chkconfig --del nm
125     chkconfig conf_files off
126     chkconfig --del conf_files
127 fi
128 ##########
129 %else
130 ########## systemd
131 if [ $1 -eq 0 ] ; then
132 #    systemctl disable fuse-pl.service
133     systemctl disable conf_files.service
134     systemctl disable nm.service
135 fi
136 ##########
137 %endif
138
139 ##############################
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 ##############################
144 %files
145 %defattr(-,root,root,-)
146 %{_datadir}/NodeManager/account.*
147 %{_datadir}/NodeManager/api.*
148 %{_datadir}/NodeManager/api_calls.*
149 %{_datadir}/NodeManager/bwmon.*
150 %{_datadir}/NodeManager/conf_files.*
151 %{_datadir}/NodeManager/config.*
152 %{_datadir}/NodeManager/controller.*
153 %{_datadir}/NodeManager/curlwrapper.*
154 %{_datadir}/NodeManager/database.*
155 %{_datadir}/NodeManager/initscript.*
156 %{_datadir}/NodeManager/iptables.*
157 %{_datadir}/NodeManager/logger.*
158 %{_datadir}/NodeManager/net.*
159 %{_datadir}/NodeManager/nodemanager.*
160 %{_datadir}/NodeManager/plcapi.*
161 %{_datadir}/NodeManager/safexmlrpc.*
162 %{_datadir}/NodeManager/slivermanager.*
163 %{_datadir}/NodeManager/ticket.*
164 %{_datadir}/NodeManager/tools.*
165 %{_datadir}/NodeManager/plugins/__init__.*
166 %{_datadir}/NodeManager/plugins/codemux.*
167 %{_datadir}/NodeManager/plugins/hostmap.*
168 %{_datadir}/NodeManager/plugins/interfaces.*
169 %{_datadir}/NodeManager/plugins/omf_resctl.*
170 %{_datadir}/NodeManager/plugins/privatebridge.*
171 %{_datadir}/NodeManager/plugins/rawdisk.*
172 %{_datadir}/NodeManager/plugins/reservation.*
173 %{_datadir}/NodeManager/plugins/sfagids.*
174 %{_datadir}/NodeManager/plugins/sliverauth.*
175 %{_datadir}/NodeManager/plugins/specialaccounts.*
176 %{_datadir}/NodeManager/plugins/syndicate.*
177 %{_datadir}/NodeManager/plugins/vsys.*
178 %{_datadir}/NodeManager/plugins/vsys_privs.*
179 %{_datadir}/NodeManager/sliver-initscripts/
180 %{_datadir}/NodeManager/sliver-systemd/
181 %{_bindir}/forward_api_calls
182 %{initdir}/
183 %{_sysconfdir}/logrotate.d/nodemanager
184 /var/lib/nodemanager/
185 %config(noreplace) /etc/sysconfig/nodemanager
186
187 ##############################
188 %if "%{build_lxc}" == "1"
189
190 %package -n nodemanager-lxc
191 Summary: PlanetLab Node Manager Plugin for lxc nodes
192 Group: System Environment/Daemons
193 # we use libvirt
194 Requires: libvirt
195 Requires: libvirt-python
196 # cgroups.py needs this
197 Requires: python-inotify
198 # the common package for nodemanager
199 Requires: nodemanager-lib = %{version}
200 # the lxc-specific tools for using slice images
201 Requires: lxc-sliceimage
202 Requires: openvswitch
203
204 %description -n nodemanager-lxc
205 nodemanager-lxc provides the lxc code for the PlanetLab Node Manager.
206
207 %files -n nodemanager-lxc
208 %{_datadir}/NodeManager/sliver_libvirt.*
209 %{_datadir}/NodeManager/sliver_lxc.*
210 %{_datadir}/NodeManager/cgroups.*
211 %{_datadir}/NodeManager/coresched_lxc.*
212
213 %endif
214 ##############################
215
216 ##############################
217 %if "%{build_vs}" == "1"
218
219 %package -n nodemanager-vs
220 Summary: PlanetLab Node Manager Plugin for vserver nodes
221 Group: System Environment/Daemons
222
223 # old name, when all came as a single package with vserver wired in
224 Obsoletes: NodeManager
225 # for nodeupdate 
226 Provides: nodemanager
227
228 # our interface to the vserver patch
229 Requires: util-vserver >= 0.30.208-17
230 # and the planetlab utilities
231 Requires: util-vserver-python > 0.3-16
232 # the common package for nodemanager
233 Requires: nodemanager-lib = %{version}
234 # the vserver-specific tools for using slice images
235 Requires: vserver-sliceimage
236
237 %description -n nodemanager-vs
238 nodemanager-vs provides the vserver code for the PlanetLab Node Manager.
239
240 %files -n nodemanager-vs
241 %{_datadir}/NodeManager/sliver_vs.*
242 %{_datadir}/NodeManager/coresched_vs.*
243 # this plugin uses vserver for now
244 %{_datadir}/NodeManager/plugins/drl.*
245
246 %endif
247 ##############################
248
249 ##############################
250 %changelog
251 * Wed Jul 16 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-14
252 - review packaging : one single spec file
253 - review packaging : some cleanup towards debians although not complete yet
254 - minor tweaks in exposing user's .ssh dir readonly
255
256 * Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-13
257 - improve network management in slices
258 - _has_systemctl was not declared as global - vsys was failing to restart
259
260 * Fri Apr 04 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-12
261 - this tag for the first time passes the full range of tests on fedora20
262 - robustified slice teardown wrt vsys
263 - Scott's fix for repairing veth devs
264 - removed sshsh
265 - tools.has_systemctl
266
267 * Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-11
268 - ship /etc/sysconfig/nodemanager
269 - trash sshsh
270
271 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-10
272 - comes with systemd native unit files on >= f18
273 - user-provided initscript gets started through systemd in slivers >= f18
274 - smarter to locate cgroups for various versions of libvirt
275 - nicer log format - and log program termination
276 - tweaks in codemux plugin
277 - bug fixes in libvirt driver, esp. for finding out if domain is running
278
279 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
280 - fixes in hostmap, and in interfaces
281 - new vsys_sysctl
282 - privatebridge now comes with nodemanager-lib
283
284 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
285 - omf plugin does not block any longer when running trigger script
286 - log goes into sliver's /var/log instead
287
288 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
289 - new install-scripts target in Makefile
290 - conf_files and fuse-pl initscripts chmod'ed +x
291 - omf_resctl config template tweaked to use _slicename_%_hostname_
292
293 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
294 - make sure to create /etc/planetlab/virt so others can read that
295 - expose get_node_virt() and command_in_slice()
296 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
297 - user's .profile now has right owner
298 - other tweaks in lxc slivers
299
300 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
301 - lxc slice creation: slice user was created with unknown gid - fixed
302 - lxc slice creation: .profile for root and user - fixed
303
304 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
305 - fix umounting of ssh directory when deleting omf-friendly slivers
306 - support for writing cgroups in subsystems other than cpuset
307 - add xid to template match
308 - finer-grained split between -lib -vs and -lxc
309 - first roughly complete omf_resctl for omfv6
310 - minor fix for when getslivers does not have minexemptrate
311
312 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
313 - Fix path, machine arch in slivers
314
315 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
316
317 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
318 - no-op bump to 5.2 to be in line with the rest of the system
319
320 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
321 - improvements to privatebridge
322
323 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
324 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
325
326 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
327 - fix wrong gre tunnel deleted when topology changes
328
329 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
330 - Update /etc/hosts in slivers from sliver_hostmap tag.
331
332 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
333 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
334 - initial check-in of privatebridge plugin.
335
336 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
337 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
338
339 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
340 - fix slices not deleted properly when they use vsys
341
342 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
343 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
344
345 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
346 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
347
348 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
349 - Bridge virtual interfaces to VLANs
350
351 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
352 - Add support for L2 bridged interfaces with public IPs inside a slice
353
354 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
355 - Support for freezing BestEffort slices for Vicci
356
357 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
358 - Change to use new vsh (wrapper for lxcsu)
359
360 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
361 - add missing import
362 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
363
364 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
365 - tag 2.1-7 was broken for OMF-friendly slices
366 - expose_ssh_dir was erroneously defined on the Worker class
367
368 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
369 - bwlimitlxc now ships with plnode-utils
370
371 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
372 - set LD_PRELOAD for linux-containers nodes
373
374 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
375 - first complete version for vs and lxc - functional but not thoroughly tested though
376
377 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
378 - split packaging in 3 (lib, lxc, vs)
379 - this tag will only work with lxc though
380
381 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
382 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
383
384 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
385 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
386 - purpose being to be able to run this branch on vserver nodes as well
387
388 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
389 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
390 - passes tests with lxc but won't build against vs due to conflict
391 - as bwlimit.py also ships with util-vserver-pl
392
393 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
394 - refactoring: isolate initscript functionality
395 - aimed at making initscript implementation with lxc straightforward
396 - show stack trace when module loading fails
397 - accounts.py renamed into account.py for consistency
398
399 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
400 - /var/log/nodemanager shows duration of mainloop
401
402 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
403 - first working draft for dealing with libvirt/lxc on f16 nodes
404 - not expected to work with mainline nodes (use 2.0 for that for now)
405
406 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
407 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
408
409 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
410 - Added memory scheduling to core scheduler
411 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
412
413 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
414 - tweaked log policy for the core scheduler
415 - curlwrapper has an optional verbose mode
416
417 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
418 - fixes for hmac and omf_control tags
419 - optional besteffort flag to core scheduler
420 - logrotate entry for /var/log/nodemanager.daemon
421 - a template for bash initscripts
422
423 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
424 - rename initscript_body into initscript_code
425 - fix generic vinit for broken bash syntax &>>
426
427 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
428 - new initscript_body slice tag, with stop and restart
429 - generic vinit script live updated
430 - new coresched module
431 - protect against non-existing vsys scripts
432 - use Config. instead of globals
433
434 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
435 - more robust reservation plugin
436
437 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
438 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
439 - reservation plugin more robust
440
441 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
442 - pass device to bwlimit
443
444 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
445 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
446
447 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
448 - Catch all exceptions for sfa plugin
449
450 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
451 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
452
453 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
454 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
455
456 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
457 - plugins/sliverauth.py improvements
458
459 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
460 - Disable sfagids plugin
461
462 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
463 - Re-tag nodemanager to include conflicted commits
464
465 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
466 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
467 - sfagids plugin deleted
468 - band-aid patch for lack of GetSliceFamily removed
469
470 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
471
472 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
473 - revert curlwrapper to former forking-curl version
474 - fixes in the omf plugin for ssh key location and node hrn
475 - set umask 0022 in tools.daemon
476
477 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
478 - configure omf-resctl for keys
479
480 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
481 - fix key generation
482
483 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
484 - name changes and fix typos
485
486 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
487 - remove config and options parameters from start function
488
489 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
490 - working version of reservable nodes
491 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
492 - dismantled the -s|--startup option (no convincing need for that)
493 - simpler and more robust init.d/nm
494 - initscript content management through replace_file_with_string
495 - sliverauth uses replace_file_with_string
496 - curlwrapper has a debug mode
497
498 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
499 - pretty-printing/normalized python code - hopefully neutral
500
501 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
502 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
503 - that triggers /etc/init.d/vinit.slice if present and executable
504 - (2) install the slice-provided initscript (as per the initscript tag) as
505 - /etc/init.d/vinit.slice
506 - (3) as a result the initscript are now triggered by rc as part of the
507 - standard vserver .. start, properly attached to the vserver,
508 - and properly killed upon vserver .. stop
509 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
510
511 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
512 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
513 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
514 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
515 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
516 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
517 - cleanup: nodemanger now is a class; however plugins are still dumb modules
518 - cleanup: does not depend on obsolete Set
519
520 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
521 - tagging before RC
522
523 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
524 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
525 - Added some precautions to the slice id-saving code
526 - Added log message to code that records the slice id
527
528 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
529 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
530 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
531 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
532
533 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
534 - fix log_call in plugins/drl.py
535
536 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
537 - protect against nodes in migrated PLC's not having the hrn tag yet
538
539 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
540 - new omf-resctl and drl plugins
541 - specialaccount optimized to overwrite authorized keys only upon changes
542 - codemux plugin has support for a new 'ip' setting
543 - mainloop to display ordered modules&plugins at all times
544
545 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
546 - modules and plugins have a priority
547 - specialaccounts appears soon in the priority chain
548 - logger.log_call logs process output, and has a timeout
549 - vuser{add,del} run through bash -x
550 - nm initscript has support for 'service nm restartverbose'
551 - logs reviewed for consistency
552 - use hashlib module instead of sha when available
553
554 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
555 - first working version of 5.0:
556 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
557 - nodefamily is 3-fold with pldistro-fcdistro-arch
558 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
559 - (in addition to the 'vref' tag that's still exposed too)
560 - logging reviewed for more convenience
561 - support for 'service nm restartdebug'
562 - make sync knows how to publish uncommitted code on a test node
563
564 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
565 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
566
567 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
568 - support for f10 and f12 in the vref slice tag
569
570 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
571 - build on fedora12
572 - uses slicename 'sfacm' instead of 'genicw'
573
574 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
575 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
576 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
577 - days ago.
578
579 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
580 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
581 - self-contained. With this change, they will be able to refer to the attributes associated with a
582 - slice.
583
584 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
585 - fix for syntax error
586
587 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
588 - -fixed problem with sioc import at the build side
589 - -bwlimit.set() now accepts the device and does not asume that it is eth0
590
591 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
592 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
593
594 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
595 - The seed for random previously was the meaning of life (i.e., 42) but
596 - that resulted in a not so random choice for the hmac.  This
597 - implementation now uses a random.seed that is based on the current
598 - time.
599
600 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
601 - Minor fix such that sliverauth.py makes a more specific call to
602 - GetSliceTags that include that specific tagname it is looking for.
603
604 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
605 - Fix bug that prevented 'OVERRIDES' for working correctly.
606
607 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
608 - Increase disk limits to 10G per sliver
609 - Sanity check slice for home directory before starting (hack)
610 - Check codemux arguments
611
612 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
613 - * Fix Delegation
614 - * Move plcapi in plugin-api GetSlivers() calls.
615 - * Persistent Authcheck and resync session when auth failure
616
617 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
618 - Disabling sliverauth module.  Not ready for deployment.
619
620 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
621 - Fixing overrides semantics.
622
623 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
624 - Generalized plugins
625 - Fixed initscript start up bug.
626
627 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
628 - * Fix delegation authentication problem
629 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
630
631 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
632 - * Rerun initscripts when slice goes from disabled to enabled.
633
634 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
635 - * Update session key when out of synch with PLC
636 - * PLCDefaults uses tagname
637
638 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
639 - log invokations of vsys
640
641 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
642
643 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
644
645 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
646 - Codemux supports multiple hosts mapping to single slice
647 - Fixed bug in delegation support where tickets delivered weren't
648   being passed to sm.deliver_ticket().
649
650 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
651 - Codemux now configured via slice attribute (host,port)
652 - Support for multiple vserver reference images (including different archs)
653 - Mom BW emails are sent to list defined by MyPLC's config
654 - Sirius BW loans honored correctly.  Fixed.
655 - BW totals preserved for dynamic slices so as not to game the system.
656
657 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
658 - Configures vsys via vsys slice attribute {name: vsys, value: script}
659 - CPU reservations are now calculated via percentages instead of shares
660 - BW totals preserved for dynamic slices
661 - Closes bug where node cap sets off bw slice alarms for all slices.
662
663 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
664 - Switched to SVN.
665
666 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
667 - Initial build.