reviewed packaging contents as compared with the former scheme
[nodemanager.git] / nodemanager.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 5.2
5 %define taglevel 13
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 ##############################
10 # for now we just extract all the files but package them only for either vs or lxc
11 # so bottom line is we have missing files at the end
12 # plan is to separate these target-dependant files in subdirs at some point
13 %define _unpackaged_files_terminate_build      0
14
15 ##############################
16 # use initscripts or systemd unit files to start installed services
17 %if "%{distro}" == "Fedora" && "%{distrorelease}" >= "18"
18 %define make_options WITH_SYSTEMD=true
19 %define initdir /usr/lib/systemd/system
20 %define build_lxc 1
21 %else
22 %define make_options WITH_INIT=true
23 %define initdir %{_initrddir}
24 %define build_vs 1
25 %endif
26
27 ##############################
28 Summary: PlanetLab Node Manager Library
29 Name: %{name}
30 Version: %{version}
31 Release: %{release}
32 License: PlanetLab
33 Group: System Environment/Daemons
34 Source0: %{name}-%{version}.tar.gz
35 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
36
37 Vendor: PlanetLab
38 Packager: PlanetLab Central <support@planet-lab.org>
39 Distribution: PlanetLab %{plrelease}
40 URL: %{SCMURL}
41
42 # not possible because of forward_api_calls
43 #BuildArch: noarch
44
45 # make sure we can invoke systemctl in post install script
46 %if "%{initdir}" != "%{_initrddir}"
47 Requires: systemd
48 %endif
49
50 # Uses function decorators
51 Requires: python >= 2.7
52 # connecting PLC
53 Requires: python-pycurl
54 # Signed tickets
55 Requires: gnupg
56 # sioc/plnet
57 Requires: pyplnet >= 4.3
58 # we do need the slice images in any case
59 Requires: sliceimage-%{slicefamily}
60 # for bwlimit
61 Requires: plnode-utils
62
63 %description
64 The PlanetLab Node Manager manages all aspects of PlanetLab node and
65 slice management once the node has been initialized and configured by
66 the Boot Manager. It periodically contacts its management authority
67 for configuration updates. It provides an XML-RPC API for performing
68 local operations on slices.
69 nodemanager-lib only provides a skeleton and needs as a companion
70 either nodemanager-vs or nodemanager-lxc
71
72 ##############################
73 %prep
74 %setup -q
75
76 %build
77 # make manages the C and Python stuff
78 %{__make} %{?_smp_mflags} %{make_options}
79
80 %install
81 # make manages the C and Python stuff
82 rm -rf $RPM_BUILD_ROOT
83 %{__make} %{?_smp_mflags} %{make_options} install DESTDIR="$RPM_BUILD_ROOT"
84
85 ##############################
86 %post
87 ########## traditional init
88 %if "%{initdir}" == "%{_initrddir}"
89 ##########
90 chkconfig --add conf_files
91 chkconfig conf_files on
92 chkconfig --add nm
93 chkconfig nm on
94 chkconfig --add fuse-pl
95 chkconfig fuse-pl on
96 if [ "$PL_BOOTCD" != "1" ] ; then
97     service nm restart
98     service fuse-pl restart
99 fi
100 ##########
101 %else
102 ########## systemd
103 systemctl enable nm.service
104 systemctl enable conf_files.service
105 # empty
106 #systemctl enable fuse-pl.service
107 if [ "$PL_BOOTCD" != "1" ] ; then
108     systemctl restart nm.service
109 #    systemctl restart fuse-pl.service
110 fi
111 ##########
112 %endif
113
114 ##############################
115 %preun
116 # 0 = erase, 1 = upgrade
117 ########## traditional init
118 %if "%{initdir}" == "%{_initrddir}"
119 ##########
120 if [ $1 -eq 0 ] ; then
121     chkconfig fuse-pl off
122     chkconfig --del fuse-pl
123     chkconfig nm off
124     chkconfig --del nm
125     chkconfig conf_files off
126     chkconfig --del conf_files
127 fi
128 ##########
129 %else
130 ########## systemd
131 if [ $1 -eq 0 ] ; then
132 #    systemctl disable fuse-pl.service
133     systemctl disable conf_files.service
134     systemctl disable nm.service
135 fi
136 ##########
137 %endif
138
139 ##############################
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 ##############################
144 %files
145 %defattr(-,root,root,-)
146 %{_datadir}/NodeManager/account.*
147 %{_datadir}/NodeManager/api.*
148 %{_datadir}/NodeManager/api_calls.*
149 %{_datadir}/NodeManager/bwmon.*
150 %{_datadir}/NodeManager/conf_files.*
151 %{_datadir}/NodeManager/config.*
152 %{_datadir}/NodeManager/controller.*
153 %{_datadir}/NodeManager/curlwrapper.*
154 %{_datadir}/NodeManager/database.*
155 %{_datadir}/NodeManager/initscript.*
156 %{_datadir}/NodeManager/iptables.*
157 %{_datadir}/NodeManager/logger.*
158 %{_datadir}/NodeManager/net.*
159 %{_datadir}/NodeManager/nodemanager.*
160 %{_datadir}/NodeManager/plcapi.*
161 %{_datadir}/NodeManager/safexmlrpc.*
162 %{_datadir}/NodeManager/slivermanager.*
163 %{_datadir}/NodeManager/ticket.*
164 %{_datadir}/NodeManager/tools.*
165 %{_datadir}/NodeManager/plugins/__init__.*
166 %{_datadir}/NodeManager/plugins/codemux.*
167 %{_datadir}/NodeManager/plugins/hostmap.*
168 %{_datadir}/NodeManager/plugins/interfaces.*
169 %{_datadir}/NodeManager/plugins/omf_resctl.*
170 %{_datadir}/NodeManager/plugins/privatebridge.*
171 %{_datadir}/NodeManager/plugins/rawdisk.*
172 %{_datadir}/NodeManager/plugins/reservation.*
173 %{_datadir}/NodeManager/plugins/sfagids.*
174 %{_datadir}/NodeManager/plugins/sliverauth.*
175 %{_datadir}/NodeManager/plugins/specialaccounts.*
176 %{_datadir}/NodeManager/plugins/syndicate.*
177 %{_datadir}/NodeManager/plugins/vsys.*
178 %{_datadir}/NodeManager/plugins/vsys_privs.*
179 %{datadir}/NodeManager/sliver-initscripts/
180 %{datadir}/NodeManager/sliver-systemd/
181 %{_bindir}/forward_api_calls
182 %{initdir}/
183 %{_sysconfdir}/logrotate.d/nodemanager
184 /var/lib/nodemanager/
185 %config(noreplace) /etc/sysconfig/nodemanager
186
187 ##############################
188 %if "%{build_lxc}" == "1"
189
190 %package -n nodemanager-lxc
191 Summary: PlanetLab Node Manager Plugin for lxc nodes
192 Group: System Environment/Daemons
193 # we use libvirt
194 Requires: libvirt
195 Requires: libvirt-python
196 # cgroups.py needs this
197 Requires: python-inotify
198 # the common package for nodemanager
199 Requires: nodemanager-lib = %{version}
200 # the lxc-specific tools for using slice images
201 Requires: lxc-sliceimage
202 Requires: openvswitch
203
204 %description -n nodemanager-lxc
205 nodemanager-lxc provides the lxc code for the PlanetLab Node Manager.
206
207 %files -n nodemanager-lxc
208 %{_datadir}/NodeManager/sliver_libvirt.*
209 %{_datadir}/NodeManager/sliver_lxc.*
210 %{_datadir}/NodeManager/cgroups.*
211 %{_datadir}/NodeManager/coresched_lxc.*
212
213 %endif
214 ##############################
215
216 ##############################
217 %if "%{build_vs}" == "1"
218
219 %package -n nodemanager-vs
220 Summary: PlanetLab Node Manager Plugin for vserver nodes
221 Group: System Environment/Daemons
222
223 # old name, when all came as a single package with vserver wired in
224 Obsoletes: NodeManager
225 # for nodeupdate 
226 Provides: nodemanager
227
228 # our interface to the vserver patch
229 Requires: util-vserver >= 0.30.208-17
230 # and the planetlab utilities
231 Requires: util-vserver-python > 0.3-16
232 # the common package for nodemanager
233 Requires: nodemanager-lib = %{version}
234 # the vserver-specific tools for using slice images
235 Requires: vserver-sliceimage
236
237 %description -n nodemanager-vs
238 nodemanager-vs provides the vserver code for the PlanetLab Node Manager.
239
240 %files -n nodemanager-vs
241 %{_datadir}/NodeManager/sliver_vs.*
242 %{_datadir}/NodeManager/coresched_vs.*
243 # this plugin uses vserver for now
244 %{_datadir}/NodeManager/plugins/drl.*
245
246 %endif
247 ##############################
248
249 ##############################
250 %changelog
251 * Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-13
252 - improve network management in slices
253 - _has_systemctl was not declared as global - vsys was failing to restart
254
255 * Fri Apr 04 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-12
256 - this tag for the first time passes the full range of tests on fedora20
257 - robustified slice teardown wrt vsys
258 - Scott's fix for repairing veth devs
259 - removed sshsh
260 - tools.has_systemctl
261
262 * Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-11
263 - ship /etc/sysconfig/nodemanager
264 - trash sshsh
265
266 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-10
267 - comes with systemd native unit files on >= f18
268 - user-provided initscript gets started through systemd in slivers >= f18
269 - smarter to locate cgroups for various versions of libvirt
270 - nicer log format - and log program termination
271 - tweaks in codemux plugin
272 - bug fixes in libvirt driver, esp. for finding out if domain is running
273
274 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
275 - fixes in hostmap, and in interfaces
276 - new vsys_sysctl
277 - privatebridge now comes with nodemanager-lib
278
279 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
280 - omf plugin does not block any longer when running trigger script
281 - log goes into sliver's /var/log instead
282
283 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
284 - new install-scripts target in Makefile
285 - conf_files and fuse-pl initscripts chmod'ed +x
286 - omf_resctl config template tweaked to use _slicename_%_hostname_
287
288 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
289 - make sure to create /etc/planetlab/virt so others can read that
290 - expose get_node_virt() and command_in_slice()
291 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
292 - user's .profile now has right owner
293 - other tweaks in lxc slivers
294
295 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
296 - lxc slice creation: slice user was created with unknown gid - fixed
297 - lxc slice creation: .profile for root and user - fixed
298
299 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
300 - fix umounting of ssh directory when deleting omf-friendly slivers
301 - support for writing cgroups in subsystems other than cpuset
302 - add xid to template match
303 - finer-grained split between -lib -vs and -lxc
304 - first roughly complete omf_resctl for omfv6
305 - minor fix for when getslivers does not have minexemptrate
306
307 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
308 - Fix path, machine arch in slivers
309
310 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
311
312 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
313 - no-op bump to 5.2 to be in line with the rest of the system
314
315 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
316 - improvements to privatebridge
317
318 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
319 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
320
321 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
322 - fix wrong gre tunnel deleted when topology changes
323
324 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
325 - Update /etc/hosts in slivers from sliver_hostmap tag.
326
327 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
328 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
329 - initial check-in of privatebridge plugin.
330
331 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
332 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
333
334 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
335 - fix slices not deleted properly when they use vsys
336
337 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
338 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
339
340 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
341 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
342
343 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
344 - Bridge virtual interfaces to VLANs
345
346 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
347 - Add support for L2 bridged interfaces with public IPs inside a slice
348
349 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
350 - Support for freezing BestEffort slices for Vicci
351
352 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
353 - Change to use new vsh (wrapper for lxcsu)
354
355 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
356 - add missing import
357 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
358
359 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
360 - tag 2.1-7 was broken for OMF-friendly slices
361 - expose_ssh_dir was erroneously defined on the Worker class
362
363 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
364 - bwlimitlxc now ships with plnode-utils
365
366 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
367 - set LD_PRELOAD for linux-containers nodes
368
369 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
370 - first complete version for vs and lxc - functional but not thoroughly tested though
371
372 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
373 - split packaging in 3 (lib, lxc, vs)
374 - this tag will only work with lxc though
375
376 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
377 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
378
379 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
380 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
381 - purpose being to be able to run this branch on vserver nodes as well
382
383 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
384 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
385 - passes tests with lxc but won't build against vs due to conflict
386 - as bwlimit.py also ships with util-vserver-pl
387
388 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
389 - refactoring: isolate initscript functionality
390 - aimed at making initscript implementation with lxc straightforward
391 - show stack trace when module loading fails
392 - accounts.py renamed into account.py for consistency
393
394 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
395 - /var/log/nodemanager shows duration of mainloop
396
397 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
398 - first working draft for dealing with libvirt/lxc on f16 nodes
399 - not expected to work with mainline nodes (use 2.0 for that for now)
400
401 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
402 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
403
404 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
405 - Added memory scheduling to core scheduler
406 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
407
408 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
409 - tweaked log policy for the core scheduler
410 - curlwrapper has an optional verbose mode
411
412 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
413 - fixes for hmac and omf_control tags
414 - optional besteffort flag to core scheduler
415 - logrotate entry for /var/log/nodemanager.daemon
416 - a template for bash initscripts
417
418 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
419 - rename initscript_body into initscript_code
420 - fix generic vinit for broken bash syntax &>>
421
422 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
423 - new initscript_body slice tag, with stop and restart
424 - generic vinit script live updated
425 - new coresched module
426 - protect against non-existing vsys scripts
427 - use Config. instead of globals
428
429 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
430 - more robust reservation plugin
431
432 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
433 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
434 - reservation plugin more robust
435
436 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
437 - pass device to bwlimit
438
439 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
440 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
441
442 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
443 - Catch all exceptions for sfa plugin
444
445 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
446 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
447
448 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
449 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
450
451 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
452 - plugins/sliverauth.py improvements
453
454 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
455 - Disable sfagids plugin
456
457 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
458 - Re-tag nodemanager to include conflicted commits
459
460 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
461 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
462 - sfagids plugin deleted
463 - band-aid patch for lack of GetSliceFamily removed
464
465 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
466
467 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
468 - revert curlwrapper to former forking-curl version
469 - fixes in the omf plugin for ssh key location and node hrn
470 - set umask 0022 in tools.daemon
471
472 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
473 - configure omf-resctl for keys
474
475 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
476 - fix key generation
477
478 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
479 - name changes and fix typos
480
481 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
482 - remove config and options parameters from start function
483
484 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
485 - working version of reservable nodes
486 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
487 - dismantled the -s|--startup option (no convincing need for that)
488 - simpler and more robust init.d/nm
489 - initscript content management through replace_file_with_string
490 - sliverauth uses replace_file_with_string
491 - curlwrapper has a debug mode
492
493 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
494 - pretty-printing/normalized python code - hopefully neutral
495
496 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
497 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
498 - that triggers /etc/init.d/vinit.slice if present and executable
499 - (2) install the slice-provided initscript (as per the initscript tag) as
500 - /etc/init.d/vinit.slice
501 - (3) as a result the initscript are now triggered by rc as part of the
502 - standard vserver .. start, properly attached to the vserver,
503 - and properly killed upon vserver .. stop
504 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
505
506 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
507 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
508 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
509 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
510 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
511 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
512 - cleanup: nodemanger now is a class; however plugins are still dumb modules
513 - cleanup: does not depend on obsolete Set
514
515 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
516 - tagging before RC
517
518 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
519 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
520 - Added some precautions to the slice id-saving code
521 - Added log message to code that records the slice id
522
523 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
524 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
525 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
526 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
527
528 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
529 - fix log_call in plugins/drl.py
530
531 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
532 - protect against nodes in migrated PLC's not having the hrn tag yet
533
534 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
535 - new omf-resctl and drl plugins
536 - specialaccount optimized to overwrite authorized keys only upon changes
537 - codemux plugin has support for a new 'ip' setting
538 - mainloop to display ordered modules&plugins at all times
539
540 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
541 - modules and plugins have a priority
542 - specialaccounts appears soon in the priority chain
543 - logger.log_call logs process output, and has a timeout
544 - vuser{add,del} run through bash -x
545 - nm initscript has support for 'service nm restartverbose'
546 - logs reviewed for consistency
547 - use hashlib module instead of sha when available
548
549 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
550 - first working version of 5.0:
551 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
552 - nodefamily is 3-fold with pldistro-fcdistro-arch
553 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
554 - (in addition to the 'vref' tag that's still exposed too)
555 - logging reviewed for more convenience
556 - support for 'service nm restartdebug'
557 - make sync knows how to publish uncommitted code on a test node
558
559 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
560 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
561
562 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
563 - support for f10 and f12 in the vref slice tag
564
565 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
566 - build on fedora12
567 - uses slicename 'sfacm' instead of 'genicw'
568
569 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
570 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
571 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
572 - days ago.
573
574 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
575 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
576 - self-contained. With this change, they will be able to refer to the attributes associated with a
577 - slice.
578
579 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
580 - fix for syntax error
581
582 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
583 - -fixed problem with sioc import at the build side
584 - -bwlimit.set() now accepts the device and does not asume that it is eth0
585
586 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
587 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
588
589 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
590 - The seed for random previously was the meaning of life (i.e., 42) but
591 - that resulted in a not so random choice for the hmac.  This
592 - implementation now uses a random.seed that is based on the current
593 - time.
594
595 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
596 - Minor fix such that sliverauth.py makes a more specific call to
597 - GetSliceTags that include that specific tagname it is looking for.
598
599 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
600 - Fix bug that prevented 'OVERRIDES' for working correctly.
601
602 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
603 - Increase disk limits to 10G per sliver
604 - Sanity check slice for home directory before starting (hack)
605 - Check codemux arguments
606
607 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
608 - * Fix Delegation
609 - * Move plcapi in plugin-api GetSlivers() calls.
610 - * Persistent Authcheck and resync session when auth failure
611
612 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
613 - Disabling sliverauth module.  Not ready for deployment.
614
615 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
616 - Fixing overrides semantics.
617
618 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
619 - Generalized plugins
620 - Fixed initscript start up bug.
621
622 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
623 - * Fix delegation authentication problem
624 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
625
626 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
627 - * Rerun initscripts when slice goes from disabled to enabled.
628
629 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
630 - * Update session key when out of synch with PLC
631 - * PLCDefaults uses tagname
632
633 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
634 - log invokations of vsys
635
636 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
637
638 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
639
640 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
641 - Codemux supports multiple hosts mapping to single slice
642 - Fixed bug in delegation support where tickets delivered weren't
643   being passed to sm.deliver_ticket().
644
645 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
646 - Codemux now configured via slice attribute (host,port)
647 - Support for multiple vserver reference images (including different archs)
648 - Mom BW emails are sent to list defined by MyPLC's config
649 - Sirius BW loans honored correctly.  Fixed.
650 - BW totals preserved for dynamic slices so as not to game the system.
651
652 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
653 - Configures vsys via vsys slice attribute {name: vsys, value: script}
654 - CPU reservations are now calculated via percentages instead of shares
655 - BW totals preserved for dynamic slices
656 - Closes bug where node cap sets off bw slice alarms for all slices.
657
658 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
659 - Switched to SVN.
660
661 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
662 - Initial build.