oops
[nodemanager.git] / nodemanager.spec
1 %define slicefamily %{pldistro}-%{distroname}-%{_arch}
2
3 %define name nodemanager-lib
4 %define version 5.2
5 %define taglevel 13
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 ##############################
10 # for now we just extract all the files but package them only for either vs or lxc
11 # so bottom line is we have missing files at the end
12 # plan is to separate these target-dependant files in subdirs at some point
13 %define _unpackaged_files_terminate_build      0
14
15 ##############################
16 # use initscripts or systemd unit files to start installed services
17 %if "%{distro}" == "Fedora" && "%{distrorelease}" >= "18"
18 %define make_options WITH_SYSTEMD=true
19 %define initdir /usr/lib/systemd/system
20 %define build_lxc 1
21 %else
22 %define make_options WITH_INIT=true
23 %define initdir %{_initrddir}
24 %define build_vs 1
25 %endif
26
27 ##############################
28 Summary: PlanetLab Node Manager Library
29 Name: %{name}
30 Version: %{version}
31 Release: %{release}
32 License: PlanetLab
33 Group: System Environment/Daemons
34 Source0: %{name}-%{version}.tar.gz
35 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
36
37 Vendor: PlanetLab
38 Packager: PlanetLab Central <support@planet-lab.org>
39 Distribution: PlanetLab %{plrelease}
40 URL: %{SCMURL}
41
42 # not possible because of forward_api_calls
43 #BuildArch: noarch
44
45 # make sure we can invoke systemctl in post install script
46 %if "%{initdir}" != "%{_initrddir}"
47 Requires: systemd
48 %endif
49
50 # Uses function decorators
51 Requires: python >= 2.7
52 # connecting PLC
53 Requires: python-pycurl
54 # Signed tickets
55 Requires: gnupg
56 # sioc/plnet
57 Requires: pyplnet >= 4.3
58 # we do need the slice images in any case
59 Requires: sliceimage-%{slicefamily}
60 # for bwlimit
61 Requires: plnode-utils
62
63 %description
64 The PlanetLab Node Manager manages all aspects of PlanetLab node and
65 slice management once the node has been initialized and configured by
66 the Boot Manager. It periodically contacts its management authority
67 for configuration updates. It provides an XML-RPC API for performing
68 local operations on slices.
69 nodemanager-lib only provides a skeleton and needs as a companion
70 either nodemanager-vs or nodemanager-lxc
71
72 ##############################
73 %prep
74 %setup -q
75
76 %build
77 # make manages the C and Python stuff
78 %{__make} %{?_smp_mflags} %{make_options}
79
80 %install
81 # make manages the C and Python stuff
82 rm -rf $RPM_BUILD_ROOT
83 %{__make} %{?_smp_mflags} %{make_options} install DESTDIR="$RPM_BUILD_ROOT"
84
85 ##############################
86 %post
87 ########## traditional init
88 %if "%{initdir}" == "%{_initrddir}"
89 ##########
90 chkconfig --add conf_files
91 chkconfig conf_files on
92 chkconfig --add nm
93 chkconfig nm on
94 chkconfig --add fuse-pl
95 chkconfig fuse-pl on
96 if [ "$PL_BOOTCD" != "1" ] ; then
97     service nm restart
98     service fuse-pl restart
99 fi
100 ##########
101 %else
102 ########## systemd
103 systemctl enable nm.service
104 systemctl enable conf_files.service
105 # empty
106 #systemctl enable fuse-pl.service
107 if [ "$PL_BOOTCD" != "1" ] ; then
108     systemctl restart nm.service
109 #    systemctl restart fuse-pl.service
110 fi
111 ##########
112 %endif
113
114 ##############################
115 %preun
116 # 0 = erase, 1 = upgrade
117 ########## traditional init
118 %if "%{initdir}" == "%{_initrddir}"
119 ##########
120 if [ $1 -eq 0 ] ; then
121     chkconfig fuse-pl off
122     chkconfig --del fuse-pl
123     chkconfig nm off
124     chkconfig --del nm
125     chkconfig conf_files off
126     chkconfig --del conf_files
127 fi
128 ##########
129 %else
130 ########## systemd
131 if [ $1 -eq 0 ] ; then
132 #    systemctl disable fuse-pl.service
133     systemctl disable conf_files.service
134     systemctl disable nm.service
135 fi
136 ##########
137 %endif
138
139 ##############################
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 ##############################
144 %files
145 %defattr(-,root,root,-)
146 %{_datadir}/NodeManager/account.*
147 %{_datadir}/NodeManager/api.*
148 %{_datadir}/NodeManager/api_calls.*
149 %{_datadir}/NodeManager/bwmon.*
150 %{_datadir}/NodeManager/conf_files.*
151 %{_datadir}/NodeManager/config.*
152 %{_datadir}/NodeManager/controller.*
153 %{_datadir}/NodeManager/curlwrapper.*
154 %{_datadir}/NodeManager/database.*
155 %{_datadir}/NodeManager/initscript.*
156 %{_datadir}/NodeManager/iptables.*
157 %{_datadir}/NodeManager/logger.*
158 %{_datadir}/NodeManager/net.*
159 %{_datadir}/NodeManager/nodemanager.*
160 %{_datadir}/NodeManager/plcapi.*
161 %{_datadir}/NodeManager/safexmlrpc.*
162 %{_datadir}/NodeManager/slivermanager.*
163 %{_datadir}/NodeManager/ticket.*
164 %{_datadir}/NodeManager/tools.*
165 %{_datadir}/NodeManager/plugins/codemux.*
166 %{_datadir}/NodeManager/plugins/hostmap.*
167 %{_datadir}/NodeManager/plugins/interfaces.*
168 %{_datadir}/NodeManager/plugins/omf_resctl.*
169 %{_datadir}/NodeManager/plugins/privatebridge.*
170 %{_datadir}/NodeManager/plugins/rawdisk.*
171 %{_datadir}/NodeManager/plugins/reservation.*
172 %{_datadir}/NodeManager/plugins/sfagids.*
173 %{_datadir}/NodeManager/plugins/sliverauth.*
174 %{_datadir}/NodeManager/plugins/specialaccounts.*
175 %{_datadir}/NodeManager/plugins/syndicate.*
176 %{_datadir}/NodeManager/plugins/vsys.*
177 %{_datadir}/NodeManager/plugins/vsys_privs.*
178 %{_bindir}/forward_api_calls
179 %{initdir}/
180 %{_sysconfdir}/logrotate.d/nodemanager
181 /var/lib/nodemanager/
182 %config(noreplace) /etc/sysconfig/nodemanager
183
184 ##############################
185 %if "%{build_lxc}" == "1"
186
187 %package -n nodemanager-lxc
188 Summary: PlanetLab Node Manager Plugin for lxc nodes
189 Group: System Environment/Daemons
190 # we use libvirt
191 Requires: libvirt
192 Requires: libvirt-python
193 # cgroups.py needs this
194 Requires: python-inotify
195 # the common package for nodemanager
196 Requires: nodemanager-lib = %{version}
197 # the lxc-specific tools for using slice images
198 Requires: lxc-sliceimage
199 Requires: openvswitch
200
201 %description -n nodemanager-lxc
202 nodemanager-lxc provides the lxc code for the PlanetLab Node Manager.
203
204 %files -n nodemanager-lxc
205 %{_datadir}/NodeManager/sliver_libvirt.*
206 %{_datadir}/NodeManager/sliver_lxc.*
207 %{_datadir}/NodeManager/cgroups.*
208 %{_datadir}/NodeManager/coresched_lxc.*
209
210 %endif
211 ##############################
212
213 ##############################
214 %if "%{build_vs}" == "1"
215
216 %package -n nodemanager-vs
217 Summary: PlanetLab Node Manager Plugin for vserver nodes
218 Group: System Environment/Daemons
219
220 # old name, when all came as a single package with vserver wired in
221 Obsoletes: NodeManager
222 # for nodeupdate 
223 Provides: nodemanager
224
225 # our interface to the vserver patch
226 Requires: util-vserver >= 0.30.208-17
227 # and the planetlab utilities
228 Requires: util-vserver-python > 0.3-16
229 # the common package for nodemanager
230 Requires: nodemanager-lib = %{version}
231 # the vserver-specific tools for using slice images
232 Requires: vserver-sliceimage
233
234 %description -n nodemanager-vs
235 nodemanager-vs provides the vserver code for the PlanetLab Node Manager.
236
237 %files -n nodemanager-vs
238 %{_datadir}/NodeManager/sliver_vs.*
239 %{_datadir}/NodeManager/coresched_vs.*
240 # this plugin uses vserver for now
241 %{_datadir}/NodeManager/plugins/drl.*
242
243 %endif
244 ##############################
245
246 ##############################
247 %changelog
248 * Mon Apr 28 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-13
249 - improve network management in slices
250 - _has_systemctl was not declared as global - vsys was failing to restart
251
252 * Fri Apr 04 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-12
253 - this tag for the first time passes the full range of tests on fedora20
254 - robustified slice teardown wrt vsys
255 - Scott's fix for repairing veth devs
256 - removed sshsh
257 - tools.has_systemctl
258
259 * Tue Mar 25 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-11
260 - ship /etc/sysconfig/nodemanager
261 - trash sshsh
262
263 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-10
264 - comes with systemd native unit files on >= f18
265 - user-provided initscript gets started through systemd in slivers >= f18
266 - smarter to locate cgroups for various versions of libvirt
267 - nicer log format - and log program termination
268 - tweaks in codemux plugin
269 - bug fixes in libvirt driver, esp. for finding out if domain is running
270
271 * Wed Dec 11 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-9
272 - fixes in hostmap, and in interfaces
273 - new vsys_sysctl
274 - privatebridge now comes with nodemanager-lib
275
276 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-8
277 - omf plugin does not block any longer when running trigger script
278 - log goes into sliver's /var/log instead
279
280 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-7
281 - new install-scripts target in Makefile
282 - conf_files and fuse-pl initscripts chmod'ed +x
283 - omf_resctl config template tweaked to use _slicename_%_hostname_
284
285 * Sun Jul 14 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-6
286 - make sure to create /etc/planetlab/virt so others can read that
287 - expose get_node_virt() and command_in_slice()
288 - refined omf_resctl plugin (fetches trigger, and calls it on expire change)
289 - user's .profile now has right owner
290 - other tweaks in lxc slivers
291
292 * Wed Jul 03 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-5
293 - lxc slice creation: slice user was created with unknown gid - fixed
294 - lxc slice creation: .profile for root and user - fixed
295
296 * Sat Jun 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-4
297 - fix umounting of ssh directory when deleting omf-friendly slivers
298 - support for writing cgroups in subsystems other than cpuset
299 - add xid to template match
300 - finer-grained split between -lib -vs and -lxc
301 - first roughly complete omf_resctl for omfv6
302 - minor fix for when getslivers does not have minexemptrate
303
304 * Fri May 24 2013 Andy Bavier <acb@cs.princeton.edu> - nodemanager-5.2-3
305 - Fix path, machine arch in slivers
306
307 * Tue Apr 30 2013 Stephen Soltesz <soltesz@opentechinstitute.org> - nodemanager-5.2-2
308
309 * Thu Mar 07 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-5.2-1
310 - no-op bump to 5.2 to be in line with the rest of the system
311
312 * Thu Feb 21 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-22
313 - improvements to privatebridge
314
315 * Sat Jan 19 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-21
316 - change hostnames related to private IPs to use pvt.hostname instead of slice_name.hostname
317
318 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-20
319 - fix wrong gre tunnel deleted when topology changes
320
321 * Mon Jan 14 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-19
322 - Update /etc/hosts in slivers from sliver_hostmap tag.
323
324 * Mon Jan 07 2013 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-18
325 - Support passing a list of interfaces in slice interface tag to configure multiple interfaces,
326 - initial check-in of privatebridge plugin.
327
328 * Fri Dec 14 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-17
329 - set ownership of slice homedir, att slice user to etc/sudoers inside of slice
330
331 * Wed Dec 12 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-16
332 - fix slices not deleted properly when they use vsys
333
334 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-15
335 - fix error in syndicate plugin, add error message to nodemanager for attributeerror during load/start
336
337 * Mon Dec 10 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-14
338 - Add syndicate plugin, create /etc/hostname and home directory in LXC guests
339
340 * Tue Nov 13 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-13
341 - Bridge virtual interfaces to VLANs
342
343 * Wed Oct 24 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-12
344 - Add support for L2 bridged interfaces with public IPs inside a slice
345
346 * Thu Oct 18 2012 Scott Baker <smbaker@gmail.com> - nodemanager-2.1-11
347 - Support for freezing BestEffort slices for Vicci
348
349 * Wed Sep 05 2012 Andy Bavier <acb@cs.princeton.edu> - nodemanager-2.1-10
350 - Change to use new vsh (wrapper for lxcsu)
351
352 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-9
353 - add missing import
354 - 2.1-8 is less broken than 2.1-7 for omf-friendly slices, in that the slivers would get created, but the OMF-feature probably won't work as .ssh won't get exposed to the sliver
355
356 * Thu Aug 30 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-8
357 - tag 2.1-7 was broken for OMF-friendly slices
358 - expose_ssh_dir was erroneously defined on the Worker class
359
360 * Thu Jul 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-7
361 - bwlimitlxc now ships with plnode-utils
362
363 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-6
364 - set LD_PRELOAD for linux-containers nodes
365
366 * Thu Jun 28 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-5
367 - first complete version for vs and lxc - functional but not thoroughly tested though
368
369 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-4
370 - split packaging in 3 (lib, lxc, vs)
371 - this tag will only work with lxc though
372
373 * Tue Jun 26 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-38
374 - split packaging, nodemanager-vs (obsoletes NodeManager) and nodemanager-lib
375
376 * Mon Jun 25 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-3
377 - renamed bwlimit as bwlimitlxc to avoid conflicts with util-vserver-pl
378 - purpose being to be able to run this branch on vserver nodes as well
379
380 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-2
381 - merged nodemanager-2.0-37 in 2.1/lxc_devel and add initscript support to lxc
382 - passes tests with lxc but won't build against vs due to conflict
383 - as bwlimit.py also ships with util-vserver-pl
384
385 * Thu Jun 21 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-37
386 - refactoring: isolate initscript functionality
387 - aimed at making initscript implementation with lxc straightforward
388 - show stack trace when module loading fails
389 - accounts.py renamed into account.py for consistency
390
391 * Sun Jun 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-36
392 - /var/log/nodemanager shows duration of mainloop
393
394 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.1-1
395 - first working draft for dealing with libvirt/lxc on f16 nodes
396 - not expected to work with mainline nodes (use 2.0 for that for now)
397
398 * Fri Apr 13 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-35
399 - remove Requires to deprecated vserver-* rpms, use sliceimage-* instead
400
401 * Fri Dec 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-34
402 - Added memory scheduling to core scheduler
403 - Core scheduler will now attempt to schedule cores on the same CPU to a slice, if a slice uses multiple cores
404
405 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-33
406 - tweaked log policy for the core scheduler
407 - curlwrapper has an optional verbose mode
408
409 * Mon Jun 06 2011 Baris Metin <bmetin@verivue.com> - nodemanager-2.0-32
410 - fixes for hmac and omf_control tags
411 - optional besteffort flag to core scheduler
412 - logrotate entry for /var/log/nodemanager.daemon
413 - a template for bash initscripts
414
415 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-31
416 - rename initscript_body into initscript_code
417 - fix generic vinit for broken bash syntax &>>
418
419 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-30
420 - new initscript_body slice tag, with stop and restart
421 - generic vinit script live updated
422 - new coresched module
423 - protect against non-existing vsys scripts
424 - use Config. instead of globals
425
426 * Sun Feb 20 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-29
427 - more robust reservation plugin
428
429 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-28
430 - bind-mount slice's .ssh into sliver for omf-friendly slices - no need to use dotsshmount (vsys) anymore
431 - reservation plugin more robust
432
433 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-27
434 - pass device to bwlimit
435
436 * Tue Jan 25 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-26
437 - start to use /etc/vservers/<guest>/sysctl/<id>/{setting,value} files as new kernels don't support old syntax
438
439 * Tue Jan 04 2011 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-25
440 - Catch all exceptions for sfa plugin
441
442 * Wed Dec 22 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-24
443 - Handle exception AttributeError: ComponentAPI instance has no attribute 'get_registry'
444
445 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-23
446 - Use networks key if interfaces is missing to solve the incompatibility between new NM and old API
447
448 * Mon Nov 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-22
449 - plugins/sliverauth.py improvements
450
451 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-21
452 - Disable sfagids plugin
453
454 * Mon Oct 11 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-20
455 - Re-tag nodemanager to include conflicted commits
456
457 * Thu Sep 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-19
458 - hotfix - make the UpdateSliceTag for ssh_key really incremental (was storming the API)
459 - sfagids plugin deleted
460 - band-aid patch for lack of GetSliceFamily removed
461
462 * Mon Aug 23 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - nodemanager-2.0-18
463
464 * Fri Jul 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodemanager-2.0-17
465 - revert curlwrapper to former forking-curl version
466 - fixes in the omf plugin for ssh key location and node hrn
467 - set umask 0022 in tools.daemon
468
469 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - nodemanager-2.0-16
470 - configure omf-resctl for keys
471
472 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-15
473 - fix key generation
474
475 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-14
476 - name changes and fix typos
477
478 * Mon Jun 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-13
479 - remove config and options parameters from start function
480
481 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-12
482 - working version of reservable nodes
483 - sliverauth generates an ssh keypair and export pub part as 'ssh_key' tag
484 - dismantled the -s|--startup option (no convincing need for that)
485 - simpler and more robust init.d/nm
486 - initscript content management through replace_file_with_string
487 - sliverauth uses replace_file_with_string
488 - curlwrapper has a debug mode
489
490 * Wed Jun 23 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-11
491 - pretty-printing/normalized python code - hopefully neutral
492
493 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-10
494 - (1) unconditionnally install and chkconfig-like a generic 'vinit' service
495 - that triggers /etc/init.d/vinit.slice if present and executable
496 - (2) install the slice-provided initscript (as per the initscript tag) as
497 - /etc/init.d/vinit.slice
498 - (3) as a result the initscript are now triggered by rc as part of the
499 - standard vserver .. start, properly attached to the vserver,
500 - and properly killed upon vserver .. stop
501 - (4) this works best with util-vserver-pl 0.3-31 or 0.4-12
502
503 * Wed Jun 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-9
504 - fix for 64bits nodes: add newline to the personality files that instruct util-vserver to create 32bits slivers
505 - basic/partial support from reservable nodes through the 'reservation plugin' (not fully working yet)
506 - plugins can set 'persistent_data' to receive the latests know GetSlivers in case the connection is down
507 - cleanup: moved runtime files in /var/lib/nodemanager, and logs as /var/log/nodemanager* (see specfile)
508 - cleanup: some modules renamed (e.g. nm.py becomes nodemanager.py)
509 - cleanup: nodemanger now is a class; however plugins are still dumb modules
510 - cleanup: does not depend on obsolete Set
511
512 * Fri May 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-8
513 - tagging before RC
514
515 * Wed May 12 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - NodeManager-2.0-7
516 - Fix typos in plugins/drl.py and doc/NMAPI.xml.in
517 - Added some precautions to the slice id-saving code
518 - Added log message to code that records the slice id
519
520 * Mon Apr 26 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-2.0-6
521 - This version changes the location of the slice id for components such as PlanetFlow to look up. Previously this piece
522 - of information was stored in the 'vserver name' field of the per-vserver context structure in the kernel but we needed
523 - to move it elsewhere since Daniel decided to use that for something else (the vserver name... pedantic!).
524
525 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-2.0-5
526 - fix log_call in plugins/drl.py
527
528 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-4
529 - protect against nodes in migrated PLC's not having the hrn tag yet
530
531 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-3
532 - new omf-resctl and drl plugins
533 - specialaccount optimized to overwrite authorized keys only upon changes
534 - codemux plugin has support for a new 'ip' setting
535 - mainloop to display ordered modules&plugins at all times
536
537 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-2
538 - modules and plugins have a priority
539 - specialaccounts appears soon in the priority chain
540 - logger.log_call logs process output, and has a timeout
541 - vuser{add,del} run through bash -x
542 - nm initscript has support for 'service nm restartverbose'
543 - logs reviewed for consistency
544 - use hashlib module instead of sha when available
545
546 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-2.0-1
547 - first working version of 5.0:
548 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
549 - nodefamily is 3-fold with pldistro-fcdistro-arch
550 - relies on GetSlivers to expose 'GetSliceFamily' for slivers
551 - (in addition to the 'vref' tag that's still exposed too)
552 - logging reviewed for more convenience
553 - support for 'service nm restartdebug'
554 - make sync knows how to publish uncommitted code on a test node
555
556 * Tue Jan 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-23
557 - emergency tag - make the setting of hmac by the sliverauth plugin more robust
558
559 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-22
560 - support for f10 and f12 in the vref slice tag
561
562 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-21
563 - build on fedora12
564 - uses slicename 'sfacm' instead of 'genicw'
565
566 * Fri Oct 30 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-20
567 - This tag is identical to 1.8-19. The main addition is PLC-controllable vsys scripts. The reason I am
568 - retagging is to eliminate any confusion associated with the -19 tag which was (temporarily) modified a few
569 - days ago.
570
571 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - NodeManager-1.8-19
572 - This patch makes vsys scripts PLC-configurable. Previously, vsys scripts needed to be
573 - self-contained. With this change, they will be able to refer to the attributes associated with a
574 - slice.
575
576 * Thu Oct 22 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-18
577 - fix for syntax error
578
579 * Wed Oct 21 2009 anil vengalil <avengali@sophia.inria.fr> - NodeManager-1.8-17
580 - -fixed problem with sioc import at the build side
581 - -bwlimit.set() now accepts the device and does not asume that it is eth0
582
583 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - NodeManager-1.8-16
584 - - don't hardcode the device name (depends on util-vserver-pl change rev. 15385)
585
586 * Fri Oct 09 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-15
587 - The seed for random previously was the meaning of life (i.e., 42) but
588 - that resulted in a not so random choice for the hmac.  This
589 - implementation now uses a random.seed that is based on the current
590 - time.
591
592 * Tue Oct 06 2009 Marc Fiuczynski <mef@cs.princeton.edu> - NodeManager-1.8-14
593 - Minor fix such that sliverauth.py makes a more specific call to
594 - GetSliceTags that include that specific tagname it is looking for.
595
596 * Sat Sep 19 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-13
597 - Fix bug that prevented 'OVERRIDES' for working correctly.
598
599 * Tue Sep 08 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-12
600 - Increase disk limits to 10G per sliver
601 - Sanity check slice for home directory before starting (hack)
602 - Check codemux arguments
603
604 * Thu Aug 06 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-11
605 - * Fix Delegation
606 - * Move plcapi in plugin-api GetSlivers() calls.
607 - * Persistent Authcheck and resync session when auth failure
608
609 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-10
610 - Disabling sliverauth module.  Not ready for deployment.
611
612 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-9
613 - Fixing overrides semantics.
614
615 * Mon Aug 03 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-8
616 - Generalized plugins
617 - Fixed initscript start up bug.
618
619 * Tue Jun 30 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-7
620 - * Fix delegation authentication problem
621 - * Can now disable codemux using _default slice, and setting tag {codemux: -1}
622
623 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
624 - * Rerun initscripts when slice goes from disabled to enabled.
625
626 * Tue May 26 2009 Stephen Soltesz <soltesz@cs.princeton.edu> - NodeManager-1.8-4
627 - * Update session key when out of synch with PLC
628 - * PLCDefaults uses tagname
629
630 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeManager-1.8-3
631 - log invokations of vsys
632
633 * Fri Mar 27 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-2
634
635 * Tue Mar 24 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.8-1
636
637 * Wed Apr 02 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.4
638 - Codemux supports multiple hosts mapping to single slice
639 - Fixed bug in delegation support where tickets delivered weren't
640   being passed to sm.deliver_ticket().
641
642 * Fri Mar 28 2008 Faiyaz Ahmed <faiyaza@cs.prineton.edu - NodeManager-1.7.3
643 - Codemux now configured via slice attribute (host,port)
644 - Support for multiple vserver reference images (including different archs)
645 - Mom BW emails are sent to list defined by MyPLC's config
646 - Sirius BW loans honored correctly.  Fixed.
647 - BW totals preserved for dynamic slices so as not to game the system.
648
649 * Thu Feb 14 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - NodeManager-1.7-1 NodeManager-1.7-2
650 - Configures vsys via vsys slice attribute {name: vsys, value: script}
651 - CPU reservations are now calculated via percentages instead of shares
652 - BW totals preserved for dynamic slices
653 - Closes bug where node cap sets off bw slice alarms for all slices.
654
655 * Wed Oct 03 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu> .
656 - Switched to SVN.
657
658 * Mon Nov 13 2006 Mark Huang <mlhuang@paris.CS.Princeton.EDU> - 
659 - Initial build.