Setting tag nodeupdate-0.5-10
[nodeupdate.git] / NodeUpdate.spec
index 999a6ad..3661787 100644 (file)
@@ -1,18 +1,13 @@
-#
-# $Id$
-#
-%define url $URL$
-
 %define name NodeUpdate
 %define version 0.5
-%define taglevel 5
+%define taglevel 10
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
-URL: %(echo %{url} | cut -d ' ' -f 2)
+URL: %{SCMURL}
 
 Summary: PlanetLab service to periodically update node RPMS
 Name: %{name}
@@ -36,8 +31,9 @@ PlanetLab service to periodically update node RPMS
 
 
 %install
+echo "* Installing NodeUpdate node-side files"
 install -D -m 755 NodeUpdate.py $RPM_BUILD_ROOT/usr/bin/NodeUpdate.py
-install -D -m 644 NodeUpdate.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/NodeUpdate
+install -D -m 644 logrotate/NodeUpdate $RPM_BUILD_ROOT/etc/logrotate.d/NodeUpdate
 
 %clean
 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
@@ -47,21 +43,32 @@ install -D -m 644 NodeUpdate.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/NodeUpdat
 %attr(0755,root,root) /usr/bin/NodeUpdate.py*
 %attr(0644,root,root) /etc/logrotate.d/NodeUpdate
 
-%pre
-
 %post
 /usr/bin/NodeUpdate.py updatecron
 
 %preun
 if [ "$1" = 0 ]; then
-       /usr/bin/NodeUpdate.py removecron
+    /usr/bin/NodeUpdate.py removecron
 fi
 
+%changelog
+* Mon May 06 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeupdate-0.5-10
+- bugfix in nodeupdate.RemoveRPMS, NodeUpdate.py bails out if rpms can't be removed
+
+* Fri Jul 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeupdate-0.5-9
+- support /etc/planetlab/NodeUpdate.packages and /etc/planetlab/crucial-rpm-list
+- delete exceptions from delete-rpm-list individually
 
-%postun
+* Fri Feb 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeupdate-0.5-8
+- has a builtin list of packages to update individually (NodeManager for now)
+- plus an optional set that is read from /etc/planetlab/NodeUpdate.packages
 
+* Wed Jul 14 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - nodeupdate-0.5-7
+- Use groupinstall to get new group members.
+
+* Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeUpdate-0.5-6
+- new module layout - no functional change
 
-%changelog
 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeUpdate-0.5-5
 - searches the extensions file /etc/planetlab/extensions rather than the former /etc/planetlab/extra-node-groups