extra-node-groups doesn't seem to be used. use extensions file instead. this way...
[nodeupdate.git] / NodeUpdate.spec
index 0972cf9..6638f40 100644 (file)
@@ -1,11 +1,18 @@
+#
+# $Id$
+#
+%define url $URL$
+
 %define name NodeUpdate
-%define version 0.4
-%define release 4%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+%define version 0.5
+%define taglevel 4
+
+%define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
-Distribution: PlanetLab 3.0
-URL: http://cvs.planet-lab.org/cvs/NodeUpdate
+Distribution: PlanetLab %{plrelease}
+URL: %(echo %{url} | cut -d ' ' -f 2)
 
 Summary: PlanetLab service to periodically update node RPMS
 Name: %{name}
@@ -29,7 +36,7 @@ PlanetLab service to periodically update node RPMS
 
 
 %install
-install -D -m 755 NodeUpdate.py $RPM_BUILD_ROOT/usr/local/planetlab/bin/NodeUpdate.py
+install -D -m 755 NodeUpdate.py $RPM_BUILD_ROOT/usr/bin/NodeUpdate.py
 install -D -m 644 NodeUpdate.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/NodeUpdate
 
 %clean
@@ -37,17 +44,17 @@ install -D -m 644 NodeUpdate.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/NodeUpdat
 
 %files
 %defattr(-,root,root)
-%attr(0755,root,root) /usr/local/planetlab/bin/NodeUpdate.py*
+%attr(0755,root,root) /usr/bin/NodeUpdate.py*
 %attr(0644,root,root) /etc/logrotate.d/NodeUpdate
 
 %pre
 
 %post
-/usr/local/planetlab/bin/NodeUpdate.py updatecron
+/usr/bin/NodeUpdate.py updatecron
 
 %preun
 if [ "$1" = 0 ]; then
-       /usr/local/planetlab/bin/NodeUpdate.py removecron
+       /usr/bin/NodeUpdate.py removecron
 fi
 
 
@@ -55,6 +62,17 @@ fi
 
 
 %changelog
+* Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeUpdate-0.5-4
+- invokes 'yum clean all' before updates
+- as it is more reliable, although suboptimal
+
+* Tue Jul 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeUpdate-0.5-3
+- more verbose : invoke yum with --verbose, and print timestamps
+
+* Fri Aug 10 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu>
+- Rebuild RPM Database nightly to avoid corruption
+- Move working directory from /usr/local to /usr/bin
+
 * Tue Nov 16 2004 Mark Huang <mlhuang@cs.princeton.edu>
 - cron job now dumps to /var/log/NodeUpdate instead of spewing mail
 - cron job now runs once a day instead of once an hour