bump version. updated changelog.
[nodeupdate.git] / NodeUpdate.spec
index 445a8ef..aa5b351 100644 (file)
@@ -1,18 +1,22 @@
 %define name NodeUpdate
-%define version 0.3
-%define release 1.planetlab%{?date:.%{date}}
+%define version 0.5
+%define release 1%{?pldistro:.%{pldistro}}%{?date:.%{date}}
+
+Vendor: PlanetLab
+Packager: PlanetLab Central <support@planet-lab.org>
+Distribution: PlanetLab 4.1
+URL: http://cvs.planet-lab.org/cvs/NodeUpdate
 
 Summary: PlanetLab service to periodically update node RPMS
 Name: %{name}
 Version: %{version}
 Release: %{release}
 Requires: python2 >= 2.2, yum >= 2.0.3-3_planetlab
-Copyright: GPL
-URL: http://www.planet-lab.org
+License: GPL
 Group: System Environment/Base
 Source: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}root
-Requires: cron
+Requires: vixie-cron, logrotate
 
 %description
 PlanetLab service to periodically update node RPMS
@@ -25,27 +29,25 @@ PlanetLab service to periodically update node RPMS
 
 
 %install
-mkdir -p $RPM_BUILD_ROOT/usr/local/planetlab/bin
-cp NodeUpdate.py $RPM_BUILD_ROOT/usr/local/planetlab/bin/
+install -D -m 755 NodeUpdate.py $RPM_BUILD_ROOT/usr/bin/NodeUpdate.py
+install -D -m 644 NodeUpdate.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/NodeUpdate
 
 %clean
 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(-,root,root)
-%attr(0755,root,root) /usr/local/planetlab/bin/NodeUpdate.py
+%attr(0755,root,root) /usr/bin/NodeUpdate.py*
+%attr(0644,root,root) /etc/logrotate.d/NodeUpdate
 
 %pre
 
 %post
-if [ "$1" = 1 ]; then
-       /usr/local/planetlab/bin/NodeUpdate.py updatecron
-fi
-
+/usr/bin/NodeUpdate.py updatecron
 
 %preun
 if [ "$1" = 0 ]; then
-       /usr/local/planetlab/bin/NodeUpdate.py removecron
+       /usr/bin/NodeUpdate.py removecron
 fi
 
 
@@ -53,6 +55,14 @@ fi
 
 
 %changelog
+* Fri Aug 10 2007 Faiyaz Ahmed <faiyaza@cs.princeton.edu>
+- Rebuild RPM Database nightly to avoid corruption
+- Move working directory from /usr/local to /usr/bin
+
+* Tue Nov 16 2004 Mark Huang <mlhuang@cs.princeton.edu>
+- cron job now dumps to /var/log/NodeUpdate instead of spewing mail
+- cron job now runs once a day instead of once an hour
+
 * Tue Jun 22 2004 Aaron K <alk@cs.princeton.edu>
 - added better support for different groups
 - added support for deleting rpms