Setting tag nodeupdate-1.0-0
[nodeupdate.git] / NodeUpdate.spec
index 66ddf13..d6810ee 100644 (file)
@@ -1,18 +1,13 @@
-#
-# $Id$
-#
-%define url $URL$
-
 %define name NodeUpdate
-%define version 0.5
-%define taglevel 8
+%define version 1.0
+%define taglevel 0
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
-URL: %(echo %{url} | cut -d ' ' -f 2)
+URL: %{SCMURL}
 
 Summary: PlanetLab service to periodically update node RPMS
 Name: %{name}
@@ -23,7 +18,7 @@ License: GPL
 Group: System Environment/Base
 Source: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}root
-Requires: vixie-cron, logrotate
+Requires: cronie, logrotate
 
 %description
 PlanetLab service to periodically update node RPMS
@@ -57,6 +52,30 @@ if [ "$1" = 0 ]; then
 fi
 
 %changelog
+* Mon Jan 07 2019 Thierry <Parmentelat> - nodeupdate-1.0-0
+- ported to python3 + pep8
+
+* Sun Jan 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeupdate-0.5-14
+- more robust nodeupdate (again) on dnf-based nodes
+
+* Tue Dec 08 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeupdate-0.5-13
+- dnf-based nodes (f22/f23) need to call dnf group upgrade
+- and not yum groupinstall; with this patch, slice images
+- will now make it smoothly to the node
+
+* Fri Nov 13 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeupdate-0.5-12
+- crucial nodemanager packages were not using new naming convention
+
+* Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeupdate-0.5-11
+- reflect a name change for NodeManager that becomes nodemanager as part of crucial packages
+
+* Mon May 06 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeupdate-0.5-10
+- bugfix in nodeupdate.RemoveRPMS, NodeUpdate.py bails out if rpms can't be removed
+
+* Fri Jul 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeupdate-0.5-9
+- support /etc/planetlab/NodeUpdate.packages and /etc/planetlab/crucial-rpm-list
+- delete exceptions from delete-rpm-list individually
+
 * Fri Feb 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeupdate-0.5-8
 - has a builtin list of packages to update individually (NodeManager for now)
 - plus an optional set that is read from /etc/planetlab/NodeUpdate.packages