Setting tag nodeupdate-1.0-0
[nodeupdate.git] / NodeUpdate.spec
index 999a6ad..d6810ee 100644 (file)
@@ -1,18 +1,13 @@
-#
-# $Id$
-#
-%define url $URL$
-
 %define name NodeUpdate
-%define version 0.5
-%define taglevel 5
+%define version 1.0
+%define taglevel 0
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 
 Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
-URL: %(echo %{url} | cut -d ' ' -f 2)
+URL: %{SCMURL}
 
 Summary: PlanetLab service to periodically update node RPMS
 Name: %{name}
@@ -23,7 +18,7 @@ License: GPL
 Group: System Environment/Base
 Source: %{name}-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}root
-Requires: vixie-cron, logrotate
+Requires: cronie, logrotate
 
 %description
 PlanetLab service to periodically update node RPMS
@@ -36,8 +31,9 @@ PlanetLab service to periodically update node RPMS
 
 
 %install
+echo "* Installing NodeUpdate node-side files"
 install -D -m 755 NodeUpdate.py $RPM_BUILD_ROOT/usr/bin/NodeUpdate.py
-install -D -m 644 NodeUpdate.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/NodeUpdate
+install -D -m 644 logrotate/NodeUpdate $RPM_BUILD_ROOT/etc/logrotate.d/NodeUpdate
 
 %clean
 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
@@ -47,21 +43,49 @@ install -D -m 644 NodeUpdate.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/NodeUpdat
 %attr(0755,root,root) /usr/bin/NodeUpdate.py*
 %attr(0644,root,root) /etc/logrotate.d/NodeUpdate
 
-%pre
-
 %post
 /usr/bin/NodeUpdate.py updatecron
 
 %preun
 if [ "$1" = 0 ]; then
-       /usr/bin/NodeUpdate.py removecron
+    /usr/bin/NodeUpdate.py removecron
 fi
 
+%changelog
+* Mon Jan 07 2019 Thierry <Parmentelat> - nodeupdate-1.0-0
+- ported to python3 + pep8
+
+* Sun Jan 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeupdate-0.5-14
+- more robust nodeupdate (again) on dnf-based nodes
 
-%postun
+* Tue Dec 08 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeupdate-0.5-13
+- dnf-based nodes (f22/f23) need to call dnf group upgrade
+- and not yum groupinstall; with this patch, slice images
+- will now make it smoothly to the node
 
+* Fri Nov 13 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeupdate-0.5-12
+- crucial nodemanager packages were not using new naming convention
+
+* Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeupdate-0.5-11
+- reflect a name change for NodeManager that becomes nodemanager as part of crucial packages
+
+* Mon May 06 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeupdate-0.5-10
+- bugfix in nodeupdate.RemoveRPMS, NodeUpdate.py bails out if rpms can't be removed
+
+* Fri Jul 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeupdate-0.5-9
+- support /etc/planetlab/NodeUpdate.packages and /etc/planetlab/crucial-rpm-list
+- delete exceptions from delete-rpm-list individually
+
+* Fri Feb 18 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - nodeupdate-0.5-8
+- has a builtin list of packages to update individually (NodeManager for now)
+- plus an optional set that is read from /etc/planetlab/NodeUpdate.packages
+
+* Wed Jul 14 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - nodeupdate-0.5-7
+- Use groupinstall to get new group members.
+
+* Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeUpdate-0.5-6
+- new module layout - no functional change
 
-%changelog
 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - NodeUpdate-0.5-5
 - searches the extensions file /etc/planetlab/extensions rather than the former /etc/planetlab/extra-node-groups