package template yaml file, and provide a convenience, version-neutral link in /etc
[omf.git] / omf-resctl.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 # Thierry Parmentelat - INRIA
7 # Copyright (C) 2010 INRIA
8 # License is GPL.
9
10 %define name omf-resctl
11 %define version 5.3
12 %define taglevel 1
13
14 %define plc_name %{name}-%{version}-%{taglevel}
15 %define actual_name omf-resctl-5.3-1ubuntu2-2
16
17 Summary: OMF Resource Controller - for slivers
18 Name: %{name}
19 Version: %{version}
20 Release: %{taglevel}
21 License: GPL
22 Group: System Environment/Base
23 Source0: %{plc_name}.tar.bz2
24 BuildRoot: %{_tmppath}/%{plc_name}-buildroot
25
26 Vendor: NICTA
27 Packager: PlanetLab <devel@planet-lab.org>
28 Distribution: %{pldistro} %{plrelease}
29 URL: %(echo %{url} | cut -d ' ' -f 2)
30 # BuildArch: noarch
31
32 Requires: pciutils  
33 Requires: ruby  
34 Requires: wget  
35 Requires: wireless-tools  
36 Requires: rpmlib(CompressedFileNames) <= 3.0.4-1
37 Requires: rpmlib(PayloadFilesHavePrefix) <= 4.0-1
38
39 Requires: omf-common  
40 Requires: liblog4r
41 Requires: libxmpp4r
42 Requires: imagezip
43
44 %description 
45 The OMF Resource Controller (RC) is the experiment-side of the
46 Experiment Eontroller (EC) that lets experimenter control their
47 resources. It relies on an XMPP server for exchanging with its EC.
48
49 ####################
50 %define common_actual_name omf-common-5.3-1ubuntu3-2
51
52 %package -n omf-common
53 Summary: OMF common utilities 
54 Group: System Environment/Base
55 %description -n omf-common
56 Provides utilities common to various OMF components
57
58 ####################
59 %define liblog4r_actual_name liblog4r-ruby1.8-1.2-1
60
61 %package -n liblog4r
62 Summary:  A logging library for Ruby
63 Group: System Environment/Base
64 %description -n liblog4r
65 A logging library for Ruby, needed by OMF software
66
67 ####################
68 %define libxmpp4r_actual_name libxmpp4r-ruby1.8-1.0-1
69
70 %package -n libxmpp4r
71 Summary:  XMPP/Jabber library for Ruby
72 Group: System Environment/Base
73 %description -n libxmpp4r
74 An XMPP/Jabber library for Ruby, needed by OMF software
75
76 ####################
77 %define imagezip_actual_name imagezip-1.0.0-3
78
79 %package -n imagezip
80 Summary:  filesystem image compression tool from EMULAB
81 Group: System Environment/Base
82 %description -n imagezip
83 filesystem image compression tool from EMULAB
84
85 ####################
86
87 %prep
88 %setup -n %{plc_name}
89
90 %build
91 rm -rf $RPM_BUILD_ROOT
92
93 mkdir unwrap
94
95 make omf-resctl 
96 (cd unwrap; rpm2cpio ../%{actual_name}.noarch.rpm | cpio -diu)
97 make omf-common
98 (cd unwrap ; rpm2cpio ../%{common_actual_name}.noarch.rpm | cpio -diu)
99 make liblog4r 
100 (cd unwrap; rpm2cpio ../%{liblog4r_actual_name}.noarch.rpm | cpio -diu)
101 make libxmpp4r 
102 (cd unwrap; rpm2cpio ../%{libxmpp4r_actual_name}.noarch.rpm | cpio -diu)
103 make imagezip 
104 (cd unwrap; rpm2cpio ../%{imagezip_actual_name}.i386.rpm | cpio -diu)
105
106 # cleanup any svn sequels
107 find unwrap -type d -name .svn -print0 | xargs -0 rm -rf
108
109 %install
110 rm -fr $RPM_BUILD_ROOT
111
112 install -D -m 600 omf-resctl.yaml.in $RPM_BUILD_ROOT/etc/omf-resctl-%{version}/omf-resctl.yaml.in
113 ln -s omf-resctl-%{version} $RPM_BUILD_ROOT/etc/omf-resctl 
114
115 rsync -a unwrap/ $RPM_BUILD_ROOT
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 ####################
121 %files
122 %defattr(-,root,root)
123 /etc
124 /usr/sbin
125 /usr/share/omf-resctl-%{version}
126 /usr/share/doc
127
128 #
129 %post
130 /sbin/chkconfig --add omf-resctl-%{version}
131 service omf-resctl-%{version} restart
132
133 ####################
134 %files -n omf-common
135 %defattr(-,root,root)
136 /usr/share/omf-common-%{version}
137 /usr/share/doc/omf-common-%{version}
138
139 #
140 %post -n omf-common
141 ln -s /usr/bin/ruby /usr/bin/ruby1.8
142
143 ####################
144 %files -n liblog4r
145 %defattr(-,root,root)
146 /usr/lib/ruby/1.8/log4r.rb
147 /usr/lib/ruby/1.8/log4r
148 /usr/share/doc/liblog4r-ruby1.8
149
150 ####################
151 %files -n libxmpp4r
152 %defattr(-,root,root)
153 /usr/lib/ruby/1.8/xmpp4r.rb
154 /usr/lib/ruby/1.8/xmpp4r
155 /usr/share/doc/libxmpp4r-ruby1.8
156
157 ####################
158 %files -n imagezip
159 %defattr(-,root,root)
160 /usr/bin/imagedump
161 /usr/bin/imageunzip
162 /usr/bin/imagezip
163 /usr/share/doc/imagezip
164
165 ####################
166 %changelog