fix
[omf.git] / omf-resctl.spec
1 # Thierry Parmentelat - INRIA
2 # Copyright (C) 2010 INRIA
3 # License is GPL.
4
5 %define name omf-resctl
6 %define version 5.3
7 %define taglevel 9
8
9 %define plc_name %{name}-%{version}-%{taglevel}
10 %define resctl_actual_name omf-resctl-5.3-1ubuntu11-2
11
12 Summary: OMF Resource Controller - for slivers
13 Name: %{name}
14 Version: %{version}
15 Release: %{taglevel}
16 License: GPL
17 Group: System Environment/Base
18 Source0: %{plc_name}.tar.bz2
19 BuildRoot: %{_tmppath}/%{plc_name}-buildroot
20
21 Vendor: NICTA
22 Packager: PlanetLab <devel@planet-lab.org>
23 Distribution: %{pldistro} %{plrelease}
24 URL: %{SCMURL}
25
26 BuildArch: noarch
27
28 Requires: pciutils  
29 Requires: ruby  
30 Requires: wget  
31 Requires: wireless-tools  
32 Requires: rpmlib(CompressedFileNames) <= 3.0.4-1
33 Requires: rpmlib(PayloadFilesHavePrefix) <= 4.0-1
34
35 Requires: omf-common  
36 Requires: liblog4r
37 Requires: libxmpp4r
38 #Requires: imagezip
39
40 %description 
41 The OMF Resource Controller (RC) is the experiment-side of the
42 Experiment Eontroller (EC) that lets experimenter control their
43 resources. It relies on an XMPP server for exchanging with its EC.
44
45 ####################
46 %define common_actual_name omf-common-5.3-1ubuntu10-2
47
48 %package -n omf-common
49 Summary: OMF common utilities 
50 Group: System Environment/Base
51 %description -n omf-common
52 Provides utilities common to various OMF components
53
54 ####################
55 %define liblog4r_actual_name liblog4r-ruby1.8-1.2-1
56
57 %package -n liblog4r
58 Summary:  A logging library for Ruby
59 Group: System Environment/Base
60 %description -n liblog4r
61 A logging library for Ruby, needed by OMF software
62
63 ####################
64 %define libxmpp4r_actual_name libxmpp4r-ruby1.8-1.0-1
65
66 %package -n libxmpp4r
67 Summary:  XMPP/Jabber library for Ruby
68 Group: System Environment/Base
69 %description -n libxmpp4r
70 An XMPP/Jabber library for Ruby, needed by OMF software
71
72 ####################
73 #%define imagezip_actual_name imagezip-1.0.0-3
74 #
75 #%package -n imagezip
76 #Summary:  filesystem image compression tool from EMULAB
77 #Group: System Environment/Base
78 #%description -n imagezip
79 #filesystem image compression tool from EMULAB
80
81 ####################
82
83 %prep
84 %setup -n %{plc_name}
85
86 %build
87 rm -rf $RPM_BUILD_ROOT
88
89 mkdir unwrap
90
91 make omf-resctl 
92 (cd unwrap; rpm2cpio ../%{resctl_actual_name}.noarch.rpm | cpio -diu)
93 make omf-common
94 (cd unwrap ; rpm2cpio ../%{common_actual_name}.noarch.rpm | cpio -diu)
95 make liblog4r 
96 (cd unwrap; rpm2cpio ../%{liblog4r_actual_name}.noarch.rpm | cpio -diu)
97 make libxmpp4r 
98 (cd unwrap; rpm2cpio ../%{libxmpp4r_actual_name}.noarch.rpm | cpio -diu)
99 #make imagezip 
100 #(cd unwrap; rpm2cpio ../%{imagezip_actual_name}.i386.rpm | cpio -diu)
101
102 # remove any default config if any
103 rm -f unwrap/etc/omf-resctl-%{version}/omf-resctl.yaml
104
105 # cleanup any svn sequels
106 find unwrap -type d -name .svn -print0 | xargs -0 rm -rf
107
108
109 %install
110 rm -fr $RPM_BUILD_ROOT
111
112 rsync -a unwrap/ $RPM_BUILD_ROOT
113
114 install -D -m 600 omf-resctl.yaml.in $RPM_BUILD_ROOT/etc/omf-resctl-%{version}/omf-resctl.yaml.in
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 ####################
120 %files
121 %defattr(-,root,root)
122 /etc
123 /usr/sbin
124 /usr/share/omf-resctl-%{version}
125 /usr/share/doc
126
127 #
128 %post
129 if [ -x /sbin/chkconfig ] ; then
130     /sbin/chkconfig --add omf-resctl-%{version}
131     /sbin/chkconfig omf-resctl-%{version} on
132     service omf-resctl-%{version} restart
133 fi
134
135 %preun
136 # 0 = erase, 1 = upgrade
137 if [ $1 -eq 0 ] ; then
138     service omf-resctl-%{version} stop
139     /sbin/chkconfig omf-resctl-%{version} off
140     /sbin/chkconfig --del omf-resctl-%{version}
141 fi
142
143 ####################
144 %files -n omf-common
145 %defattr(-,root,root)
146 /usr/share/omf-common-%{version}
147 /usr/share/doc/omf-common-%{version}
148
149 #
150 %post -n omf-common
151 ln -s /usr/bin/ruby /usr/bin/ruby1.8
152
153 ####################
154 %files -n liblog4r
155 %defattr(-,root,root)
156 /usr/lib/ruby/1.8/log4r.rb
157 /usr/lib/ruby/1.8/log4r
158 /usr/share/doc/liblog4r-ruby1.8
159
160 ####################
161 %files -n libxmpp4r
162 %defattr(-,root,root)
163 /usr/lib/ruby/1.8/xmpp4r.rb
164 /usr/lib/ruby/1.8/xmpp4r
165 /usr/share/doc/libxmpp4r-ruby1.8
166
167 ####################
168 #%files -n imagezip
169 #%defattr(-,root,root)
170 #/usr/bin/imagedump
171 #/usr/bin/imageunzip
172 #/usr/bin/imagezip
173 #/usr/share/doc/imagezip
174
175 ####################
176 %changelog
177 * Mon Jan 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - omf-5.3-9
178 - no semantic change - just fixed specfile for git URL
179
180 * Mon Aug 30 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - omf-5.3-8
181 - new packages from NICTA
182
183 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - omf-5.3-7
184 - fix omf-expctl build
185
186 * Thu Jul 08 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - omf-5.3-6
187 - updated omf packages
188
189 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - omf-5.3-5
190 - cleaned up specfile for smoother upgrades
191
192 * Tue May 25 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - omf-5.3-4
193 - fix stupid typo in tag 5.3-3
194
195 * Tue May 25 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - omf-5.3-3
196 - fetch from the tagged omf-5.3-federation-v1.1 - and turn SHA1SUM checking back on again
197
198 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - omf-5.3-2
199 - package the exp. controller as well for user convenience
200