Attempts to write to vsys FIFO when file exists. If process is blocked, kill and...
[pf2slice.git] / pf2slice.spec
1 # please keep these three lines as they are used by the tagging script
2 # see build/module-tag.py for details
3 %define name pf2slice
4 %define version 1.0
5 %define taglevel 1
6
7 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
8
9 Name:           %{name}
10 Version:        %{version}
11 Release:        %{release}
12 Summary:        pf2slice - Tools for starting and managing the PF2 slice
13 Group:          Network/Monitoring
14 License:        GPL
15 Source0:        %{name}-%{version}.tar.bz2
16 Buildroot:      %{_tmppath}/%{name}-buildroot
17 Provides:       pf2slice
18
19 %description
20 pf2slice - Populates the planetflow slice with the right initscript, keychains and so on
21
22 %prep
23 %setup -q
24
25 %install
26 rm -rf %{buildroot}
27 install -d -v %{buildroot}/etc/init.d
28 install -m 755 -v pf2slice-initscript %{buildroot}/etc/init.d/pf2slice
29 install -d -m 700 %{buildroot}/home/pl_netflow/.ssh
30 install -m 600 authorized_keys %{buildroot}/home/pl_netflow/.ssh/authorized_keys
31 mkdir -p %{buildroot}/home/pl_netflow/.ssh
32 mkdir -p %{buildroot}/pf
33
34
35 %clean
36 rm -rf %{buildroot}
37
38 %files
39 %defattr(-,root,root)
40 /etc/init.d/pf2slice
41 /home/pl_netflow/.ssh/authorized_keys
42 /home/*
43 /pf
44
45 %post
46 chkconfig --add pf2slice
47 chkconfig pf2slice on
48
49 %changelog