This commit was generated by cvs2svn to compensate for changes in r45,
[pingofdeath.git] / ipod.spec
1 Summary: PlanetLab ICMP Ping of Death
2 Name: ipod
3 Version: 2.0
4 Release: 2
5 Copyright: GPL
6 Group: System Environment/Kernel
7 Source: ipod-2.0.tar.gz
8
9 %description
10 Startup service to enable Ping Of Death
11
12 %prep
13
14 %setup
15
16 %build
17 make
18
19 %install
20 make install
21
22 %clean
23
24 %files
25 %defattr(-, root, root)
26 /etc/init.d/pod
27 /usr/local/planetlab/bin/pl-poddoit
28
29 %pre
30
31 %post 
32 RUNLEVEL=`/sbin/runlevel`
33
34 if [ "$1" = 1 ]; then
35         chkconfig --add pod
36         chkconfig pod on
37
38         if [[ "$RUNLEVEL" != "unknown" ]]; then
39                 /etc/init.d/pod start
40         fi
41 fi
42
43 %preun
44 if [ "$1" = 0 ]; then
45         chkconfig pod off
46         chkconfig --del pod
47 fi
48
49 %postun
50