Incorporate identifying string into .rpm
[pl_sshd.git] / pl_sshd.spec
1 Summary: SSH server config for PlanetLab
2 Name: pl_sshd
3 Version: 0.1
4 Release: 1
5 Requires: automount, sshd
6 Copyright: GPL
7 URL: http://www.planet-lab.org
8 Group: System Environment/Base
9 Source: %{_fullname}.tar.gz
10
11 %description 
12 SSH server configuration for PlanetLab nodes.  Configures an automounted
13 directory as source for authorized_keys files and points sshd to that
14 directory.
15
16 Created from $Header$.
17 %prep
18 %setup
19
20 %build
21
22
23 %install
24 install -m 0755 -o root -g root pl_sshd.sh $RPM_BUILD_ROOT/usr/local/sbin
25 install -m 0755 -o root -g root pl_sshd $RPM_BUILD_ROOT/etc/init.d
26 install -m 0755 -o root -g root auto.pl_sshd $RPM_BUILD_ROOT/etc
27 echo "OPTIONS='-p 806'" >$RPM_BUILD_ROOT/etc/sysconfig/sshd
28
29 %clean
30 rm -rf $RPM_BUILD_ROOT
31
32 %files
33 %defattr(-,root,root)
34 %attr(0755,root,root) /usr/local/sbin/pl_sshd.sh
35 %attr(0755,root,root) /etc/init.d/pl_sshd
36 %attr(0755,root,root) /etc/auto.pl_sshd
37
38 %pre
39
40
41 %post
42 RUNLEVEL=`/sbin/runlevel`
43
44 if [ "$1" -ge 1 ]; then
45         chkconfig --add pl_sshd
46
47         if [[ "$RUNLEVEL" != "unknown" ]]; then
48                 /etc/init.d/pl_sshd restart
49         fi
50 fi
51
52 %preun
53 if [ "$1" = 0 ]; then
54         chkconfig --del pl_sshd
55 fi
56
57
58 %postun
59
60
61 %changelog
62 * Tue Nov 25 2003 Steve Muir <smuir@cs.princeton.edu>
63 - fixed a couple of Node Manager bugs:
64   - bootstrapping pl_conf state when boot server unreachable
65   - canonical hostnames should be all lower-case
66 - fixup UID and GID of users within vservers to match real world
67 - enable access to dynamic slices through port 806 sshd
68
69 * Sun Oct 26 2003 Aaron Klingaman <Aaron.L.Klingaman@intel.com>
70 - readded start/stop only when runlevel is known, for install purposes
71
72 * Thu Oct 16 2003 Jeff Sedayao <Jeff.Sedayao@intel.com>
73 - Fixed bug in pl_conf  - it was getting negative wait times.  Also added
74   duke4 as a trusted user. 
75
76 * Tue Oct  8 2003 Jeff Sedayao <Jeff.Sedayao@intel.com>
77 - Removed special fetch login from init function, updated release
78
79 * Tue Oct  7 2003 Jeff Sedayao <Jeff.Sedayao@intel.com>
80 - Moved special fetch login into main loop, fix account deletion
81   problem
82
83 * Tue Oct  7 2003 Aaron Klingaman <Aaron.L.Klingaman@intel.com>
84 - Commented out code to start pl_* upon install
85
86 * Wed Aug 26 2003 Tammo Spalink <tammo.spalink@intel.com>
87 - Initial build.
88