081c5d3dcae9d020e5bc73937f8c718333ace614
[plcapi.git] / PLCAPI.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name PLCAPI
8 %define version 5.0
9 %define taglevel 2
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: PlanetLab Central API
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: PlanetLab
18 Group: System Environment/Daemons
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Obsoletes: plcapilib
28
29 # We use set everywhere
30 Requires: python >= 2.4
31 Requires: postgresql >= 8.2, postgresql-server >= 8.2
32 Requires: postgresql-python
33 Requires: python-psycopg2
34 Requires: python-pycurl
35 Requires: httpd
36 Requires: mod_python
37 Requires: mod_ssl
38 Requires: SOAPpy
39 # for the RebootNodeWithPCU method
40 Requires: pcucontrol
41
42 ### avoid having yum complain about updates, as stuff is moving around
43 # plc.d/api
44 Conflicts: MyPLC <= 4.3
45
46 # We use psycopg2
47 BuildRequires: postgresql-devel
48
49 # Standard xmlrpc.so that ships with PHP does not marshal NULL
50 BuildRequires: php-devel
51 Obsoletes: php-xmlrpc
52 Provides: php-xmlrpc
53
54 # PostgreSQL and SOAPpy are necessary to run the API server, but not
55 # plcsh. Since the only supported method of running the server is via
56 # MyPLC anyway, don't be so stringent about binary requirements, in
57 # case people want to install this package just for plcsh.
58 # Requires: postgresql-server, SOAPpy
59 AutoReqProv: no
60
61 %description
62 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
63 PlanetLab Central (PLC) database. The API may be accessed directly via
64 the Python shell program plcsh, through a toy standalone server, or
65 through Apache mod_python.
66
67 %prep
68 %setup -q
69
70 %build
71 # python-pycurl and python-psycopg2 avail. from fedora 5
72 # we used to ship our own version of psycopg2 and pycurl, for fedora4
73 # starting with 4.3, support for these two modules is taken out
74
75 # Build __init__.py metafiles and PHP API. 
76 %{__make} %{?_smp_mflags}
77 %{__make} -C wsdl
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
82
83 # Install shell symlink
84 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
85 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
86
87 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
88 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
89 ; Enable xmlrpc extension module
90 extension=xmlrpc.so
91 EOF
92
93 # Install initscripts
94 echo "* Installing initscripts"
95 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
96 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
97
98 # Install db-config.d files
99 echo "* Installing db-config.d files"
100 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
101 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
102 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
103
104 # Install wsdl
105 echo "* Installing wsdl"
106 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %define php_extension_dir %(php-config --extension-dir)
112
113 %files
114 %defattr(-,root,root,-)
115 %dir %{_datadir}/plc_api
116 %{_datadir}/plc_api/*
117 %{_bindir}/plcsh
118 %{php_extension_dir}/xmlrpc.so
119 %{_sysconfdir}/php.d/xmlrpc.ini
120 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
121 /etc/plc.d
122 /etc/planetlab/db-config.d
123 /var/www/html/wsdl/plcapi.wsdl
124
125 %changelog
126 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
127 - major cleanup
128 - get rid of all 4.2-related legacy code
129 - reset the migrations code, planetlab5.sql somes with (5,100)
130 - uses hashlib module when available
131
132 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
133 - first working version of 5.0:
134 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
135 - nodefamily is 3-fold with pldistro-fcdistro-arch
136 - site and person tags
137 - new methods GetSliceFamily and GetNodeFlavour
138 - deprecated the dummynet stuff that were for the external dummyboxes
139 - tags definition : more consistency between db-config scripts and accessors
140 - (get accessor to create the tag type too if absent)
141 - logging an event for AddSliceToNodes
142
143 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
144 - support for fedora 12
145 - fix subtle bug in filtering with ] and quotes
146
147 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
148 - * patch for php-5.3 (the one in f12)
149 - * validate email addresses with regex
150 - * add PersonTags and SiteTags
151 - * add additional accessors for node tags (kvariant, serial, ..)
152
153 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
154 - Redacting password, session, and authstring values from the event log.
155
156 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
157 - let AddSite set ext_consortium_id - required for the poorman registration pages
158 - drop version constraint on Requires: postgresql-python
159 - don't log system calls nor ReportRunLevel
160
161 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
162 - Fix requires for CentOS.
163
164 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
165 - Require postgresql 8.2 (for array operators && and @>)
166
167 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
168 - Filter now supports the | and & features to match in sequence values
169 - bugfix in the postgresql wrapper for sequence filter values
170 - reviewed GetSlivers to export admin keys more efficiently
171 - fix checking roles in UpdateSliceTag
172
173 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
174 - - Some typos in the documentation were fixed.
175 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
176 - to the tag's min_role_id.
177
178 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
179
180 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
181 - Ongoing work to add upcalls, using new SFA class
182 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
183 - reviewed type-checking for the 3 taggable classes node-interface-slice
184 - cleanup ald dummynet stuff
185 - expose the 'extensions' accessors to the API
186 - tweaked checks in AddSliceTag
187 - GetPersons exposes roles by default
188 - bugfix in ReportRunLevel for non-string levels
189 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
190
191 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
192 - new BindObjectToPeer method for sfa
193 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
194
195 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
196 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
197 - reportrunlevel logs its calls only when run_level changes
198 - pycurl more robust wrt to xmlrpclib.Transport
199
200 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
201 - produce a wsdl interface
202 - bugfix in getbootmedium for nodes with interface tags
203
204 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
205 - bugfix for some rare pattern-based filters
206
207 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
208 - improvements in the 4.2 legacy layer
209
210 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
211 - bugfix required for slice tags set on nodegroups
212
213 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
214 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
215
216 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
217 - more powerful legacy layer with 4.2
218
219 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
220 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
221 - migration script has an option for running interactively
222
223 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
224 - skips already added entries
225
226 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
227 - yet another set of fixes for external dummynet boxes
228
229 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
230 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
231 - and tmp file is cleaned up
232
233 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
234 - restore missing ResolveSlices
235
236 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
237 - new method GetDummyBoxMedium
238
239 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
240 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
241
242 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
243 - support for external dummynet boxes back in 4.3 - first draft
244
245 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
246 - fixes for smooth federation between 4.2 and 4.3
247 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
248
249 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
250 - support for BootCD variants (GetBootMedium ['variant:centos5'])
251 - fix corner case with filters like {'~slice_id':[]}
252 - fix transaction leak that caused the db connections pool to exhaust
253 - properly expose all methods, including Legacy/, and not only Methods/
254
255 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
256 - renumbered as 4.3
257 - nodes have new fields run_level (in addition to boot_state) and verified
258 - tweaked migration from 4.2
259 - tuned rpm dependencies
260 - doc generation more explicit about errors like missing python modules
261 - removed obsolete method GetSlicesMD5
262
263 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
264 - unified all tags
265 - renamed interface settings into interface tags and slice attributes into slice tags
266 - nodes have a node_type
267 - various changes on the way to 4.3
268
269 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
270 - Checkpointing : this version still has interface settings and slice attributes
271
272 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
273 - first iteration with taggable nodes/interfaces/slices
274 - embryo for ilinks
275 - cleaned up boot states
276 - migration script moslty complete
277
278 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
279 - fixed doc build by locating locally installed DTDs at build-time
280
281 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
282 - no more doc packaged outside of myplc-docs - doc/ cleaned up
283 - enhancements in doc on filters 
284 - bootcd-aware GetBootMedium merged from onelab
285
286 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
287 - checkpoint while the new myplc-docs package is underway
288 - bugfix: GetSlivers & conf files
289 - doc: removed target files 
290
291 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
292 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
293 - the non-deleted fields were index, resulting in massivly slow queries.
294
295
296 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
297 - plcsh: better handling of options when running as a shell script
298 - getbootmedium exports compute_key
299 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
300
301 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
302 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
303 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
304
305 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
306 - refresh peer script to use a month-dependent logfile
307 - tracking the starting point for UniPi integration of the dummynet boxes
308
309 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
310 - plcsh adds its own path to sys.path
311 - fix so GetNodes can be called from a Node
312
313 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
314 - Initial build.
315
316 %define module_current_branch 4.3