0b2cdd95e07a92ae6e24bad57c2b883d01b3ecfe
[plcapi.git] / PLCAPI.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name PLCAPI
8 %define version 4.3
9 %define taglevel 32
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: PlanetLab Central API
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: PlanetLab
18 Group: System Environment/Daemons
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Obsoletes: plcapilib
28
29 # We use set everywhere
30 Requires: python >= 2.4
31 Requires: postgresql >= 8.2, postgresql-server >= 8.2
32 Requires: postgresql-python
33 Requires: python-psycopg2
34 Requires: python-pycurl
35 Requires: httpd
36 Requires: mod_python
37 Requires: mod_ssl
38 Requires: SOAPpy
39
40 # We use psycopg2
41 BuildRequires: postgresql-devel
42
43 # Standard xmlrpc.so that ships with PHP does not marshal NULL
44 BuildRequires: php-devel
45 Obsoletes: php-xmlrpc
46 Provides: php-xmlrpc
47
48 # PostgreSQL and SOAPpy are necessary to run the API server, but not
49 # plcsh. Since the only supported method of running the server is via
50 # MyPLC anyway, don't be so stringent about binary requirements, in
51 # case people want to install this package just for plcsh.
52 # Requires: postgresql-server, SOAPpy
53 AutoReqProv: no
54
55 %description
56 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
57 PlanetLab Central (PLC) database. The API may be accessed directly via
58 the Python shell program plcsh, through a toy standalone server, or
59 through Apache mod_python.
60
61 %prep
62 %setup -q
63
64 %build
65 # python-pycurl and python-psycopg2 avail. from fedora 5
66 # we used to ship our own version of psycopg2 and pycurl, for fedora4
67 # starting with 4.3, support for these two modules is taken out
68
69 # Build __init__.py metafiles and PHP API. 
70 %{__make} %{?_smp_mflags}
71 %{__make} -C wsdl
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
76 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
77
78 # Install shell symlink
79 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
80 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
81
82 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
83 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
84 ; Enable xmlrpc extension module
85 extension=xmlrpc.so
86 EOF
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %define php_extension_dir %(php-config --extension-dir)
92
93 %files
94 %defattr(-,root,root,-)
95 %dir %{_datadir}/plc_api
96 %{_datadir}/plc_api/*
97 %{_bindir}/plcsh
98 %{php_extension_dir}/xmlrpc.so
99 %{_sysconfdir}/php.d/xmlrpc.ini
100 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
101 /var/www/html/wsdl/plcapi.wsdl
102
103 %changelog
104 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
105 - support for fedora 12
106 - fix subtle bug in filering with ] and quotes
107
108 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
109 - * patch for php-5.3 (the one in f12)
110 - * validate email addresses with regex
111 - * add PersonTags and SiteTags
112 - * add additional accessors for node tags (kvariant, serial, ..)
113
114 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
115 - Redacting password, session, and authstring values from the event log.
116
117 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
118 - let AddSite set ext_consortium_id - required for the poorman registration pages
119 - drop version constraint on Requires: postgresql-python
120 - don't log system calls nor ReportRunLevel
121
122 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
123 - Fix requires for CentOS.
124
125 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
126 - Require postgresql 8.2 (for array operators && and @>)
127
128 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
129 - Filter now supports the | and & features to match in sequence values
130 - bugfix in the postgresql wrapper for sequence filter values
131 - reviewed GetSlivers to export admin keys more efficiently
132 - fix checking roles in UpdateSliceTag
133
134 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
135 - - Some typos in the documentation were fixed.
136 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
137 - to the tag's min_role_id.
138
139 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
140
141 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
142 - Ongoing work to add upcalls, using new SFA class
143 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
144 - reviewed type-checking for the 3 taggable classes node-interface-slice
145 - cleanup ald dummynet stuff
146 - expose the 'extensions' accessors to the API
147 - tweaked checks in AddSliceTag
148 - GetPersons exposes roles by default
149 - bugfix in ReportRunLevel for non-string levels
150 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
151
152 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
153 - new BindObjectToPeer method for sfa
154 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
155
156 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
157 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
158 - reportrunlevel logs its calls only when run_level changes
159 - pycurl more robust wrt to xmlrpclib.Transport
160
161 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
162 - produce a wsdl interface
163 - bugfix in getbootmedium for nodes with interface tags
164
165 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
166 - bugfix for some rare pattern-based filters
167
168 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
169 - improvements in the 4.2 legacy layer
170
171 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
172 - bugfix required for slice tags set on nodegroups
173
174 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
175 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
176
177 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
178 - more powerful legacy layer with 4.2
179
180 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
181 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
182 - migration script has an option for running interactively
183
184 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
185 - skips already added entries
186
187 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
188 - yet another set of fixes for external dummynet boxes
189
190 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
191 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
192 - and tmp file is cleaned up
193
194 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
195 - restore missing ResolveSlices
196
197 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
198 - new method GetDummyBoxMedium
199
200 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
201 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
202
203 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
204 - support for external dummynet boxes back in 4.3 - first draft
205
206 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
207 - fixes for smooth federation between 4.2 and 4.3
208 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
209
210 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
211 - support for BootCD variants (GetBootMedium ['variant:centos5'])
212 - fix corner case with filters like {'~slice_id':[]}
213 - fix transaction leak that caused the db connections pool to exhaust
214 - properly expose all methods, including Legacy/, and not only Methods/
215
216 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
217 - renumbered as 4.3
218 - nodes have new fields run_level (in addition to boot_state) and verified
219 - tweaked migration from 4.2
220 - tuned rpm dependencies
221 - doc generation more explicit about errors like missing python modules
222 - removed obsolete method GetSlicesMD5
223
224 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
225 - unified all tags
226 - renamed interface settings into interface tags and slice attributes into slice tags
227 - nodes have a node_type
228 - various changes on the way to 4.3
229
230 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
231 - Checkpointing : this version still has interface settings and slice attributes
232
233 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
234 - first iteration with taggable nodes/interfaces/slices
235 - embryo for ilinks
236 - cleaned up boot states
237 - migration script moslty complete
238
239 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
240 - fixed doc build by locating locally installed DTDs at build-time
241
242 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
243 - no more doc packaged outside of myplc-docs - doc/ cleaned up
244 - enhancements in doc on filters 
245 - bootcd-aware GetBootMedium merged from onelab
246
247 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
248 - checkpoint while the new myplc-docs package is underway
249 - bugfix: GetSlivers & conf files
250 - doc: removed target files 
251
252 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
253 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
254 - the non-deleted fields were index, resulting in massivly slow queries.
255
256
257 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
258 - plcsh: better handling of options when running as a shell script
259 - getbootmedium exports compute_key
260 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
261
262 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
263 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
264 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
265
266 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
267 - refresh peer script to use a month-dependent logfile
268 - tracking the starting point for UniPi integration of the dummynet boxes
269
270 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
271 - plcsh adds its own path to sys.path
272 - fix so GetNodes can be called from a Node
273
274 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
275 - Initial build.
276
277 %define module_current_branch 4.2