48cbf26123f581940a0e7fa846630aa8a5ab89bd
[plcapi.git] / PLCAPI.spec
1 %define name PLCAPI
2 %define version 5.1
3 %define taglevel 6
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Obsoletes: plcapilib
22
23 # We use set everywhere
24 Requires: python >= 2.4
25 Requires: postgresql >= 8.2, postgresql-server >= 8.2
26 Requires: postgresql-python
27 Requires: python-psycopg2
28 Requires: python-pycurl
29 Requires: httpd
30 %if "%{distro}" == "Fedora" && %{distrorelease} < 16
31 Requires: mod_python
32 %else
33 # mod_wsgi will replace mod_python when we are ready
34 Requires: mod_wsgi
35 %endif
36 Requires: mod_ssl
37 Requires: SOAPpy
38 Requires: python-simplejson
39 # for the RebootNodeWithPCU method
40 Requires: pcucontrol >= 1.0-6
41 # for OMF integration
42 Requires: pyaspects >= 0.4
43 Requires: python-twisted-words
44 Requires: python-twisted-web
45 # ldap
46 Requires: python-ldap
47 # for memcache
48 Requires: python-memcached
49 Requires: memcached
50 Requires: Django
51 ### avoid having yum complain about updates, as stuff is moving around
52 # plc.d/api
53 Conflicts: MyPLC <= 4.3
54
55 # We use psycopg2
56 #
57 # but we don't need to rebuild it as we depend on distro's packages - baris
58 # BuildRequires: postgresql-devel
59
60 # Standard xmlrpc.so that ships with PHP does not marshal NULL
61 BuildRequires: php-devel PyXML python-simplejson
62 Obsoletes: php-xmlrpc
63 Provides: php-xmlrpc
64
65 # PostgreSQL and SOAPpy are necessary to run the API server, but not
66 # plcsh. Since the only supported method of running the server is via
67 # MyPLC anyway, don't be so stringent about binary requirements, in
68 # case people want to install this package just for plcsh.
69 # Requires: postgresql-server, SOAPpy
70 AutoReqProv: no
71
72 %description
73 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
74 PlanetLab Central (PLC) database. The API may be accessed directly via
75 the Python shell program plcsh, through a toy standalone server, or
76 through Apache mod_python.
77
78 %prep
79 %setup -q
80
81 %build
82 # python-pycurl and python-psycopg2 avail. from fedora 5
83 # we used to ship our own version of psycopg2 and pycurl, for fedora4
84 # starting with 4.3, support for these two modules is taken out
85
86 # Build __init__.py metafiles and PHP API. 
87 %{__make} %{?_smp_mflags}
88 %{__make} -C wsdl
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
93
94 # Install shell symlink
95 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
96 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
97
98 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
99 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
100 ; Enable xmlrpc extension module
101 extension=xmlrpc.so
102 EOF
103
104 # Install initscripts
105 echo "* Installing initscripts"
106 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
107 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
108
109 # Install db-config.d files
110 echo "* Installing db-config.d files"
111 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
112 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
113 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
114
115 # Install wsdl
116 echo "* Installing wsdl"
117 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
118
119 # Install omf_slicemgr.py
120 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
121 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
122 mkdir -p $RPM_BUILD_ROOT/var/log/omf
123
124 # Install ratelimit log
125 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
126 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %define php_extension_dir %(php-config --extension-dir)
132
133 %files
134 %defattr(-,root,root,-)
135 %dir %{_datadir}/plc_api
136 %dir /var/log/omf/
137 %{_datadir}/plc_api/*
138 %{_bindir}/plcsh
139 %{php_extension_dir}/xmlrpc.so
140 %{_sysconfdir}/php.d/xmlrpc.ini
141 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
142 /etc/plc.d
143 /etc/planetlab/db-config.d
144 /var/www/html/wsdl/plcapi.wsdl
145 /usr/bin/omf_slicemgr.py*
146 /usr/bin/reset_xmpp_pubsub_nodes.py*
147 /var/log/plc_api_ratelimit.log
148
149
150 %changelog
151 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
152 - implement PLC_VSYS_DEFAULTS in AddSlice
153
154 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
155 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
156 - AddPerson and UpdatePerson are now tag-aware
157 - as a side-effect AddPerson is more picky and rejects invalid fields
158 - which results in a requirement to use sfa-2.1-22 with this tag
159 - marginal improvement on the xml doc on tags
160
161 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
162 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
163 - reset_xmpp_pubsub_nodes now hos options and usage
164 - new Accessors for vicci
165
166 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
167 - fixed imports for tags management with sites and persons
168 - add predefined 'cpu_freezable' tag
169
170 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
171 - tweaks in interface initialization
172 - has 'vsys_vnet' as a predefined tagtype
173 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
174 - bugfix: GetSlivers & nodegroups
175 - bugfix: in jabber groups management
176
177 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
178 - fix gpg-authentication for Persons (thanks Jordan)
179 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
180 - ip address/network check: v4 or v6
181 - customized DB Message survive upgrade
182 - make sync works in lxc-hosted tests
183 - no svn keywords anymore
184
185 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
186 - fix sorting for methods list in docs
187 - untested but needed tweak for postgres startup in f16
188
189 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
190 - tweaks in postgresql setup - in line with sfa
191
192 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
193 - slight tweaks in Persons.py
194
195 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
196 - GetSession has support for more than one day sessions
197 - reset_xmpp_pubsub_nodes is much more efficient
198 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
199 - bugfix - deleting a person in the middle of the signup process
200
201 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
202 - ratelimit aspects
203 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
204 - requires Django for cache_utils
205 - attempt to expose 'pldistro' to sfa
206 - last_time_spent_online, last_time_spent_offline: new fields in Node
207 - new slice tags 'isolate_loopback' and 'cpu_cores'
208 - refresh-peer federation logs dump exceptions
209 - modpython logs have a timestamp
210 - more verbose/accurate php error reporting
211 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
212 - AddNode, UpdateNode: manage tags directly rather than through another method
213 - BootUpdateNode: only update once
214 - GetPersons: techs can access the list of persons on their site
215 - GetSlices and GetSliceTags: techs can see slices on their nodes
216 - GetSlivers: isrootonsite tag; cacheable
217
218 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
219 - rename initscript_body into initscript_code
220
221 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
222 - new initscript_body tag
223
224 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
225 - working draft for GetSliceSshKeys
226
227 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
228 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
229 - (this is for people who cancel their download)
230
231 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
232 - fix db-config sequence : accessors step now merged in, and occurs at the right time
233 - db-config also more robust
234 - no more explicit 'accessors' step in plc.d
235
236 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
237 - session auth: do *not* delete session when node runs a method that does not have 'node' role
238 - session auth: remove support for bootonce in old boot CDs
239 - give a reason when caller_may_write_slice_tag fails
240 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
241
242 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
243 - SetSliceVref needed the node role
244 - protect GetSliceFamily
245 - Fix bugs in tag authorizations
246
247 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
248 - altered checking of optional fields in Interfaces
249 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
250 - has pyxml and python-simplejson as new deps
251
252 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
253 - tweak doc extraction for fedora14
254
255 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
256 - builtin accessors for the myslice page
257 - Get{Node,Interface}Tags allowed to techs
258 - tweak in ratelimitaspect.py
259
260 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
261 - add admin role to accessor-related tags (arch, {fc,pl}distro)
262
263 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
264 - bugfix in {Update,Delete}PersonTag
265 - updated xml doc for filters, accessors and tagtypes
266 - more explicit msg in case of missing roles
267 - improvements in ratelimitaspects.py
268
269 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
270 - fix the roles for ssh_key and hmac tags
271
272 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
273 - tag permissions system based on roles and not min_role_ids
274 - accessors simplified accordingly (no more min_role_id)
275 - new methods AddRoleToTagType and DeleteRoleFromTagType
276 - accessor-related tagtypes are created sooner, and enforced
277 - cleaned up redundancy between db-config.d and accessors
278
279 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
280 - fix RefreshPeer that was not working in 5.0-17
281
282 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
283 - RefreshPeer is able to cope with 2 peers running different releases of the api
284 - DeletePerson can be used on duplicates
285 - first appearance of ModPythonJson.py
286
287 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
288 - set accessors return the new value
289 - tweaks in the pubsub groups management
290
291 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
292 - convert hostnames to lower case and use ILIKE instead of LIKE
293
294 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
295 - use hrn in pubsub groups
296
297 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
298 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
299 - - OMF fixes
300
301 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
302 - automatically set vsys tag for omf controlled slices
303
304 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
305 - addition of the 'ssh_key' slice tag
306 - first draft of the LDAP interface
307
308 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
309 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
310 - and readable through GetLeaseGranularity
311 - GetSlivers to expose reservation_policy and lease_granularity
312 - GetBootMedium fixed for reservable nodes
313 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
314 - new Apache mod_wsgi python interface
315
316 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
317 - the leases system
318
319 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
320 - previous tag had gone wrong
321
322 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
323 - fix pubsub hostname
324
325 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
326 - tweaks for the omf support (xmpp groups and RC-controlled slices)
327 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
328 - GetNodeFlavour exposes fcdistro
329
330 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
331 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
332
333 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
334 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
335 - pyaspect hooks allow to  maintain the namespace xmpp groups
336 - new omf_slicemgr is a proxy to xmpp, used by these hooks
337 - nodes have their hrn exposed in the 'hrn' tag
338 - node hrn exposed in GetSlivers, as well as the overall xmpp config
339 - system slice 'drl' gets created by db-config
340 - daniel's changes to Filter for supporting wildcards in lists
341 - AddSliceTag consistency check tweaked
342
343 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
344 - major cleanup
345 - get rid of all 4.2-related legacy code
346 - reset the migrations code, planetlab5.sql somes with (5,100)
347 - uses hashlib module when available
348
349 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
350 - first working version of 5.0:
351 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
352 - nodefamily is 3-fold with pldistro-fcdistro-arch
353 - site and person tags
354 - new methods GetSliceFamily and GetNodeFlavour
355 - deprecated the dummynet stuff that were for the external dummyboxes
356 - tags definition : more consistency between db-config scripts and accessors
357 - (get accessor to create the tag type too if absent)
358 - logging an event for AddSliceToNodes
359
360 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
361 - support for fedora 12
362 - fix subtle bug in filtering with ] and quotes
363
364 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
365 - * patch for php-5.3 (the one in f12)
366 - * validate email addresses with regex
367 - * add PersonTags and SiteTags
368 - * add additional accessors for node tags (kvariant, serial, ..)
369
370 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
371 - Redacting password, session, and authstring values from the event log.
372
373 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
374 - let AddSite set ext_consortium_id - required for the poorman registration pages
375 - drop version constraint on Requires: postgresql-python
376 - don't log system calls nor ReportRunLevel
377
378 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
379 - Fix requires for CentOS.
380
381 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
382 - Require postgresql 8.2 (for array operators && and @>)
383
384 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
385 - Filter now supports the | and & features to match in sequence values
386 - bugfix in the postgresql wrapper for sequence filter values
387 - reviewed GetSlivers to export admin keys more efficiently
388 - fix checking roles in UpdateSliceTag
389
390 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
391 - - Some typos in the documentation were fixed.
392 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
393 - to the tag's min_role_id.
394
395 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
396
397 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
398 - Ongoing work to add upcalls, using new SFA class
399 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
400 - reviewed type-checking for the 3 taggable classes node-interface-slice
401 - cleanup ald dummynet stuff
402 - expose the 'extensions' accessors to the API
403 - tweaked checks in AddSliceTag
404 - GetPersons exposes roles by default
405 - bugfix in ReportRunLevel for non-string levels
406 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
407
408 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
409 - new BindObjectToPeer method for sfa
410 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
411
412 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
413 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
414 - reportrunlevel logs its calls only when run_level changes
415 - pycurl more robust wrt to xmlrpclib.Transport
416
417 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
418 - produce a wsdl interface
419 - bugfix in getbootmedium for nodes with interface tags
420
421 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
422 - bugfix for some rare pattern-based filters
423
424 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
425 - improvements in the 4.2 legacy layer
426
427 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
428 - bugfix required for slice tags set on nodegroups
429
430 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
431 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
432
433 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
434 - more powerful legacy layer with 4.2
435
436 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
437 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
438 - migration script has an option for running interactively
439
440 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
441 - skips already added entries
442
443 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
444 - yet another set of fixes for external dummynet boxes
445
446 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
447 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
448 - and tmp file is cleaned up
449
450 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
451 - restore missing ResolveSlices
452
453 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
454 - new method GetDummyBoxMedium
455
456 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
457 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
458
459 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
460 - support for external dummynet boxes back in 4.3 - first draft
461
462 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
463 - fixes for smooth federation between 4.2 and 4.3
464 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
465
466 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
467 - support for BootCD variants (GetBootMedium ['variant:centos5'])
468 - fix corner case with filters like {'~slice_id':[]}
469 - fix transaction leak that caused the db connections pool to exhaust
470 - properly expose all methods, including Legacy/, and not only Methods/
471
472 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
473 - renumbered as 4.3
474 - nodes have new fields run_level (in addition to boot_state) and verified
475 - tweaked migration from 4.2
476 - tuned rpm dependencies
477 - doc generation more explicit about errors like missing python modules
478 - removed obsolete method GetSlicesMD5
479
480 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
481 - unified all tags
482 - renamed interface settings into interface tags and slice attributes into slice tags
483 - nodes have a node_type
484 - various changes on the way to 4.3
485
486 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
487 - Checkpointing : this version still has interface settings and slice attributes
488
489 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
490 - first iteration with taggable nodes/interfaces/slices
491 - embryo for ilinks
492 - cleaned up boot states
493 - migration script moslty complete
494
495 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
496 - fixed doc build by locating locally installed DTDs at build-time
497
498 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
499 - no more doc packaged outside of myplc-docs - doc/ cleaned up
500 - enhancements in doc on filters 
501 - bootcd-aware GetBootMedium merged from onelab
502
503 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
504 - checkpoint while the new myplc-docs package is underway
505 - bugfix: GetSlivers & conf files
506 - doc: removed target files 
507
508 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
509 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
510 - the non-deleted fields were index, resulting in massivly slow queries.
511
512
513 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
514 - plcsh: better handling of options when running as a shell script
515 - getbootmedium exports compute_key
516 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
517
518 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
519 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
520 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
521
522 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
523 - refresh peer script to use a month-dependent logfile
524 - tracking the starting point for UniPi integration of the dummynet boxes
525
526 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
527 - plcsh adds its own path to sys.path
528 - fix so GetNodes can be called from a Node
529
530 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
531 - Initial build.
532
533 %define module_current_branch 4.3