b31dfe868f8b25bbb193d90d4d19fe0bdd9e14ed
[plcapi.git] / PLCAPI.spec
1 %define name PLCAPI
2 %define version 5.1
3 %define taglevel 6
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Obsoletes: plcapilib
22
23 # We use set everywhere
24 Requires: python >= 2.4
25 Requires: postgresql >= 8.2, postgresql-server >= 8.2
26 Requires: postgresql-python
27 Requires: python-psycopg2
28 Requires: python-pycurl
29 Requires: httpd
30 %if "%{distro}" == "Fedora" && %{distrorelease} <= 17
31 Requires: mod_python
32 %endif
33 # mod_wsgi will replace mod_python when we are ready
34 Requires: mod_wsgi
35 Requires: mod_ssl
36 Requires: SOAPpy
37 Requires: python-simplejson
38 # for the RebootNodeWithPCU method
39 Requires: pcucontrol >= 1.0-6
40 # for OMF integration
41 Requires: pyaspects >= 0.4
42 Requires: python-twisted-words
43 Requires: python-twisted-web
44 # ldap
45 Requires: python-ldap
46 # for memcache
47 Requires: python-memcached
48 Requires: memcached
49 Requires: Django
50 ### avoid having yum complain about updates, as stuff is moving around
51 # plc.d/api
52 Conflicts: MyPLC <= 4.3
53
54 # We use psycopg2
55 #
56 # but we don't need to rebuild it as we depend on distro's packages - baris
57 # BuildRequires: postgresql-devel
58
59 # Standard xmlrpc.so that ships with PHP does not marshal NULL
60 BuildRequires: php-devel PyXML python-simplejson
61 Obsoletes: php-xmlrpc
62 Provides: php-xmlrpc
63
64 # PostgreSQL and SOAPpy are necessary to run the API server, but not
65 # plcsh. Since the only supported method of running the server is via
66 # MyPLC anyway, don't be so stringent about binary requirements, in
67 # case people want to install this package just for plcsh.
68 # Requires: postgresql-server, SOAPpy
69 AutoReqProv: no
70
71 %description
72 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
73 PlanetLab Central (PLC) database. The API may be accessed directly via
74 the Python shell program plcsh, through a toy standalone server, or
75 through Apache mod_python.
76
77 %prep
78 %setup -q
79
80 %build
81 # python-pycurl and python-psycopg2 avail. from fedora 5
82 # we used to ship our own version of psycopg2 and pycurl, for fedora4
83 # starting with 4.3, support for these two modules is taken out
84
85 # Build __init__.py metafiles and PHP API. 
86 %{__make} %{?_smp_mflags}
87 %{__make} -C wsdl
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
92
93 # Install shell symlink
94 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
95 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
96
97 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
98 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
99 ; Enable xmlrpc extension module
100 extension=xmlrpc.so
101 EOF
102
103 # Install initscripts
104 echo "* Installing initscripts"
105 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
106 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
107
108 # Install db-config.d files
109 echo "* Installing db-config.d files"
110 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
111 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
112 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
113
114 # Install wsdl
115 echo "* Installing wsdl"
116 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
117
118 # Install omf_slicemgr.py
119 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
120 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
121 mkdir -p $RPM_BUILD_ROOT/var/log/omf
122
123 # Install ratelimit log
124 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
125 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %define php_extension_dir %(php-config --extension-dir)
131
132 %files
133 %defattr(-,root,root,-)
134 %dir %{_datadir}/plc_api
135 %dir /var/log/omf/
136 %{_datadir}/plc_api/*
137 %{_bindir}/plcsh
138 %{php_extension_dir}/xmlrpc.so
139 %{_sysconfdir}/php.d/xmlrpc.ini
140 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
141 /etc/plc.d
142 /etc/planetlab/db-config.d
143 /var/www/html/wsdl/plcapi.wsdl
144 /usr/bin/omf_slicemgr.py*
145 /usr/bin/reset_xmpp_pubsub_nodes.py*
146 /var/log/plc_api_ratelimit.log
147
148
149 %changelog
150 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
151 - implement PLC_VSYS_DEFAULTS in AddSlice
152
153 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
154 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
155 - AddPerson and UpdatePerson are now tag-aware
156 - as a side-effect AddPerson is more picky and rejects invalid fields
157 - which results in a requirement to use sfa-2.1-22 with this tag
158 - marginal improvement on the xml doc on tags
159
160 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
161 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
162 - reset_xmpp_pubsub_nodes now hos options and usage
163 - new Accessors for vicci
164
165 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
166 - fixed imports for tags management with sites and persons
167 - add predefined 'cpu_freezable' tag
168
169 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
170 - tweaks in interface initialization
171 - has 'vsys_vnet' as a predefined tagtype
172 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
173 - bugfix: GetSlivers & nodegroups
174 - bugfix: in jabber groups management
175
176 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
177 - fix gpg-authentication for Persons (thanks Jordan)
178 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
179 - ip address/network check: v4 or v6
180 - customized DB Message survive upgrade
181 - make sync works in lxc-hosted tests
182 - no svn keywords anymore
183
184 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
185 - fix sorting for methods list in docs
186 - untested but needed tweak for postgres startup in f16
187
188 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
189 - tweaks in postgresql setup - in line with sfa
190
191 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
192 - slight tweaks in Persons.py
193
194 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
195 - GetSession has support for more than one day sessions
196 - reset_xmpp_pubsub_nodes is much more efficient
197 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
198 - bugfix - deleting a person in the middle of the signup process
199
200 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
201 - ratelimit aspects
202 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
203 - requires Django for cache_utils
204 - attempt to expose 'pldistro' to sfa
205 - last_time_spent_online, last_time_spent_offline: new fields in Node
206 - new slice tags 'isolate_loopback' and 'cpu_cores'
207 - refresh-peer federation logs dump exceptions
208 - modpython logs have a timestamp
209 - more verbose/accurate php error reporting
210 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
211 - AddNode, UpdateNode: manage tags directly rather than through another method
212 - BootUpdateNode: only update once
213 - GetPersons: techs can access the list of persons on their site
214 - GetSlices and GetSliceTags: techs can see slices on their nodes
215 - GetSlivers: isrootonsite tag; cacheable
216
217 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
218 - rename initscript_body into initscript_code
219
220 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
221 - new initscript_body tag
222
223 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
224 - working draft for GetSliceSshKeys
225
226 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
227 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
228 - (this is for people who cancel their download)
229
230 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
231 - fix db-config sequence : accessors step now merged in, and occurs at the right time
232 - db-config also more robust
233 - no more explicit 'accessors' step in plc.d
234
235 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
236 - session auth: do *not* delete session when node runs a method that does not have 'node' role
237 - session auth: remove support for bootonce in old boot CDs
238 - give a reason when caller_may_write_slice_tag fails
239 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
240
241 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
242 - SetSliceVref needed the node role
243 - protect GetSliceFamily
244 - Fix bugs in tag authorizations
245
246 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
247 - altered checking of optional fields in Interfaces
248 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
249 - has pyxml and python-simplejson as new deps
250
251 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
252 - tweak doc extraction for fedora14
253
254 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
255 - builtin accessors for the myslice page
256 - Get{Node,Interface}Tags allowed to techs
257 - tweak in ratelimitaspect.py
258
259 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
260 - add admin role to accessor-related tags (arch, {fc,pl}distro)
261
262 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
263 - bugfix in {Update,Delete}PersonTag
264 - updated xml doc for filters, accessors and tagtypes
265 - more explicit msg in case of missing roles
266 - improvements in ratelimitaspects.py
267
268 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
269 - fix the roles for ssh_key and hmac tags
270
271 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
272 - tag permissions system based on roles and not min_role_ids
273 - accessors simplified accordingly (no more min_role_id)
274 - new methods AddRoleToTagType and DeleteRoleFromTagType
275 - accessor-related tagtypes are created sooner, and enforced
276 - cleaned up redundancy between db-config.d and accessors
277
278 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
279 - fix RefreshPeer that was not working in 5.0-17
280
281 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
282 - RefreshPeer is able to cope with 2 peers running different releases of the api
283 - DeletePerson can be used on duplicates
284 - first appearance of ModPythonJson.py
285
286 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
287 - set accessors return the new value
288 - tweaks in the pubsub groups management
289
290 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
291 - convert hostnames to lower case and use ILIKE instead of LIKE
292
293 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
294 - use hrn in pubsub groups
295
296 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
297 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
298 - - OMF fixes
299
300 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
301 - automatically set vsys tag for omf controlled slices
302
303 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
304 - addition of the 'ssh_key' slice tag
305 - first draft of the LDAP interface
306
307 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
308 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
309 - and readable through GetLeaseGranularity
310 - GetSlivers to expose reservation_policy and lease_granularity
311 - GetBootMedium fixed for reservable nodes
312 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
313 - new Apache mod_wsgi python interface
314
315 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
316 - the leases system
317
318 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
319 - previous tag had gone wrong
320
321 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
322 - fix pubsub hostname
323
324 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
325 - tweaks for the omf support (xmpp groups and RC-controlled slices)
326 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
327 - GetNodeFlavour exposes fcdistro
328
329 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
330 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
331
332 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
333 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
334 - pyaspect hooks allow to  maintain the namespace xmpp groups
335 - new omf_slicemgr is a proxy to xmpp, used by these hooks
336 - nodes have their hrn exposed in the 'hrn' tag
337 - node hrn exposed in GetSlivers, as well as the overall xmpp config
338 - system slice 'drl' gets created by db-config
339 - daniel's changes to Filter for supporting wildcards in lists
340 - AddSliceTag consistency check tweaked
341
342 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
343 - major cleanup
344 - get rid of all 4.2-related legacy code
345 - reset the migrations code, planetlab5.sql somes with (5,100)
346 - uses hashlib module when available
347
348 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
349 - first working version of 5.0:
350 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
351 - nodefamily is 3-fold with pldistro-fcdistro-arch
352 - site and person tags
353 - new methods GetSliceFamily and GetNodeFlavour
354 - deprecated the dummynet stuff that were for the external dummyboxes
355 - tags definition : more consistency between db-config scripts and accessors
356 - (get accessor to create the tag type too if absent)
357 - logging an event for AddSliceToNodes
358
359 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
360 - support for fedora 12
361 - fix subtle bug in filtering with ] and quotes
362
363 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
364 - * patch for php-5.3 (the one in f12)
365 - * validate email addresses with regex
366 - * add PersonTags and SiteTags
367 - * add additional accessors for node tags (kvariant, serial, ..)
368
369 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
370 - Redacting password, session, and authstring values from the event log.
371
372 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
373 - let AddSite set ext_consortium_id - required for the poorman registration pages
374 - drop version constraint on Requires: postgresql-python
375 - don't log system calls nor ReportRunLevel
376
377 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
378 - Fix requires for CentOS.
379
380 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
381 - Require postgresql 8.2 (for array operators && and @>)
382
383 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
384 - Filter now supports the | and & features to match in sequence values
385 - bugfix in the postgresql wrapper for sequence filter values
386 - reviewed GetSlivers to export admin keys more efficiently
387 - fix checking roles in UpdateSliceTag
388
389 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
390 - - Some typos in the documentation were fixed.
391 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
392 - to the tag's min_role_id.
393
394 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
395
396 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
397 - Ongoing work to add upcalls, using new SFA class
398 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
399 - reviewed type-checking for the 3 taggable classes node-interface-slice
400 - cleanup ald dummynet stuff
401 - expose the 'extensions' accessors to the API
402 - tweaked checks in AddSliceTag
403 - GetPersons exposes roles by default
404 - bugfix in ReportRunLevel for non-string levels
405 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
406
407 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
408 - new BindObjectToPeer method for sfa
409 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
410
411 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
412 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
413 - reportrunlevel logs its calls only when run_level changes
414 - pycurl more robust wrt to xmlrpclib.Transport
415
416 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
417 - produce a wsdl interface
418 - bugfix in getbootmedium for nodes with interface tags
419
420 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
421 - bugfix for some rare pattern-based filters
422
423 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
424 - improvements in the 4.2 legacy layer
425
426 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
427 - bugfix required for slice tags set on nodegroups
428
429 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
430 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
431
432 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
433 - more powerful legacy layer with 4.2
434
435 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
436 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
437 - migration script has an option for running interactively
438
439 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
440 - skips already added entries
441
442 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
443 - yet another set of fixes for external dummynet boxes
444
445 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
446 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
447 - and tmp file is cleaned up
448
449 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
450 - restore missing ResolveSlices
451
452 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
453 - new method GetDummyBoxMedium
454
455 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
456 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
457
458 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
459 - support for external dummynet boxes back in 4.3 - first draft
460
461 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
462 - fixes for smooth federation between 4.2 and 4.3
463 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
464
465 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
466 - support for BootCD variants (GetBootMedium ['variant:centos5'])
467 - fix corner case with filters like {'~slice_id':[]}
468 - fix transaction leak that caused the db connections pool to exhaust
469 - properly expose all methods, including Legacy/, and not only Methods/
470
471 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
472 - renumbered as 4.3
473 - nodes have new fields run_level (in addition to boot_state) and verified
474 - tweaked migration from 4.2
475 - tuned rpm dependencies
476 - doc generation more explicit about errors like missing python modules
477 - removed obsolete method GetSlicesMD5
478
479 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
480 - unified all tags
481 - renamed interface settings into interface tags and slice attributes into slice tags
482 - nodes have a node_type
483 - various changes on the way to 4.3
484
485 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
486 - Checkpointing : this version still has interface settings and slice attributes
487
488 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
489 - first iteration with taggable nodes/interfaces/slices
490 - embryo for ilinks
491 - cleaned up boot states
492 - migration script moslty complete
493
494 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
495 - fixed doc build by locating locally installed DTDs at build-time
496
497 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
498 - no more doc packaged outside of myplc-docs - doc/ cleaned up
499 - enhancements in doc on filters 
500 - bootcd-aware GetBootMedium merged from onelab
501
502 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
503 - checkpoint while the new myplc-docs package is underway
504 - bugfix: GetSlivers & conf files
505 - doc: removed target files 
506
507 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
508 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
509 - the non-deleted fields were index, resulting in massivly slow queries.
510
511
512 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
513 - plcsh: better handling of options when running as a shell script
514 - getbootmedium exports compute_key
515 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
516
517 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
518 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
519 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
520
521 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
522 - refresh peer script to use a month-dependent logfile
523 - tracking the starting point for UniPi integration of the dummynet boxes
524
525 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
526 - plcsh adds its own path to sys.path
527 - fix so GetNodes can be called from a Node
528
529 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
530 - Initial build.
531
532 %define module_current_branch 4.3