b87fb4ed9eee9ffda1eb07db21ff656f08354608
[plcapi.git] / PLCAPI.spec
1 %define name PLCAPI
2 %define version 5.0
3 %define taglevel 28
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Obsoletes: plcapilib
22
23 # We use set everywhere
24 Requires: python >= 2.4
25 Requires: postgresql >= 8.2, postgresql-server >= 8.2
26 Requires: postgresql-python
27 Requires: python-psycopg2
28 Requires: python-pycurl
29 Requires: httpd
30 Requires: mod_python
31 # mod_wsgi will replace mod_python when we are ready
32 Requires: mod_wsgi
33 Requires: mod_ssl
34 Requires: SOAPpy
35 Requires: python-simplejson
36 # for the RebootNodeWithPCU method
37 Requires: pcucontrol >= 1.0-6
38 # for OMF integration
39 Requires: pyaspects >= 0.4
40 Requires: python-twisted-words
41 Requires: python-twisted-web
42 # ldap
43 Requires: python-ldap
44 # for memcache
45 Requires: python-memcached
46 Requires: memcached
47 ### avoid having yum complain about updates, as stuff is moving around
48 # plc.d/api
49 Conflicts: MyPLC <= 4.3
50
51 # We use psycopg2
52 #
53 # but we don't need to rebuild it as we depend on distro's packages - baris
54 # BuildRequires: postgresql-devel
55
56 # Standard xmlrpc.so that ships with PHP does not marshal NULL
57 BuildRequires: php-devel PyXML python-simplejson
58 Obsoletes: php-xmlrpc
59 Provides: php-xmlrpc
60
61 # PostgreSQL and SOAPpy are necessary to run the API server, but not
62 # plcsh. Since the only supported method of running the server is via
63 # MyPLC anyway, don't be so stringent about binary requirements, in
64 # case people want to install this package just for plcsh.
65 # Requires: postgresql-server, SOAPpy
66 AutoReqProv: no
67
68 %description
69 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
70 PlanetLab Central (PLC) database. The API may be accessed directly via
71 the Python shell program plcsh, through a toy standalone server, or
72 through Apache mod_python.
73
74 %prep
75 %setup -q
76
77 %build
78 # python-pycurl and python-psycopg2 avail. from fedora 5
79 # we used to ship our own version of psycopg2 and pycurl, for fedora4
80 # starting with 4.3, support for these two modules is taken out
81
82 # Build __init__.py metafiles and PHP API. 
83 %{__make} %{?_smp_mflags}
84 %{__make} -C wsdl
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
89
90 # Install shell symlink
91 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
92 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
93
94 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
95 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
96 ; Enable xmlrpc extension module
97 extension=xmlrpc.so
98 EOF
99
100 # Install initscripts
101 echo "* Installing initscripts"
102 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
103 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
104
105 # Install db-config.d files
106 echo "* Installing db-config.d files"
107 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
108 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
110
111 # Install wsdl
112 echo "* Installing wsdl"
113 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
114
115 # Install omf_slicemgr.py
116 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
117 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
118 mkdir -p $RPM_BUILD_ROOT/var/log/omf
119
120 # Install ratelimit log
121 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
122 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %define php_extension_dir %(php-config --extension-dir)
128
129 %files
130 %defattr(-,root,root,-)
131 %dir %{_datadir}/plc_api
132 %dir /var/log/omf/
133 %{_datadir}/plc_api/*
134 %{_bindir}/plcsh
135 %{php_extension_dir}/xmlrpc.so
136 %{_sysconfdir}/php.d/xmlrpc.ini
137 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
138 /etc/plc.d
139 /etc/planetlab/db-config.d
140 /var/www/html/wsdl/plcapi.wsdl
141 /usr/bin/omf_slicemgr.py*
142 /usr/bin/reset_xmpp_pubsub_nodes.py*
143 /var/log/plc_api_ratelimit.log
144
145
146 %changelog
147 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
148 - fix db-config sequence : accessors step now merged in, and occurs at the right time
149 - db-config also more robust
150 - no more explicit 'accessors' step in plc.d
151
152 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
153 - session auth: do *not* delete session when node runs a method that does not have 'node' role
154 - session auth: remove support for bootonce in old boot CDs
155 - give a reason when caller_may_write_slice_tag fails
156 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
157
158 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
159 - SetSliceVref needed the node role
160 - protect GetSliceFamily
161 - Fix bugs in tag authorizations
162
163 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
164 - altered checking of optional fields in Interfaces
165 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
166 - has pyxml and python-simplejson as new deps
167
168 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
169 - tweak doc extraction for fedora14
170
171 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
172 - builtin accessors for the myslice page
173 - Get{Node,Interface}Tags allowed to techs
174 - tweak in ratelimitaspect.py
175
176 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
177 - add admin role to accessor-related tags (arch, {fc,pl}distro)
178
179 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
180 - bugfix in {Update,Delete}PersonTag
181 - updated xml doc for filters, accessors and tagtypes
182 - more explicit msg in case of missing roles
183 - improvements in ratelimitaspects.py
184
185 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
186 - fix the roles for ssh_key and hmac tags
187
188 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
189 - tag permissions system based on roles and not min_role_ids
190 - accessors simplified accordingly (no more min_role_id)
191 - new methods AddRoleToTagType and DeleteRoleFromTagType
192 - accessor-related tagtypes are created sooner, and enforced
193 - cleaned up redundancy between db-config.d and accessors
194
195 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
196 - fix RefreshPeer that was not working in 5.0-17
197
198 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
199 - RefreshPeer is able to cope with 2 peers running different releases of the api
200 - DeletePerson can be used on duplicates
201 - first appearance of ModPythonJson.py
202
203 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
204 - set accessors return the new value
205 - tweaks in the pubsub groups management
206
207 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
208 - convert hostnames to lower case and use ILIKE instead of LIKE
209
210 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
211 - use hrn in pubsub groups
212
213 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
214 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
215 - - OMF fixes
216
217 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
218 - automatically set vsys tag for omf controlled slices
219
220 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
221 - addition of the 'ssh_key' slice tag
222 - first draft of the LDAP interface
223
224 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
225 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
226 - and readable through GetLeaseGranularity
227 - GetSlivers to expose reservation_policy and lease_granularity
228 - GetBootMedium fixed for reservable nodes
229 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
230 - new Apache mod_wsgi python interface
231
232 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
233 - the leases system
234
235 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
236 - previous tag had gone wrong
237
238 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
239 - fix pubsub hostname
240
241 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
242 - tweaks for the omf support (xmpp groups and RC-controlled slices)
243 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
244 - GetNodeFlavour exposes fcdistro
245
246 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
247 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
248
249 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
250 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
251 - pyaspect hooks allow to  maintain the namespace xmpp groups
252 - new omf_slicemgr is a proxy to xmpp, used by these hooks
253 - nodes have their hrn exposed in the 'hrn' tag
254 - node hrn exposed in GetSlivers, as well as the overall xmpp config
255 - system slice 'drl' gets created by db-config
256 - daniel's changes to Filter for supporting wildcards in lists
257 - AddSliceTag consistency check tweaked
258
259 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
260 - major cleanup
261 - get rid of all 4.2-related legacy code
262 - reset the migrations code, planetlab5.sql somes with (5,100)
263 - uses hashlib module when available
264
265 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
266 - first working version of 5.0:
267 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
268 - nodefamily is 3-fold with pldistro-fcdistro-arch
269 - site and person tags
270 - new methods GetSliceFamily and GetNodeFlavour
271 - deprecated the dummynet stuff that were for the external dummyboxes
272 - tags definition : more consistency between db-config scripts and accessors
273 - (get accessor to create the tag type too if absent)
274 - logging an event for AddSliceToNodes
275
276 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
277 - support for fedora 12
278 - fix subtle bug in filtering with ] and quotes
279
280 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
281 - * patch for php-5.3 (the one in f12)
282 - * validate email addresses with regex
283 - * add PersonTags and SiteTags
284 - * add additional accessors for node tags (kvariant, serial, ..)
285
286 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
287 - Redacting password, session, and authstring values from the event log.
288
289 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
290 - let AddSite set ext_consortium_id - required for the poorman registration pages
291 - drop version constraint on Requires: postgresql-python
292 - don't log system calls nor ReportRunLevel
293
294 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
295 - Fix requires for CentOS.
296
297 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
298 - Require postgresql 8.2 (for array operators && and @>)
299
300 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
301 - Filter now supports the | and & features to match in sequence values
302 - bugfix in the postgresql wrapper for sequence filter values
303 - reviewed GetSlivers to export admin keys more efficiently
304 - fix checking roles in UpdateSliceTag
305
306 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
307 - - Some typos in the documentation were fixed.
308 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
309 - to the tag's min_role_id.
310
311 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
312
313 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
314 - Ongoing work to add upcalls, using new SFA class
315 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
316 - reviewed type-checking for the 3 taggable classes node-interface-slice
317 - cleanup ald dummynet stuff
318 - expose the 'extensions' accessors to the API
319 - tweaked checks in AddSliceTag
320 - GetPersons exposes roles by default
321 - bugfix in ReportRunLevel for non-string levels
322 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
323
324 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
325 - new BindObjectToPeer method for sfa
326 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
327
328 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
329 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
330 - reportrunlevel logs its calls only when run_level changes
331 - pycurl more robust wrt to xmlrpclib.Transport
332
333 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
334 - produce a wsdl interface
335 - bugfix in getbootmedium for nodes with interface tags
336
337 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
338 - bugfix for some rare pattern-based filters
339
340 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
341 - improvements in the 4.2 legacy layer
342
343 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
344 - bugfix required for slice tags set on nodegroups
345
346 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
347 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
348
349 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
350 - more powerful legacy layer with 4.2
351
352 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
353 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
354 - migration script has an option for running interactively
355
356 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
357 - skips already added entries
358
359 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
360 - yet another set of fixes for external dummynet boxes
361
362 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
363 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
364 - and tmp file is cleaned up
365
366 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
367 - restore missing ResolveSlices
368
369 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
370 - new method GetDummyBoxMedium
371
372 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
373 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
374
375 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
376 - support for external dummynet boxes back in 4.3 - first draft
377
378 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
379 - fixes for smooth federation between 4.2 and 4.3
380 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
381
382 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
383 - support for BootCD variants (GetBootMedium ['variant:centos5'])
384 - fix corner case with filters like {'~slice_id':[]}
385 - fix transaction leak that caused the db connections pool to exhaust
386 - properly expose all methods, including Legacy/, and not only Methods/
387
388 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
389 - renumbered as 4.3
390 - nodes have new fields run_level (in addition to boot_state) and verified
391 - tweaked migration from 4.2
392 - tuned rpm dependencies
393 - doc generation more explicit about errors like missing python modules
394 - removed obsolete method GetSlicesMD5
395
396 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
397 - unified all tags
398 - renamed interface settings into interface tags and slice attributes into slice tags
399 - nodes have a node_type
400 - various changes on the way to 4.3
401
402 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
403 - Checkpointing : this version still has interface settings and slice attributes
404
405 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
406 - first iteration with taggable nodes/interfaces/slices
407 - embryo for ilinks
408 - cleaned up boot states
409 - migration script moslty complete
410
411 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
412 - fixed doc build by locating locally installed DTDs at build-time
413
414 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
415 - no more doc packaged outside of myplc-docs - doc/ cleaned up
416 - enhancements in doc on filters 
417 - bootcd-aware GetBootMedium merged from onelab
418
419 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
420 - checkpoint while the new myplc-docs package is underway
421 - bugfix: GetSlivers & conf files
422 - doc: removed target files 
423
424 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
425 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
426 - the non-deleted fields were index, resulting in massivly slow queries.
427
428
429 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
430 - plcsh: better handling of options when running as a shell script
431 - getbootmedium exports compute_key
432 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
433
434 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
435 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
436 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
437
438 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
439 - refresh peer script to use a month-dependent logfile
440 - tracking the starting point for UniPi integration of the dummynet boxes
441
442 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
443 - plcsh adds its own path to sys.path
444 - fix so GetNodes can be called from a Node
445
446 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
447 - Initial build.
448
449 %define module_current_branch 4.3