df59efff335e87fbe52fb7132e821503a80dd8b2
[plcapi.git] / PLCAPI.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name PLCAPI
8 %define version 5.0
9 %define taglevel 18
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: PlanetLab Central API
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: PlanetLab
18 Group: System Environment/Daemons
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Obsoletes: plcapilib
28
29 # We use set everywhere
30 Requires: python >= 2.4
31 Requires: postgresql >= 8.2, postgresql-server >= 8.2
32 Requires: postgresql-python
33 Requires: python-psycopg2
34 Requires: python-pycurl
35 Requires: httpd
36 Requires: mod_python
37 # mod_wsgi will replace mod_python when we are ready
38 Requires: mod_wsgi
39 Requires: mod_ssl
40 Requires: SOAPpy
41 Requires: python-simplejson
42 # for the RebootNodeWithPCU method
43 Requires: pcucontrol >= 1.0-6
44 # for OMF integration
45 Requires: pyaspects >= 0.4
46 Requires: python-twisted-words
47 Requires: python-twisted-web
48 # ldap
49 Requires: python-ldap
50 # for memcache
51 Requires: python-memcached
52 Requires: memcached
53 Requires: php-pecl-memcache
54 ### avoid having yum complain about updates, as stuff is moving around
55 # plc.d/api
56 Conflicts: MyPLC <= 4.3
57
58 # We use psycopg2
59 #
60 # but we don't need to rebuild it as we depend on distro's packages - baris
61 # BuildRequires: postgresql-devel
62
63 # Standard xmlrpc.so that ships with PHP does not marshal NULL
64 BuildRequires: php-devel
65 Obsoletes: php-xmlrpc
66 Provides: php-xmlrpc
67
68 # PostgreSQL and SOAPpy are necessary to run the API server, but not
69 # plcsh. Since the only supported method of running the server is via
70 # MyPLC anyway, don't be so stringent about binary requirements, in
71 # case people want to install this package just for plcsh.
72 # Requires: postgresql-server, SOAPpy
73 AutoReqProv: no
74
75 %description
76 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
77 PlanetLab Central (PLC) database. The API may be accessed directly via
78 the Python shell program plcsh, through a toy standalone server, or
79 through Apache mod_python.
80
81 %prep
82 %setup -q
83
84 %build
85 # python-pycurl and python-psycopg2 avail. from fedora 5
86 # we used to ship our own version of psycopg2 and pycurl, for fedora4
87 # starting with 4.3, support for these two modules is taken out
88
89 # Build __init__.py metafiles and PHP API. 
90 %{__make} %{?_smp_mflags}
91 %{__make} -C wsdl
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
96
97 # Install shell symlink
98 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
99 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
100
101 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
102 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
103 ; Enable xmlrpc extension module
104 extension=xmlrpc.so
105 EOF
106
107 # Install initscripts
108 echo "* Installing initscripts"
109 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
110 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
111
112 # Install db-config.d files
113 echo "* Installing db-config.d files"
114 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
115 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
116 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
117
118 # Install wsdl
119 echo "* Installing wsdl"
120 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
121
122 # Install omf_slicemgr.py
123 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
124 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
125 mkdir -p $RPM_BUILD_ROOT/var/log/omf
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %define php_extension_dir %(php-config --extension-dir)
131
132 %files
133 %defattr(-,root,root,-)
134 %dir %{_datadir}/plc_api
135 %dir /var/log/omf/
136 %{_datadir}/plc_api/*
137 %{_bindir}/plcsh
138 %{php_extension_dir}/xmlrpc.so
139 %{_sysconfdir}/php.d/xmlrpc.ini
140 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
141 /etc/plc.d
142 /etc/planetlab/db-config.d
143 /var/www/html/wsdl/plcapi.wsdl
144 /usr/bin/omf_slicemgr.py*
145 /usr/bin/reset_xmpp_pubsub_nodes.py*
146
147
148 %changelog
149 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
150 - fix RefreshPeer that was not working in 5.0-17
151
152 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
153 - RefreshPeer is able to cope with 2 peers running different releases of the api
154 - DeletePerson can be used on duplicates
155 - first appearance of ModPythonJson.py
156
157 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
158 - set accessors return the new value
159 - tweaks in the pubsub groups management
160
161 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
162 - convert hostnames to lower case and use ILIKE instead of LIKE
163
164 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
165 - use hrn in pubsub groups
166
167 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
168 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
169 - - OMF fixes
170
171 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
172 - automatically set vsys tag for omf controlled slices
173
174 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
175 - addition of the 'ssh_key' slice tag
176 - first draft of the LDAP interface
177
178 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
179 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
180 - and readable through GetLeaseGranularity
181 - GetSlivers to expose reservation_policy and lease_granularity
182 - GetBootMedium fixed for reservable nodes
183 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
184 - new Apache mod_wsgi python interface
185
186 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
187 - the leases system
188
189 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
190 - previous tag had gone wrong
191
192 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
193 - fix pubsub hostname
194
195 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
196 - tweaks for the omf support (xmpp groups and RC-controlled slices)
197 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
198 - GetNodeFlavour exposes fcdistro
199
200 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
201 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
202
203 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
204 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
205 - pyaspect hooks allow to  maintain the namespace xmpp groups
206 - new omf_slicemgr is a proxy to xmpp, used by these hooks
207 - nodes have their hrn exposed in the 'hrn' tag
208 - node hrn exposed in GetSlivers, as well as the overall xmpp config
209 - system slice 'drl' gets created by db-config
210 - daniel's changes to Filter for supporting wildcards in lists
211 - AddSliceTag consistency check tweaked
212
213 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
214 - major cleanup
215 - get rid of all 4.2-related legacy code
216 - reset the migrations code, planetlab5.sql somes with (5,100)
217 - uses hashlib module when available
218
219 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
220 - first working version of 5.0:
221 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
222 - nodefamily is 3-fold with pldistro-fcdistro-arch
223 - site and person tags
224 - new methods GetSliceFamily and GetNodeFlavour
225 - deprecated the dummynet stuff that were for the external dummyboxes
226 - tags definition : more consistency between db-config scripts and accessors
227 - (get accessor to create the tag type too if absent)
228 - logging an event for AddSliceToNodes
229
230 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
231 - support for fedora 12
232 - fix subtle bug in filtering with ] and quotes
233
234 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
235 - * patch for php-5.3 (the one in f12)
236 - * validate email addresses with regex
237 - * add PersonTags and SiteTags
238 - * add additional accessors for node tags (kvariant, serial, ..)
239
240 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
241 - Redacting password, session, and authstring values from the event log.
242
243 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
244 - let AddSite set ext_consortium_id - required for the poorman registration pages
245 - drop version constraint on Requires: postgresql-python
246 - don't log system calls nor ReportRunLevel
247
248 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
249 - Fix requires for CentOS.
250
251 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
252 - Require postgresql 8.2 (for array operators && and @>)
253
254 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
255 - Filter now supports the | and & features to match in sequence values
256 - bugfix in the postgresql wrapper for sequence filter values
257 - reviewed GetSlivers to export admin keys more efficiently
258 - fix checking roles in UpdateSliceTag
259
260 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
261 - - Some typos in the documentation were fixed.
262 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
263 - to the tag's min_role_id.
264
265 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
266
267 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
268 - Ongoing work to add upcalls, using new SFA class
269 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
270 - reviewed type-checking for the 3 taggable classes node-interface-slice
271 - cleanup ald dummynet stuff
272 - expose the 'extensions' accessors to the API
273 - tweaked checks in AddSliceTag
274 - GetPersons exposes roles by default
275 - bugfix in ReportRunLevel for non-string levels
276 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
277
278 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
279 - new BindObjectToPeer method for sfa
280 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
281
282 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
283 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
284 - reportrunlevel logs its calls only when run_level changes
285 - pycurl more robust wrt to xmlrpclib.Transport
286
287 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
288 - produce a wsdl interface
289 - bugfix in getbootmedium for nodes with interface tags
290
291 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
292 - bugfix for some rare pattern-based filters
293
294 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
295 - improvements in the 4.2 legacy layer
296
297 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
298 - bugfix required for slice tags set on nodegroups
299
300 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
301 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
302
303 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
304 - more powerful legacy layer with 4.2
305
306 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
307 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
308 - migration script has an option for running interactively
309
310 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
311 - skips already added entries
312
313 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
314 - yet another set of fixes for external dummynet boxes
315
316 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
317 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
318 - and tmp file is cleaned up
319
320 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
321 - restore missing ResolveSlices
322
323 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
324 - new method GetDummyBoxMedium
325
326 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
327 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
328
329 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
330 - support for external dummynet boxes back in 4.3 - first draft
331
332 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
333 - fixes for smooth federation between 4.2 and 4.3
334 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
335
336 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
337 - support for BootCD variants (GetBootMedium ['variant:centos5'])
338 - fix corner case with filters like {'~slice_id':[]}
339 - fix transaction leak that caused the db connections pool to exhaust
340 - properly expose all methods, including Legacy/, and not only Methods/
341
342 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
343 - renumbered as 4.3
344 - nodes have new fields run_level (in addition to boot_state) and verified
345 - tweaked migration from 4.2
346 - tuned rpm dependencies
347 - doc generation more explicit about errors like missing python modules
348 - removed obsolete method GetSlicesMD5
349
350 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
351 - unified all tags
352 - renamed interface settings into interface tags and slice attributes into slice tags
353 - nodes have a node_type
354 - various changes on the way to 4.3
355
356 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
357 - Checkpointing : this version still has interface settings and slice attributes
358
359 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
360 - first iteration with taggable nodes/interfaces/slices
361 - embryo for ilinks
362 - cleaned up boot states
363 - migration script moslty complete
364
365 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
366 - fixed doc build by locating locally installed DTDs at build-time
367
368 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
369 - no more doc packaged outside of myplc-docs - doc/ cleaned up
370 - enhancements in doc on filters 
371 - bootcd-aware GetBootMedium merged from onelab
372
373 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
374 - checkpoint while the new myplc-docs package is underway
375 - bugfix: GetSlivers & conf files
376 - doc: removed target files 
377
378 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
379 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
380 - the non-deleted fields were index, resulting in massivly slow queries.
381
382
383 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
384 - plcsh: better handling of options when running as a shell script
385 - getbootmedium exports compute_key
386 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
387
388 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
389 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
390 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
391
392 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
393 - refresh peer script to use a month-dependent logfile
394 - tracking the starting point for UniPi integration of the dummynet boxes
395
396 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
397 - plcsh adds its own path to sys.path
398 - fix so GetNodes can be called from a Node
399
400 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
401 - Initial build.
402
403 %define module_current_branch 4.3