5e3cf6d4bc38e7dcbea982970b75519c44f04919
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.4
3 %define taglevel 1
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # requirement to mod_python or mod_wsgi: deferred to myplc
25 Requires: httpd mod_ssl
26 # f29 does not come with an rpm for that; use pip instead
27 # Requires: Django
28 Requires: postgresql >= 8.2, postgresql-server >= 8.2
29 # We use set everywhere
30 Requires: python >= 2.7
31 Requires: postgresql-python
32 Requires: python-psycopg2
33 Requires: python-pycurl
34 # used in GPG.py as a replacement to PyXML's Canonicalize
35 Requires: python-lxml
36 # Fedora had support for SOAPpy up to fedora20
37 # https://lists.fedoraproject.org/pipermail/devel/2014-June/199730.html
38 # https://lists.fedoraproject.org/pipermail/devel/2014-June/200379.html
39 %if ("%{distro}" == "Fedora" && %{distrorelease} <= 20) || ("%{distro}" != "Fedora")
40 Requires: SOAPpy
41 %endif
42 #Requires: python-simplejson
43 # for the RebootNodeWithPCU method
44 Requires: pcucontrol >= 1.0-6
45 # for memcache
46 Requires: memcached python-memcached
47 ### avoid having yum complain about updates, as stuff is moving around
48 # plc.d/api
49 Conflicts: MyPLC <= 4.3
50
51 ####################
52 # obsolete
53 ####################
54 # standard xmlrpc.so that ships with PHP does not marshal NULL
55 # prior to May 2017 we used to ship our own brew of xmlrpc but
56 # that does not build anymore on f25
57 # So bottom line is:
58 # * don't use fedora's php-xmlrpc (no support for marshalling NULL)
59 # * don't use our own that is way too old
60 # * instead - thank you Ciro - we pull it as a git subtree from
61 # https://github.com/gggeek/phpxmlrpc.git
62 # that stuff requires the following though
63 Requires: php-xml
64 ####################
65
66
67 # PostgreSQL and SOAPpy are necessary to run the API server, but not
68 # plcsh. Since the only supported method of running the server is via
69 # MyPLC anyway, don't be so stringent about binary requirements, in
70 # case people want to install this package just for plcsh.
71 # Requires: postgresql-server, SOAPpy
72 AutoReqProv: no
73
74 %description
75 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
76 PlanetLab Central (PLC) database. The API may be accessed directly via
77 the Python shell program plcsh, through a toy standalone server, or
78 through Apache mod_python.
79
80 %prep
81 %setup -q
82
83 %build
84 # python-pycurl and python-psycopg2 avail. from fedora 5
85 # we used to ship our own version of psycopg2 and pycurl, for fedora4
86 # starting with 4.3, support for these two modules is taken out
87 #
88 # Build __init__.py metafiles and PHP API.
89 %{__make} %{?_smp_mflags}
90 %{__make} -C wsdl
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
95
96 # Install shell symlink
97 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
98 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
99
100 # Install initscripts
101 echo "* Installing initscripts"
102 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
103 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
104
105 # Install db-config.d files
106 echo "* Installing db-config.d files"
107 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
108 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
110
111 # Install wsdl
112 echo "* Installing wsdl"
113 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
114
115 ## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
116 ## Install omf_slicemgr.py
117 #install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
118 #install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
119 #mkdir -p $RPM_BUILD_ROOT/var/log/omf
120
121 # Create log file for plcapi
122 mkdir -p $RPM_BUILD_ROOT/var/log
123 touch $RPM_BUILD_ROOT/var/log/plcapi.log
124 chown apache:apache $RPM_BUILD_ROOT/var/log/plcapi.log
125
126 # Install ratelimit log
127 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
128 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 ###%define php_extension_dir %(php-config --extension-dir)
134
135 %files
136 %defattr(-,root,root,-)
137 %dir %{_datadir}/plc_api
138 #%dir /var/log/omf/
139 %{_datadir}/plc_api/*
140 %{_bindir}/plcsh
141 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
142 /etc/plc.d
143 /etc/planetlab/db-config.d
144 /var/www/html/wsdl/plcapi.wsdl
145 #/usr/bin/omf_slicemgr.py*
146 #/usr/bin/reset_xmpp_pubsub_nodes.py*
147 /var/log/plcapi.log
148 /var/log/plc_api_ratelimit.log
149
150
151 %changelog
152 * Wed May 16 2018 Thierry <Parmentelat> - plcapi-5.4-1
153 - define accessor for site tag disabled_registration (used in plewww-5.2-9)
154 - set disable_existing_loggers = False in logging config, that otherwise voids sfa logs
155
156 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.4-0
157 - embed phpxmlrpc as a git subtree from github (OK with fedora24 and 25, probably sooner too)
158 - logs in /var/log/plcapi.log
159 - context managers for most open files
160
161 * Wed Feb 08 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-11
162 - mostly issued for the R2lab deployment
163 - *** major
164 - * dots allowed in login_base and slice name
165 - * new lease filter 'day'
166 - *** minor
167 - * more explicit message in case of overlapping resas
168 - * bugfix: escaping unicode in xml
169 - * GetLeases allowed to anonymous callers
170 - *** miscell
171 - * use plain json library
172
173 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-10
174 - GetBootMedium with systemd-debug option : add kernel arg systemd.log_target=console
175
176 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-9
177 - new bootstate 'upgrade' is like reinstall but leaves slices intact
178
179 * Fri Apr 24 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-8
180 - GetBootMedium now keeps logs of created bootCD's in /var/tmp/bootmedium
181
182 * Fri Apr 03 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-7
183 - reviewed logging strategy, no more direct print but use log instead
184
185 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-6
186 - extensions for the ipv6 feature
187 - DeleteSliceTag can be run with the 'node' auth
188 - xmlrpc-epi-php.c has has a tweak for f21/php-5.6
189 - also SOAPpy is not present in f21 anymore, so drop that dep. with f>=21
190
191 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-5
192 - allow GetSlices to filter on tags as well
193
194 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-4
195 - enable filtering on tags (like hrn) with GetPersons and GetSites
196
197 * Mon Jun 02 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-3
198 - provide more context in messages from AddPersonToSlice and DeletePersonFromSlice
199
200 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-2
201 - don't use PyXML that is deprecated in f20, use lxml instead
202 - higher max size for login_base (32 vs 20) and slice name (64 vs 32)
203
204 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-1
205 - create accessor 'hrn' for site as well
206 - create accessors 'sfa_created' for site/slice/person
207 - AddSite() and AddSlice() set respectively Site HRN and Slice HRN.
208 - UpdatePerson() updates Person HRN according to updated email.
209 - UpdateSite() updates Site HRN according to updated login_base.
210 - Fix AddPersonToSite().
211 - GetPeerData() ignores Sites/Slices/Persons that have tag sfa_created=='True'
212 - RefreshPeer() manages Site*Person and Person*Role relationships.
213
214 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-10
215 - provide a slicename_to_hrn function
216
217 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-9
218 - add an hrn accessor for slice so the SFA code can keep track of the federation-wide name of the slice
219
220 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-8
221 - fix for wsgi-based deployments, each thread has its own api()
222
223 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
224 - also cleanup omf-slicemgr initscript
225
226 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
227 - tear down omf-related aspects as this is no longer needed with omfv6
228
229 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
230 - also expose 'expires' in ResolveSlices
231
232 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
233 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
234
235 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
236 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
237
238 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
239 - use SFA code for computing hrn's when available
240
241 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
242 - new slice tag 'interface' for configuring a virtual interface
243 - new builtin 030-interface_tags
244 - new node accessor and tag 'virt' for mixing lxc & vs nodes
245 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
246 - moved ModPypthon and plc.wsgi in the apache/ subdir
247 - renamed PLCAPI.spec into plcapi.spec
248 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
249 - support for php-5.4
250
251 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
252 - implement PLC_VSYS_DEFAULTS in AddSlice
253
254 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
255 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
256 - AddPerson and UpdatePerson are now tag-aware
257 - as a side-effect AddPerson is more picky and rejects invalid fields
258 - which results in a requirement to use sfa-2.1-22 with this tag
259 - marginal improvement on the xml doc on tags
260
261 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
262 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
263 - reset_xmpp_pubsub_nodes now hos options and usage
264 - new Accessors for vicci
265
266 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
267 - fixed imports for tags management with sites and persons
268 - add predefined 'cpu_freezable' tag
269
270 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
271 - tweaks in interface initialization
272 - has 'vsys_vnet' as a predefined tagtype
273 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
274 - bugfix: GetSlivers & nodegroups
275 - bugfix: in jabber groups management
276
277 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
278 - fix gpg-authentication for Persons (thanks Jordan)
279 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
280 - ip address/network check: v4 or v6
281 - customized DB Message survive upgrade
282 - make sync works in lxc-hosted tests
283 - no svn keywords anymore
284
285 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
286 - fix sorting for methods list in docs
287 - untested but needed tweak for postgres startup in f16
288
289 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
290 - tweaks in postgresql setup - in line with sfa
291
292 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
293 - slight tweaks in Persons.py
294
295 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
296 - GetSession has support for more than one day sessions
297 - reset_xmpp_pubsub_nodes is much more efficient
298 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
299 - bugfix - deleting a person in the middle of the signup process
300
301 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
302 - ratelimit aspects
303 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
304 - requires Django for cache_utils
305 - attempt to expose 'pldistro' to sfa
306 - last_time_spent_online, last_time_spent_offline: new fields in Node
307 - new slice tags 'isolate_loopback' and 'cpu_cores'
308 - refresh-peer federation logs dump exceptions
309 - modpython logs have a timestamp
310 - more verbose/accurate php error reporting
311 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
312 - AddNode, UpdateNode: manage tags directly rather than through another method
313 - BootUpdateNode: only update once
314 - GetPersons: techs can access the list of persons on their site
315 - GetSlices and GetSliceTags: techs can see slices on their nodes
316 - GetSlivers: isrootonsite tag; cacheable
317
318 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
319 - rename initscript_body into initscript_code
320
321 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
322 - new initscript_body tag
323
324 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
325 - working draft for GetSliceSshKeys
326
327 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
328 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
329 - (this is for people who cancel their download)
330
331 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
332 - fix db-config sequence : accessors step now merged in, and occurs at the right time
333 - db-config also more robust
334 - no more explicit 'accessors' step in plc.d
335
336 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
337 - session auth: do *not* delete session when node runs a method that does not have 'node' role
338 - session auth: remove support for bootonce in old boot CDs
339 - give a reason when caller_may_write_slice_tag fails
340 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
341
342 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
343 - SetSliceVref needed the node role
344 - protect GetSliceFamily
345 - Fix bugs in tag authorizations
346
347 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
348 - altered checking of optional fields in Interfaces
349 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
350 - has pyxml and python-simplejson as new deps
351
352 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
353 - tweak doc extraction for fedora14
354
355 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
356 - builtin accessors for the myslice page
357 - Get{Node,Interface}Tags allowed to techs
358 - tweak in ratelimitaspect.py
359
360 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
361 - add admin role to accessor-related tags (arch, {fc,pl}distro)
362
363 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
364 - bugfix in {Update,Delete}PersonTag
365 - updated xml doc for filters, accessors and tagtypes
366 - more explicit msg in case of missing roles
367 - improvements in ratelimitaspects.py
368
369 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
370 - fix the roles for ssh_key and hmac tags
371
372 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
373 - tag permissions system based on roles and not min_role_ids
374 - accessors simplified accordingly (no more min_role_id)
375 - new methods AddRoleToTagType and DeleteRoleFromTagType
376 - accessor-related tagtypes are created sooner, and enforced
377 - cleaned up redundancy between db-config.d and accessors
378
379 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
380 - fix RefreshPeer that was not working in 5.0-17
381
382 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
383 - RefreshPeer is able to cope with 2 peers running different releases of the api
384 - DeletePerson can be used on duplicates
385 - first appearance of ModPythonJson.py
386
387 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
388 - set accessors return the new value
389 - tweaks in the pubsub groups management
390
391 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
392 - convert hostnames to lower case and use ILIKE instead of LIKE
393
394 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
395 - use hrn in pubsub groups
396
397 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
398 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
399 - OMF fixes
400
401 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
402 - automatically set vsys tag for omf controlled slices
403
404 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
405 - addition of the 'ssh_key' slice tag
406 - first draft of the LDAP interface
407
408 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
409 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
410 - and readable through GetLeaseGranularity
411 - GetSlivers to expose reservation_policy and lease_granularity
412 - GetBootMedium fixed for reservable nodes
413 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
414 - new Apache mod_wsgi python interface
415
416 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
417 - the leases system
418
419 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
420 - previous tag had gone wrong
421
422 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
423 - fix pubsub hostname
424
425 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
426 - tweaks for the omf support (xmpp groups and RC-controlled slices)
427 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
428 - GetNodeFlavour exposes fcdistro
429
430 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
431 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
432
433 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
434 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
435 - pyaspect hooks allow to  maintain the namespace xmpp groups
436 - new omf_slicemgr is a proxy to xmpp, used by these hooks
437 - nodes have their hrn exposed in the 'hrn' tag
438 - node hrn exposed in GetSlivers, as well as the overall xmpp config
439 - system slice 'drl' gets created by db-config
440 - daniel's changes to Filter for supporting wildcards in lists
441 - AddSliceTag consistency check tweaked
442
443 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
444 - major cleanup
445 - get rid of all 4.2-related legacy code
446 - reset the migrations code, planetlab5.sql somes with (5,100)
447 - uses hashlib module when available
448
449 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
450 - first working version of 5.0:
451 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
452 - nodefamily is 3-fold with pldistro-fcdistro-arch
453 - site and person tags
454 - new methods GetSliceFamily and GetNodeFlavour
455 - deprecated the dummynet stuff that were for the external dummyboxes
456 - tags definition : more consistency between db-config scripts and accessors
457 - (get accessor to create the tag type too if absent)
458 - logging an event for AddSliceToNodes
459
460 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
461 - support for fedora 12
462 - fix subtle bug in filtering with ] and quotes
463
464 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
465 - * patch for php-5.3 (the one in f12)
466 - * validate email addresses with regex
467 - * add PersonTags and SiteTags
468 - * add additional accessors for node tags (kvariant, serial, ..)
469
470 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
471 - Redacting password, session, and authstring values from the event log.
472
473 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
474 - let AddSite set ext_consortium_id - required for the poorman registration pages
475 - drop version constraint on Requires: postgresql-python
476 - don't log system calls nor ReportRunLevel
477
478 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
479 - Fix requires for CentOS.
480
481 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
482 - Require postgresql 8.2 (for array operators && and @>)
483
484 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
485 - Filter now supports the | and & features to match in sequence values
486 - bugfix in the postgresql wrapper for sequence filter values
487 - reviewed GetSlivers to export admin keys more efficiently
488 - fix checking roles in UpdateSliceTag
489
490 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
491 - - Some typos in the documentation were fixed.
492 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
493 - to the tag's min_role_id.
494
495 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
496
497 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
498 - Ongoing work to add upcalls, using new SFA class
499 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
500 - reviewed type-checking for the 3 taggable classes node-interface-slice
501 - cleanup ald dummynet stuff
502 - expose the 'extensions' accessors to the API
503 - tweaked checks in AddSliceTag
504 - GetPersons exposes roles by default
505 - bugfix in ReportRunLevel for non-string levels
506 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
507
508 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
509 - new BindObjectToPeer method for sfa
510 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
511
512 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
513 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
514 - reportrunlevel logs its calls only when run_level changes
515 - pycurl more robust wrt to xmlrpclib.Transport
516
517 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
518 - produce a wsdl interface
519 - bugfix in getbootmedium for nodes with interface tags
520
521 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
522 - bugfix for some rare pattern-based filters
523
524 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
525 - improvements in the 4.2 legacy layer
526
527 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
528 - bugfix required for slice tags set on nodegroups
529
530 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
531 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
532
533 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
534 - more powerful legacy layer with 4.2
535
536 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
537 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
538 - migration script has an option for running interactively
539
540 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
541 - skips already added entries
542
543 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
544 - yet another set of fixes for external dummynet boxes
545
546 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
547 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
548 - and tmp file is cleaned up
549
550 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
551 - restore missing ResolveSlices
552
553 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
554 - new method GetDummyBoxMedium
555
556 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
557 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
558
559 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
560 - support for external dummynet boxes back in 4.3 - first draft
561
562 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
563 - fixes for smooth federation between 4.2 and 4.3
564 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
565
566 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
567 - support for BootCD variants (GetBootMedium ['variant:centos5'])
568 - fix corner case with filters like {'~slice_id':[]}
569 - fix transaction leak that caused the db connections pool to exhaust
570 - properly expose all methods, including Legacy/, and not only Methods/
571
572 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
573 - renumbered as 4.3
574 - nodes have new fields run_level (in addition to boot_state) and verified
575 - tweaked migration from 4.2
576 - tuned rpm dependencies
577 - doc generation more explicit about errors like missing python modules
578 - removed obsolete method GetSlicesMD5
579
580 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
581 - unified all tags
582 - renamed interface settings into interface tags and slice attributes into slice tags
583 - nodes have a node_type
584 - various changes on the way to 4.3
585
586 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
587 - Checkpointing : this version still has interface settings and slice attributes
588
589 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
590 - first iteration with taggable nodes/interfaces/slices
591 - embryo for ilinks
592 - cleaned up boot states
593 - migration script moslty complete
594
595 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
596 - fixed doc build by locating locally installed DTDs at build-time
597
598 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
599 - no more doc packaged outside of myplc-docs - doc/ cleaned up
600 - enhancements in doc on filters
601 - bootcd-aware GetBootMedium merged from onelab
602
603 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
604 - checkpoint while the new myplc-docs package is underway
605 - bugfix: GetSlivers & conf files
606 - doc: removed target files
607
608 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
609 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
610 - the non-deleted fields were index, resulting in massivly slow queries.
611 -
612
613 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
614 - plcsh: better handling of options when running as a shell script
615 - getbootmedium exports compute_key
616 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
617
618 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
619 - GetBootMedium support for build.sh full options, incl. serial & console_spec
620 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
621
622 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
623 - refresh peer script to use a month-dependent logfile
624 - tracking the starting point for UniPi integration of the dummynet boxes
625
626 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
627 - plcsh adds its own path to sys.path
628 - fix so GetNodes can be called from a Node
629
630 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> -
631 - Initial build.
632
633 %define module_current_branch 4.3