749eb185c6ab90fedb127c10729c38c901b14759
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.4
3 %define taglevel 1
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # requirement to mod_python or mod_wsgi: deferred to myplc
25 Requires: httpd mod_ssl
26 Requires: Django
27 Requires: postgresql >= 8.2, postgresql-server >= 8.2
28 # We use set everywhere
29 Requires: python >= 2.7
30 Requires: postgresql-python
31 Requires: python-psycopg2
32 Requires: python-pycurl
33 # used in GPG.py as a replacement to PyXML's Canonicalize
34 Requires: python-lxml
35 # Fedora had support for SOAPpy up to fedora20
36 # https://lists.fedoraproject.org/pipermail/devel/2014-June/199730.html
37 # https://lists.fedoraproject.org/pipermail/devel/2014-June/200379.html
38 %if ("%{distro}" == "Fedora" && %{distrorelease} <= 20) || ("%{distro}" != "Fedora")
39 Requires: SOAPpy
40 %endif
41 #Requires: python-simplejson
42 # for the RebootNodeWithPCU method
43 Requires: pcucontrol >= 1.0-6
44 # for OMF integration
45 Requires: pyaspects >= 0.4
46 Requires: python-twisted-words
47 Requires: python-twisted-web
48 # ldap
49 Requires: python-ldap
50 # for memcache
51 Requires: memcached python-memcached
52 ### avoid having yum complain about updates, as stuff is moving around
53 # plc.d/api
54 Conflicts: MyPLC <= 4.3
55
56 ####################
57 # obsolete
58 ####################
59 # standard xmlrpc.so that ships with PHP does not marshal NULL
60 # prior to May 2017 we used to ship our own brew of xmlrpc but
61 # that does not build anymore on f25
62 # So bottom line is:
63 # * don't use fedora's php-xmlrpc (no support for marshalling NULL)
64 # * don't use our own that is way too old
65 # * instead - thank you Ciro - we pull it as a git subtree from
66 # https://github.com/gggeek/phpxmlrpc.git
67 # that stuff requires the following though
68 Requires: php-xml
69 ####################
70
71
72 # PostgreSQL and SOAPpy are necessary to run the API server, but not
73 # plcsh. Since the only supported method of running the server is via
74 # MyPLC anyway, don't be so stringent about binary requirements, in
75 # case people want to install this package just for plcsh.
76 # Requires: postgresql-server, SOAPpy
77 AutoReqProv: no
78
79 %description
80 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
81 PlanetLab Central (PLC) database. The API may be accessed directly via
82 the Python shell program plcsh, through a toy standalone server, or
83 through Apache mod_python.
84
85 %prep
86 %setup -q
87
88 %build
89 # python-pycurl and python-psycopg2 avail. from fedora 5
90 # we used to ship our own version of psycopg2 and pycurl, for fedora4
91 # starting with 4.3, support for these two modules is taken out
92
93 # Build __init__.py metafiles and PHP API. 
94 %{__make} %{?_smp_mflags}
95 %{__make} -C wsdl
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
100
101 # Install shell symlink
102 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
103 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
104
105 # Install initscripts
106 echo "* Installing initscripts"
107 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
108 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
109
110 # Install db-config.d files
111 echo "* Installing db-config.d files"
112 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
113 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
114 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
115
116 # Install wsdl
117 echo "* Installing wsdl"
118 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
119
120 ## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
121 ## Install omf_slicemgr.py
122 #install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
123 #install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
124 #mkdir -p $RPM_BUILD_ROOT/var/log/omf
125
126 # Create log file for plcapi
127 mkdir -p $RPM_BUILD_ROOT/var/log
128 touch $RPM_BUILD_ROOT/var/log/plcapi.log
129 chown apache:apache $RPM_BUILD_ROOT/var/log/plcapi.log
130
131 # Install ratelimit log
132 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
133 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 ###%define php_extension_dir %(php-config --extension-dir)
139
140 %files
141 %defattr(-,root,root,-)
142 %dir %{_datadir}/plc_api
143 #%dir /var/log/omf/
144 %{_datadir}/plc_api/*
145 %{_bindir}/plcsh
146 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
147 /etc/plc.d
148 /etc/planetlab/db-config.d
149 /var/www/html/wsdl/plcapi.wsdl
150 #/usr/bin/omf_slicemgr.py*
151 #/usr/bin/reset_xmpp_pubsub_nodes.py*
152 /var/log/plcapi.log
153 /var/log/plc_api_ratelimit.log
154
155
156 %changelog
157 * Wed May 16 2018 Thierry <Parmentelat> - plcapi-5.4-1
158 - define accessor for site tag disabled_registration (used in plewww-5.2-9)
159 - set disable_existing_loggers = False in logging config, that otherwise voids sfa logs
160
161 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.4-0
162 - embed phpxmlrpc as a git subtree from github (OK with fedora24 and 25, probably sooner too)
163 - logs in /var/log/plcapi.log
164 - context managers for most open files
165
166 * Wed Feb 08 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-11
167 - mostly issued for the R2lab deployment
168 - *** major
169 - * dots allowed in login_base and slice name
170 - * new lease filter 'day'
171 - *** minor
172 - * more explicit message in case of overlapping resas
173 - * bugfix: escaping unicode in xml
174 - * GetLeases allowed to anonymous callers
175 - *** miscell
176 - * use plain json library
177
178 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-10
179 - GetBootMedium with systemd-debug option : add kernel arg systemd.log_target=console
180
181 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-9
182 - new bootstate 'upgrade' is like reinstall but leaves slices intact
183
184 * Fri Apr 24 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-8
185 - GetBootMedium now keeps logs of created bootCD's in /var/tmp/bootmedium
186
187 * Fri Apr 03 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-7
188 - reviewed logging strategy, no more direct print but use log instead
189
190 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-6
191 - extensions for the ipv6 feature
192 - DeleteSliceTag can be run with the 'node' auth
193 - xmlrpc-epi-php.c has has a tweak for f21/php-5.6
194 - also SOAPpy is not present in f21 anymore, so drop that dep. with f>=21
195
196 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-5
197 - allow GetSlices to filter on tags as well
198
199 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-4
200 - enable filtering on tags (like hrn) with GetPersons and GetSites
201
202 * Mon Jun 02 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-3
203 - provide more context in messages from AddPersonToSlice and DeletePersonFromSlice
204
205 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-2
206 - don't use PyXML that is deprecated in f20, use lxml instead
207 - higher max size for login_base (32 vs 20) and slice name (64 vs 32)
208
209 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-1
210 - create accessor 'hrn' for site as well
211 - create accessors 'sfa_created' for site/slice/person
212 - AddSite() and AddSlice() set respectively Site HRN and Slice HRN.
213 - UpdatePerson() updates Person HRN according to updated email.
214 - UpdateSite() updates Site HRN according to updated login_base.
215 - Fix AddPersonToSite().
216 - GetPeerData() ignores Sites/Slices/Persons that have tag sfa_created=='True'
217 - RefreshPeer() manages Site*Person and Person*Role relationships.
218
219 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-10
220 - provide a slicename_to_hrn function
221
222 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-9
223 - add an hrn accessor for slice so the SFA code can keep track of the federation-wide name of the slice
224
225 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-8
226 - fix for wsgi-based deployments, each thread has its own api()
227
228 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
229 - also cleanup omf-slicemgr initscript
230
231 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
232 - tear down omf-related aspects as this is no longer needed with omfv6
233
234 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
235 - also expose 'expires' in ResolveSlices
236
237 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
238 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
239
240 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
241 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
242
243 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
244 - use SFA code for computing hrn's when available
245
246 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
247 - new slice tag 'interface' for configuring a virtual interface
248 - new builtin 030-interface_tags
249 - new node accessor and tag 'virt' for mixing lxc & vs nodes
250 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
251 - moved ModPypthon and plc.wsgi in the apache/ subdir
252 - renamed PLCAPI.spec into plcapi.spec
253 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
254 - support for php-5.4
255
256 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
257 - implement PLC_VSYS_DEFAULTS in AddSlice
258
259 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
260 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
261 - AddPerson and UpdatePerson are now tag-aware
262 - as a side-effect AddPerson is more picky and rejects invalid fields
263 - which results in a requirement to use sfa-2.1-22 with this tag
264 - marginal improvement on the xml doc on tags
265
266 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
267 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
268 - reset_xmpp_pubsub_nodes now hos options and usage
269 - new Accessors for vicci
270
271 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
272 - fixed imports for tags management with sites and persons
273 - add predefined 'cpu_freezable' tag
274
275 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
276 - tweaks in interface initialization
277 - has 'vsys_vnet' as a predefined tagtype
278 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
279 - bugfix: GetSlivers & nodegroups
280 - bugfix: in jabber groups management
281
282 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
283 - fix gpg-authentication for Persons (thanks Jordan)
284 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
285 - ip address/network check: v4 or v6
286 - customized DB Message survive upgrade
287 - make sync works in lxc-hosted tests
288 - no svn keywords anymore
289
290 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
291 - fix sorting for methods list in docs
292 - untested but needed tweak for postgres startup in f16
293
294 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
295 - tweaks in postgresql setup - in line with sfa
296
297 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
298 - slight tweaks in Persons.py
299
300 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
301 - GetSession has support for more than one day sessions
302 - reset_xmpp_pubsub_nodes is much more efficient
303 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
304 - bugfix - deleting a person in the middle of the signup process
305
306 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
307 - ratelimit aspects
308 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
309 - requires Django for cache_utils
310 - attempt to expose 'pldistro' to sfa
311 - last_time_spent_online, last_time_spent_offline: new fields in Node
312 - new slice tags 'isolate_loopback' and 'cpu_cores'
313 - refresh-peer federation logs dump exceptions
314 - modpython logs have a timestamp
315 - more verbose/accurate php error reporting
316 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
317 - AddNode, UpdateNode: manage tags directly rather than through another method
318 - BootUpdateNode: only update once
319 - GetPersons: techs can access the list of persons on their site
320 - GetSlices and GetSliceTags: techs can see slices on their nodes
321 - GetSlivers: isrootonsite tag; cacheable
322
323 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
324 - rename initscript_body into initscript_code
325
326 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
327 - new initscript_body tag
328
329 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
330 - working draft for GetSliceSshKeys
331
332 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
333 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
334 - (this is for people who cancel their download)
335
336 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
337 - fix db-config sequence : accessors step now merged in, and occurs at the right time
338 - db-config also more robust
339 - no more explicit 'accessors' step in plc.d
340
341 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
342 - session auth: do *not* delete session when node runs a method that does not have 'node' role
343 - session auth: remove support for bootonce in old boot CDs
344 - give a reason when caller_may_write_slice_tag fails
345 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
346
347 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
348 - SetSliceVref needed the node role
349 - protect GetSliceFamily
350 - Fix bugs in tag authorizations
351
352 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
353 - altered checking of optional fields in Interfaces
354 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
355 - has pyxml and python-simplejson as new deps
356
357 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
358 - tweak doc extraction for fedora14
359
360 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
361 - builtin accessors for the myslice page
362 - Get{Node,Interface}Tags allowed to techs
363 - tweak in ratelimitaspect.py
364
365 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
366 - add admin role to accessor-related tags (arch, {fc,pl}distro)
367
368 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
369 - bugfix in {Update,Delete}PersonTag
370 - updated xml doc for filters, accessors and tagtypes
371 - more explicit msg in case of missing roles
372 - improvements in ratelimitaspects.py
373
374 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
375 - fix the roles for ssh_key and hmac tags
376
377 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
378 - tag permissions system based on roles and not min_role_ids
379 - accessors simplified accordingly (no more min_role_id)
380 - new methods AddRoleToTagType and DeleteRoleFromTagType
381 - accessor-related tagtypes are created sooner, and enforced
382 - cleaned up redundancy between db-config.d and accessors
383
384 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
385 - fix RefreshPeer that was not working in 5.0-17
386
387 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
388 - RefreshPeer is able to cope with 2 peers running different releases of the api
389 - DeletePerson can be used on duplicates
390 - first appearance of ModPythonJson.py
391
392 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
393 - set accessors return the new value
394 - tweaks in the pubsub groups management
395
396 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
397 - convert hostnames to lower case and use ILIKE instead of LIKE
398
399 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
400 - use hrn in pubsub groups
401
402 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
403 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
404 - OMF fixes
405
406 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
407 - automatically set vsys tag for omf controlled slices
408
409 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
410 - addition of the 'ssh_key' slice tag
411 - first draft of the LDAP interface
412
413 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
414 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
415 - and readable through GetLeaseGranularity
416 - GetSlivers to expose reservation_policy and lease_granularity
417 - GetBootMedium fixed for reservable nodes
418 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
419 - new Apache mod_wsgi python interface
420
421 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
422 - the leases system
423
424 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
425 - previous tag had gone wrong
426
427 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
428 - fix pubsub hostname
429
430 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
431 - tweaks for the omf support (xmpp groups and RC-controlled slices)
432 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
433 - GetNodeFlavour exposes fcdistro
434
435 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
436 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
437
438 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
439 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
440 - pyaspect hooks allow to  maintain the namespace xmpp groups
441 - new omf_slicemgr is a proxy to xmpp, used by these hooks
442 - nodes have their hrn exposed in the 'hrn' tag
443 - node hrn exposed in GetSlivers, as well as the overall xmpp config
444 - system slice 'drl' gets created by db-config
445 - daniel's changes to Filter for supporting wildcards in lists
446 - AddSliceTag consistency check tweaked
447
448 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
449 - major cleanup
450 - get rid of all 4.2-related legacy code
451 - reset the migrations code, planetlab5.sql somes with (5,100)
452 - uses hashlib module when available
453
454 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
455 - first working version of 5.0:
456 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
457 - nodefamily is 3-fold with pldistro-fcdistro-arch
458 - site and person tags
459 - new methods GetSliceFamily and GetNodeFlavour
460 - deprecated the dummynet stuff that were for the external dummyboxes
461 - tags definition : more consistency between db-config scripts and accessors
462 - (get accessor to create the tag type too if absent)
463 - logging an event for AddSliceToNodes
464
465 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
466 - support for fedora 12
467 - fix subtle bug in filtering with ] and quotes
468
469 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
470 - * patch for php-5.3 (the one in f12)
471 - * validate email addresses with regex
472 - * add PersonTags and SiteTags
473 - * add additional accessors for node tags (kvariant, serial, ..)
474
475 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
476 - Redacting password, session, and authstring values from the event log.
477
478 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
479 - let AddSite set ext_consortium_id - required for the poorman registration pages
480 - drop version constraint on Requires: postgresql-python
481 - don't log system calls nor ReportRunLevel
482
483 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
484 - Fix requires for CentOS.
485
486 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
487 - Require postgresql 8.2 (for array operators && and @>)
488
489 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
490 - Filter now supports the | and & features to match in sequence values
491 - bugfix in the postgresql wrapper for sequence filter values
492 - reviewed GetSlivers to export admin keys more efficiently
493 - fix checking roles in UpdateSliceTag
494
495 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
496 - - Some typos in the documentation were fixed.
497 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
498 - to the tag's min_role_id.
499
500 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
501
502 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
503 - Ongoing work to add upcalls, using new SFA class
504 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
505 - reviewed type-checking for the 3 taggable classes node-interface-slice
506 - cleanup ald dummynet stuff
507 - expose the 'extensions' accessors to the API
508 - tweaked checks in AddSliceTag
509 - GetPersons exposes roles by default
510 - bugfix in ReportRunLevel for non-string levels
511 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
512
513 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
514 - new BindObjectToPeer method for sfa
515 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
516
517 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
518 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
519 - reportrunlevel logs its calls only when run_level changes
520 - pycurl more robust wrt to xmlrpclib.Transport
521
522 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
523 - produce a wsdl interface
524 - bugfix in getbootmedium for nodes with interface tags
525
526 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
527 - bugfix for some rare pattern-based filters
528
529 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
530 - improvements in the 4.2 legacy layer
531
532 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
533 - bugfix required for slice tags set on nodegroups
534
535 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
536 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
537
538 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
539 - more powerful legacy layer with 4.2
540
541 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
542 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
543 - migration script has an option for running interactively
544
545 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
546 - skips already added entries
547
548 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
549 - yet another set of fixes for external dummynet boxes
550
551 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
552 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
553 - and tmp file is cleaned up
554
555 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
556 - restore missing ResolveSlices
557
558 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
559 - new method GetDummyBoxMedium
560
561 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
562 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
563
564 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
565 - support for external dummynet boxes back in 4.3 - first draft
566
567 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
568 - fixes for smooth federation between 4.2 and 4.3
569 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
570
571 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
572 - support for BootCD variants (GetBootMedium ['variant:centos5'])
573 - fix corner case with filters like {'~slice_id':[]}
574 - fix transaction leak that caused the db connections pool to exhaust
575 - properly expose all methods, including Legacy/, and not only Methods/
576
577 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
578 - renumbered as 4.3
579 - nodes have new fields run_level (in addition to boot_state) and verified
580 - tweaked migration from 4.2
581 - tuned rpm dependencies
582 - doc generation more explicit about errors like missing python modules
583 - removed obsolete method GetSlicesMD5
584
585 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
586 - unified all tags
587 - renamed interface settings into interface tags and slice attributes into slice tags
588 - nodes have a node_type
589 - various changes on the way to 4.3
590
591 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
592 - Checkpointing : this version still has interface settings and slice attributes
593
594 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
595 - first iteration with taggable nodes/interfaces/slices
596 - embryo for ilinks
597 - cleaned up boot states
598 - migration script moslty complete
599
600 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
601 - fixed doc build by locating locally installed DTDs at build-time
602
603 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
604 - no more doc packaged outside of myplc-docs - doc/ cleaned up
605 - enhancements in doc on filters 
606 - bootcd-aware GetBootMedium merged from onelab
607
608 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
609 - checkpoint while the new myplc-docs package is underway
610 - bugfix: GetSlivers & conf files
611 - doc: removed target files 
612
613 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
614 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
615 - the non-deleted fields were index, resulting in massivly slow queries.
616
617
618 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
619 - plcsh: better handling of options when running as a shell script
620 - getbootmedium exports compute_key
621 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
622
623 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
624 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
625 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
626
627 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
628 - refresh peer script to use a month-dependent logfile
629 - tracking the starting point for UniPi integration of the dummynet boxes
630
631 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
632 - plcsh adds its own path to sys.path
633 - fix so GetNodes can be called from a Node
634
635 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
636 - Initial build.
637
638 %define module_current_branch 4.3